Community discussions

MikroTik App
 
Philomena
just joined
Topic Author
Posts: 4
Joined: Fri Apr 27, 2012 10:09 am

Mikrotik v6.33.3 QOS, queue tree

Fri Dec 11, 2015 5:01 pm

We want to set up queue tree to give voice packets priority over other traffic,
Router is sxt, our local interface is ether1, and WAN is wlan1.

Configuration is not working and we will appreciate any help.

ip firewall mangle print


0 ;;; up-voice
chain=prerouting action=mark-connection new-connection-mark=up-voice passthrough=yes dst-address=(sip.server) in-interface=ether1 log=no log-prefix=""
1 ;;; down-voice
chain=prerouting action=mark-connection new-connection-mark=down-voice passthrough=yes src-address=(sip.server) in-interface=wlan1 log=no log-prefix=""
2 ;;; up-data
chain=prerouting action=mark-connection new-connection-mark=up-data passthrough=yes dst-address=!(sip.server) in-interface=ether1 log=no log-prefix=""
3 ;;; down-data
chain=prerouting action=mark-connection new-connection-mark=down-data passthrough=yes src-address=!(sip.server) in-interface=wlan1 log=no log-prefix=""
4 ;;; up-voice
chain=prerouting action=mark-packet new-packet-mark=up-voice passthrough=no connection-mark=up-voice log=no log-prefix=""
5 ;;; down-voice
chain=prerouting action=mark-packet new-packet-mark=down-voice passthrough=no connection-mark=down-voice log=no log-prefix=""
6 ;;; up-data
chain=prerouting action=mark-packet new-packet-mark=up-data passthrough=no connection-mark=up-data log=no log-prefix=""
7 ;;; down-data
chain=prerouting action=mark-packet new-packet-mark=down-data passthrough=no connection-mark=down-data log=no log-prefix=""




queue tree print

0 name="download" parent=global packet-mark="" limit-at=0 queue=default
priority=1 max-limit=4M burst-limit=0 burst-threshold=0 burst-time=0s

1 name="upload" parent=global packet-mark="" limit-at=0 queue=default
priority=1 max-limit=2M burst-limit=0 burst-threshold=0 burst-time=0s

2 name="down-voice" parent=download packet-mark=down-voice limit-at=0
queue=default priority=1 max-limit=4M burst-limit=0 burst-threshold=0
burst-time=0s

3 name="up-voice" parent=upload packet-mark=up-voice limit-at=0 queue=default
priority=1 max-limit=2M burst-limit=0 burst-threshold=0 burst-time=0s

4 name="down-data" parent=download packet-mark=down-data limit-at=0
queue=default priority=8 max-limit=3M burst-limit=0 burst-threshold=0
burst-time=0s

5 name="up-data" parent=upload packet-mark=up-data limit-at=0 queue=default
priority=8 max-limit=1M burst-limit=0 burst-threshold=0 burst-time=0s
 
fleegle
just joined
Posts: 6
Joined: Mon May 13, 2013 7:02 pm

Re: Mikrotik v6.33.3 QOS, queue tree

Tue Feb 16, 2016 5:13 am

@Philomena

Hi, could you solve the problem? I'm having the same issue here, don't know what else to do, I'm freaked out. Thanks.
 
pe1chl
Forum Guru
Forum Guru
Posts: 10240
Joined: Mon Jun 08, 2015 12:09 pm

Re: Mikrotik v6.33.3 QOS, queue tree

Thu Feb 18, 2016 8:30 pm

Did you turn off fast path in IP settings?
 
fleegle
just joined
Posts: 6
Joined: Mon May 13, 2013 7:02 pm

Re: Mikrotik v6.33.3 QOS, queue tree

Thu Feb 18, 2016 8:34 pm

Actually I don't know. I'm gonna check and let you know. :shock:
 
fleegle
just joined
Posts: 6
Joined: Mon May 13, 2013 7:02 pm

Re: Mikrotik v6.33.3 QOS, queue tree

Fri Feb 19, 2016 5:43 am

Did you turn off fast path in IP settings?
I tried turning off fast path but same problem, as an example, here is my config:

0 ;;; ICMP Packets
chain=prerouting action=mark-connection new-connection-mark=Services_P1_Conn_Upload passthrough=yes protocol=icmp icmp-options=8:0-255 log=no
log-prefix=""

1 chain=prerouting action=mark-packet new-packet-mark=Services_P1_Traffic_Upload passthrough=no connection-mark=Services_P1_Conn_Upload log=no
log-prefix=""

2 chain=postrouting action=mark-connection new-connection-mark=Services_P1_Conn_Download passthrough=yes protocol=icmp icmp-options=0:0-255
log=no log-prefix=""

3 chain=postrouting action=mark-packet new-packet-mark=Services_P1_Traffic_Download passthrough=no connection-mark=Services_P1_Conn_Download
log=no log-prefix=""

------------------output ommitted (more rules)------------------------

/queue tree
add max-limit=3600k name=Total-Download parent=global priority=1 queue=Download
add max-limit=690k name=Total-Upload parent=global priority=1 queue=Upload
add limit-at=1 max-limit=32k name=Services_P1_Download packet-mark=Services_P1_Traffic_Download parent=Total-Download priority=1 queue=Download
add limit-at=1 max-limit=32k name=Services_P1_Upload packet-mark=Services_P1_Traffic_Upload parent=Total-Upload priority=1 queue=Upload
add limit-at=1 max-limit=1M name=Gaming_P2_Download packet-mark=Gaming_P2_Traffic_Download parent=Total-Download priority=2 queue=Download
add limit-at=1 max-limit=512k name=Gaming_P2_Upload packet-mark=Gaming_P2_Traffic_Upload parent=Total-Upload priority=2 queue=Upload
add limit-at=1 max-limit=3400k name=0M-1M_P4_Download packet-mark=0M_P4_Traffic_Download parent=Total-Download priority=4 queue=Download
add limit-at=1 max-limit=512k name=0M-1M_P4_Upload packet-mark=0M_P4_Traffic_Upload parent=Total-Upload priority=4 queue=Upload
add limit-at=1 max-limit=3400k name=1M-3M_P5_Download packet-mark=1M_P5_Traffic_Download parent=Total-Download priority=5 queue=Download
add limit-at=1 max-limit=512k name=1M-3M_P5_Upload packet-mark=1M_P5_Traffic_Upload parent=Total-Upload priority=5 queue=Upload
add limit-at=1 max-limit=3400k name=3M-10M_P6_Download packet-mark=3M_P6_Traffic_Download parent=Total-Download priority=6 queue=Download
add limit-at=1 max-limit=512k name=3M-10M_P6_Upload packet-mark=3M_P6_Traffic_Upload parent=Total-Upload priority=6 queue=Upload
add limit-at=1 max-limit=3400k name=10M-30M_P7_Download packet-mark=10M_P7_Traffic_Download parent=Total-Download priority=7 queue=Download
add limit-at=1 max-limit=512k name=10M-30M_P7_Upload packet-mark=10M_P7_Traffic_Upload parent=Total-Upload priority=7 queue=Upload
add limit-at=1 max-limit=3400k name=30M-Infinite_P8_Download packet-mark=30M_P8_Traffic_Download parent=Total-Download \
queue=Download
add limit-at=1 max-limit=512k name=30M-Infinite_P8_Upload packet-mark=30M_P8_Traffic_Upload, parent=Total-Upload queue=\
Upload


Actually, when I tried to ping when the connection is overloaded, the ping doesn't take priority 1, the time in ms are higher than when the connections is with a normal use.

board-name: RB951Ui-2HnD
version: 6.34.1 (stable)
additional info: SOHO default configuration by MikroTik (dhcp, default filters, etc)

What I would like to do is to give priority to specific traffic, but doesn't work very well. Any advice? :(
 
pe1chl
Forum Guru
Forum Guru
Posts: 10240
Joined: Mon Jun 08, 2015 12:09 pm

Re: Mikrotik v6.33.3 QOS, queue tree

Fri Feb 19, 2016 11:21 am

It is too difficult to debug someone else's problem with just a snippet of the config, but I can assure you that
the queue tree works well here. But fast path needs to be off.
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1764
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: Mikrotik v6.33.3 QOS, queue tree

Fri Feb 19, 2016 11:28 am

Just fasttrack-connection all voip connections, and problem solved. (you will need to enable ip fastpath back )
 
fleegle
just joined
Posts: 6
Joined: Mon May 13, 2013 7:02 pm

Re: Mikrotik v6.33.3 QOS, queue tree

Fri Feb 19, 2016 2:23 pm

Hi all, thanks for taking your time, just to avoid reading the config, the algorithm is like this:

Ip firewall mangle
1- mark Icmp prerouting connections, pass-through =yes
2- mark packets of above icmp prerouting connection pass-through =no
3- mark Icmp postrouting connections pass-through =yes
4- mark packets of above rule pass-through =no

Queue tree
1-Parent upload and download created with just max limit setted to 90% of connection
2- create other queues with upload and download as parents and use the marks I setted up in mangle and give its priorities.

Problem
1- I tried to give priority 1 to icmp and give it a limit at and max limit options (I have tried almost every possible combination of limit at and max limit) and seems that that priority doesn't work as I expect, why? Because when the connections is not overloades the ping takes like 68ms the reach an Ip on the Internet, but when the bandwidht is reaching the max limit the ping starts to increment the time from 68ms to 159ms or more (250ms and more)

What I want?
Give icmp (or other protocols a real priority against the rest of traffic.

Thanks, I hope someone can help me.

PD. Haven't tried fast tracking very well, I'm gonna test it.

PD2. Disabling just fast path didn't work, but anyway I'm gonna try some other possible configs with fast path enabled.

Who is online

Users browsing this forum: Bing [Bot], Javokhir, pturmel, sindy, sirbryan, tdw and 209 guests