Broadcast's please! also multicasting.
BETA Testing and Feature Suggestions for the next RouterOS release (ROS v7)

3 posts   •   Page 1 of 1
ceacu
just joined
 
Posts: 8
Joined: Tue Nov 08, 2005 1:22 am

Broadcast's please! also multicasting.

by ceacu » Wed May 24, 2006 12:09 pm

Broadcast forwarding (on demand).
NAT from/to broadcast addresses.

It seems that this rule:
/ip firewall nat add chain=dstnat in-interface=WAN dst-address=WAN_IP protocol=udp dst-port=7 action=dst-nat to-addresses=LAN_BROADCAST_IP to-ports=7
kiks in but the packet is not forwarded.
Also the "fake" ARP entry is installed:
/ip arp add address=LAN_BROADCAST_IP mac-address=FF:FF:FF:FF:FF:FF interface=LAN

Is this a bug or is a 'feature' wich is not (yet) implemented?

Also:
/ip firewall nat add chain=dstnat in-interface=WAN dst-address=[255.255.255.255 or WAN_BROADCAST_IP] protocol=udp dst-port=xx action=dst-nat to-addresses=LAN_IP_XX to-ports=xx
didn't working.

Don't ask me why I need this.

Regards, Claudiu Marusceac.

reddflash
just joined
 
Posts: 7
Joined: Mon Dec 03, 2012 11:33 pm

Re: Broadcast's please! also multicasting.

by reddflash » Thu Oct 03, 2013 2:33 am

Same problem for me. Any explanations?

Best regards,
redd flash

User avatar
Chupaka
Forum Guru
Forum Guru
 
Posts: 7229
Joined: Mon Jun 19, 2006 11:15 pm
Location: Home Network Ltd., Minsk, Belarus

Re: Broadcast's please! also multicasting.

by Chupaka » Thu Oct 03, 2013 5:01 pm

maybe, that LAN_BROADCAST is received locally, that's why it's not forwarded. the same with router's addresses :)

in those network pervertions you can go further and try to route that packet to some fake gateway with 'ff:ff::ff' MAC address %) probably you will need VRF to move around local routes
For every complex problem, there is a solution that is simple, neat, and wrong.

¡ɹǝ|SOɹǝʇnoɹ ʞıʇoɹʞıW ɯ‚|

MikroTik. Your life. Your routing.

skype: pavel.skuratovich

3 posts   •   Page 1 of 1

Who is online

Users browsing this forum: Yahoo [Bot] and 13 guests

It is currently Sun Nov 23, 2014 2:43 pm