Community discussions

MikroTik App
 
Gitarex
just joined
Topic Author
Posts: 5
Joined: Thu Feb 01, 2024 9:05 am

mikrotik vlan mgmt, access ptp connect

Fri Mar 15, 2024 1:10 pm

Hi everyone !

I have a problem, I want to configure mikrotiki (Router, transmitter and receiver). The problem is to do it in such a way that from the administrative level (vlan89) you can "see" these devices, but from the client vlan level (vlan17) you cannot see the receiver and transmitter, and this is where the problem arises. I want to configure Vlan so that the router to the transmitter is tagged and also tagged from the transmitter to the receiver, but from the receiver so that untagged frames go to the client's host via the ether1 port (for security purposes, the client does not see the antennas at all and only has access to Internet.. Only the administrator should have visibility of all devices). What should you do to meet these guidelines?

Here is the configuration of my devices:

Router (main):
# 1970-01-07 22:52:40 by RouterOS 7.13.3
# software id = MDM3-964C
# model = RB750GL
/interface bridge
add admin-mac=4C:5E:0C:D7:C2:74 auto-mac=no comment=defconf name=LAN-Bridge
/interface ethernet
set [ find default-name=ether1 ] name=LAN
set [ find default-name=ether5 ] name=WAN
/interface vlan
add interface=LAN-Bridge name=vlan17 vlan-id=17
add interface=LAN-Bridge name=vlan89 vlan-id=89
/ip pool
add name=dhcp_vlan17 ranges=10.0.17.100-10.0.17.150
add name=dhcp_vlan89 ranges=10.0.89.100-10.0.89.150
add name=dhcp_bridge ranges=10.1.1.1-10.1.1.253
/ip dhcp-server
add address-pool=dhcp_vlan17 interface=vlan17 name=dhcp1
add address-pool=dhcp_vlan89 interface=vlan89 name=dhcp2
add address-pool=dhcp_bridge disabled=yes interface=LAN-Bridge name=dhcp3
/interface bridge port
add bridge=LAN-Bridge comment=defconf interface=LAN
add bridge=LAN-Bridge comment=defconf interface=ether2
add bridge=LAN-Bridge comment=defconf interface=ether3
add bridge=LAN-Bridge comment=defconf interface=ether4
add bridge=LAN-Bridge comment=defconf interface=WAN
/interface bridge vlan
add bridge=LAN-Bridge tagged=LAN vlan-ids=17
add bridge=LAN-Bridge tagged=LAN vlan-ids=89
/ip address
add address=10.1.1.254/24 disabled=yes interface=LAN-Bridge network=10.1.1.0
add address=10.109.3.80/24 interface=WAN network=10.109.3.0
add address=10.0.17.1/24 interface=vlan17 network=10.0.17.0
add address=10.0.89.1/24 interface=vlan89 network=10.0.89.0
/ip dhcp-client
add comment=defconf interface=LAN-Bridge
/ip dhcp-server network
add address=10.0.17.0/24 dns-server=1.1.1.1,8.8.8.8 gateway=10.0.17.1
add address=10.0.89.0/24 dns-server=1.1.1.1,8.8.8.8 gateway=10.0.89.1
/ip firewall nat
add action=masquerade chain=srcnat
/system note
set show-at-login=no

Transmitter:
# feb/23/2024 05:20:13 by RouterOS 6.49.8
# software id = ZE3R-73IY
#
# model = 911G-5HPacD
/interface bridge
add name=LAN-Bridge
/interface wireless
set [ find default-name=wlan1 ] antenna-gain=2 band=5ghz-onlyn channel-width=\
20/40mhz-Ce country=poland disabled=no frequency=auto installation=\
outdoor mode=bridge nv2-preshared-key=test1234 nv2-security=enabled \
radio-name=JPII ssid=MikroTik wireless-protocol=nv2
/interface vlan
add interface=LAN-Bridge name=vlan17 vlan-id=17
add interface=LAN-Bridge name=vlan89 vlan-id=89
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
/tool user-manager customer
set admin access=\
own-routers,own-users,own-profiles,own-limits,config-payment-gw
/interface bridge port
add bridge=LAN-Bridge interface=wlan1
add bridge=LAN-Bridge interface=ether1
add bridge=LAN-Bridge interface=vlan17
add bridge=LAN-Bridge interface=vlan89
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface bridge vlan
add bridge=LAN-Bridge untagged=wlan1 vlan-ids=17
add bridge=LAN-Bridge untagged=wlan1 vlan-ids=89
/interface list member
add comment=defconf interface=ether1 list=LAN
add comment=defconf interface=wlan1 list=WAN
/ip address
add address=192.168.1.2/24 interface=LAN-Bridge network=192.168.1.0
/ip dhcp-client
add disabled=no interface=LAN-Bridge
add disabled=no interface=vlan17
add disabled=no interface=vlan89
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 comment=defconf name=router.lan
/ip firewall filter
add action=accept chain=input comment=\
"defconf: accept established,related,untracked" connection-state=\
established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=\
"defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
connection-state=established,related
add action=accept chain=forward comment=\
"defconf: accept established,related, untracked" connection-state=\
established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
connection-state=invalid
add action=drop chain=forward comment=\
"defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
ipsec-policy=out,none out-interface-list=WAN
/ipv6 firewall address-list
add address=::/128 comment="defconf: unspecified address" list=bad_ipv6
add address=::1/128 comment="defconf: lo" list=bad_ipv6
add address=fec0::/10 comment="defconf: site-local" list=bad_ipv6
add address=::ffff:0.0.0.0/96 comment="defconf: ipv4-mapped" list=bad_ipv6
add address=::/96 comment="defconf: ipv4 compat" list=bad_ipv6
add address=100::/64 comment="defconf: discard only " list=bad_ipv6
add address=2001:db8::/32 comment="defconf: documentation" list=bad_ipv6
add address=2001:10::/28 comment="defconf: ORCHID" list=bad_ipv6
add address=3ffe::/16 comment="defconf: 6bone" list=bad_ipv6
/ipv6 firewall filter
add action=accept chain=input comment=\
"defconf: accept established,related,untracked" connection-state=\
established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
invalid
add action=accept chain=input comment="defconf: accept ICMPv6" protocol=\
icmpv6
add action=accept chain=input comment="defconf: accept UDP traceroute" port=\
33434-33534 protocol=udp
add action=accept chain=input comment=\
"defconf: accept DHCPv6-Client prefix delegation." dst-port=546 protocol=\
udp src-address=fe80::/10
add action=accept chain=input comment="defconf: accept IKE" dst-port=500,4500 \
protocol=udp
add action=accept chain=input comment="defconf: accept ipsec AH" protocol=\
ipsec-ah
add action=accept chain=input comment="defconf: accept ipsec ESP" protocol=\
ipsec-esp
add action=accept chain=input comment=\
"defconf: accept all that matches ipsec policy" ipsec-policy=in,ipsec
add action=drop chain=input comment=\
"defconf: drop everything else not coming from LAN" in-interface-list=\
!LAN
add action=accept chain=forward comment=\
"defconf: accept established,related,untracked" connection-state=\
established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
connection-state=invalid
add action=drop chain=forward comment=\
"defconf: drop packets with bad src ipv6" src-address-list=bad_ipv6
add action=drop chain=forward comment=\
"defconf: drop packets with bad dst ipv6" dst-address-list=bad_ipv6
add action=drop chain=forward comment="defconf: rfc4890 drop hop-limit=1" \
hop-limit=equal:1 protocol=icmpv6
add action=accept chain=forward comment="defconf: accept ICMPv6" protocol=\
icmpv6
add action=accept chain=forward comment="defconf: accept HIP" protocol=139
add action=accept chain=forward comment="defconf: accept IKE" dst-port=\
500,4500 protocol=udp
add action=accept chain=forward comment="defconf: accept ipsec AH" protocol=\
ipsec-ah
add action=accept chain=forward comment="defconf: accept ipsec ESP" protocol=\
ipsec-esp
add action=accept chain=forward comment=\
"defconf: accept all that matches ipsec policy" ipsec-policy=in,ipsec
add action=drop chain=forward comment=\
"defconf: drop everything else not coming from LAN" in-interface-list=\
!LAN
/system clock
set time-zone-name=Europe/Warsaw
/system identity
set name=MikroTik02
/system lcd
set contrast=0 enabled=no port=parallel type=24x4
/system lcd page
set time disabled=yes display-time=5s
set resources disabled=yes display-time=5s
set uptime disabled=yes display-time=5s
set packets disabled=yes display-time=5s
set bits disabled=yes display-time=5s
set version disabled=yes display-time=5s
set identity disabled=yes display-time=5s
set vlan89 disabled=yes display-time=5s
set vlan17 disabled=yes display-time=5s
set LAN-Bridge disabled=yes display-time=5s
set wlan1 disabled=yes display-time=5s
set ether1 disabled=yes display-time=5s
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
/tool user-manager database
set db-path=user-manager


Receiver (client side):
# feb/23/2024 04:47:20 by RouterOS 6.49.8
# software id = FFCK-QRZD
#
# model = 911-5HnD
/interface bridge
add name=LAN-Bridge
/interface vlan
add interface=LAN-Bridge name=vlan17 vlan-id=17
add interface=LAN-Bridge name=vlan89 vlan-id=89
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa-psk,wpa2-psk mode=dynamic-keys name=\
mikrotik_conn supplicant-identity="" wpa-pre-shared-key="papie\BFak69!" \
wpa2-pre-shared-key="papie\BFak69!"
/interface wireless
set [ find default-name=wlan1 ] antenna-gain=2 band=5ghz-onlyn channel-width=\
20/40mhz-Ce country=poland disabled=no frequency=auto installation=\
outdoor mode=station-bridge nv2-preshared-key=test1234 nv2-security=\
enabled radio-name=JP2 security-profile=mikrotik_conn ssid=MikroTik \
wireless-protocol=nv2
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
/interface bridge port
add bridge=LAN-Bridge interface=wlan1
add bridge=LAN-Bridge interface=ether1
add bridge=LAN-Bridge interface=vlan17
add bridge=LAN-Bridge interface=vlan89
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface bridge vlan
add bridge=LAN-Bridge untagged=ether1,wlan1 vlan-ids=17
add bridge=LAN-Bridge untagged=ether1,wlan1 vlan-ids=89
/interface list member
add comment=defconf interface=ether1 list=LAN
add comment=defconf interface=wlan1 list=WAN
/ip dhcp-client
add disabled=no interface=LAN-Bridge
add disabled=no interface=vlan89
add disabled=no interface=vlan17
/ip dns
set allow-remote-requests=yes servers=8.8.8.8
/ip dns static
add address=192.168.88.1 comment=defconf name=router.lan
/ip firewall filter
add action=accept chain=input comment=\
"defconf: accept established,related,untracked" connection-state=\
established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=\
"defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
connection-state=established,related
add action=accept chain=forward comment=\
"defconf: accept established,related, untracked" connection-state=\
established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
connection-state=invalid
add action=drop chain=forward comment=\
"defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
ipsec-policy=out,none out-interface-list=WAN
/system clock
set time-zone-name=Europe/Warsaw
/system identity
set name=MikroTik03
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN


Image
You do not have the required permissions to view the files attached to this post.
 
User avatar
anav
Forum Guru
Forum Guru
Posts: 19395
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada
Contact:

Re: mikrotik vlan mgmt, access ptp connect  [SOLVED]

Fri Mar 15, 2024 4:44 pm

What your missing is that each smart device should get an IP from a management vlan.
Data vlans 17 and 89 are carried forward to each smart device as well.
Assuming that the ROUTER has its own internal LAN, wheras, the receiver/txitter are acting solely as AP/switches and do not need an internal LAN so to speak.


You forget as the last rule change to make bridge vlan-filtering=yes.
There is no such bridge or wlan port called LAN, so first entry in /interface bridge ports should be removed!!!!!
Bridge needs to be tagged in /interface bridge vlans
Ensure you identify the out interface for source nat.
WAN port is not normally on bridge.....
WHY on WHY do you have IP DHCP client set to LAN bridge.......
It looks like you are getting a private IP address from an upstream modem router.......... no need for dhcp client (aka disabled) if you have put a static IP address for it. You will also need to add a manual route......
Highly recommend you do config on each device OFF bridge -see next ( okay your two rx, tx devices only have a single port, make sure you use safe mode to make changes. )

OFF Bridge ( for all three MT devices for configuration and emergency access )
- take one port off the bridge
- give it an IP address anything add address=192.168.55.1/24 interface=etherportX network=192.168.55.0
- add it to MGMT Interface as a member
- put static ipv4 setting on pc as 192.168.55.5 for example and you should have access.
- I have ether1as being local LAN access port, ether2 is a local access port for management network, ether3 trunk port going to MT TX, ether4 off bridge, ether5 is WAN
.......
Main differences for RX/TX from router.
No dhcp,
Only management vlan is tagged on bridge
Only management vlan is defined
Every smart device gets its IP address on the management vlan
...........
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
# model = RB750GL
/interface bridge
add admin-mac=4C:5E:0C:D7:C2:74 auto-mac=no comment=defconf name=LAN-Bridge vlan-filtering=yes
/interface list
add name=WAN
add name=LAN
add name=MGMT
/interface ethernet
set [ find default-name=ether1 ] name=LAN1
set [ find default-name=ether2 ] name=Mgmt2
set [ find default-name=ether3 ] name=TRUNK3
set [ find default-name=ether4 ] name=Off-Bridge
set [ find default-name=ether5 ] name=WAN5
/interface vlan
add interface=LAN-Bridge name=vlan17 vlan-id=17
add interface=LAN-Bridge name=vlan89 vlan-id=89
add interface=LAN-Bridge name=Home20 vlan-id=20
add interface=LAN-Bridge name=MGMT99  vlan-ids=99
/ip neighbor discovery-settings
set discover-interface-list=MGMT
/interface list member
add  interface=Vlan-MGMT  list=MGMT
add  interface=Vlan-MGMT  list=LAN
add interface=vlan17  list=LAN
add interface=vlan89  list=LAN
add interface=Home20  list=LAN
add interface=WAN5 list=WAN
/ip pool
add name=dhcp_vlan17 ranges=10.0.17.100-10.0.17.150
add name=dhcp_vlan89 ranges=10.0.89.100-10.0.89.150
add name=dhcp_vlan99 ranges=10.0.99.100-10.0.99.110
add name=dhcp_main ranges=10.1.1.1-10.1.1.253
/ip dhcp-server
add address-pool=dhcp_vlan17 interface=vlan17 name=dhcp1
add address-pool=dhcp_vlan89 interface=vlan89 name=dhcp2
add address-pool=dhcp_vlan99 interface=MGMT99 name=dhcp99
add address-pool=dhcp_main   interface=Home20 name=dhcp3
/interface bridge port
add bridge=LAN-Bridge comment=defconf interface=LAN1  ingress-filtering=yes  frame-types=admit-only-priority-and-untagged  pvid=20
add bridge=LAN-Bridge comment=defconf interface=Mgmt2  ingress-filtering=yes  frame-types=admit-only-priority-and-untagged  pvid=99
add bridge=LAN-Bridge comment=defconf interface=TRUNK3  ingress-filtering=yes  frame-types=admit-only-vlan-tagged
/interface bridge vlan
add bridge=LAN-Bridge tagged=LAN-Bridge  untagged=LAN1,  vlan-ids=20
add bridge=LAN-Bridge tagged=LAN-Bridge,Trunk3  untagged=Mgmt2,  vlan-ids=99
add bridge=LAN-Bridge tagged=LAN-Bridge,Trunk3  vlan-ids=17,89
/ip address
add address=10.109.3.80/24 interface=WAN5 network=10.109.3.0
add address=10.1.1.254/24  interface=Main20 network=10.1.1.0
add address=10.0.17.1/24 interface=vlan17 network=10.0.17.0
add address=10.0.89.1/24 interface=vlan89 network=10.0.89.0
add address=10.0.99.1/24 interface=MGMT99  network=10.0.99.0
/ip dhcp-client
add comment=defconf  disabled=yes
/ip dhcp-server network
add address=10.0.17.0/24 dns-server=10.0.17.1 gateway=10.0.17.1
add address=10.0.89.0/24 dns-server=10.0.89.1 gateway=10.0.89.1
add address=10.1.1.0/24 dns-server=10.1.1.254 gateway=10.1.1.254
add address=10.0.99.0/24 dns-server=10.0.99.1 gateway=10.0.99.1
/ip dns
set allow-remote-requests=yes servers=1.1.1.1,8.8.8.8
/ip firewall nat
add action=masquerade chain=srcnat out-interface-list=WAN
/ip route
add dst=0.0.0.0/0 gateway=10.109.3.1 routing-table=main
/tool mac-server
set allowed-interface-list=MGMT
/tool mac-server mac-winbox
set allowed-interface-list=MGMT



...

Remove static IP DNS from default settings.
Remove any ipv6 noise
no need for firewall, nat any router stuff...........
.........

Transmitter:
# feb/23/2024 05:20:13 by RouterOS 6.49.8
#
# model = 911G-5HPacD
/interface bridge
add name=TX-Bridge vlan-filtering=yes
/interface ethernet
set [ find default-name=ether1 ] name=TrunkPort-TX
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/interface wireless
set [ find default-name=wlan1 ] antenna-gain=2 band=5ghz-onlyn channel-width=\
20/40mhz-Ce country=poland disabled=no frequency=auto installation=\
outdoor mode=bridge nv2-preshared-key=test1234 nv2-security=enabled \
radio-name=JPII ssid=MikroTik wireless-protocol=nv2
/interface vlan
add interface=TX-Bridge name=vlan-MGMT vlan-id=99
/interface list
add name=MGMT
/tool user-manager customer
set admin access=\
own-routers,own-users,own-profiles,own-limits,config-payment-gw
/interface bridge port
add bridge=TX-Bridge interface=TrunkPort-TX ingress-filtering=yes  frame-types=admit-only-vlan-tagged 
add bridge=TX-Bridge  interface=wlan1 ingress-filtering=yes  frame-types=admit-only-vlan-tagged 
/ip neighbor discovery-settings
set discover-interface-list=MGMT
/interface bridge vlan
add bridge=TX-Bridge  tagged=TX-Bridge,TrunkPort-TX,wlan1   vlan-ids=17,89,99
/interface list member
add  interface=Vlan-MGMT  list=MGMT
/ip address
add address=10.0.99.2./24 interface=vlan-MGMT network=10.0.99.0
/ip dns
set allow-remote-requests=yes servers=10.0.99.1
/ip route
add dst-address=0.0.0.0/0 gateway=10.0.99.1  routing-table=main
/tool mac-server
set allowed-interface-list=MGMT
/tool mac-server mac-winbox
set allowed-interface-list=MGMT
...........
As per above, VLANs are not etherport or WLAN ports and not set in /interface bridge ports
..................


Receiver (client side):
# feb/23/2024 04:47:20 by RouterOS 6.49.8
#
# model = 911-5HnD

/interface bridge
add name=RX-Bridge vlan-filtering=yes
/interface ethernet
set [ find default-name=ether1 ] name=TrunkPort-RX
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa-psk,wpa2-psk mode=dynamic-keys name=\
mikrotik_conn supplicant-identity="" wpa-pre-shared-key="papie\BFak69!" \
wpa2-pre-shared-key="papie\BFak69!"
/interface wireless
set [ find default-name=wlan1 ] antenna-gain=2 band=5ghz-onlyn channel-width=\
20/40mhz-Ce country=poland disabled=no frequency=auto installation=\
outdoor mode=station-bridge nv2-preshared-key=test1234 nv2-security=\
enabled radio-name=JP2 security-profile=mikrotik_conn ssid=MikroTik \
wireless-protocol=nv2
/interface vlan
add interface=RX-Bridge name=vlan-MGMT vlan-id=99
/interface list
add name=MGMT
/interface bridge port
add bridge=RX-Bridge  interface=TrunkPort-TX ingress-filtering=yes  frame-types=admit-only-vlan-tagged 
add bridge=RX-Bridge  interface=wlan1 ingress-filtering=yes  frame-types=admit-only-vlan-tagged 
/ip neighbor discovery-settings
set discover-interface-list=MGMT
/interface bridge vlan
add bridge=RX-Bridge  tagged=RX-Bridge,TrunkPort-RX,wlan1   vlan-ids=17,89,99
/interface list member
add  interface=Vlan-MGMT  list=MGMT
/ip address
add address=10.0.99.3/24 interface=vlan-MGMT network=10.0.99.0
/ip dns
set allow-remote-requests=yes servers=10.0.99.1
/ip route
add dst-address=0.0.0.0/0 gateway=10.0.99.1  routing-table=main
/tool mac-server
set allowed-interface-list=MGMT
/tool mac-server mac-winbox
set allowed-interface-list=MGMT
 
Gitarex
just joined
Topic Author
Posts: 5
Joined: Thu Feb 01, 2024 9:05 am

Re: mikrotik vlan mgmt, access ptp connect

Mon Mar 18, 2024 9:29 am

What your missing is that each smart device should get an IP from a management vlan.
Data vlans 17 and 89 are carried forward to each smart device as well.
Assuming that the ROUTER has its own internal LAN, wheras, the receiver/txitter are acting solely as AP/switches and do not need an internal LAN so to speak.


You forget as the last rule change to make bridge vlan-filtering=yes.
There is no such bridge or wlan port called LAN, so first entry in /interface bridge ports should be removed!!!!!
Bridge needs to be tagged in /interface bridge vlans
Ensure you identify the out interface for source nat.
WAN port is not normally on bridge.....
WHY on WHY do you have IP DHCP client set to LAN bridge.......
It looks like you are getting a private IP address from an upstream modem router.......... no need for dhcp client (aka disabled) if you have put a static IP address for it. You will also need to add a manual route......
Highly recommend you do config on each device OFF bridge -see next ( okay your two rx, tx devices only have a single port, make sure you use safe mode to make changes. )

OFF Bridge ( for all three MT devices for configuration and emergency access )
- take one port off the bridge
- give it an IP address anything add address=192.168.55.1/24 interface=etherportX network=192.168.55.0
- add it to MGMT Interface as a member
- put static ipv4 setting on pc as 192.168.55.5 for example and you should have access.
- I have ether1as being local LAN access port, ether2 is a local access port for management network, ether3 trunk port going to MT TX, ether4 off bridge, ether5 is WAN
.......
Main differences for RX/TX from router.
No dhcp,
Only management vlan is tagged on bridge
Only management vlan is defined
Every smart device gets its IP address on the management vlan
...........
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
# model = RB750GL
/interface bridge
add admin-mac=4C:5E:0C:D7:C2:74 auto-mac=no comment=defconf name=LAN-Bridge vlan-filtering=yes
/interface list
add name=WAN
add name=LAN
add name=MGMT
/interface ethernet
set [ find default-name=ether1 ] name=LAN1
set [ find default-name=ether2 ] name=Mgmt2
set [ find default-name=ether3 ] name=TRUNK3
set [ find default-name=ether4 ] name=Off-Bridge
set [ find default-name=ether5 ] name=WAN5
/interface vlan
add interface=LAN-Bridge name=vlan17 vlan-id=17
add interface=LAN-Bridge name=vlan89 vlan-id=89
add interface=LAN-Bridge name=Home20 vlan-id=20
add interface=LAN-Bridge name=MGMT99  vlan-ids=99
/ip neighbor discovery-settings
set discover-interface-list=MGMT
/interface list member
add  interface=Vlan-MGMT  list=MGMT
add  interface=Vlan-MGMT  list=LAN
add interface=vlan17  list=LAN
add interface=vlan89  list=LAN
add interface=Home20  list=LAN
add interface=WAN5 list=WAN
/ip pool
add name=dhcp_vlan17 ranges=10.0.17.100-10.0.17.150
add name=dhcp_vlan89 ranges=10.0.89.100-10.0.89.150
add name=dhcp_vlan99 ranges=10.0.99.100-10.0.99.110
add name=dhcp_main ranges=10.1.1.1-10.1.1.253
/ip dhcp-server
add address-pool=dhcp_vlan17 interface=vlan17 name=dhcp1
add address-pool=dhcp_vlan89 interface=vlan89 name=dhcp2
add address-pool=dhcp_vlan99 interface=MGMT99 name=dhcp99
add address-pool=dhcp_main   interface=Home20 name=dhcp3
/interface bridge port
add bridge=LAN-Bridge comment=defconf interface=LAN1  ingress-filtering=yes  frame-types=admit-only-priority-and-untagged  pvid=20
add bridge=LAN-Bridge comment=defconf interface=Mgmt2  ingress-filtering=yes  frame-types=admit-only-priority-and-untagged  pvid=99
add bridge=LAN-Bridge comment=defconf interface=TRUNK3  ingress-filtering=yes  frame-types=admit-only-vlan-tagged
/interface bridge vlan
add bridge=LAN-Bridge tagged=LAN-Bridge  untagged=LAN1,  vlan-ids=20
add bridge=LAN-Bridge tagged=LAN-Bridge,Trunk3  untagged=Mgmt2,  vlan-ids=99
add bridge=LAN-Bridge tagged=LAN-Bridge,Trunk3  vlan-ids=17,89
/ip address
add address=10.109.3.80/24 interface=WAN5 network=10.109.3.0
add address=10.1.1.254/24  interface=Main20 network=10.1.1.0
add address=10.0.17.1/24 interface=vlan17 network=10.0.17.0
add address=10.0.89.1/24 interface=vlan89 network=10.0.89.0
add address=10.0.99.1/24 interface=MGMT99  network=10.0.99.0
/ip dhcp-client
add comment=defconf  disabled=yes
/ip dhcp-server network
add address=10.0.17.0/24 dns-server=10.0.17.1 gateway=10.0.17.1
add address=10.0.89.0/24 dns-server=10.0.89.1 gateway=10.0.89.1
add address=10.1.1.0/24 dns-server=10.1.1.254 gateway=10.1.1.254
add address=10.0.99.0/24 dns-server=10.0.99.1 gateway=10.0.99.1
/ip dns
set allow-remote-requests=yes servers=1.1.1.1,8.8.8.8
/ip firewall nat
add action=masquerade chain=srcnat out-interface-list=WAN
/ip route
add dst=0.0.0.0/0 gateway=10.109.3.1 routing-table=main
/tool mac-server
set allowed-interface-list=MGMT
/tool mac-server mac-winbox
set allowed-interface-list=MGMT



...

Remove static IP DNS from default settings.
Remove any ipv6 noise
no need for firewall, nat any router stuff...........
.........

Transmitter:
# feb/23/2024 05:20:13 by RouterOS 6.49.8
#
# model = 911G-5HPacD
/interface bridge
add name=TX-Bridge vlan-filtering=yes
/interface ethernet
set [ find default-name=ether1 ] name=TrunkPort-TX
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/interface wireless
set [ find default-name=wlan1 ] antenna-gain=2 band=5ghz-onlyn channel-width=\
20/40mhz-Ce country=poland disabled=no frequency=auto installation=\
outdoor mode=bridge nv2-preshared-key=test1234 nv2-security=enabled \
radio-name=JPII ssid=MikroTik wireless-protocol=nv2
/interface vlan
add interface=TX-Bridge name=vlan-MGMT vlan-id=99
/interface list
add name=MGMT
/tool user-manager customer
set admin access=\
own-routers,own-users,own-profiles,own-limits,config-payment-gw
/interface bridge port
add bridge=TX-Bridge interface=TrunkPort-TX ingress-filtering=yes  frame-types=admit-only-vlan-tagged 
add bridge=TX-Bridge  interface=wlan1 ingress-filtering=yes  frame-types=admit-only-vlan-tagged 
/ip neighbor discovery-settings
set discover-interface-list=MGMT
/interface bridge vlan
add bridge=TX-Bridge  tagged=TX-Bridge,TrunkPort-TX,wlan1   vlan-ids=17,89,99
/interface list member
add  interface=Vlan-MGMT  list=MGMT
/ip address
add address=10.0.99.2./24 interface=vlan-MGMT network=10.0.99.0
/ip dns
set allow-remote-requests=yes servers=10.0.99.1
/ip route
add dst-address=0.0.0.0/0 gateway=10.0.99.1  routing-table=main
/tool mac-server
set allowed-interface-list=MGMT
/tool mac-server mac-winbox
set allowed-interface-list=MGMT
...........
As per above, VLANs are not etherport or WLAN ports and not set in /interface bridge ports
..................


Receiver (client side):
# feb/23/2024 04:47:20 by RouterOS 6.49.8
#
# model = 911-5HnD

/interface bridge
add name=RX-Bridge vlan-filtering=yes
/interface ethernet
set [ find default-name=ether1 ] name=TrunkPort-RX
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa-psk,wpa2-psk mode=dynamic-keys name=\
mikrotik_conn supplicant-identity="" wpa-pre-shared-key="papie\BFak69!" \
wpa2-pre-shared-key="papie\BFak69!"
/interface wireless
set [ find default-name=wlan1 ] antenna-gain=2 band=5ghz-onlyn channel-width=\
20/40mhz-Ce country=poland disabled=no frequency=auto installation=\
outdoor mode=station-bridge nv2-preshared-key=test1234 nv2-security=\
enabled radio-name=JP2 security-profile=mikrotik_conn ssid=MikroTik \
wireless-protocol=nv2
/interface vlan
add interface=RX-Bridge name=vlan-MGMT vlan-id=99
/interface list
add name=MGMT
/interface bridge port
add bridge=RX-Bridge  interface=TrunkPort-TX ingress-filtering=yes  frame-types=admit-only-vlan-tagged 
add bridge=RX-Bridge  interface=wlan1 ingress-filtering=yes  frame-types=admit-only-vlan-tagged 
/ip neighbor discovery-settings
set discover-interface-list=MGMT
/interface bridge vlan
add bridge=RX-Bridge  tagged=RX-Bridge,TrunkPort-RX,wlan1   vlan-ids=17,89,99
/interface list member
add  interface=Vlan-MGMT  list=MGMT
/ip address
add address=10.0.99.3/24 interface=vlan-MGMT network=10.0.99.0
/ip dns
set allow-remote-requests=yes servers=10.0.99.1
/ip route
add dst-address=0.0.0.0/0 gateway=10.0.99.1  routing-table=main
/tool mac-server
set allowed-interface-list=MGMT
/tool mac-server mac-winbox
set allowed-interface-list=MGMT
Thank you very much for your clarification

Who is online

Users browsing this forum: MrdotApple, narapon and 15 guests