Simple OSPF problem
If you installed RouterOS just now, and don't know where to start - ask here!

2 posts   •   Page 1 of 1
jt2048
newbie
 
Posts: 40
Joined: Mon Feb 06, 2012 10:53 pm

Simple OSPF problem

by jt2048 » Thu Feb 16, 2012 11:53 pm

I'm trying to get an RB750 to join and existing (Fortigate) OSPF area. Routing is very simple in this area, all area 0, network 192.168.0.0/16 . I can see broadcasts being sent by both ends but can't form an adjacency (no neighbor on the RB750).

Config as follows;

[admin@MikroTik] /routing ospf network> print
Flags: X - disabled, I - invalid
# NETWORK AREA
0 192.168.0.0/16 backbone
==========================================================
[admin@MikroTik] /routing ospf interface> print
Flags: X - disabled, I - inactive, D - dynamic, P - passive
# INTERFACE COST PRI NETWORK-TYPE AUT... AUTHENTICATIO...
0 ether1-gateway 10 1 broadcast none
1 ether2-master-local 10 1 broadcast none
==========================================================
[admin@MikroTik] /routing ospf instance> print
Flags: X - disabled
0 ;;; foo
name="default" router-id=192.168.88.1 distribute-default=never
redistribute-connected=as-type-1 redistribute-static=as-type-1
redistribute-rip=no redistribute-bgp=no redistribute-other-ospf=no
metric-default=1 metric-connected=20 metric-static=20 metric-rip=20
metric-bgp=auto metric-other-ospf=auto in-filter=ospf-in
out-filter=ospf-out
==================
No neighbors
[admin@MikroTik] /routing ospf neighbor> print

[admin@MikroTik] /routing ospf neighbor>

Packet sniff from Fortigate end;

Fortigate-DE $ diagnose sniffer packet internal 'proto 89'
interfaces=[internal]
filters=[proto 89]
5.319350 192.168.250.1 -> 224.0.0.5: ip-proto-89 44
8.319288 192.168.51.1 -> 224.0.0.5: ip-proto-89 44
9.854719 192.168.51.116 -> 224.0.0.5: ip-proto-89 44
14.319342 192.168.250.1 -> 224.0.0.5: ip-proto-89 44
(RB750 broadcast in red)

I'm clearly missing something but what?

TIA ... JT

jt2048
newbie
 
Posts: 40
Joined: Mon Feb 06, 2012 10:53 pm

Re: Simple OSPF problem

by jt2048 » Sat Feb 18, 2012 1:59 am

And the answer is... :shock: User idiocy....

Somehow the instance-id was confused on the interface facing the rest of the system. I happened to disable ether1-gateway interface in OSPF and noticed that the new, dynamic interface was working (OSPF broadcast packets were the correct size for a system with an adjacency). I have no idea where that instance-id of 52 came from, I don't even know how to set one....

[admin@MikroTik] > /routing ospf interface print detail
Flags: X - disabled, I - inactive, D - dynamic, P - passive
0 X interface=ether1-gateway cost=10 priority=1 authentication=none
authentication-key="" authentication-key-id=1 network-type=broadcast
instance-id=52 retransmit-interval=5s transmit-delay=1s hello-interval=10s
dead-interval=40s use-bfd=no

1 interface=ether2-master-local cost=10 priority=1 authentication=none
authentication-key="" authentication-key-id=1 network-type=broadcast
instance-id=0 retransmit-interval=5s transmit-delay=1s hello-interval=10s
dead-interval=40s use-bfd=no

2 interface=Network 52 cost=10 priority=1 authentication=none
authentication-key="" authentication-key-id=1 network-type=broadcast
instance-id=0 retransmit-interval=5s transmit-delay=1s hello-interval=10s
dead-interval=40s use-bfd=no

3 D interface=ether1-gateway cost=10 priority=1 authentication=none
authentication-key="" authentication-key-id=1 network-type=broadcast
instance-id=0 retransmit-interval=5s transmit-delay=1s hello-interval=10s
dead-interval=40s use-bfd=no

(after deleting bogus instance)

[admin@MikroTik] > /routing ospf interface print detail
Flags: X - disabled, I - inactive, D - dynamic, P - passive
0 interface=ether2-master-local cost=10 priority=1 authentication=none
authentication-key="" authentication-key-id=1 network-type=broadcast
instance-id=0 retransmit-interval=5s transmit-delay=1s hello-interval=10s
dead-interval=40s use-bfd=no

1 interface=Network 52 cost=10 priority=1 authentication=none
authentication-key="" authentication-key-id=1 network-type=broadcast
instance-id=0 retransmit-interval=5s transmit-delay=1s hello-interval=10s
dead-interval=40s use-bfd=no

2 D interface=ether1-gateway cost=10 priority=1 authentication=none
authentication-key="" authentication-key-id=1 network-type=broadcast
instance-id=0 retransmit-interval=5s transmit-delay=1s hello-interval=10s
dead-interval=40s use-bfd=no
[admin@MikroTik] >

So, get everyone in the same instance and it works fine. Since I do have a network 52 I must have somehow fat fingered the instance ID, still not sure how. So, can I give myself karma now ? :lol:

2 posts   •   Page 1 of 1

Who is online

Users browsing this forum: Arcee, Bing [Bot] and 17 guests

It is currently Sun Nov 23, 2014 7:31 am