global-in / global-out - mangle
If you installed RouterOS just now, and don't know where to start - ask here!

5 posts   •   Page 1 of 1
macastefan
just joined
 
Posts: 3
Joined: Tue Mar 06, 2012 10:21 pm
Location: poland

global-in / global-out - mangle

by macastefan » Mon Apr 09, 2012 10:44 pm

Hello!
Can you tell me which entries are correct? (limit-at and max-limit are not important)

1.
I think that is correct:
Code: Select all
/ip firewall mangle
add chain=prerouting in-interface=LAN action=mark-packet new-packet-mark=upload
add chain=postrouting out-interface=LAN action=mark-packet new-packet-mark=download

/queue tree
add limit-at=10000000 max-limit=10000000 name=upload packet-mark=upload parent=global-in queue=upload-pcq
add limit-at=10000000 max-limit=10000000 name=download packet-mark=download parent=global-out queue=download-pcq



2.
I try mark and shape download and upload only in global-in
Code: Select all
/ip firewall mangle
add chain=prerouting in-interface=LAN1 action=mark-packet new-packet-mark=upload
add chain=prerouting in-interface=WAN action=mark-packet new-packet-mark=download

/queue tree
add limit-at=10000000 max-limit=10000000 name=upload packet-mark=upload parent=global-in queue=upload-pcq
add limit-at=10000000 max-limit=10000000 name=download packet-mark=download parent=global-in queue=download-pcq



3.
I try mark and shape download and upload only in global-out.
Code: Select all
/ip firewall mangle
add chain=postrouting out-interface=WAN action=mark-packet new-packet-mark=upload
add chain=postrouting out-interface=LAN1 action=mark-packet new-packet-mark=download

/queue tree
add limit-at=10000000 max-limit=10000000 name=upload packet-mark=upload parent=global-out queue=upload-pcq
add limit-at=10000000 max-limit=10000000 name=download packet-mark=download parent=global-out queue=download-pcq

jackman
Frequent Visitor
Frequent Visitor
 
Posts: 57
Joined: Tue Mar 13, 2012 6:30 am
Location: Jakarta, Indonesia

Re: global-in / global-out - mangle

by jackman » Wed Apr 11, 2012 11:19 am

As long as you marking the packet based on the interface all is fine. I think you don't even need to mark the packet.
May this could help

Tenny Bagindo

akosenko
newbie
 
Posts: 45
Joined: Fri Aug 21, 2009 8:56 am
Location: Lipetsk, Russia

Re: global-in / global-out - mangle

by akosenko » Wed Apr 11, 2012 3:52 pm

All three examples are correct. All as according to the rules described here http://wiki.mikrotik.com/wiki/NetworkPro_on_Quality_of_Service. And all 3 examples will be working correct with PCQ.

macastefan
just joined
 
Posts: 3
Joined: Tue Mar 06, 2012 10:21 pm
Location: poland

Re: global-in / global-out - mangle

by macastefan » Wed Apr 11, 2012 4:52 pm

thx! thx! thx!
Finally understood!

sankarklm
just joined
 
Posts: 20
Joined: Fri Aug 13, 2010 7:05 pm
Location: Bangalore,India

Re: global-in / global-out - mangle

by sankarklm » Wed Sep 25, 2013 2:10 pm

Hi

I was trying to free icmp from shaping, which was working on earlier versions, but on 6.XX i am find even though packet is getting marked, /queue tree is unable to capture it. especially on pre-routing.

[Mikrotik@MikroTik] /ip firewall mangle pr
Flags: X - disabled, I - invalid, D - dynamic
0 chain=prerouting action=mark-packet new-packet-mark=ICMP-IN passthrough=yes protocol=icmp

1 chain=postrouting action=mark-packet new-packet-mark=ICMP-OUT passthrough=yes protocol=icmp
[Mikrotik@MikroTik] > /queue tree print
Flags: X - disabled, I - invalid
0 name="ICMP-OUT" parent=global packet-mark=ICMP-OUT limit-at=0 queue=default priority=1 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s

1 name="ICMP-IN" parent=global packet-mark=ICMP-IN limit-at=0 queue=default priority=1 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s
Attachments
ICMP Mikrotik.png
ICMP Mikrotik.png (84.54 KiB) Viewed 2514 times

5 posts   •   Page 1 of 1

Who is online

Users browsing this forum: No registered users and 16 guests

It is currently Sat Nov 22, 2014 6:14 pm