DVR outside network access
BGP, OSFP, MPLS, MME, RIP, HWMPplus

benmikrotik
Frequent Visitor
Frequent Visitor
Posts: 64
Joined: Mon Apr 26, 2010 5:12 am
Reputation: 0
First RouterOS version: 4.6

DVR outside network access

by benmikrotik » Tue Jul 27, 2010 8:35 am

Hi,

How do I port forward to be able to access my DVR from outside the network. I could access it through LAN but not outside.

port tcp 34567
udp 34568
http 80

DVR IP 192.168.1.100
ISP's IP assigned to my WAN is 124.XXX.XXX.XXX

blake
Member
Member
Posts: 426
Joined: Mon May 31, 2010 10:46 pm
Reputation: 0
First RouterOS version: 3.30
Location: Arizona

Re: DVR outside network access

by blake » Tue Jul 27, 2010 8:55 am

http://wiki.mikrotik.com/wiki/Manual:IP ... rt_mapping

Code: Select all

/ip firewall nat
add chain=dstnat action=dst-nat protocol=tcp dst-address=124.XXX.XXX.XXX dst-port=80 to-addresses=192.168.1.100 to-ports=80
add chain=dstnat action=dst-nat protocol=tcp dst-address=124.XXX.XXX.XXX dst-port=34567 to-addresses=192.168.1.100 to-ports=34567
add chain=dstnat action=dst-nat protocol=udp dst-address=124.XXX.XXX.XXX dst-port=34568 to-addresses=192.168.1.100 to-ports=34568

You may need to add the following depending on your forward policy.

Code: Select all

/ip firewall filter
add chain=forward action=accept protocol=tcp dst-address=192.168.1.100 dst-port=80,34567
add chain=forward action=accept protocol=udp dst-address=192.168.1.100 dst-port=34568
IT consultant. Network manager. Packet junkie.
1-928-328-1509

benmikrotik
Frequent Visitor
Frequent Visitor
Posts: 64
Joined: Mon Apr 26, 2010 5:12 am
Reputation: 0
First RouterOS version: 4.6

Re: DVR outside network access

by benmikrotik » Tue Jul 27, 2010 6:36 pm

Thanks a lot blake, I have gotten it to work.

How important is the second code?

It's working without it.

blake
Member
Member
Posts: 426
Joined: Mon May 31, 2010 10:46 pm
Reputation: 0
First RouterOS version: 3.30
Location: Arizona

Re: DVR outside network access

by blake » Tue Jul 27, 2010 10:51 pm

If you have a deny (see below) at the end of your forward chain then you would need the second set of rules placed somewhere above that deny.

Code: Select all

/ip firewall filter add chain=forward action=drop
IT consultant. Network manager. Packet junkie.
1-928-328-1509

benmikrotik
Frequent Visitor
Frequent Visitor
Posts: 64
Joined: Mon Apr 26, 2010 5:12 am
Reputation: 0
First RouterOS version: 4.6

Re: DVR outside network access

by benmikrotik » Wed Jul 28, 2010 11:06 am

Thanks again. :D

Who is online

Users browsing this forum: No registered users and 2 guests

It is currently Fri Jul 31, 2015 1:58 am