Page 1 of 1

DVR outside network access

Posted: Tue Jul 27, 2010 8:35 am
by benmikrotik
Hi,

How do I port forward to be able to access my DVR from outside the network. I could access it through LAN but not outside.

port tcp 34567
udp 34568
http 80

DVR IP 192.168.1.100
ISP's IP assigned to my WAN is 124.XXX.XXX.XXX

Re: DVR outside network access

Posted: Tue Jul 27, 2010 8:55 am
by blake
http://wiki.mikrotik.com/wiki/Manual:IP ... rt_mapping
/ip firewall nat
add chain=dstnat action=dst-nat protocol=tcp dst-address=124.XXX.XXX.XXX dst-port=80 to-addresses=192.168.1.100 to-ports=80
add chain=dstnat action=dst-nat protocol=tcp dst-address=124.XXX.XXX.XXX dst-port=34567 to-addresses=192.168.1.100 to-ports=34567
add chain=dstnat action=dst-nat protocol=udp dst-address=124.XXX.XXX.XXX dst-port=34568 to-addresses=192.168.1.100 to-ports=34568
You may need to add the following depending on your forward policy.
/ip firewall filter
add chain=forward action=accept protocol=tcp dst-address=192.168.1.100 dst-port=80,34567
add chain=forward action=accept protocol=udp dst-address=192.168.1.100 dst-port=34568

Re: DVR outside network access

Posted: Tue Jul 27, 2010 6:36 pm
by benmikrotik
Thanks a lot blake, I have gotten it to work.

How important is the second code?

It's working without it.

Re: DVR outside network access

Posted: Tue Jul 27, 2010 10:51 pm
by blake
If you have a deny (see below) at the end of your forward chain then you would need the second set of rules placed somewhere above that deny.
/ip firewall filter add chain=forward action=drop

Re: DVR outside network access

Posted: Wed Jul 28, 2010 11:06 am
by benmikrotik
Thanks again. :D