PIM/IGMP over OVPN
BGP, OSFP, MPLS, MME, RIP, HWMPplus

3 posts   •   Page 1 of 1
Rattlehead
just joined
 
Posts: 20
Joined: Mon Mar 01, 2010 3:09 pm

PIM/IGMP over OVPN

by Rattlehead » Tue Jun 21, 2011 2:03 pm

Hey guys, looking for a small bit of assistance regarding the below setup.
We have a core router 750G "VPN Concentrator" connected to one of our own connections (I work for an ISP) that provides TV streaming.
There are several of us that are not on our own ISP network (using diff providers) and wish to be able to take advantage of our own streams. So we have decided to setup our own network using oVPN, IGMP, PIM and BGP in an attempt to facilitate this. Basically we want the concentrator to subscribe to the feed the same way that a client machine would.
{see network Diagram below}
Image

Each user or VPN client is assigned a IP statically from the 172.29.0.0/24 range. oVPN is set to eth mode. .1 always being the concentrator and then incrementing +1 for each client.
Main issue we have is that we can see the group joins on each of the clients when a request comes in, but there is no sign of it being seen on the concentrator.

Rattlehead
just joined
 
Posts: 20
Joined: Mon Mar 01, 2010 3:09 pm

Re: PIM/IGMP over OVPN

by Rattlehead » Wed Jun 22, 2011 1:00 am

Trying a slightly different approach to this problem. We are just going to try and stick with and cascade IGMP-P and not overly complicate things.
The issue we are seeing is that on the client routers (Router A, B....) when a request is made. The request is seen on the client router but under the MFC while the Group and Source are correct in the details. the upstream interface is coming up as "unknown" as apposed the oVPN interface.
for e.g I should see an entry like
Group Source Upstream IF Downstream
239.192.193.1 172.29.1.10 oVPN LAN

but as I said upstream shows as unknown while downstream is blank.
I do however get every so often (even when a request isn't being made)
Group Source Upstream IF Downstream
239.255.255.250 172.29.1.10 oVPN LAN

User avatar
janisk
MikroTik Support
MikroTik Support
 
Posts: 5906
Joined: Tue Feb 14, 2006 10:46 am
Location: Riga, Latvia

Re: PIM/IGMP over OVPN

by janisk » Tue Jul 05, 2011 11:41 am

could you try other tunnel (like L2TP could be better suited for the task). On the other hand, any tunnel should work.

Also, if you have chain of routers, are requests propagated correctly through all the routers, and what happens if you set up manual MFC?

Also, all this is somehow fragile, so it would be good idea to set up configuration and then reboot the router.

3 posts   •   Page 1 of 1

Who is online

Users browsing this forum: Exabot [Bot] and 5 guests

It is currently Sun Nov 23, 2014 7:28 am