RB450G + openwrt Metarouter strange problem
MetaRouter, KVM and Xen

222 posts   •   Page 1 of 5   •   1, 2, 3, 4, 5
User avatar
webasdf
Frequent Visitor
Frequent Visitor
 
Posts: 78
Joined: Mon Jan 26, 2009 7:37 pm

RB450G + openwrt Metarouter strange problem

by webasdf » Fri Oct 16, 2009 5:24 pm

I compiled my own version of openWRT for Metarouter according to the instructions found in the Metarouter wiki article. I used this metarouter image with no problems at all on a 433AH (mikrotik firmware 3.30). When I tried the same image on the 450G (both 3.30 and 4.0 firmware), I get the following strange behavior:

  • Metarouter starts fine on router boot
  • After anywhere between 5 and 45 minutes, the router reboots itself
  • I turned on logging and saw "system error - router was rebooted without proper shutdown by watchdog timer" (Kernel panic from RouterOS??)
  • Sometimes the meta router also locks up on the 450G and I have to manually disable and re-enable the metarouter (effectively rebooting it) to get it working again.

Has anyone else seen these problems in this configuration? I tried Mikrotik 3.30 and new 4.0 firmware and still same strange issues. Any ideas on how to correct this?

User avatar
janisk
MikroTik Support
MikroTik Support
 
Posts: 5906
Joined: Tue Feb 14, 2006 10:46 am
Location: Riga, Latvia

Re: RB450G + openwrt Metarouter strange problem

by janisk » Mon Oct 19, 2009 10:12 am

can you get more information about your router? i am trying to reproduce it on my test RB450G with 2.23 boot loader 4.1 RouterOS and it does not hand or reboot.

edit: also, what is CPU frequency of that board?

User avatar
webasdf
Frequent Visitor
Frequent Visitor
 
Posts: 78
Joined: Mon Jan 26, 2009 7:37 pm

Re: RB450G + openwrt Metarouter strange problem

by webasdf » Mon Oct 19, 2009 4:22 pm

CPU frequency is 680MHz.
I'm not sure on the boot loader version. Is this only visible on the serial interface? I'm not local to the unit as I work off-site, but I can get someone to serial into the 450G to find this out if you think it is important.

I've noticed that problems seems to happen when I'm doing network I/O on the Metarouter. If no network I/O on the metarouter happens, it is very stable. But, once I SSH into the metarouter and start doing a top or other command line tasks, it only lasts a little while before lock up or reboot. One thing I did differently just a few minutes ago was to re-upload the image by scp. I previously uploaded by FTP and I'm not sure if it was in binary mode. Obviously, this would cause big problems. I'm trying the same tests on the new metarouter now and will post results.

I also haven't tried the default WRT build that Normis posted in another thread (I think Normis posted it). I am still using the build that I built.

User avatar
webasdf
Frequent Visitor
Frequent Visitor
 
Posts: 78
Joined: Mon Jan 26, 2009 7:37 pm

Re: RB450G + openwrt Metarouter strange problem

by webasdf » Mon Oct 19, 2009 9:47 pm

Tried the pre-built image posted by Normis. Made sure I used scp to ensure binary transfer. Same issue. We were testing some VLAN settings on the same board and it ended up in a perpetual boot state.

We attempted to reload firmware via netinstall, but no success. Stuck on the message "sending offer". We tried to flash it with the 4.0 net installer (per other forum posts), but same thing. After taking power off for a while and powering it back up, it was able to boot again. We did a memory scan from bios and it didn't appear there were any memory problems. Then, we reset all configurations. I also found a way to upgrade the boot loader from the forums. So, I did that. Previous version was 2.20 and I upgraded to 2.23. Then, re-configured router from scratch.

After all this, same issue. Random reboots when doing I/O on the metarouter on 450G. Just to check, I did the same thing to a 433AH and no issue there.

Should we keep trying to netinstall or does this point to a hardware problem?

User avatar
webasdf
Frequent Visitor
Frequent Visitor
 
Posts: 78
Joined: Mon Jan 26, 2009 7:37 pm

Re: RB450G + openwrt Metarouter strange problem

by webasdf » Mon Oct 19, 2009 10:46 pm

BTW, exactly what I'm doing when this happens:
In winbox, I have console open and running top

In an ssh session remotely, I am executing a shell script:
Code: Select all
#!/bin/sh
while true
do
clear
date
df -h
uptime
sleep 3
done


If I let these conditions go for 40-60 minutes, router will reboot at some point in there. I've also noticed that router will reboot during these conditions if some other random events happen on the router.

The meta router is set up on a bridge called "wrt". IP address on wrt bridge is 10.20.1.1/30. IP address on meta router is 10.20.1.2/30. Gateway and DNS are set up on meta router. Dstnat is used to get to meta router ssh remotely via tcp port 3333.

I was also able to get the 450G to reboot when simply letting top run in that same image (while leaving winbox open to monitor it) and disabling the metarouter interfaces and metarouter bridge altogether. It happened in about the same amount of time....last time, it took about an hour.

Tried a different 450G board w/ the posted image (not my compiled one) and same result. I've tried everything I know to try and still get this problem.

User avatar
janisk
MikroTik Support
MikroTik Support
 
Posts: 5906
Joined: Tue Feb 14, 2006 10:46 am
Location: Riga, Latvia

Re: RB450G + openwrt Metarouter strange problem

by janisk » Tue Oct 20, 2009 9:17 am

thank you for reporting in detail. We are looking into the problem.

Bootloader version can be seen under /system routerboard print

[admin@MikroTik] > system routerboard print
Code: Select all
       routerboard: yes
             model: "600"
     serial-number: "ASDFASDFASD"
  current-firmware: "2.20"
  upgrade-firmware: "2.20"


under that menu there are many interesting things that usually you can change at boot time while hanging in bootlaoders menus.

User avatar
webasdf
Frequent Visitor
Frequent Visitor
 
Posts: 78
Joined: Mon Jan 26, 2009 7:37 pm

Re: RB450G + openwrt Metarouter strange problem

by webasdf » Tue Oct 20, 2009 3:47 pm

Were you able to reproduce the problem?

User avatar
janisk
MikroTik Support
MikroTik Support
 
Posts: 5906
Joined: Tue Feb 14, 2006 10:46 am
Location: Riga, Latvia

Re: RB450G + openwrt Metarouter strange problem

by janisk » Tue Oct 20, 2009 3:53 pm

i got one problem, but not sure that is one you got on your router.

can you do the following:

1) disable watchdog timer
Code: Select all
system watchdog set watchdog-timer=no

2) check if your router reboots. or something freezes when you think that it should have been hanged. for example do /ip proxy print

User avatar
soho
newbie
 
Posts: 28
Joined: Sat Sep 09, 2006 3:05 am

Re: RB450G + openwrt Metarouter strange problem

by soho » Tue Oct 20, 2009 5:24 pm

janisk wrote:i got one problem, but not sure that is one you got on your router.

can you do the following:

1) disable watchdog timer
Code: Select all
system watchdog set watchdog-timer=no

2) check if your router reboots. or something freezes when you think that it should have been hanged. for example do /ip proxy print



I have this same problem on RB450G.

I did update for 4.1, bootloader 2.23, watchdog disable and this problem persist.
I did downgrade for 3.30, bootloader 2.20, watchdog disable and this problem persist.
I did downgrade for 3.28, bootloader 2.20, watchdog disable and this problem persist.

I have a RB493AUH with 3.28 version and 2.20 bootloader and this problem not occurs (yet).

User avatar
webasdf
Frequent Visitor
Frequent Visitor
 
Posts: 78
Joined: Mon Jan 26, 2009 7:37 pm

Re: RB450G + openwrt Metarouter strange problem

by webasdf » Tue Oct 20, 2009 6:03 pm

OK.
  • Disabled watchdog timer.
  • Started top from command line on console inside my wrt metarouter (previously posted image by Normis).
  • The metarouter had no network communications enabled, so it was not doing network i/o
  • About an hour later, it locked up and didn't reboot...had to kill power and restart manually

I also tried to import the pre-built wrt metarouter image onto a regular RB450 and got an immediate reboot. After reboot happened, the metarouter listing was not there.

Thanks for the input Soho. At least I know I'm not doing something wrong with the Metarouter. :)

User avatar
soho
newbie
 
Posts: 28
Joined: Sat Sep 09, 2006 3:05 am

Re: RB450G + openwrt Metarouter strange problem

by soho » Tue Oct 20, 2009 10:28 pm

webasdf wrote:OK.
  • Disabled watchdog timer.
  • Started top from command line on console inside my wrt metarouter (previously posted image by Normis).
  • The metarouter had no network communications enabled, so it was not doing network i/o
  • About an hour later, it locked up and didn't reboot...had to kill power and restart manually

I also tried to import the pre-built wrt metarouter image onto a regular RB450 and got an immediate reboot. After reboot happened, the metarouter listing was not there.

Thanks for the input Soho. At least I know I'm not doing something wrong with the Metarouter. :)



Interesting is the problem, as you mentioned ... The system (Mikrotik) freezes and back without me doing anything. You lose access to Mikrotik, it seems that the interfaces simply stop responding. When the system returns, there is no log, as if nothing had happened.

In one of these frozen I turned off the RB and when I turned on, the image of OpenWRT simply disappeared (deleted).

User avatar
webasdf
Frequent Visitor
Frequent Visitor
 
Posts: 78
Joined: Mon Jan 26, 2009 7:37 pm

Re: RB450G + openwrt Metarouter strange problem

by webasdf » Wed Oct 21, 2009 4:10 pm

Can we hope for a fix from Mikrotik in the next stable software release?

User avatar
janisk
MikroTik Support
MikroTik Support
 
Posts: 5906
Joined: Tue Feb 14, 2006 10:46 am
Location: Riga, Latvia

Re: RB450G + openwrt Metarouter strange problem

by janisk » Thu Oct 22, 2009 12:58 pm

what else you have configured on your board?

i am running RB450G with normis posted OpenWRT image and its uptime is several hours already and nothing has hanged. i am using that router as gateway.

User avatar
soho
newbie
 
Posts: 28
Joined: Sat Sep 09, 2006 3:05 am

Re: RB450G + openwrt Metarouter strange problem

by soho » Thu Oct 22, 2009 3:04 pm

janisk wrote:what else you have configured on your board?

i am running RB450G with normis posted OpenWRT image and its uptime is several hours already and nothing has hanged. i am using that router as gateway.


Code: Select all
[admin@MetaRouter] > metarouter export
# oct/22/2009 10:02:39 by RouterOS 3.28
# software id = 8SUH-T8YM
#
/metarouter
add comment="" disabled=no disk-size=unlimited memory-size=128MiB name=mr2
/metarouter interface
add comment="" disabled=no dynamic-bridge=none dynamic-mac-address=02:5D:55:6F:7F:98 type=dynamic virtual-machine=mr2 \
    vm-mac-address=02:11:54:6C:27:89


Code: Select all
[admin@MetaRouter] > interface export
# oct/22/2009 10:03:27 by RouterOS 3.28
# software id = 8SUH-T8YM
#
/interface ethernet
set 0 arp=enabled auto-negotiation=yes comment="" disabled=no full-duplex=yes l2mtu=1526 mac-address=00:0C:42:54:05:ED \
    mtu=1500 name=ether1 speed=100Mbps
set 1 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited comment="" disabled=no full-duplex=yes l2mtu=1524 \
    mac-address=00:0C:42:54:05:EE master-port=none mtu=1500 name=ether2 speed=100Mbps
set 2 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited comment="" disabled=no full-duplex=yes l2mtu=1524 \
    mac-address=00:0C:42:54:05:EF master-port=none mtu=1500 name=ether3 speed=100Mbps
set 3 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited comment="" disabled=no full-duplex=yes l2mtu=1524 \
    mac-address=00:0C:42:54:05:F0 master-port=none mtu=1500 name=ether4 speed=100Mbps
set 4 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited comment="" disabled=yes full-duplex=yes \
    mac-address=00:0C:42:54:05:F1 master-port=none mtu=1500 name=ether5 speed=100Mbps
/interface bridge settings
set use-ip-firewall=yes use-ip-firewall-for-pppoe=yes use-ip-firewall-for-vlan=yes
/interface ethernet mirror
set mirror-port=none source-port=none
/interface l2tp-server server
set authentication=pap,chap,mschap1,mschap2 default-profile=default-encryption enabled=no max-mru=1460 max-mtu=1460 \
    mrru=disabled
/interface ovpn-server server
set auth=sha1,md5 certificate=none cipher=blowfish128,aes128 default-profile=default enabled=no keepalive-timeout=60 \
    mac-address=FE:D0:41:7D:84:65 max-mtu=1500 mode=ip netmask=24 port=1194 require-client-certificate=no
/interface pptp-server server
set authentication=mschap1,mschap2 default-profile=default-encryption enabled=no keepalive-timeout=30 max-mru=1460 \
    max-mtu=1460 mrru=disabled


Code: Select all
[admin@MetaRouter] > ip address print
Flags: X - disabled, I - invalid, D - dynamic
 #   ADDRESS            NETWORK         BROADCAST       INTERFACE                                                       
 0   192.168.1.254/24   192.168.1.0     192.168.1.255   vif1                                                             
 1 D 10.10.200.2/28     10.10.200.0     10.10.200.15    ether1                                                           
[admin@MetaRouter] > ip route print
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
B - blackhole, U - unreachable, P - prohibit
 #      DST-ADDRESS        PREF-SRC        GATEWAY-STATE GATEWAY                        DISTANCE INTERFACE               
 0 ADS  0.0.0.0/0                          reachable     10.10.200.1                    0        ether1                 
 1 ADC  10.10.200.0/28     10.10.200.2                                                  0        ether1                 
 2 ADC  192.168.1.0/24     192.168.1.254                                                0        vif1                   
[admin@MetaRouter] >


Code: Select all
[admin@MetaRouter] > system watchdog export
# oct/22/2009 11:29:29 by RouterOS 3.28
# software id = 8SUH-T8YM
#
/system watchdog
set auto-send-supout=no automatic-supout=no no-ping-delay=5m watch-address=none watchdog-timer=no



No more configuration in RB450G.

User avatar
webasdf
Frequent Visitor
Frequent Visitor
 
Posts: 78
Joined: Mon Jan 26, 2009 7:37 pm

Re: RB450G + openwrt Metarouter strange problem

by webasdf » Thu Oct 22, 2009 4:48 pm

janisk wrote:what else you have configured on your board?

i am running RB450G with normis posted OpenWRT image and its uptime is several hours already and nothing has hanged. i am using that router as gateway.


OpenWRT image runs fine until you start doing things with it. For example, we run top command from OpenWRT, leave console open and router will reboot itself (kernel panic) within an hour. If we aren't really doing anything with OpenWRT, it is fine and doesn't reboot. I also just got the box to reboot itself in about 5 minutes (console in winbox was closed) running top on the WRT image in an SSH session from a remote client...give it a try...

The system is currently not in production anywhere...is a development system (we are developing some custom html pages inside the metarouter...at least we hope to if this problem can be solved.)

General specs
  • The board itself is a standard RB450G
  • 256MB memory
  • CPU: MIPS 24K V7.4 @ 680MHz
  • 520MB flash HDD space
  • No other devices are attached (I don't think there are any ports to do this anyway)
  • Running RouterOS version 3.30 (tried 4.0 and 4.1....all do the same thing)
  • Boot loader version 2.20 (although on another board we tried, 2.23 was installed)

Installed packages
We are primarily using these as hotspot gateways (basic NAT only), so if there are any suggested packages that we can remove or disable that may fix the problem, please suggest :)
  • calea
  • routeros-mipsbe
  • advanced-tools
  • dhcp
  • hotspot
  • ipv6 (disabled)
  • ppp
  • routerboard
  • routing
  • routing-test (disabled)
  • security
  • system
  • wireless
  • user-manager

Metarouter specs
  • openWRT image (posted by Normis)
  • memory 16 MB
  • disk size 128000kiB

Do you need any other information? If you need, I can send a support.rif as well.

Thanks.

enderx
just joined
 
Posts: 6
Joined: Fri Sep 04, 2009 7:16 pm

Re: RB450G + openwrt Metarouter strange problem

by enderx » Fri Oct 23, 2009 5:46 pm

Ditto.

Things I've tried that don't fix the problem:
Underclocking doesn't help.
Cannot be forced to produce.. (doing a bunch of stressful tasks in the openwrt does not reboot it.)
never writing to the disk subsystem has no effect.
Openwrt never shows any kernel errors.

I'm kinda concerned about the metarouter feature.. just doesn't seem to be very important.

User avatar
webasdf
Frequent Visitor
Frequent Visitor
 
Posts: 78
Joined: Mon Jan 26, 2009 7:37 pm

Re: RB450G + openwrt Metarouter strange problem

by webasdf » Fri Oct 23, 2009 8:23 pm

enderx wrote:Ditto.

Things I've tried that don't fix the problem:
Underclocking doesn't help.
Cannot be forced to produce.. (doing a bunch of stressful tasks in the openwrt does not reboot it.)
never writing to the disk subsystem has no effect.
Openwrt never shows any kernel errors.

I'm kinda concerned about the metarouter feature.. just doesn't seem to be very important.


Hopefully Mikrotik can reproduce our problems and fix in the next RouterOS version, but I haven't heard that they will do so at this time. IMHO - Almost seems like a memory leak somewhere in metarouter causing kernel panic and router reboot...

QpoX
Member
Member
 
Posts: 387
Joined: Mon Mar 24, 2008 8:42 pm
Location: Lemvig, Denmark

Re: RB450G + openwrt Metarouter strange problem

by QpoX » Sat Oct 24, 2009 6:09 am

Did also have problems with Metarouter on my RB750 (i have 4) and RB411U when i add a metarouter (just RouterOS) and both with and without network on it.
It starts up (can see it using metarouter console), then i get disconnected from Winbox and i can't get in again...
Just gets random reboots after i got kick'd out from the box.
Even using telnet or ssh i can't login, and typing username takes some time before i see what was type'd and same on serial on RB411U.
Did also try with OpenWRT with 8 and 16MB of Ram same result.

So did need to netinstall both before i could them running again!

I was using 4.1 and 3.30 running the latest firmware.
And making a Supout was a no go since i could not login after this!

User avatar
janisk
MikroTik Support
MikroTik Support
 
Posts: 5906
Joined: Tue Feb 14, 2006 10:46 am
Location: Riga, Latvia

Re: RB450G + openwrt Metarouter strange problem

by janisk » Mon Oct 26, 2009 9:38 am

metarouter by default assigns minimum amount of RAM to the system - 16MB that might cause problems with it on boards that have 32MB of ram..

About Metarouter on RB450G, that have plentiful storage and RAM to run several metarouter instances - Normis posted image hanged once, last week. after that - metarouter has ran bash script posted in one of previous posts (viewtopic.php?p=176206#p176206) non-stop every second.

From last post about configuration - i do not have calea package installed. Maybe you could send e-mail to support with details - how we could get connected to that board, since my RB450G at this moment seem to be resilient to this problem.

User avatar
webasdf
Frequent Visitor
Frequent Visitor
 
Posts: 78
Joined: Mon Jan 26, 2009 7:37 pm

Re: RB450G + openwrt Metarouter strange problem

by webasdf » Mon Oct 26, 2009 7:16 pm

janisk wrote:From last post about configuration - i do not have calea package installed.

I disabled calea ran same tests, and still same result. Rebooted itself in only 5 minutes this time.

janisk wrote:Maybe you could send e-mail to support with details - how we could get connected to that board, since my RB450G at this moment seem to be resilient to this problem.

I have contacted you at support with router IP details.

enderx
just joined
 
Posts: 6
Joined: Fri Sep 04, 2009 7:16 pm

Re: RB450G + openwrt Metarouter strange problem

by enderx » Wed Oct 28, 2009 7:22 pm

Conclusion.. Bad power supplies..

badpowersupply.jpg
badpowersupply.jpg (33.65 KiB) Viewed 22027 times


I've moved to using POE and different supply.. works good so far.. 18 hours. on a 12v 1A supply.

enderx
just joined
 
Posts: 6
Joined: Fri Sep 04, 2009 7:16 pm

Re: RB450G + openwrt Metarouter strange problem

by enderx » Wed Oct 28, 2009 10:34 pm

Maybe not bad power supply.. maybe more toward something wrong with using the barrel jacks on the 450g.
That would be pretty wild if the flaw in it would only be exposed when you used metarouter features with openwrt images... please someone tell me I'm not crazy. :-)

Edited:
Never mind.. finally crashed using poe with stock power supply. Definitely a power supply problem. regardless of POE or barrels.

User avatar
webasdf
Frequent Visitor
Frequent Visitor
 
Posts: 78
Joined: Mon Jan 26, 2009 7:37 pm

Re: RB450G + openwrt Metarouter strange problem

by webasdf » Thu Oct 29, 2009 5:00 pm

We are using the same power supply. We will try a different power supply with more watts to see if that helps.

enderx
just joined
 
Posts: 6
Joined: Fri Sep 04, 2009 7:16 pm

Re: RB450G + openwrt Metarouter strange problem

by enderx » Thu Oct 29, 2009 5:26 pm

Seems like the power regulating circuitry is more robust on the POE instead of the barrels... I've ran 19 hours using the POE and Original power supply pictured above. One reboot in 23 hours. My other box is still running on the 12v 1A via POE, 23 hours no reboots.
For a while there ASDF I thought I caught your virus.. you mentioned instability and Boom! instability appeared.
Sure glad we figured this out.. I was getting worried I was going to have to come up with a different more expensive and less elegant solution. We planned on buying 250 boxes.. I was having nightmares of what that was going to be like.
Sam.

PS wish I could get a level4+ x86 license

User avatar
webasdf
Frequent Visitor
Frequent Visitor
 
Posts: 78
Joined: Mon Jan 26, 2009 7:37 pm

Re: RB450G + openwrt Metarouter strange problem

by webasdf » Fri Oct 30, 2009 12:26 am

enderx wrote:Seems like the power regulating circuitry is more robust on the POE instead of the barrels... I've ran 19 hours using the POE and Original power supply pictured above. One reboot in 23 hours. My other box is still running on the 12v 1A via POE, 23 hours no reboots.


Well, that seems to have worked! We found a 12v 1.5A power supply in the lab and gave it a shot...uptime is currently 23 hours and it seems to be very stable. We are planning on testing the higher wattage power supply available from roc-noc or other Tik dealers (http://www.roc-noc.com/product.php?productid=89&cat=3&page=1). It's 24VDC 1.6 amp instead of the 24VDC 800 mA on the other power supply that seems to have caused this issue.

I will post our results. Strange thing is, I have a different 433AH board that I power with 12VDC 300mA supply and it is very stable (no issues w/ metarouter at all on that board).

Any input from Mikrotik as to why a lower wattage power supply would cause this problem? Does the board use more power when Metarouter is enabled?

User avatar
janisk
MikroTik Support
MikroTik Support
 
Posts: 5906
Joined: Tue Feb 14, 2006 10:46 am
Location: Riga, Latvia

Re: RB450G + openwrt Metarouter strange problem

by janisk » Fri Oct 30, 2009 12:37 pm

RB433AH is different board, different hardware, that is why there is a difference.

User avatar
soho
newbie
 
Posts: 28
Joined: Sat Sep 09, 2006 3:05 am

Re: RB450G + openwrt Metarouter strange problem

by soho » Sat Oct 31, 2009 11:47 pm

hummm ... interesting, I'll change the power supply and test.

User avatar
janisk
MikroTik Support
MikroTik Support
 
Posts: 5906
Joined: Tue Feb 14, 2006 10:46 am
Location: Riga, Latvia

Re: RB450G + openwrt Metarouter strange problem

by janisk » Tue Nov 03, 2009 12:24 pm

my PSU change failed, so do not have high hopes about that, it might do something, but not solve the problem completely.
we are still working on the problem. Thank you for supout.rif files sent.

User avatar
webasdf
Frequent Visitor
Frequent Visitor
 
Posts: 78
Joined: Mon Jan 26, 2009 7:37 pm

Re: RB450G + openwrt Metarouter strange problem

by webasdf » Thu Nov 05, 2009 6:10 pm

janisk wrote:my PSU change failed, so do not have high hopes about that, it might do something, but not solve the problem completely.
we are still working on the problem. Thank you for supout.rif files sent.


An update. I am developing some custom html screens on a 433AH. Running with a 12V 300mA PS. I was running 4.1 firmware and it was relatively stable (would reboot once every 2 or 3 days). I upgraded to 4.2 firmware this morning and it rebooted itself 2 times in half an hour. I downgraded to 4.0 (because I lost my 4.1 install packages :) ). It is more stable now.

On the 450G board. Our power supply upgrade to 12V 1.5 amp made that board really stable. It still reboots itself, though...but only once every 4 to 5 days instead of once per hour.

Hope this helps any further diagnosis of the issue.

UPDATE:
On the 450G board we tried the higher voltage 24V power supply (24V 1.6amp). It rebooted by itself within 27 minutes. We switched back to 12V 1.5 amp and is running better....as before.

User avatar
janisk
MikroTik Support
MikroTik Support
 
Posts: 5906
Joined: Tue Feb 14, 2006 10:46 am
Location: Riga, Latvia

Re: RB450G + openwrt Metarouter strange problem

by janisk » Fri Nov 20, 2009 4:52 pm

we are still working on the problem, cannot promise results soon thought.

od3m
just joined
 
Posts: 14
Joined: Sun Nov 15, 2009 12:11 pm

Re: RB450G + openwrt Metarouter strange problem

by od3m » Sun Nov 22, 2009 4:54 pm

hey,

i´m new to mikrotik boards.
i ran alix2c3 before.

i got the same problems.... rb450g reboots sometimes...
hope you´ll find a solution.

ccr
Frequent Visitor
Frequent Visitor
 
Posts: 83
Joined: Mon Oct 23, 2006 10:40 pm
Location: Iowa, USA

Re: RB450G + openwrt Metarouter strange problem

by ccr » Tue Dec 01, 2009 1:18 am

I have a bunch of 450's out in the field using 24v power supplies. Not working right at all. Rebooting. Losing their config. Is 24v power supplies the problem? Will 18v fix it? What a mess.

enderx
just joined
 
Posts: 6
Joined: Fri Sep 04, 2009 7:16 pm

Re: RB450G + openwrt Metarouter strange problem

by enderx » Tue Dec 01, 2009 1:28 am

ccr, what are you powering yours with?

These are the power supplys I've tried:
1. 28v 0.8amp the one pictured above.
2. ubiquity nanostation2 12v 1amp
3. Tycon Power Systems 5port switch 24v 5amp version

The nanostation2's is the only one that seems stable, which is odd because it seems like a cheap wall wart.

ccr
Frequent Visitor
Frequent Visitor
 
Posts: 83
Joined: Mon Oct 23, 2006 10:40 pm
Location: Iowa, USA

Re: RB450G + openwrt Metarouter strange problem

by ccr » Tue Dec 01, 2009 1:42 am

enderx wrote:ccr, what are you powering yours with?

These are the power supplys I've tried:
1. 28v 0.8amp the one pictured above.
2. ubiquity nanostation2 12v 1amp
3. Tycon Power Systems 5port switch 24v 5amp version

The nanostation2's is the only one that seems stable, which is odd because it seems like a cheap wall wart.


Hello

The 450g Meta Routers I have been having problems with were using the 24v .8amp pictured above. Exact same.
I am now going to try some 18v to see if that helps.
Pretty much the Meta Routers/450g have been in complete meltdown mode; dying everywhere; losing config. Read this thread and figured it was probably the power supply. Going to try 18v and if it works great;

It looks like 24v is what is having problems.

User avatar
roc-noc.com
Forum Veteran
Forum Veteran
 
Posts: 833
Joined: Sun Dec 02, 2007 4:27 am
Location: Rockford, IL USA

Re: RB450G + openwrt Metarouter strange problem

by roc-noc.com » Fri Dec 04, 2009 2:40 am

Thanks for pointing me to this thread Drew. I just read through it and have some comments to post.

I have worked in electronics including product design since the early 1980s. My company designed and manufactured electronic computer products successfully for a number of years before I became an ISP. Some of the designs were my own and I was involved in all of the designs.

Before we jump the gun and blame the power supply, lets look at a couple of facts.

1) Metarouter appears to have some stability issues. We are not sure if it is version specific or environment specific but the complaints in this thread all relate to running an application in metarouter under various ROS versions with various amounts of RAM, and on various RouterBoards.

2) While it doesn't appear to be a cure, there have been some differences noticed in the frequency of the crash when changing to various voltage power supplies.

3) This thread was originally opened as a question about the RB450G with Metarouter but has spanned several routerboards including RB450G, RB750, RB433, and RB493. I am going to stay focused on just the RB450G as it has enough RAM and CPU power to handle most virtual applications. Some of the others mentioned do not.

Problem #1 looks like software or resource problem. I think the focus of this problem should remain there.

I have a problem with fact #2. The RB450G and most of the RouterBoards from the past two years (and all RB4xx boards) use the same power supply circuit. They use a Richtek RT9206 power controller which takes 4.75 to 28vdc in and puts out 3.3vdc.

I found the data sheet here:
http://www.cheertech.com.tw/RichTek%20C ... 206-09.pdf

This should remain the same whether we are feeding it 12vdc or 24vdc. The power capacity only needs to be sufficient to run the RB450G at full load. I suspect that would be about 3 watts since that is what the RB493AH is supposed to use. The RB450G has 4 fewer ports but Gigabit ethernet instead of 10/100. I call that an equal power tradeoff. Any power supply from 8vdc to 28vdc with at least 3 watts of capacity should work fine to power it.

<putting on my Mikrotik distributor hat> The 18POW is one of our best selling products. We have sold about 800 RB450G-complete (with case and power supply) this year that included the 24volt, 19 watt 18POW. We are only one of the 12 US Mikrotik distributors and there are many other Mikrotik distributors around the world. That means many thousands of these have been sold and deployed.

We have been selling these since the beginning of 2009. This is the first that I have heard of a stability problem with the RB450G and 18POW supply and most of my RB450G customers are using that combination.

The missing part in the failure discussed in this thread is Metarouter with operwrt running a script or application.

Again, I am thinking.... software problem.

Sorry to bore you with my opinion but I think this thread needed some new blood.

Many thanks,

Tom
-----------------------------------------------
http://www.roc-noc.com
Tom, CCNA, ISP, USA Mikrotik Distributor
888-762-5662
-----------------------------------------------

gcakici
Frequent Visitor
Frequent Visitor
 
Posts: 59
Joined: Thu Feb 23, 2006 12:44 pm

Re: RB450G + openwrt Metarouter strange problem

by gcakici » Fri Dec 04, 2009 12:54 pm

We're using same configuration and never seen such problems with openwrt. (this is for honoring the RB450G)

What we see is when we change the configuration of a service in openwrt such as network configuration or syslog configuration while they're running, services becomes sometimes unstable (sometimes stable) or after rebooting our modifications gone and files turns back to original states. So we stop the service first then change the configuration and when we think it's all done we reboot the system with fresh configuration. This is because some services don't die exactly the way we want in openwrt.

Regards
Gokalp

ccr
Frequent Visitor
Frequent Visitor
 
Posts: 83
Joined: Mon Oct 23, 2006 10:40 pm
Location: Iowa, USA

Re: RB450G + openwrt Metarouter strange problem

by ccr » Fri Dec 04, 2009 7:56 pm

Tom

I didn't read your post but I am leaning towards version problem. 3.x and Metarouter don't work together correctly. I have quite a bit running on 4.3 so far without trouble. I will let you know...

User avatar
janisk
MikroTik Support
MikroTik Support
 
Posts: 5906
Joined: Tue Feb 14, 2006 10:46 am
Location: Riga, Latvia

Re: RB450G + openwrt Metarouter strange problem

by janisk » Mon Dec 07, 2009 9:52 am

lets wait for 4.4 and see if that version solves your problem with hanging (rebooting) routers.

QpoX
Member
Member
 
Posts: 387
Joined: Mon Mar 24, 2008 8:42 pm
Location: Lemvig, Denmark

Re: RB450G + openwrt Metarouter strange problem

by QpoX » Mon Dec 07, 2009 10:10 am

janisk wrote:lets wait for 4.4 and see if that version solves your problem with hanging (rebooting) routers.


When is 4.4 due?

User avatar
normis
MikroTik Support
MikroTik Support
 
Posts: 19266
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RB450G + openwrt Metarouter strange problem

by normis » Mon Dec 07, 2009 11:26 am

this week
No answer to your question? How to write posts

QpoX
Member
Member
 
Posts: 387
Joined: Mon Mar 24, 2008 8:42 pm
Location: Lemvig, Denmark

Re: RB450G + openwrt Metarouter strange problem

by QpoX » Fri Dec 11, 2009 3:36 pm

normis wrote:this week


Like today or before Sunday?

User avatar
normis
MikroTik Support
MikroTik Support
 
Posts: 19266
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RB450G + openwrt Metarouter strange problem

by normis » Fri Dec 11, 2009 4:48 pm

ok, monday ! apparently I'm not so good at predictions.
No answer to your question? How to write posts

QpoX
Member
Member
 
Posts: 387
Joined: Mon Mar 24, 2008 8:42 pm
Location: Lemvig, Denmark

Re: RB450G + openwrt Metarouter strange problem

by QpoX » Fri Dec 11, 2009 5:20 pm

normis wrote:ok, monday ! apparently I'm not so good at predictions.


Yes i did notice that :)

User avatar
Chupaka
Forum Guru
Forum Guru
 
Posts: 7229
Joined: Mon Jun 19, 2006 11:15 pm
Location: Home Network Ltd., Minsk, Belarus

Re: RB450G + openwrt Metarouter strange problem

by Chupaka » Fri Dec 11, 2009 5:44 pm

let's buy a fortune-teller's magical crystal globe by the next MUM and present it to Normis ))
For every complex problem, there is a solution that is simple, neat, and wrong.

¡ɹǝ|SOɹǝʇnoɹ ʞıʇoɹʞıW ɯ‚|

MikroTik. Your life. Your routing.

skype: pavel.skuratovich

QpoX
Member
Member
 
Posts: 387
Joined: Mon Mar 24, 2008 8:42 pm
Location: Lemvig, Denmark

Re: RB450G + openwrt Metarouter strange problem

by QpoX » Fri Dec 11, 2009 6:25 pm

Chupaka wrote:let's buy a fortune-teller's magical crystal globe by the next MUM and present it to Normis ))


Madam Normis? :lol:

QpoX
Member
Member
 
Posts: 387
Joined: Mon Mar 24, 2008 8:42 pm
Location: Lemvig, Denmark

Re: RB450G + openwrt Metarouter strange problem

by QpoX » Mon Dec 14, 2009 9:31 pm

normis wrote:ok, monday ! apparently I'm not so good at predictions.


Normis you really need to get your crystalball clean'd! :)

QpoX
Member
Member
 
Posts: 387
Joined: Mon Mar 24, 2008 8:42 pm
Location: Lemvig, Denmark

Re: RB450G + openwrt Metarouter strange problem

by QpoX » Wed Dec 16, 2009 12:14 pm

QpoX wrote:
normis wrote:ok, monday ! apparently I'm not so good at predictions.


Normis you really need to get your crystalball clean'd! :)


Hmm... bump?

User avatar
normis
MikroTik Support
MikroTik Support
 
Posts: 19266
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RB450G + openwrt Metarouter strange problem

by normis » Wed Dec 16, 2009 1:02 pm

We are working on some remaining issues. This week is 99.99%
No answer to your question? How to write posts

User avatar
normis
MikroTik Support
MikroTik Support
 
Posts: 19266
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RB450G + openwrt Metarouter strange problem

by normis » Wed Dec 16, 2009 1:03 pm

however, I can't vouch for that "let's see if it fixes your rebooting router", as I don't know if you submitted this issue to support and if it was fixed ...
No answer to your question? How to write posts

User avatar
janisk
MikroTik Support
MikroTik Support
 
Posts: 5906
Joined: Tue Feb 14, 2006 10:46 am
Location: Riga, Latvia

Re: RB450G + openwrt Metarouter strange problem

by janisk » Wed Dec 16, 2009 1:52 pm

it should fix rebooting router problem, at least my test routers have not rebooted after installing version with patches. Sadly other problems in that build prevent me for giving out some pre-release versions.

  Next
222 posts   •   Page 1 of 5   •   1, 2, 3, 4, 5

Who is online

Users browsing this forum: No registered users and 3 guests

It is currently Mon Nov 24, 2014 7:57 am