Community discussions

MikroTik App
 
Vectorrx7
just joined
Topic Author
Posts: 1
Joined: Fri Feb 17, 2017 7:35 pm

Wireless and Guest wirless

Fri Feb 17, 2017 7:53 pm

I have to setup a wireless that offers both a connection to the internet for guest users and a connection to our network for domain users. I need this because our employees are all connecting phones to our WIFI and we are running out of IP addresses. My thought was to create a network on interface 8 that would offer 2 vlans, one with our internal IP and one with an IP of 192.168.50.x

Being new to this device, I am finding that there are a few additional steps needed to pull this off and somehow I am missing them. I have created a DHCP scope of Wireless with the address that I wish to assign. Next, I add the entry into the Address List and Networks tab under the DHCP Server.

I am not able to get an IP on a device plugged into Interface 8 until I create a bridge but that means that I simply missed something.

I have looked for tutorials online but nothing seems to put this all together for me.
 
AldoJimenez
Trainer
Trainer
Posts: 30
Joined: Fri Feb 12, 2016 11:49 pm
Contact:

Re: Wireless and Guest wirless

Tue Feb 28, 2017 7:13 pm

An alternate option would be to create a Virtual AP with a VLAN and network assigned to it. Assign the correct IP information and create a DHCP Server on that VLAN. From here you can control what happens with that guest traffic via filter rules and queues. Below is a code snippet with a general idea.
/interface wireless
add disabled=no keepalive-frames=disabled master-interface=wlan1 mode=ap-bridge multicast-buffering=\
    disabled name=wlan3 security-profile=default ssid=Guest_Wifi vlan-id=100 vlan-mode=use-tag wds-cost-range=0 wds-default-cost=0 \
    wps-mode=disabled
/interface vlan
add interface=wlan2 name=vlan100 vlan-id=100
/ip address
add address=192.168.50.1/24 interface=vlan100 network=192.168.50.0
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=vlan100 name=dhcp1
/ip dhcp-server network
add address=192.168.50.0/24 dns-server=8.8.8.8 gateway=192.168.50.1
/ip pool
add name=dhcp_pool1 ranges=192.168.50.2-192.168.50.254

Who is online

Users browsing this forum: anav, Billiam, MauriceW, patrikg and 107 guests