Mikrotik + Web Proxy Queueing is Impossible ?
RouterOS general discussion

102 posts   •   Page 2 of 3   •   1, 2, 3
User avatar
samsoft08
Long time Member
Long time Member
 
Posts: 617
Joined: Sat Nov 26, 2005 11:52 pm

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by samsoft08 » Wed Sep 05, 2007 12:15 pm

I made a rule to check if any packet coming from the internet with TOS =4 , for hours its = 0 , but I wonder if TOS may change by internal processing ( any process except cahce ) ??

User avatar
GWISA
Member
Member
 
Posts: 394
Joined: Tue Jan 31, 2006 3:37 pm
Location: Johannesburg, South Africa

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by GWISA » Wed Sep 05, 2007 1:55 pm

samsoft08 wrote:no its working with me on v3rc3 , i dont know how it can work on 2.9 ?


With the same TOS setting of 4?

User avatar
samsoft08
Long time Member
Long time Member
 
Posts: 617
Joined: Sat Nov 26, 2005 11:52 pm

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by samsoft08 » Wed Sep 05, 2007 8:36 pm

i don't know if the packets generate from the cache disk in 2.9 have TOS=4 !!! couse i never know about TOS , I read there are 4 kinds of TOS from the manual , but i didnt work with it before ..

User avatar
GWISA
Member
Member
 
Posts: 394
Joined: Tue Jan 31, 2006 3:37 pm
Location: Johannesburg, South Africa

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by GWISA » Thu Sep 06, 2007 10:21 am

hmmm.... just a thought now - can we use the change-TOS function for traffic re-directed to the proxy?

User avatar
hulk-bd
Member Candidate
Member Candidate
 
Posts: 226
Joined: Mon Sep 03, 2007 7:19 pm
Location: Uttara, Dhaka, Bangladesh

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by hulk-bd » Thu Sep 06, 2007 2:48 pm

Hey guys,

Hope you are find a real good solution with TOS, actually I don't know much about TOS. have anyone tried my solution yet? or I'm talking bullshit here!!! :?

Peace

User avatar
janisk
MikroTik Support
MikroTik Support
 
Posts: 5925
Joined: Tue Feb 14, 2006 10:46 am
Location: Riga, Latvia

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by janisk » Thu Sep 06, 2007 4:13 pm

i just wanted to say - that you have to take into account from where traffic originates

so, if you have set up caching and your proxy is answering you that traffic is on the outgoing chain, if you get that data directly you get it from forward chain, knowing that you can build your solution using your own knowledge and it is not that hard.

but stating that it cannot be done is completely wrong - maybe for someone that is impossible to achieve, thats why Mikrotik have consultants available worldwide and by sending people to consultant Mikrotik is not gaining anything and everything stays between you and consultant of your choice.

and to configure RouterOS effectively you have to know packet flow of RouterOS and networking as configuration language of RouterOS is very easy to understand and get used to. If you lack that knowledge that is your problem, not our. That is why a lot of training courses are available through-out the world, so everyone can become consultant.

User avatar
GWISA
Member
Member
 
Posts: 394
Joined: Tue Jan 31, 2006 3:37 pm
Location: Johannesburg, South Africa

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by GWISA » Thu Sep 06, 2007 6:23 pm

yes yes - we've been through all that and proved that that is NOT the case...

Training has been done (you would have seen if you read the thread).
With proxy enabled AND a firewall redirect rule, ALL http traffic flows THROUGH the proxy - other traffic does not.

Have a look at the rest of the thread and see what we have been through already...

Please don't hijack what has become a constructive discussion just to advertise your services...

User avatar
samsoft08
Long time Member
Long time Member
 
Posts: 617
Joined: Sat Nov 26, 2005 11:52 pm

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by samsoft08 » Sat Sep 08, 2007 9:20 pm

GWISA wrote:Please don't hijack what has become a constructive discussion just to advertise your services...


i agree , couse we solve this issue after a long discussion :

Code: Select all
add action=mark-packet chain=output comment="CACHE" disabled=no dscp=4 new-packet-mark=cache-packets \
    out-interface=(local)  passthrough=no

User avatar
hulk-bd
Member Candidate
Member Candidate
 
Posts: 226
Joined: Mon Sep 03, 2007 7:19 pm
Location: Uttara, Dhaka, Bangladesh

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by hulk-bd » Sun Sep 09, 2007 7:57 pm

O MAN, my solution is working like hell, it's really do. Just do what have i told you before with 2 MT OS and see what is the result, and I don't know why you people don't interested in my web-proxy solution with 2 MT OS?

But I'm 100% sure about my solution.

Take care

:(

User avatar
GWISA
Member
Member
 
Posts: 394
Joined: Tue Jan 31, 2006 3:37 pm
Location: Johannesburg, South Africa

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by GWISA » Mon Sep 10, 2007 1:59 am

hulk-bd wrote:I don't know why you people don't interested in my web-proxy solution with 2 MT OS?


I'm thinking if we find a way to make it work with one ROS, why waste resources & use two?

User avatar
hulk-bd
Member Candidate
Member Candidate
 
Posts: 226
Joined: Mon Sep 03, 2007 7:19 pm
Location: Uttara, Dhaka, Bangladesh

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by hulk-bd » Mon Sep 10, 2007 7:03 pm

If we can do with 1 MT OS then it'll be the best solution, but haven't found any thing like it, am I right? so plz find a solution with 1 MT OS from where we can get the bandwidth from our web proxy cache as like our LAN speed.


Thanks

User avatar
samsoft08
Long time Member
Long time Member
 
Posts: 617
Joined: Sat Nov 26, 2005 11:52 pm

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by samsoft08 » Mon Sep 10, 2007 9:19 pm

hello , i dont know if read my past topic or not ? it has been solved my friends , and i'm monitoring the results , and it is perfect ..
its by marking traffic coming from proxy with TOS = 4 , its the traffic generated in local process ( hard disk cache ) ..
for example i downloaded a file for the first time , my Q limit reachs the max limit ( red ) , and its the same value i can see in tourch , downloading the file for the second time in tourch it's more than 1.5M/s while my Q still at about 25k/s , i repeated the test many many times and i can see how successfull is this way ..
here is the rules i wrote :

Mangle : first rule in mangle
Code: Select all
add action=mark-packet chain=output comment="CACHE" disabled=no dscp=4 new-packet-mark=cache-packets  out-interface=(Local) passthrough=no

Simple Q : first rule in simple Q
Code: Select all
add comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all limit-at=10000/20000 \
    max-limit=30000/3000000 name="CACHED-PACKETS" packet-marks=cache-packets parent=none priority=3 \
    queue=pcq-upload/pcq-download target-addresses=192.168.1.0/24 total-queue=default-small

and i will post some capture images of the result..

offcourse thanks to npbrasil
Hi! The solution is in 3.0 version. Change tos from "hits" in the proxy - Cache Hit DSCP (TOS) - option in web-proxy general settings, then mangle or anything. In version 2.9 or prior is not possible.

User avatar
hulk-bd
Member Candidate
Member Candidate
 
Posts: 226
Joined: Mon Sep 03, 2007 7:19 pm
Location: Uttara, Dhaka, Bangladesh

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by hulk-bd » Tue Sep 11, 2007 1:00 am

Dear samsoft08,

Happy to know you have solved the problem, but have you done it with 2.9.46 version or you used Ver.3.rc? Cause ver3.3-4rc is not stable version so far. this version has so many bugs right now and can't use this version right now.

regards

User avatar
GWISA
Member
Member
 
Posts: 394
Joined: Tue Jan 31, 2006 3:37 pm
Location: Johannesburg, South Africa

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by GWISA » Tue Sep 11, 2007 1:59 am

Is there an echo in this room? ;)

User avatar
samsoft08
Long time Member
Long time Member
 
Posts: 617
Joined: Sat Nov 26, 2005 11:52 pm

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by samsoft08 » Tue Sep 11, 2007 3:43 am

offcourse thanks to npbrasil

Quote:
Hi! The solution is in 3.0 version. Change tos from "hits" in the proxy - Cache Hit DSCP (TOS) - option in web-proxy general settings, then mangle or anything. In version 2.9 or prior is not possible.


which version is stable in your opinion ?? why do you upgrade before untill you reach v 2.9.46 ?

User avatar
samsoft08
Long time Member
Long time Member
 
Posts: 617
Joined: Sat Nov 26, 2005 11:52 pm

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by samsoft08 » Tue Sep 11, 2007 3:50 am

this is a sample image for what happen when i downloaded a file exist in the cache drive , the file is dude.exe , my total VSAT download is 512k/s , and i can reach 1.5M as showen whithout any effect to my Q limit , my internet bandwidth still nearly empty ..

[img]Image
[/img]

User avatar
hulk-bd
Member Candidate
Member Candidate
 
Posts: 226
Joined: Mon Sep 03, 2007 7:19 pm
Location: Uttara, Dhaka, Bangladesh

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by hulk-bd » Thu Sep 13, 2007 12:44 am

Dear Sam, so are you comfortable with the MT OS Ver.3.4rc, cause you told in another topic that you are having PC hung problem too, maybe the Ver.3.4rc is causing that problem. :?

User avatar
samsoft08
Long time Member
Long time Member
 
Posts: 617
Joined: Sat Nov 26, 2005 11:52 pm

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by samsoft08 » Thu Sep 13, 2007 8:12 am

no i didnt say i'm 100% comfortable with v3 , there is some bothering things in winbox , like its not saving settings in its windows , i mean when i choose the columns i want to apear , it wint next time i open the same window in winbox , thats all i'm facing in winbox right now ..
pc hang up , it exist since i was running 2.944 ,2.945 , 2.946 , i still cant figure out the reason ..
but for what i did with cach packet marking , i'm so pleased with it , really ..

pokeman
Member Candidate
Member Candidate
 
Posts: 136
Joined: Fri Jun 05, 2009 10:52 pm

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by pokeman » Thu Sep 13, 2007 8:52 am

samsoft08 wrote:hello , i dont know if read my past topic or not ? it has been solved my friends , and i'm monitoring the results , and it is perfect ..
its by marking traffic coming from proxy with TOS = 4 , its the traffic generated in local process ( hard disk cache ) ..
for example i downloaded a file for the first time , my Q limit reachs the max limit ( red ) , and its the same value i can see in tourch , downloading the file for the second time in tourch it's more than 1.5M/s while my Q still at about 25k/s , i repeated the test many many times and i can see how successfull is this way ..
here is the rules i wrote :

Mangle : first rule in mangle
Code: Select all
add action=mark-packet chain=output comment="CACHE" disabled=no dscp=4 new-packet-mark=cache-packets  out-interface=(Local) passthrough=no

Simple Q : first rule in simple Q
Code: Select all
add comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all limit-at=10000/20000 \
    max-limit=30000/3000000 name="CACHED-PACKETS" packet-marks=cache-packets parent=none priority=3 \
    queue=pcq-upload/pcq-download target-addresses=192.168.1.0/24 total-queue=default-small

and i will post some capture images of the result..

offcourse thanks to npbrasil
Hi! The solution is in 3.0 version. Change tos from "hits" in the proxy - Cache Hit DSCP (TOS) - option in web-proxy general settings, then mangle or anything. In version 2.9 or prior is not possible.



hello dude

i am using 2.9.27 its works with this version ?

valens
Member Candidate
Member Candidate
 
Posts: 246
Joined: Tue Jun 01, 2004 5:42 pm
Location: INDONESIA

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by valens » Thu Sep 13, 2007 12:47 pm

Hello all friends.....!

I just know this interesting discussion. Quite surprise, my wiki topic, and also my pdf become reference on this topic. My presentation is based on MT ver 2.9, and once again, it's not possible to know which traffic is MISS and which traffic is HIT.

I'm glad in ver 3.0 we can do that. I haven't try in my lab to use TOS, but I imagine, it should work. I suggest this kind of solution also in ver 3.0 wishlist, but not many people vote for it. But I'm glad MT make it.

Thank you again for all friends here for the good discussion, specially for npbrasil. I think it's the time to revise my page on the WIKI :)

User avatar
t3rm
Member Candidate
Member Candidate
 
Posts: 143
Joined: Sat Aug 04, 2007 1:57 pm
Location: Bandung - WJ - Indonesia

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by t3rm » Thu Sep 13, 2007 7:47 pm

Valens:

Take the google: Iptables+DSCP
The magic is in DSCP :lol:

Version 2.9.x didnt have DSCP. So it wont work.
I guess your Wiki and PDF should be update.

User avatar
hulk-bd
Member Candidate
Member Candidate
 
Posts: 226
Joined: Mon Sep 03, 2007 7:19 pm
Location: Uttara, Dhaka, Bangladesh

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by hulk-bd » Sat Sep 15, 2007 3:20 pm

Hello Friends,

Hope all are fine. I have told you that my solution about web-proxy was working 100% but sorry to say it's not. So I should let you people know that it's not 100% ok, I'm having few problems after I have installed another MT OS as a web proxy between my local network n main MT router, the browsing speed is Reduced but the download is having full lan speed. I have worked on it, changed few configurations but not happy with it. And now I'm sure I have to wait for the final MT OS VER.3 to have my web proxy in my main MT router. Thanks Samsoft for your help here I'll do it as you have done in your MT OS.

Thanks n Take Care

valens
Member Candidate
Member Candidate
 
Posts: 246
Joined: Tue Jun 01, 2004 5:42 pm
Location: INDONESIA

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by valens » Mon Sep 17, 2007 9:30 am


emmanuel
newbie
 
Posts: 37
Joined: Thu Jan 05, 2006 9:23 pm
Location: nigeria

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by emmanuel » Fri Sep 21, 2007 6:49 pm

TOS setting of 4 is not working in 3.0rc5 pl chcek it out

User avatar
hulk-bd
Member Candidate
Member Candidate
 
Posts: 226
Joined: Mon Sep 03, 2007 7:19 pm
Location: Uttara, Dhaka, Bangladesh

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by hulk-bd » Fri Sep 21, 2007 6:58 pm

emmanuel wrote: TOS setting of 4 is not working in 3.0rc5 pl chcek it out


Yes emmanuel you are right, TOS 4 is not working in my MT (3.0rc4n5) too.

User avatar
skillful
Long time Member
Long time Member
 
Posts: 535
Joined: Wed Sep 06, 2006 1:42 pm
Location: Abuja, Nigeria

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by skillful » Fri Sep 21, 2007 7:17 pm

I have ROS 3.0RC5 and the DSCP TOS 4 setting is working fine. Maybe you need to hire a consultant to configure your router for you.

[admin@gccl-gateway] /ip proxy> pr
enabled: yes
src-address: 0.0.0.0
port: 3128
parent-proxy: 0.0.0.0
parent-proxy-port: 0
cache-drive: secondary-master
cache-administrator: "*******"
max-cache-size: 11828000KiB
cache-on-disk: yes
maximal-client-connections: 1000
maximal-server-connections: 1000
max-fresh-time: 3d
serialize-connections: no
cache-hit-dscp: 4

Code: Select all
/ip firewall mangle
add action=mark-packet chain=output comment="cached packets" disabled=no \
    dscp=4 new-packet-mark=cached out-interface=!wan passthrough=no


Code: Select all
/queue simple
add comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all \
    limit-at=0/0 max-limit=0/0 name="cached" packet-marks=cached parent=none \
    priority=8 queue=default-small/default-small \
    target-addresses=192.168.0.0/16 total-queue=default-small

emmanuel
newbie
 
Posts: 37
Joined: Thu Jan 05, 2006 9:23 pm
Location: nigeria

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by emmanuel » Fri Sep 21, 2007 7:46 pm

skillful when is working in 3.0cr4 is there any compliant and look am not the only person say that ok

User avatar
hulk-bd
Member Candidate
Member Candidate
 
Posts: 226
Joined: Mon Sep 03, 2007 7:19 pm
Location: Uttara, Dhaka, Bangladesh

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by hulk-bd » Sat Sep 22, 2007 7:50 am

skillful wrote:Maybe you need to hire a consultant to configure your router for you.


Hey, what do u think u r? Am I sounds like a dump **it?!!

hoga dea boirademu howwar poola.

Thanks

marcelocbf
newbie
 
Posts: 35
Joined: Sat Jun 09, 2007 2:31 am

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by marcelocbf » Mon Sep 24, 2007 4:51 am

Hello guys,

I was looking exactly for this solution ... because I need to implement a web-proxy cache in my MTOS (2.9.XX) and I was dealing in how to differenciate both traffic (Internal and Internet) for my customers ... After reading all the posts and happy with the peace achieved :D I still have one question ...

Who acess the internet ?????? I mean, who requests the HTTP traffic from the internet ? The web-proxy or my customer ?

Because, please correct me if I'm wrong ... If all the HTTP traffic is redirected to the proxy, and if the proxy detects that the it doesn't have what is requested in the cache and pulls from the internet, The proxy is who is consuming the bandwidth ... so there is no need to change TOS, queue the customer's HTTP traffic. I should cap the web-proxy's traffic right ? If this it true, I would need a PCQ queue for the web-cache instead, right ?

If I'm correct, I don't need to differentiate both traffics, as the tcp traffic is connection-oriented, it's gonna be slowed down itself as the web-cache doesn't serve it at the speed it expects ...

Please help me understand ...
If my customer has a cap of 64k and downloads a 3MB file for the first time. In the v3.0Rcxx, the proxy detects it is not a cache hit and do not change the TOS. So, with the queues properly configured my customer will have the 64k cap on the traffic coming from the web-proxy and the web-proxy will download the file at my full link speed (if I don't have a specific queue, right ?) If it is in the cache, the web-proxy change the TOS to 4 (for example) and gives full speed on the webproxy<->customer connection and there is no download needed from the internet ...

But my problem is ... if I have 10 customers downloading each one different 100MB files. They will not notice increased speed, because it is the first time the file is downloaded. My connection will be clogged up by the 10 web-proxy full-speed downloads, as well as all my other customer's connections ... SMTP, FTP, VPN, Voice, etc ...

Can someone help me understand if this is true ? Actually ... answering my first question resolves this issue ...

Thanks in advance guys,

laze81
just joined
 
Posts: 4
Joined: Mon Sep 24, 2007 4:55 am

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by laze81 » Mon Sep 24, 2007 5:08 am

Thx samsoft08 :)))))))) wark for me in v3.0rc5

User avatar
omega-00
Forum Guru
Forum Guru
 
Posts: 1125
Joined: Sat Jun 06, 2009 4:54 am
Location: Brisbane, Australia

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by omega-00 » Tue Sep 25, 2007 4:05 am

Perhaps this should be added in as part of the automatic configuration of the web-proxy package when enabled.

pokeman
Member Candidate
Member Candidate
 
Posts: 136
Joined: Fri Jun 05, 2009 10:52 pm

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by pokeman » Mon Oct 01, 2007 1:27 pm

hello

can anyone guide me how can i do this on my linux machine i have 700 clients i switch my clients on MT but not running fine and getting lots of system resources . thats way i want to done on linux distro

User avatar
mac86
Frequent Visitor
Frequent Visitor
 
Posts: 98
Joined: Sat Nov 25, 2006 1:52 am
Location: bahia blanca - argentina

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by mac86 » Wed Oct 03, 2007 3:40 am

Hi,

If you check this old post:

http://forum.mikrotik.com/viewtopic.php?f=2&t=12334&hilit=

you can see that I've asked this web-cache issue last year (without reply).

Also, I asked this on my last Mikrotik training and get no answer :-(

This is Not possible with 2.9.x routeros (at least until 2.9.46).

With routeros 3.0 you can do it , as wiki article said

how ever , routeros 3 is unestable yet.

In order to mark HIT OBJETS, I use a Linux box , with squid patched
with:

http://zph.bratcheda.org

This is the *only way* to get HIT cache objets with unlimited rate,
on routeros 2.9 series.

HIT objects are marked with ToS on squid configuration.

a MT rule on mangle table, can sent that objects to a simple (and unlimited) queue.

Regards...

pokeman
Member Candidate
Member Candidate
 
Posts: 136
Joined: Fri Jun 05, 2009 10:52 pm

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by pokeman » Thu Oct 04, 2007 2:28 pm

thanks mac
i am apply this on my linux box i am getting some error .please check your email

waiting your positive response

laze81
just joined
 
Posts: 4
Joined: Mon Sep 24, 2007 4:55 am

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by laze81 » Sat Oct 06, 2007 1:33 am

mac86 wrote:Hi,

If you check this old post:

http://forum.mikrotik.com/viewtopic.php?f=2&t=12334&hilit=

you can see that I've asked this web-cache issue last year (without reply).

Also, I asked this on my last Mikrotik training and get no answer :-(

This is Not possible with 2.9.x routeros (at least until 2.9.46).

With routeros 3.0 you can do it , as wiki article said

how ever , routeros 3 is unestable yet.

In order to mark HIT OBJETS, I use a Linux box , with squid patched
with:

http://zph.bratcheda.org

This is the *only way* to get HIT cache objets with unlimited rate,
on routeros 2.9 series.

HIT objects are marked with ToS on squid configuration.

a MT rule on mangle table, can sent that objects to a simple (and unlimited) queue.

Regards...


to get HIT cache objects with unlimited rate
get some nice motherboard with Intel chipset p4 dual core Intel 2gb ram and RAPTOR SATA HDD
MT 3.0 (now it's baggy but work fine for me
u'll get what u wont

pokeman
Member Candidate
Member Candidate
 
Posts: 136
Joined: Fri Jun 05, 2009 10:52 pm

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by pokeman » Tue Oct 16, 2007 7:57 pm

thanks mac86

for your give hint . i make posible this to my linux box ! :) over 20 mb wan link and 2000 users are running well since 3 days ! thanks again

marko_bg
Member Candidate
Member Candidate
 
Posts: 119
Joined: Sat Jun 03, 2006 11:48 am

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by marko_bg » Sun Oct 21, 2007 1:42 am

Hi samsoft08,

tos work for me fine in 3.0rc7,

but I need to make one more rule, ...

I need to make rule for noncached traffic , like this ...

user have 256kbps with 1mbps burst limit, ...

I make PCQ with 256kbps for non cached traffic, and it's work.

but how to make burst limit on that , if I make burst limit in General , this is for all user total,
an I need for each user , this: viewtopic.php?f=2&t=19264

any idea ?

User avatar
hulk-bd
Member Candidate
Member Candidate
 
Posts: 226
Joined: Mon Sep 03, 2007 7:19 pm
Location: Uttara, Dhaka, Bangladesh

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by hulk-bd » Sun Oct 21, 2007 2:17 pm

To samsoft,

Dear sam, I couldn't do it as you given your solution with MT OS V3, all work fine except the proxy cache HIT ratio as LAN speed, I mean I can't download things as lan speed but if I desiable my simple queue then I can download things as lan speed. your given simple queue is not working:

Simple Q : first rule in simple Q

Code:
add comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all limit-at=10000/20000 \
max-limit=30000/3000000 name="CACHED-PACKETS" packet-marks=cache-packets parent=none priority=3 \
queue=pcq-upload/pcq-download target-addresses=192.168.1.0/24 total-queue=default-small


Can you help me out, or it is not possible with MT OS??!! :(
Don't worry, be happy :) .......

marko_bg
Member Candidate
Member Candidate
 
Posts: 119
Joined: Sat Jun 03, 2006 11:48 am

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by marko_bg » Sun Oct 21, 2007 2:40 pm

hulk-bd,

you must put this in first simplequeue (sam rule): limit-at=0/0 max-limit=0/0 ,

and if you need, in PCQ rule make lan speed, or put 0, if you make lan speed on other MT.

and you must put one more rule , second ,with speed for noncache traffic .

like this:
name="cached" dst-address=0.0.0.0/0 interface=all parent=none packet-marks=cached direction=both
priority=8 queue=default-small/default-small limit-at=0/0 max-limit=0/0 total-queue=default-small

name="no_cached" dst-address=0.0.0.0/0 interface=all parent=none direction=both priority=8
queue=512k_PCQ_upload/512k_PCQ_download limit-at=0/0 max-limit=0/0 total-queue=default-small

I have only Proxy on this MT, an I have only this 2 rules.

User avatar
samsoft08
Long time Member
Long time Member
 
Posts: 617
Joined: Sat Nov 26, 2005 11:52 pm

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by samsoft08 » Sun Oct 21, 2007 2:51 pm

you must put this rule as the FIRST rule in the simple Q list , or its not working for each rule above it ..
and you have to be sure that you mangle correctly any hit packet ..
its working and its so simple , although i cant run web-proxy with V3 couse the system will freez after some hours , i hope you guys help me to find out whts the problem , i tested 3 different hardware , it freezes after some hours ..... :?

marko_bg
Member Candidate
Member Candidate
 
Posts: 119
Joined: Sat Jun 03, 2006 11:48 am

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by marko_bg » Sun Oct 21, 2007 3:08 pm

I have diferent question,

proxy can not cache msn and yahoo ?

this sites not suport cache or I make mistake in setup ?


samsoft , did you have 2 hdd, one for sistem one for cache ?

User avatar
mac86
Frequent Visitor
Frequent Visitor
 
Posts: 98
Joined: Sat Nov 25, 2006 1:52 am
Location: bahia blanca - argentina

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by mac86 » Sun Oct 21, 2007 4:43 pm

Hi Pokeman!

for your give hint . i make posible this to my linux box ! :) over 20 mb wan link and 2000 users are running well since 3 days ! thanks again



Very very good ...!!

Have you tested Mikrotik web proxy (on RouterOs 3.x) ?

User avatar
samsoft08
Long time Member
Long time Member
 
Posts: 617
Joined: Sat Nov 26, 2005 11:52 pm

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by samsoft08 » Mon Oct 22, 2007 2:10 am

to marko_bg : yes 2 hdd .

to ALL : anybody tested web-proxy in V3 for more than 1 day ?

User avatar
hulk-bd
Member Candidate
Member Candidate
 
Posts: 226
Joined: Mon Sep 03, 2007 7:19 pm
Location: Uttara, Dhaka, Bangladesh

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by hulk-bd » Mon Oct 22, 2007 3:18 am

Thanks a lot guys, I didn't put that rule in the first place, ok now I think it'll work. Samsoft I'll let you know about web-proxy in ver.3 after 2 days. cause I have to run it 2 days long which you are complaining about.

Thanks
Don't worry, be happy :) .......

User avatar
hulk-bd
Member Candidate
Member Candidate
 
Posts: 226
Joined: Mon Sep 03, 2007 7:19 pm
Location: Uttara, Dhaka, Bangladesh

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by hulk-bd » Tue Oct 23, 2007 10:33 am

Hi Dudes,

I'm here again with a question :) , First to Samsoft: thank you for your configuration, it is working fine I'm running my MT OS Ver.3rc7 with web proxy near a day and not yet facing any hung problem, if I find any I'll inform you. I see a disadvantage with Ver.3 web proxy and that is we can't put any max object size here and that's why when I download a file size more then 15 MB it can't be cached by web proxy now but with the older ver2.9 web proxy we can put the max object size like 24 MB and can have file cached with 24 MB size. like with Ver2.9 web proxy I can cache MSN installer (18 MB) and I can download the file from proxy cache but I can't do that with ver.3 web proxy. It can cache small files size like 3 to 5 MB max I think.

Any one think about it?

To Dear MT Programmer team can you put max object size in your new web proxy?

I think it'll be very helpful.

Thanks n Regards
Don't worry, be happy :) .......

User avatar
samsoft08
Long time Member
Long time Member
 
Posts: 617
Joined: Sat Nov 26, 2005 11:52 pm

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by samsoft08 » Wed Oct 24, 2007 1:14 am

dear hulk-bd , about your test , how many users were online ? or it was only you testing ? i tested different hardware BUT with the same RB44 lan card !!!! every time the system will freez , i need caching web pages , so its so important to me ..

mps01k
Frequent Visitor
Frequent Visitor
 
Posts: 89
Joined: Fri Mar 23, 2007 10:09 pm
Location: HONDURAS

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by mps01k » Wed Oct 24, 2007 1:49 am

i have the above setup running on 3.0vr6

and it works well. it does save msn download for me.. really cool. i have tried with up to a 24mb file and worked fine, cant figure out how to make it save youtube tho.

i have it running on 6 servers at the moment for up to 3 weeks on the very first one and have had no problems exept on the server with 6 gb it overflowed and killed my usermanger database and i had to reinstall usermanger database.

config is : p3 1ghz 256ram 6gb dell 512k/1544k (satelite) 60 users
p4 3.2 512ram 80gb clone 2M/2M(fiber) 50 users
p3 400mhz 128 ram 20gb dell 512k/1024k (microwave 45miles to fiber) 30 users
celron 2.4 512ram 40gb 512k/512k (microwave 80miles to fiber) 20 users
p3 1ghz 256ram 10gb dell 512k/512k (microwave 80miles to fiber) 35 users
p3 1ghz 256ram 10gb dell 512k/2048k (satelite) 38 users
setting up small WISP in Honduras over Satelite connections

User avatar
hulk-bd
Member Candidate
Member Candidate
 
Posts: 226
Joined: Mon Sep 03, 2007 7:19 pm
Location: Uttara, Dhaka, Bangladesh

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by hulk-bd » Wed Oct 24, 2007 9:55 pm

Dear mps01k,

Can you please give your web proxy setting here, It'll be very helpful. Cause I can't download big files from my web proxy cache, I don't know what is wrong.!!??

Regards
Don't worry, be happy :) .......

mps01k
Frequent Visitor
Frequent Visitor
 
Posts: 89
Joined: Fri Mar 23, 2007 10:09 pm
Location: HONDURAS

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by mps01k » Wed Oct 24, 2007 11:02 pm

enabled: yes
src-address: 0.0.0.0
port: 8080
parent-proxy: 0.0.0.0
parent-proxy-port: 0
cache-drive: system
cache-administrator: "webmaster"
max-cache-size: 4037000KiB
cache-on-disk: yes
maximal-client-connections: 400
maximal-server-connections: 150
max-fresh-time: 3d
serialize-connections: no
cache-hit-dscp: 4
setting up small WISP in Honduras over Satelite connections

emersonmillnitz
just joined
 
Posts: 1
Joined: Wed Mar 28, 2007 11:49 pm

Re: Mikrotik + Web Proxy Queueing is Impossible ?

by emersonmillnitz » Wed Feb 13, 2008 4:22 pm

Hello,

Is possible this solution with 02 links with LoadBalance for service?

  Previous   Next
102 posts   •   Page 2 of 3   •   1, 2, 3

Who is online

Users browsing this forum: bazzer, Bing [Bot], dimosl, gkary13, prawira and 61 guests

It is currently Thu Dec 18, 2014 7:21 pm