VLAN switch problem
RouterOS general discussion

4 posts   •   Page 1 of 1
User avatar
LatinSuD
Member Candidate
Member Candidate
 
Posts: 129
Joined: Wed Jun 29, 2005 1:05 pm
Location: Spain

VLAN switch problem

by LatinSuD » Mon Jan 14, 2008 7:14 pm

I have a routeros with 2 lan ports: users and internet gateways. I'd like to have more ports to monitor and control all internet gateways independently.

I have a SMC 8024L2 VLAN switch and I try to set it up like this, but it seems not to work:
- Gateways go on untagged vlan ports (vlan2, vlan3, vlan4...).
- Routeros go on a tagged vlan port that belongs to all vlans (vlan2, vlan3, vlan4...).

The problem seems to be that routeros uses a single mac address for all vlan addresses, and for the switch a mac address can belong only to one vlan.
Is it possible to assign a different mac address to a vlan interface (i think it can be done in linux)?
Or have multiple mac addresses per ethernet interface?

User avatar
Chupaka
Forum Guru
Forum Guru
 
Posts: 7229
Joined: Mon Jun 19, 2006 11:15 pm
Location: Home Network Ltd., Minsk, Belarus

Re: VLAN switch problem

by Chupaka » Tue Jan 15, 2008 3:24 am

I do not have such troubles even with D-Link 1226G switches. Look at switch settings - maybe there is too big security in MAC area =)
For every complex problem, there is a solution that is simple, neat, and wrong.

¡ɹǝ|SOɹǝʇnoɹ ʞıʇoɹʞıW ɯ‚|

MikroTik. Your life. Your routing.

skype: pavel.skuratovich

User avatar
dankerr
Frequent Visitor
Frequent Visitor
 
Posts: 77
Joined: Wed Sep 12, 2007 10:56 pm
Location: Atlanta, GA USA

Re: VLAN switch problem

by dankerr » Tue Jan 15, 2008 7:11 am

On a Cisco or a Dell you'd need to put the switch port in trunk mode. You may also need to enable vlan sharing. The commands are different on each (sometimes from model to model); but I'm sure the SMC needs a similar configuration. On older SMC and Netgear switches I've worked on it was very close to to Cisco; so it'd be something like ""interface name" switchport mode trunk" from configure mode. The vlan command is similar; but I don't remember the exact syntax though I don't think you need it unless you want to limit which vlans are trunked.

On one Dell switch (I think a 6224) we also needed to put vlan1 on the RouterOS interface for the switch to see the other vlans. After a later firmware upgrade on the switch to fix a different issue we didn't need to do this.

Diganet
Member
Member
 
Posts: 349
Joined: Sun Oct 30, 2005 10:30 pm
Location: Denmark

Re: VLAN switch problem

by Diganet » Wed Jan 16, 2008 1:55 pm

LatinSuD wrote:I have a routeros with 2 lan ports: users and internet gateways. I'd like to have more ports to monitor and control all internet gateways independently.

I have a SMC 8024L2 VLAN switch and I try to set it up like this, but it seems not to work:
- Gateways go on untagged vlan ports (vlan2, vlan3, vlan4...).
- Routeros go on a tagged vlan port that belongs to all vlans (vlan2, vlan3, vlan4...).

The problem seems to be that routeros uses a single mac address for all vlan addresses, and for the switch a mac address can belong only to one vlan.
Is it possible to assign a different mac address to a vlan interface (i think it can be done in linux)?
Or have multiple mac addresses per ethernet interface?


You create the different VLANs you need on the MT. You give those interfaces a different IP/Subnet like (10.0.1.1/24, 10.0.2.1/24 etc.)
Set up a DHCP server on each VLAN. Then you attach the VLANS to one ethernet port (trunk).

On the switch you create the same VLAN tags on the trunk port. Then you assign the ports on the switch as untagged ports, so that port 1 belongs to VLAN 1, port 2 belongs to VLAN 2 etc. After this is done you should be able to put a PC in any port, get an IP address in the right subnet and control each subnet (VLAN) as you wish. You can also set up rules so that the different subnets can't see each other.

Regards

/Henrik

4 posts   •   Page 1 of 1

Who is online

Users browsing this forum: No registered users and 26 guests

It is currently Sun Nov 23, 2014 1:50 pm