Community discussions

 
chichken
just joined
Topic Author
Posts: 8
Joined: Mon Jun 19, 2006 3:33 pm
Reputation: 0

DHCP option code 224-254 (privat use)

Sat May 17, 2008 4:56 pm

Hi!

I migrated my firewall from linux (Debian) to Mikrotik, but i found a problem.
I can't use mikrotik dhcp server option code 252. This is for automatic proxy
setting.

In ISC dhcp server :
option local-pac-server code 252 = text;
option local-pac-server "http://192.168.19.254/proxy.pac";


in mikrotik:
/ip dhcp-server option add name="local-pac-server" code=252 value="http://192.168.19.254/proxy.pac"

and I added it to networks.

As I see, it doesnt send the option code to the client.
Is it possible, that Mikrotik software can't manage option codes after 224 ?

I'm tried with different versions of MT, and tried with the latest too...

Do u have any idea?

Thx,
chichken
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 7427
Joined: Mon Jun 19, 2006 11:15 pm
Reputation: 25
First RouterOS version: 2.8
Location: Home Network Ltd., Minsk, Belarus
Contact:

Re: DHCP option code 224-254 (privat use)

Sat May 17, 2008 5:54 pm

option 249 works for me on v3.7 - so no 224 limit =)
Russian-speaking forum: http://forum.mikrotik.by. Welcome :)

For every complex problem, there is a solution that is simple, neat, and wrong.

¡ɹǝ|SOɹǝʇnoɹ ʞıʇoɹʞıW ɯ‚|

MikroTik. Your life. Your routing.
 
chichken
just joined
Topic Author
Posts: 8
Joined: Mon Jun 19, 2006 3:33 pm
Reputation: 0

Re: DHCP option code 224-254 (privat use)

Sat May 17, 2008 6:05 pm

Chupaka wrote:
option 249 works for me on v3.7 - so no 224 limit =)


Yes, u are right. I'm tried it, and worked, but 252 didn't works...
 
User avatar
jwcn
Forum Guru
Forum Guru
Posts: 1501
Joined: Sun Aug 27, 2006 6:49 am
Reputation: 0
First RouterOS version: 2.9.51
Location: Maryland, USA
Contact:

Re: DHCP option code 224-254 (privat use)

Sat May 17, 2008 7:05 pm

Where can you find a list of what options do what?
 
chichken
just joined
Topic Author
Posts: 8
Joined: Mon Jun 19, 2006 3:33 pm
Reputation: 0

Re: DHCP option code 224-254 (privat use)

Sat May 17, 2008 7:19 pm

jwcn wrote:
Where can you find a list of what options do what?


In the forum :)
http://forum.mikrotik.com/viewtopic.php?f=2&t=19183&p=106906

the 3rd answer: http://www.iana.org/assignments/bootp-dhcp-parameters

For my original post: Any Mikrotik developer here ? :)
 
chichken
just joined
Topic Author
Posts: 8
Joined: Mon Jun 19, 2006 3:33 pm
Reputation: 0

Re: DHCP option code 224-254 (privat use)

Sat May 17, 2008 11:21 pm

Hi again,

i'm tried to find out what is the difference in isc dhcp server and mikrotik dhcp server.

I used tcpdump and i found internesting thing :)

First isc server dump (only the ack packet):
Option: (t=53,l=1) DHCP Message Type = DHCP ACK
Option: (t=54,l=4) Server Identifier = 192.192.192.113
Option: (t=1,l=4) Subnet Mask = 255.255.255.0
Option: (t=3,l=4) Router = 192.192.192.111
Option: (t=6,l=4) Domain Name Server = 192.192.192.2
Option: (t=44,l=4) NetBIOS over TCP/IP Name Server = 192.192.192.2
Option: (t=252,l=32) Proxy autodiscovery = "http://192.192.192.113/proxy.pac"


Don't tell me too much about 192.192.192.x network... my client wanna it. Forget it.

You can see the last Option, the isc dhcp server sent the 252-es option code.

Second the mikrotik dhcp dump:
Option: (t=53,l=1) DHCP Message Type = DHCP ACK
Option: (t=54,l=4) Server Identifier = 192.168.95.147
Option: (t=51,l=4) IP Address Lease Time = 3 days
Option: (t=1,l=4) Subnet Mask = 255.255.255.0
Option: (t=15,l=8) Domain Name = "abcd.xy"
Option: (t=3,l=4) Router = 192.192.192.111


Hmm hmm, i can't see the required option code.... Why?
Maybe it went to /dev/null ? (without any error log....)

I'm tried this in 3.7 (today i upgraded mt), in two way:
First:
add name=local-pac code=252 value=”http://192.192.192.113/proxy.pac”

Second:
add name=local-pac code=252 value="0x687474703a2f2f3139322e3139322e3139322e3131332f70726f78792e706163"


Each time i got the same: no option code was sent by Mikrotik!

Please help me, i don't wanna migrate back to the old system.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 7427
Joined: Mon Jun 19, 2006 11:15 pm
Reputation: 25
First RouterOS version: 2.8
Location: Home Network Ltd., Minsk, Belarus
Contact:

Re: DHCP option code 224-254 (privat use)

Sun May 18, 2008 3:49 am

you think it's a bug? write support@mikrotik.com
Russian-speaking forum: http://forum.mikrotik.by. Welcome :)

For every complex problem, there is a solution that is simple, neat, and wrong.

¡ɹǝ|SOɹǝʇnoɹ ʞıʇoɹʞıW ɯ‚|

MikroTik. Your life. Your routing.
 
chichken
just joined
Topic Author
Posts: 8
Joined: Mon Jun 19, 2006 3:33 pm
Reputation: 0

Re: DHCP option code 224-254 (privat use)

Sun May 18, 2008 10:22 pm

Chupaka wrote:
you think it's a bug? write support@mikrotik.com



OK, i did it. I get an email: new ticket has been created :)

I hope they answer me.

Peter
 
mangust
Member Candidate
Member Candidate
Posts: 224
Joined: Thu Jun 14, 2007 11:14 am
Reputation: 0

Re: DHCP option code 224-254 (privat use)

Mon May 19, 2008 10:22 am

ROS version ?
 
chichken
just joined
Topic Author
Posts: 8
Joined: Mon Jun 19, 2006 3:33 pm
Reputation: 0

Re: DHCP option code 224-254 (privat use)

Mon May 19, 2008 12:33 pm

mangust wrote:
ROS version ?

3.9
 
mangust
Member Candidate
Member Candidate
Posts: 224
Joined: Thu Jun 14, 2007 11:14 am
Reputation: 0

Re: DHCP option code 224-254 (privat use)

Mon May 19, 2008 5:50 pm

chichken wrote:
mangust wrote:
ROS version ?

3.9


Was the same problem with opt 242, until 3.0rc14, where
fixed bug - dhcp server failed to give out options with code > 127;
This also should be fixed in 2.9.51.

May be it's a new bug ?
 
chichken
just joined
Topic Author
Posts: 8
Joined: Mon Jun 19, 2006 3:33 pm
Reputation: 0

Re: DHCP option code 224-254 (privat use)

Mon May 19, 2008 9:45 pm

mangust wrote:
chichken wrote:
mangust wrote:
ROS version ?

3.9


Was the same problem with opt 242, until 3.0rc14, where
fixed bug - dhcp server failed to give out options with code > 127;
This also should be fixed in 2.9.51.

May be it's a new bug ?


I read that : fixed bug - dhcp server failed to give out options with code > 127;

But i think, this is a new bug :)
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 4652
Joined: Wed Feb 07, 2007 1:45 pm
Reputation: 40
First RouterOS version: 2.9.24
Location: Latvia
Contact:

Re: DHCP option code 224-254 (privat use)

Tue May 20, 2008 2:29 pm

Mikrotik as a DHCP server and linux as DHCP client. DHCP server gave out option 252 so it can't be ROuterOS bug.
 
chichken
just joined
Topic Author
Posts: 8
Joined: Mon Jun 19, 2006 3:33 pm
Reputation: 0

Re: DHCP option code 224-254 (privat use)

Fri May 23, 2008 3:41 pm

The problem solved by Mikrotik developers.

Thanks for that!

I think, this will be in next release.

ps: mrz: that was a bug.

Who is online

Users browsing this forum: Nightkillian, rjscomms and 37 guests