BGP + filter - community - routing mark + shaping
RouterOS general discussion

2 posts   •   Page 1 of 1
psalek
just joined
 
Posts: 14
Joined: Thu Sep 22, 2005 8:16 pm

BGP + filter - community - routing mark + shaping

by psalek » Sat Dec 20, 2008 10:23 pm

Hi,

I'm getting BGP routes from my peer, I apply input routing filter, where I match against community ID and set routing mark and then I try to set packet mark based on the routing mark. The routes get filtered OK, they show correct routing mark set, but no mangle rule with set Routing Mark is not working.

Should it be working, has anyone tried it?

Thank you

Best Regards

Petr

psalek
just joined
 
Posts: 14
Joined: Thu Sep 22, 2005 8:16 pm

Re: BGP + filter - community - routing mark + shaping

by psalek » Sun Dec 21, 2008 1:08 pm

Solved, had to use script and address-lists and queue.

Script looks like this:


:log info "QOS Removing NIX, starting sync."
:foreach subnet in [/ip firewall address-list find list=NIX] do {
/ip firewall address-list remove $subnet
}


:local founds "";

:foreach subnet in [/ip route find bgp-communities="24971:1001"] do {
:set founds [/ip route get $subnet dst-address]
:log info ("QOS add NIX network " . $founds )
/ip firewall address-list add list=NIX address=$founds

}

2 posts   •   Page 1 of 1

Who is online

Users browsing this forum: Bing [Bot], Bomber67 and 49 guests

It is currently Wed Nov 26, 2014 9:13 am