Simple Queue before dinamic simple queue
RouterOS general discussion

2 posts   •   Page 1 of 1
User avatar
jackwisp
Frequent Visitor
Frequent Visitor
 
Posts: 68
Joined: Thu May 07, 2009 2:13 am
Location: Montevideo - Uruguay

Simple Queue before dinamic simple queue

by jackwisp » Tue Feb 07, 2012 4:52 pm

Hello, we're dealing with a simple queue issue.
We have implemented a PPPoE server, via radius I send some rate limits, when the PPP session is established I get a simple queue associated to this PPP session to limit it, at this point all work fine.

Now I'm trying to avoid this rate limit for some protocols, for example, I've done a mangle rule to mark ICMP packets, then I defined a simple queue that match those ICMP packets (previously mangled) and apply no rate limits.

The mangle rule works fine, I seed how the ICMP packets are marked, but this traffic don't go trough the simple queue I defined for.

Here are some config lines from my mikrotik router:

The mangle rule:

Code: Select all
/ip firewall mangle
add action=mark-packet chain=forward disabled=no new-packet-mark="ICMP Packet" passthrough=no protocol=icmp


The simple queue rule:

Code: Select all
/queue simple
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=both disabled=no interface=all limit-at=0/0 max-limit=0/0 name="No limit for ICMP" packet-marks=\
    "ICMP Packet" parent=none priority=8 queue=default-small/default-small total-queue=default-small


The "No limit for ICMP" queue is in position #0, all other dinamic simple queues are down this one.

Any idea?, I think I'm missing some stupid think, but I can't deal with it.

Regards,
Jack.

User avatar
eszaknet
just joined
 
Posts: 18
Joined: Tue Oct 18, 2011 11:56 pm

Re: Simple Queue before dinamic simple queue

by eszaknet » Wed Feb 08, 2012 10:54 pm

Hi,

Try to change the chain from forward to prerouting. I have an SMTP queue with a mangle rule and it works.

2 posts   •   Page 1 of 1

Who is online

Users browsing this forum: Exabot [Bot], Google [Bot] and 33 guests

It is currently Fri Nov 28, 2014 7:03 am