PCC load balance...what am I doing wrong....eeep!
RouterOS general discussion

3 posts   •   Page 1 of 1
schiele
Frequent Visitor
Frequent Visitor
 
Posts: 70
Joined: Wed Sep 10, 2008 3:45 am
Location: Canada

PCC load balance...what am I doing wrong....eeep!

by schiele » Fri Apr 20, 2012 8:20 am

I have traffic passing fine out WAN1 but only a trickle going out WAN2 for some reason...anyways first time trying out PCC load balancing so I got tired of not knowing the mangle rules very confidently and how this works, i thought I would post my config for you pro's....if you can see that my config is off for the load balancing please let me know and i will see if any changes help with evening out the load over the two WAN connections, definitely lop sided as it stands.

Cheers,

# jan/02/1970 09:41:09 by RouterOS 5.12
# software id = LQWZ-A0S3
#
/interface bridge
add admin-mac=00:00:00:00:00:00 ageing-time=5m arp=enabled auto-mac=yes \
disabled=no forward-delay=15s l2mtu=1598 max-message-age=20s mtu=1500 \
name=bridge1 priority=0x8000 protocol-mode=rstp transmit-hold-count=6
/interface ethernet
set 0 arp=enabled auto-negotiation=yes disabled=no full-duplex=yes l2mtu=1600 \
mac-address=00:0C:42:D2:8B:6A mtu=1500 name=ether10 speed=100Mbps
set 1 arp=enabled auto-negotiation=yes disabled=no full-duplex=yes l2mtu=1600 \
mac-address=00:0C:42:D2:8B:6B mtu=1500 name=ether9 speed=100Mbps
set 2 arp=enabled auto-negotiation=yes disabled=no full-duplex=yes l2mtu=1600 \
mac-address=00:0C:42:D2:8B:6D mtu=1500 name=ether7 speed=100Mbps
set 3 arp=enabled auto-negotiation=yes disabled=no full-duplex=yes l2mtu=1600 \
mac-address=00:0C:42:D2:8B:6C mtu=1500 name=ether8 speed=100Mbps
set 4 arp=enabled auto-negotiation=yes disabled=no full-duplex=yes l2mtu=1600 \
mac-address=00:0C:42:D2:8B:6E mtu=1500 name=ether6 speed=100Mbps
set 5 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited \
disabled=no full-duplex=yes l2mtu=1598 mac-address=00:0C:42:D2:8B:6F \
master-port=none mtu=1500 name=ether5 speed=100Mbps
set 6 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited \
disabled=no full-duplex=yes l2mtu=1598 mac-address=00:0C:42:D2:8B:70 \
master-port=none mtu=1500 name=ether4 speed=100Mbps
set 7 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited \
disabled=no full-duplex=yes l2mtu=1598 mac-address=00:0C:42:D2:8B:71 \
master-port=none mtu=1500 name=ether3 speed=100Mbps
set 8 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited \
disabled=no full-duplex=yes l2mtu=1598 mac-address=00:0C:42:D2:8B:72 \
master-port=none mtu=1500 name=WAN2 speed=100Mbps
set 9 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited \
disabled=no full-duplex=yes l2mtu=1598 mac-address=00:0C:42:D2:8B:73 \
master-port=none mtu=1500 name=WAN1 speed=100Mbps
/interface ethernet switch
set 0 mirror-source=none mirror-target=none name=switch1
/ip hotspot profile
set [ find default=yes ] dns-name="" hotspot-address=0.0.0.0 html-directory=\
hotspot http-cookie-lifetime=3d http-proxy=0.0.0.0:0 login-by=\
cookie,http-chap name=default rate-limit="" smtp-server=0.0.0.0 \
split-user-domain=no use-radius=no
add dns-name="" hotspot-address=192.168.2.1 html-directory=hotspot \
http-proxy=0.0.0.0:0 login-by=http-pap name=hsprof1 rate-limit="" \
smtp-server=64.59.128.135 split-user-domain=no use-radius=no
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m name=default \
rate-limit=384k/2066k shared-users=99 status-autorefresh=1m \
transparent-proxy=no
/ip ipsec proposal
set [ find default=yes ] auth-algorithms=sha1 disabled=no enc-algorithms=3des \
lifetime=30m name=default pfs-group=modp1024
/ip pool
add name=pool1 ranges=192.168.2.20-192.168.2.200
/ip dhcp-server
add address-pool=pool1 authoritative=after-2sec-delay bootp-support=static \
disabled=no interface=bridge1 lease-time=1d name=server1
/ip hotspot
add address-pool=pool1 addresses-per-mac=2 disabled=no idle-timeout=5m \
interface=bridge1 keepalive-timeout=none name=hotspot1 profile=hsprof1
/port
set 0 baud-rate=115200 data-bits=8 flow-control=none name=serial0 parity=none \
stop-bits=1
set 1 baud-rate=115200 data-bits=8 flow-control=none name=serial1 parity=none \
stop-bits=1
/ppp profile
set 0 change-tcp-mss=yes name=default only-one=default use-compression=\
default use-encryption=default use-mpls=default use-vj-compression=\
default
set 1 change-tcp-mss=yes name=default-encryption only-one=default \
use-compression=default use-encryption=yes use-mpls=default \
use-vj-compression=default
/queue type
set 0 kind=pfifo name=default pfifo-limit=50
set 1 kind=pfifo name=ethernet-default pfifo-limit=50
set 2 kind=sfq name=wireless-default sfq-allot=1514 sfq-perturb=5
set 3 kind=red name=synchronous-default red-avg-packet=1000 red-burst=20 \
red-limit=60 red-max-threshold=50 red-min-threshold=10
set 4 kind=sfq name=hotspot-default sfq-allot=1514 sfq-perturb=5
set 5 kind=none name=only-hardware-queue
set 6 kind=mq-pfifo mq-pfifo-limit=50 name=multi-queue-ethernet-default
set 7 kind=pfifo name=default-small pfifo-limit=10
/routing bgp instance
set default as=65530 client-to-client-reflection=yes disabled=no \
ignore-as-path-len=no name=default out-filter="" redistribute-connected=\
no redistribute-ospf=no redistribute-other-bgp=no redistribute-rip=no \
redistribute-static=no router-id=0.0.0.0 routing-table=""
/routing ospf instance
set [ find default=yes ] disabled=no distribute-default=never in-filter=\
ospf-in metric-bgp=auto metric-connected=20 metric-default=1 \
metric-other-ospf=auto metric-rip=20 metric-static=20 name=default \
out-filter=ospf-out redistribute-bgp=no redistribute-connected=no \
redistribute-other-ospf=no redistribute-rip=no redistribute-static=no \
router-id=0.0.0.0
/routing ospf area
set [ find default=yes ] area-id=0.0.0.0 disabled=no instance=default name=\
backbone type=default
/snmp community
set [ find default=yes ] address=70.76.64.215/32 authentication-password="" \
authentication-protocol=MD5 encryption-password="" encryption-protocol=\
DES name=public read-access=yes security=none write-access=no
/system logging action
set 0 memory-lines=100 memory-stop-on-full=no name=memory target=memory
set 1 disk-file-count=2 disk-file-name=log disk-lines-per-file=100 \
disk-stop-on-full=no name=disk target=disk
set 2 name=echo remember=yes target=echo
set 3 bsd-syslog=no name=remote remote-port=514 syslog-facility=daemon \
syslog-severity=auto target=remote
/user group
set read skin=default
set write skin=default
set full skin=default
/interface bridge port
add bridge=bridge1 disabled=no edge=auto external-fdb=auto horizon=none \
interface=ether3 path-cost=10 point-to-point=auto priority=0x80
add bridge=bridge1 disabled=no edge=auto external-fdb=auto horizon=none \
interface=ether4 path-cost=10 point-to-point=auto priority=0x80
add bridge=bridge1 disabled=no edge=auto external-fdb=auto horizon=none \
interface=ether5 path-cost=10 point-to-point=auto priority=0x80
/interface bridge settings
set use-ip-firewall=no use-ip-firewall-for-pppoe=no use-ip-firewall-for-vlan=\
no
/interface ethernet switch port
set 0 vlan-header=leave-as-is vlan-mode=fallback
set 1 vlan-header=leave-as-is vlan-mode=fallback
set 2 vlan-header=leave-as-is vlan-mode=fallback
set 3 vlan-header=leave-as-is vlan-mode=fallback
set 4 vlan-header=leave-as-is vlan-mode=fallback
set 5 vlan-header=leave-as-is vlan-mode=fallback
/interface l2tp-server server
set authentication=pap,chap,mschap1,mschap2 default-profile=\
default-encryption enabled=no max-mru=1460 max-mtu=1460 mrru=disabled
/interface ovpn-server server
set auth=sha1,md5 certificate=none cipher=blowfish128,aes128 default-profile=\
default enabled=no keepalive-timeout=60 mac-address=FE:98:4A:79:C9:13 \
max-mtu=1500 mode=ip netmask=24 port=1194 require-client-certificate=no
/interface pptp-server server
set authentication=mschap1,mschap2 default-profile=default-encryption \
enabled=no keepalive-timeout=30 max-mru=1460 max-mtu=1460 mrru=disabled
/interface sstp-server server
set authentication=pap,chap,mschap1,mschap2 certificate=none default-profile=\
default enabled=no keepalive-timeout=60 max-mru=1500 max-mtu=1500 mrru=\
disabled port=443 verify-client-certificate=no
/ip accounting
set account-local-traffic=no enabled=no threshold=256
/ip accounting web-access
set accessible-via-web=no address=0.0.0.0/0
/ip address
add address=70.64.252.233/24 disabled=no interface=WAN1 network=70.64.252.0
add address=192.168.2.1/24 disabled=no interface=bridge1 network=192.168.2.0
add address=71.17.11.213/24 disabled=no interface=WAN2 network=71.17.11.0
/ip dhcp-server config
set store-leases-disk=5m
/ip dhcp-server network
add address=192.168.2.0/24 dhcp-option="" dns-server="" gateway=192.168.2.1 \
ntp-server="" wins-server=""
/ip dns
set allow-remote-requests=yes cache-max-ttl=1w cache-size=5000KiB \
max-udp-packet-size=512 servers=4.2.2.2,8.8.8.8
/ip firewall connection tracking
set enabled=yes generic-timeout=10m icmp-timeout=10s tcp-close-timeout=10s \
tcp-close-wait-timeout=10s tcp-established-timeout=1d \
tcp-fin-wait-timeout=10s tcp-last-ack-timeout=10s \
tcp-syn-received-timeout=5s tcp-syn-sent-timeout=5s tcp-syncookie=no \
tcp-time-wait-timeout=10s udp-stream-timeout=3m udp-timeout=10s
/ip firewall filter
add action=passthrough chain=unused-hs-chain comment=\
"place hotspot rules here" disabled=yes
/ip firewall mangle
add action=mark-connection chain=input disabled=no in-interface=WAN1 \
new-connection-mark=WAN1_conn passthrough=yes
add action=mark-connection chain=input disabled=no in-interface=WAN2 \
new-connection-mark=WAN2_conn passthrough=yes
add action=mark-routing chain=output connection-mark=WAN1_conn disabled=no \
new-routing-mark=to_WAN1 passthrough=yes
add action=mark-routing chain=output connection-mark=WAN2_conn disabled=no \
new-routing-mark=to_WAN2 passthrough=yes
add action=accept chain=prerouting disabled=no dst-address=70.64.252.0/24 \
in-interface=bridge1
add action=accept chain=prerouting disabled=no dst-address=71.17.11.0/24 \
in-interface=bridge1
add action=mark-connection chain=prerouting disabled=no dst-address-type=\
local in-interface=bridge1 new-connection-mark=WAN1_conn passthrough=yes \
per-connection-classifier=src-address:2/0
add action=mark-connection chain=prerouting disabled=no dst-address-type=\
local in-interface=bridge1 new-connection-mark=WAN2_conn passthrough=yes \
per-connection-classifier=src-address:2/1
add action=mark-routing chain=prerouting connection-mark=WAN1_conn disabled=\
no in-interface=bridge1 new-routing-mark=to_WAN1 passthrough=yes
add action=mark-routing chain=prerouting connection-mark=WAN2_conn disabled=\
no in-interface=bridge1 new-routing-mark=to_WAN2 passthrough=yes
/ip firewall nat
add action=passthrough chain=unused-hs-chain comment=\
"place hotspot rules here" disabled=yes
add action=masquerade chain=srcnat disabled=no out-interface=WAN1
add action=masquerade chain=srcnat disabled=no out-interface=WAN2
add action=masquerade chain=srcnat comment="masquerade hotspot network" \
disabled=no src-address=192.168.2.0/24
add action=dst-nat chain=dstnat disabled=no dst-port=9000 in-interface=WAN1 \
protocol=tcp to-addresses=192.168.2.113 to-ports=9000
add action=dst-nat chain=dstnat disabled=no dst-port=113 in-interface=WAN1 \
protocol=tcp to-addresses=192.168.2.113 to-ports=80
/ip firewall service-port
set ftp disabled=no ports=21
set tftp disabled=no ports=69
set irc disabled=no ports=6667
set h323 disabled=no
set sip disabled=no ports=5060,5061 sip-direct-media=yes
set pptp disabled=no
/ip hotspot ip-binding
add address=192.168.2.4 disabled=no mac-address=00:0C:42:08:6D:50 to-address=\
192.168.2.4 type=bypassed
add address=192.168.2.2 disabled=no mac-address=00:0C:42:14:0D:30 server=\
hotspot1 to-address=192.168.2.2 type=bypassed
add address=192.168.2.3 disabled=no mac-address=00:0C:42:08:6D:54 server=\
hotspot1 to-address=192.168.2.3 type=bypassed
add address=192.168.2.5 disabled=no mac-address=00:0C:42:14:0D:2E server=\
hotspot1 to-address=192.168.2.5 type=bypassed
add address=192.168.2.113 comment=DVR disabled=no mac-address=\
00:18:F5:01:72:F2 server=hotspot1 to-address=192.168.2.113 type=bypassed
add address=192.168.2.35 comment="Federal PC worker" disabled=no mac-address=\
00:1C:C4:C9:25:21 server=hotspot1 to-address=192.168.2.35 type=bypassed
add address=192.168.2.194 comment="CRA Federal Worker" disabled=no \
mac-address=00:1C:C4:C9:33:8E server=hotspot1 to-address=192.168.2.194 \
type=bypassed
add address=192.168.2.67 comment="Room 405" disabled=no mac-address=\
00:13:E8:9D:C6:11 server=hotspot1 to-address=192.168.2.67
add address=192.168.2.35 comment="Rm 219" disabled=no mac-address=\
00:1D:60:AA:A6:E0 server=hotspot1
add address=192.168.2.60 disabled=no mac-address=00:25:D3:6F:EC:DD type=\
bypassed
add disabled=no mac-address=0C:60:76:4F:41:34
add disabled=no mac-address=00:1D:D8:B4:7B:90 type=bypassed
add disabled=no mac-address=00:24:2C:1B:86:25 type=bypassed
add disabled=no mac-address=68:A3:C4:08:A4:F2 type=bypassed
add disabled=no mac-address=68:A3:C4:7E:42:8C
add disabled=no mac-address=00:24:E8:B7:1F:F9 type=bypassed
add disabled=no mac-address=AC:81:12:33:37:9A type=bypassed
add address=192.168.2.22 disabled=no mac-address=00:23:12:03:49:74 server=\
hotspot1 to-address=192.168.2.22 type=bypassed
add address=192.168.2.198 disabled=no mac-address=4C:ED:DE:2C:BA:18 server=\
hotspot1 to-address=192.168.2.198 type=bypassed
add address=192.168.2.105 disabled=no mac-address=60:C5:47:08:2A:68 type=\
bypassed
add address=192.168.2.143 disabled=no mac-address=4C:0F:6E:0F:53:EB server=\
hotspot1 to-address=192.168.2.143 type=bypassed
/ip hotspot service-port
set ftp disabled=no ports=21
/ip hotspot user
add disabled=no name=admin password=******** profile=default
add disabled=no name=generic_user password=generic_password profile=default
/ip hotspot walled-garden
add action=allow disabled=no dst-host=suitesolutions.ca dst-port=""
add action=allow disabled=no dst-host=www.suitesolutions.ca dst-port=""
add action=allow disabled=no dst-host=statcounter.com dst-port=""
add action=allow disabled=no dst-host=http://statcounter.com dst-port=""
add action=allow disabled=no dst-host=http://c.statcounter.com dst-port=""
add action=allow disabled=no dst-host=c.statcounter.com dst-port=""
add action=allow disabled=no dst-host=www.c.statcounter.com dst-port=""
add action=allow disabled=no dst-host=www.statcounter.com dst-port=""
add action=allow disabled=no dst-host=http://www.statcounter.com dst-port=""
/ip neighbor discovery
set ether10 disabled=no
set ether9 disabled=no
set ether7 disabled=no
set ether8 disabled=no
set ether6 disabled=no
set ether5 disabled=no
set ether4 disabled=no
set ether3 disabled=no
set WAN2 disabled=no
set WAN1 disabled=no
set bridge1 disabled=no
/ip proxy
set always-from-cache=no cache-administrator=webmaster cache-hit-dscp=4 \
cache-on-disk=no enabled=no max-cache-size=none max-client-connections=\
600 max-fresh-time=3d max-server-connections=600 parent-proxy=0.0.0.0 \
parent-proxy-port=0 port=8080 serialize-connections=no src-address=\
0.0.0.0
/ip route
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
70.64.252.1 routing-mark=to_WAN1 scope=30 target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
71.17.11.254 routing-mark=to_WAN2 scope=30 target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
71.17.11.254 scope=30 target-scope=10
add check-gateway=ping disabled=no distance=2 dst-address=0.0.0.0/0 gateway=\
70.64.252.1 scope=30 target-scope=10
/ip service
set telnet address="" disabled=no port=23
set ftp address="" disabled=yes port=21
set www address="" disabled=yes port=80
set ssh address="" disabled=yes port=22
set www-ssl address="" certificate=none disabled=yes port=443
set api address="" disabled=yes port=8728
set winbox address="" disabled=no port=8291
/ip smb
set allow-guests=yes comment=MikrotikSMB domain=MSHOME enabled=no interfaces=\
all
/ip smb shares
set [ find default=yes ] comment="default share" directory=/pub disabled=no \
max-sessions=10 name=pub
/ip smb users
set [ find default=yes ] disabled=no name=guest password="" read-only=yes
/ip socks
set connection-idle-timeout=2m enabled=no max-connections=200 port=1080
/ip traffic-flow
set active-flow-timeout=30m cache-entries=4k enabled=no \
inactive-flow-timeout=15s interfaces=all
/ip upnp
set allow-disable-external-interface=yes enabled=no show-dummy-rule=yes
/mpls
set dynamic-label-range=16-1048575 propagate-ttl=yes
/mpls interface
set [ find default=yes ] disabled=no interface=all mpls-mtu=1508
/mpls ldp
set distribute-for-default-route=no enabled=no hop-limit=255 loop-detect=no \
lsr-id=0.0.0.0 path-vector-limit=255 transport-address=0.0.0.0 \
use-explicit-null=no
/port firmware
set directory=firmware
/ppp aaa
set accounting=yes interim-update=0s use-radius=no
/queue interface
set ether10 queue=ethernet-default
set ether9 queue=ethernet-default
set ether7 queue=ethernet-default
set ether8 queue=ethernet-default
set ether6 queue=ethernet-default
set ether5 queue=ethernet-default
set ether4 queue=ethernet-default
set ether3 queue=ethernet-default
set WAN2 queue=ethernet-default
set WAN1 queue=ethernet-default
set bridge1 queue=only-hardware-queue
/radius incoming
set accept=no port=3799
/routing bfd interface
set [ find default=yes ] disabled=no interface=all interval=0.2s min-rx=0.2s \
multiplier=5
/routing mme
set bidirectional-timeout=2 gateway-class=none gateway-keepalive=1m \
gateway-selection=no-gateway origination-interval=5s preferred-gateway=\
0.0.0.0 timeout=1m ttl=50
/routing rip
set distribute-default=never garbage-timer=2m metric-bgp=1 metric-connected=1 \
metric-default=1 metric-ospf=1 metric-static=1 redistribute-bgp=no \
redistribute-connected=no redistribute-ospf=no redistribute-static=no \
routing-table=main timeout-timer=3m update-timer=30s
/snmp
set contact="" enabled=no engine-id="" location="" trap-generators="" \
trap-target="" trap-version=1
/system clock
set time-zone-name=manual
/system clock manual
set dst-delta=+00:00 dst-end="jan/01/1970 00:00:00" dst-start=\
"jan/01/1970 00:00:00" time-zone=+00:00
/system console
set [ find port=serial0 ] disabled=no port=serial0 term=vt102
/system identity
set name=gateway
/system logging
set 0 action=memory disabled=no prefix="" topics=info
set 1 action=memory disabled=no prefix="" topics=error
set 2 action=memory disabled=no prefix="" topics=warning
set 3 action=echo disabled=no prefix="" topics=critical
/system note
set note="" show-at-login=yes
/system ntp client
set enabled=no mode=broadcast primary-ntp=0.0.0.0 secondary-ntp=0.0.0.0
/system resource irq
set 0 cpu=auto
set 1 cpu=auto
set 2 cpu=auto
set 3 cpu=auto
set 4 cpu=auto
set 5 cpu=auto
set 6 cpu=auto
set 7 cpu=auto
set 8 cpu=auto
set 9 cpu=auto
set 10 cpu=auto
set 11 cpu=auto
set 12 cpu=auto
set 13 cpu=auto
/system routerboard settings
set baud-rate=115200 boot-delay=2s boot-device=nand-if-fail-then-ethernet \
boot-protocol=bootp cpu-frequency=1GHz<400DDR> enable-jumper-reset=yes \
enter-setup-on=any-key force-backup-booter=no silent-boot=no
/system upgrade mirror
set check-interval=1d enabled=no primary-server=0.0.0.0 secondary-server=\
0.0.0.0 user=""
/system watchdog
set auto-send-supout=no automatic-supout=yes no-ping-delay=5m watch-address=\
none watchdog-timer=yes
/tool bandwidth-server
set allocate-udp-ports-from=2000 authenticate=yes enabled=yes max-sessions=\
100
/tool e-mail
set address=0.0.0.0 from=<> password="" port=25 user=""
/tool graphing
set page-refresh=300 store-every=5min
/tool mac-server
set [ find default=yes ] disabled=no interface=all
/tool mac-server mac-winbox
set [ find default=yes ] disabled=no interface=all
/tool mac-server ping
set enabled=yes
/tool sms
set allowed-number="" channel=0 keep-max-sms=0 receive-enabled=no secret=""
/tool sniffer
set file-limit=1000KiB file-name="" filter-ip-address="" filter-ip-protocol=\
"" filter-mac-address="" filter-mac-protocol="" filter-port="" \
filter-stream=yes interface=all memory-limit=100KiB memory-scroll=yes \
only-headers=no streaming-enabled=no streaming-server=0.0.0.0
/tool traffic-generator
set latency-distribution-scale=10 test-id=0
/user aaa
set accounting=yes default-group=read exclude-groups="" interim-update=0s \
use-radius=no

Feklar
Forum Guru
Forum Guru
 
Posts: 1421
Joined: Wed Dec 02, 2009 12:46 am

Re: PCC load balance...what am I doing wrong....eeep!

by Feklar » Fri Apr 20, 2012 7:19 pm

Code: Select all
add action=mark-connection chain=prerouting disabled=no dst-address-type=\
local in-interface=bridge1 new-connection-mark=WAN1_conn passthrough=yes \
per-connection-classifier=src-address:2/0
add action=mark-connection chain=prerouting disabled=no dst-address-type=\
local in-interface=bridge1 new-connection-mark=WAN2_conn passthrough=yes \
per-connection-classifier=src-address:2/1


Either make "dst-address-type=local" into "dst-address-type=!local"(not local) or remove that firewall matcher from the rules.

schiele
Frequent Visitor
Frequent Visitor
 
Posts: 70
Joined: Wed Sep 10, 2008 3:45 am
Location: Canada

Re: PCC load balance...what am I doing wrong....eeep!

by schiele » Sat Apr 21, 2012 5:30 pm

:D

Yep...that was it!!! good eye. thank you Sir. :)

3 posts   •   Page 1 of 1

Who is online

Users browsing this forum: Google [Bot], NetdumaLuke and 19 guests

It is currently Fri Nov 28, 2014 3:02 am