Community discussions

MikroTik App
 
SGregg
just joined
Topic Author
Posts: 14
Joined: Wed Mar 28, 2012 10:11 pm

Simple QOS for Shoretel VoIP?

Tue May 15, 2012 8:55 pm

Hello All,

I need to impliment QOS over my WAN to support QOS. I have a relatively simple network and do not need multiple levels of QOS. I have looked at applying a mangle filter to all UDP/5004 packets and giving them higher priority than all other traffic. Could you take a look at what I came up with and let me know if I am on the right track?

Thanks

Stephen
--------------------------
/ip firewall mangle

add action=mark-connection chain=prerouting disabled=no new-connection-mark=\
VOIP passthrough=yes protocol=udp src-port=5004
add action=mark-packet chain=prerouting connection-mark=VOIP disabled=no \
new-packet-mark=VOIP passthrough=no



/queue type
set default kind=pfifo name=default pfifo-limit=50
set ethernet-default kind=pfifo name=ethernet-default pfifo-limit=50
set wireless-default kind=sfq name=wireless-default sfq-allot=1514 \
sfq-perturb=5
set synchronous-default kind=red name=synchronous-default red-avg-packet=1000 \
red-burst=20 red-limit=60 red-max-threshold=50 red-min-threshold=10
set hotspot-default kind=sfq name=hotspot-default sfq-allot=1514 sfq-perturb=\
5
set default-small kind=pfifo name=default-small pfifo-limit=10
/queue simple
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=both \
disabled=no dst-address=0.0.0.0/0 interface=all limit-at=0/0 max-limit=\
0/0 name="VOIP Traffic" packet-marks=VOIP parent=none priority=1 queue=\
default-small/default-small total-queue=default-small
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=both \
disabled=no dst-address=0.0.0.0/0 interface=all limit-at=0/0 max-limit=\
0/0 name="All Other Traffic" parent=none priority=8 queue=\
default-small/default-small total-queue=default-small
/queue interface
set ether1 queue=ethernet-default
set ether2 queue=ethernet-default
set ether3 queue=ethernet-default
set ether4 queue=ethernet-default
set ether5 queue=ethernet-default
set ether6 queue=ethernet-default
 
sasafras
just joined
Posts: 2
Joined: Mon Oct 09, 2006 7:27 pm

Re: Simple QOS for Shoretel VoIP?

Tue May 15, 2012 10:44 pm

Hi Stephen,
It's not a good idea to apply QOS by port as ports are dynamic. VoIP traffic by default(most) uses DSCP value 46 to prioritize. This value is equal to TOS 184, and Mikrotik's Priority 3. So, with some help with our friends on the forum, I've put together the script below and it seems to work pretty well.
I hope this helps.

Seth


/ip firewall mangle
add action=mark-packet chain=postrouting comment="" disabled=no dscp=46 new-packet-mark=P3 passthrough=no

/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=Download parent=global-out priority=1
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=P3 packet-mark=P3 parent=Download priority=3 queue=default

Who is online

Users browsing this forum: Bing [Bot], d513, sch, Ullinator and 116 guests