Community discussions

MikroTik App
 
ekkas
Long time Member
Long time Member
Topic Author
Posts: 567
Joined: Mon Sep 26, 2005 1:01 pm
Location: South Africa

Queues question

Thu Jun 14, 2012 4:48 pm

Hi all,
I do Load Balancing using PCQ and Nth but is a bit of a noob with bandwidth management/queues and some help would be appreciated.
But on my one router, I need to limit users to a maximum certain speed.
The bandwidth is highly contended, so I do not want to divide bandwidth, just limit users in a group to a certain speed, based on address lists.

this is what I've done so far.
TRUE interface is my internal users networks, there are 6 outgoing WAN connections that is load balanced.
/ip firewall mangle
add action=mark-packet chain=forward dst-address-list=64k new-packet-mark=pm64 passthrough=no
add action=mark-packet chain=forward src-address-list=64k new-packet-mark=pm64 passthrough=no
add action=mark-packet chain=forward dst-address-list=128k new-packet-mark=pm128 passthrough=no
add action=mark-packet chain=forward src-address-list=128k new-packet-mark=pm128 passthrough=no
add action=mark-packet chain=forward dst-address-list=256k new-packet-mark=pm256 passthrough=no
add action=mark-packet chain=forward src-address-list=256k new-packet-mark=pm256 passthrough=no
add action=mark-packet chain=forward dst-address-list=512k new-packet-mark=pm512 passthrough=no
add action=mark-packet chain=forward src-address-list=512k new-packet-mark=pm512 passthrough=no
add action=mark-packet chain=forward dst-address-list=1024k new-packet-mark=pm1024 passthrough=no
add action=mark-packet chain=forward src-address-list=1024k new-packet-mark=pm1024 passthrough=no
add action=mark-packet chain=forward dst-address-list=4000k new-packet-mark=pm4000 passthrough=no
add action=mark-packet chain=forward src-address-list=4000k new-packet-mark=pm4000 passthrough=no

/queue type
add kind=pcq name=4000dn pcq-burst-time=5s pcq-classifier=dst-address pcq-rate=4M
add kind=pcq name=256up pcq-classifier=src-address pcq-rate=256k
add kind=pcq name=256dn pcq-classifier=dst-address pcq-rate=256k
add kind=pcq name=128up pcq-classifier=src-address pcq-rate=128k
add kind=pcq name=64dn pcq-classifier=dst-address pcq-rate=64k
add kind=pcq name=64up pcq-classifier=src-address pcq-rate=64k
add kind=pcq name=1000dn pcq-classifier=dst-address pcq-rate=1M
add kind=pcq name=512dn pcq-classifier=dst-address pcq-rate=512k
add kind=pcq name=128dn pcq-classifier=dst-address pcq-rate=128k
set 17 pfifo-limit=30

/queue simple
add interface=TRUE name=4000_512 packet-marks=pm4000 priority=4 queue=256up/4000dn total-queue=synchronous-default
add interface=TRUE name=1024_512 packet-marks=pm1024 priority=4 queue=256up/1000dn total-queue=synchronous-default
add interface=TRUE name=512_128 packet-marks=pm512 priority=4 queue=128up/512dn total-queue=synchronous-default
add interface=TRUE name=256_128 packet-marks=pm256 priority=4 queue=128up/256dn total-queue=synchronous-default
add interface=TRUE name=128_64 packet-marks=pm128 priority=4 queue=64up/128dn total-queue=synchronous-default
add interface=TRUE name=64_64 packet-marks=pm64 priority=4 queue=64up/64dn total-queue=synchronous-default
This seems to work to a certain extent, but when I enable the packet marks (to start using the queues), it seem sthat everyboby slows down. Almost like I limit all e.g. 4Mbps users to share a single 4Mbps. I need them each to be able to reach 4Mbps max, if total bandwidth allows.

Thanks in advance
Ekkas

Who is online

Users browsing this forum: infabo and 123 guests