Community discussions

MikroTik App
 
achundee
just joined
Topic Author
Posts: 2
Joined: Mon Aug 06, 2012 7:51 pm

Simple queues not quite doing what I expected them to do

Mon Aug 06, 2012 8:03 pm

Hi guys,

If anyone can shed any light on this, i would be very appreciative. I have started learning RouterOS using a book called "RouterOS by Example". I have used three simple queues to achieve the following:

1. Traffic to/from our hosted VOIP platform, reserved 512kbit symmetrically, priority 1. Traffic is identified using two mangles - incoming and outgoing traffic from the hosted server.
2. All other traffic, unlimited bandwidth, priority 7.
3. Replication traffic for our off-site backup system (identified by the ports and destination IP), reserved 512kbit upstream, priority 8.

This seems to work fine, but what I wanted to do really was to allow the backup traffic to take as much upstream as possible, as long as the VOIP had taken what it needed first. I was under the impression that because the backup traffic only had priority 8, that this would automatically make this the case. However, the VOIP suffers badly when I allow it unlimited bandwidth.

Do I need to be doing something differently please? Also, if I set an unlimited "target upload" and a "target download", I cannot see how much data is flowing through the queue in detailed view. Is there a reason for this? Should I have set the max upload in the WAN interface to help matters?

Thanks in advance!
 
RomelSan
newbie
Posts: 37
Joined: Fri Jul 06, 2012 1:53 am

Re: Simple queues not quite doing what I expected them to do

Fri Aug 10, 2012 7:21 am

Study QoS Tree first, then simple queue rules will be easy, because it also uses a parent child structure.

So,

Case Example:
* Later you will be able to setup rules against services or entire networks

Important Device = 192.168.6.100 unlimited speed
Secondary Device = 192.168.6.150 limited (Download: 2mbps, Upload: 1mbps)

Change IPs to your IPs, and change parent=YOUR_WAN_INTERFACE
to your WAN interface.
/ip firewall mangle
add chain=prerouting src-address=192.168.6.100 action=mark-connection new-connection-mark=IMPORTANT_DEVICE_conn comment="IMPORTANT DEVICE Conn" 
add chain=prerouting connection-mark=IMPORTANT_DEVICE_conn action=mark-packet new-packet-mark=IMPORTANT_DEVICE_PACKET passthrough=no
add chain=prerouting src-address=192.168.6.150 action=mark-connection new-connection-mark=SECONDARY_IP_Conn comment="SECONDARY DEVICES"
add chain=prerouting connection-mark=SECONDARY_IP_Conn action=mark-packet new-packet-mark="SECONDARY_IP_PACKETS" passthrough=no

/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name="Internet Download" packet-mark="" parent=global-in priority=1
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name="Important Device Down Limit" packet-mark=IMPORTANT_DEVICE_PACKET parent="Internet Download" priority=1
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=2M name="Secondary Device Down Limit" packet-mark=SECONDARY_IP_PACKETS parent="Internet Download" priority=2

add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name="Internet Upload" packet-mark="" parent=YOUR_WAN_INTERFACE priority=1
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name="Important Device Up Limit" packet-mark=IMPORTANT_DEVICE_PACKET parent="Internet Upload" priority=1
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=1M name="Secondary Device Up Limit" packet-mark=SECONDARY_IP_PACKETS parent="Internet Upload" priority=2
Thats all!

Take a look at my entire QoS home setup: http://forum.mikrotik.com/viewtopic.php?f=13&t=64586

Cheers,
Dont Forget to Karma+ :)
 
achundee
just joined
Topic Author
Posts: 2
Joined: Mon Aug 06, 2012 7:51 pm

Re: Simple queues not quite doing what I expected them to do

Fri Aug 10, 2012 11:14 am

Thanks RomelSan, I will have a look at this and let you know how I get on!

Cheers!

Who is online

Users browsing this forum: edielson_atm, GoogleOther [Bot], peracchi, SpOuK3, syslog and 86 guests