Close All Ports Just Http and Yahoo Gmail and Hotmail
RouterOS general discussion

6 posts   •   Page 1 of 1
Mohe12
just joined
 
Posts: 3
Joined: Wed Feb 24, 2010 10:06 am

Close All Ports Just Http and Yahoo Gmail and Hotmail

by Mohe12 » Wed Feb 24, 2010 10:33 am

Hi Friends..........

I closed all ports by redirect 80 to 8080 and just opened port 80 in webproxy, but I cannot open yahoo,gmail, and hotmail.
the webpage ask me the email and password but when i enter it and ok the router dont let me to open my email.

Feklar
Forum Guru
Forum Guru
 
Posts: 1437
Joined: Wed Dec 02, 2009 12:46 am

Re: Close All Ports Just Http and Yahoo Gmail and Hotmail

by Feklar » Wed Feb 24, 2010 11:58 pm

That would be because those pages use https when they sign you in and not http. you will also need to allow https in order for it to work properly, port 443.

Mohe12
just joined
 
Posts: 3
Joined: Wed Feb 24, 2010 10:06 am

Re: Close All Ports Just Http and Yahoo Gmail and Hotmail

by Mohe12 » Thu Feb 25, 2010 12:38 pm

Thans for the reply
But I opened smtp, pop, ftp,and https, but still I have the problem .........

Feklar
Forum Guru
Forum Guru
 
Posts: 1437
Joined: Wed Dec 02, 2009 12:46 am

Re: Close All Ports Just Http and Yahoo Gmail and Hotmail

by Feklar » Thu Feb 25, 2010 11:56 pm

What exactly are you trying to accomplish? Depending on what you are doing, it will probably be much easier for you to drop all of the ports you don't want to use, and allow the ones you want to instead of using the redirect action.

Something like:

Code: Select all
/ip firewall filter
add chain=forward disabled=no action=accept in-interface=LAN protocol=tcp dst-port=21
add chain=forward disabled=no action=accept in-interface=LAN protocol=tcp dst-port=25
add chain=forward disabled=no action=accept in-interface=LAN protocol=tcp dst-port=80
add chain=forward disabled=no action=accept in-interface=LAN protocol=tcp dst-port=110
add chain=forward disabled=no action=accept in-interface=LAN protocol=tcp dst-port=443
add chain=forward disabled=no action=accept in-interface=LAN protocol=tcp dst-port=8080
add chain=forward disabled=no action=drop in-interface=LAN


The first set of rule are there to specifically allow services that you want through the router, the last rule will drop everything else. This also restricts it to just one interface.

User avatar
mahnet
Long time Member
Long time Member
 
Posts: 650
Joined: Tue Jul 07, 2009 9:11 pm

Re: Close All Ports Just Http and Yahoo Gmail and Hotmail

by mahnet » Fri Feb 26, 2010 6:17 am

This would still drop many smtp and pop accounts using port 587, 995 etc :)

Mohe12
just joined
 
Posts: 3
Joined: Wed Feb 24, 2010 10:06 am

Re: Close All Ports Just Http and Yahoo Gmail and Hotmail

by Mohe12 » Mon Mar 01, 2010 1:10 pm

Thanks for your help, but it does not success just goole page would be open

6 posts   •   Page 1 of 1

Who is online

Users browsing this forum: Bing [Bot], Yahoo [Bot] and 32 guests

It is currently Sat Dec 20, 2014 11:07 pm