Community discussions

MikroTik App
 
whatda
just joined
Topic Author
Posts: 20
Joined: Sun Apr 15, 2012 2:05 pm

How do I separate 2 DHCP ?

Sat Oct 26, 2013 2:22 am

HI guys I have 2 networks bridged together but I wish to separate the two DHCP servers so devices don't get each others DHCP servers.
Here is my network how do I separate the DHCP ?
network.jpg
AP
[admin@Bridge Peter] > /export compact
# jan/18/1970 22:10:49 by RouterOS 6.1
# software id = N8UG-UVGN
#
/interface bridge
add l2mtu=1600 name=bridge1 protocol-mode=rstp
/interface wireless
set 0 band=5ghz-onlyn channel-width=20/40mhz-ht-above country=australia \
default-authentication=no dfs-mode=no-radar-detect frequency=5260 \
ht-ampdu-priorities=0,1,2,3,4,5,6,7 ht-guard-interval=long ht-rxchains=\
0,1 ht-txchains=0,1 l2mtu=2290 mode=ap-bridge nv2-cell-radius=10 ssid=\
Parkview tdma-period-size=1 tx-power=4 tx-power-mode=all-rates-fixed \
wireless-protocol=nv2
/interface wireless nstreme
set wlan1 enable-nstreme=yes
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip dhcp-server
add interface=ether1 name=dhcp1
add interface=bridge1 name=dhcp2
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m \
mac-cookie-timeout=3d
/tool user-manager customer
add backup-allowed=yes disabled=no login=admin password="" \
paypal-accept-pending=no paypal-allowed=no paypal-secure-response=no \
permissions=owner signup-allowed=no time-zone=-00:00
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=wlan1
/interface bridge settings
set use-ip-firewall=yes use-ip-firewall-for-vlan=yes
/interface wireless access-list
add interface=wlan1 mac-address=00:0C:42:F7:85:99
/ip address
add address=192.168.0.4/23 interface=wlan1 network=192.168.0.0
/ip service
set api disabled=yes
/system identity
set name="Bridge Peter"
/system lcd
set contrast=0 enabled=no port=parallel type=24x4
/system lcd page
set time disabled=yes display-time=5s
set resources disabled=yes display-time=5s
set uptime disabled=yes display-time=5s
set packets disabled=yes display-time=5s
set bits disabled=yes display-time=5s
set version disabled=yes display-time=5s
set identity disabled=yes display-time=5s
set bridge1 disabled=yes display-time=5s
set wlan1 disabled=yes display-time=5s
set ether1 disabled=yes display-time=5s
/system leds
set 0 interface=wlan1
/system routerboard settings
set cpu-frequency=250MHz
[admin@Bridge Peter] >



CP
[admin@Bridge Brett] > /export compact
# feb/22/1970 01:52:21 by RouterOS 6.0rc14
# software id = AMPR-24DV
#
/interface bridge
add l2mtu=1600 name=bridge1 protocol-mode=rstp
/interface wireless
set 0 band=5ghz-onlyn channel-width=20/40mhz-ht-below country=australia dfs-mode=no
tx-power-mode=all-rates-fixed
/interface wireless nstreme
set wlan1 enable-nstreme=yes
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip dhcp-server
add interface=bridge1 name=dhcp1
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=wlan1
/interface wireless access-list
add interface=wlan1 mac-address=D4:CA:6D:47:40:73
/ip address
add address=192.168.1.4/23 interface=ether1 network=192.168.0.0
/system clock
set time-zone-name=Australia/Melbourne
/system identity
set name="Bridge Brett"
/system leds
set 0 interface=wlan1
/system ntp client
set enabled=yes mode=unicast primary-ntp=150.203.1.10
[admin@Bridge Brett] >
You do not have the required permissions to view the files attached to this post.
 
npero
Member
Member
Posts: 317
Joined: Tue Mar 01, 2005 1:59 pm
Location: Serbia

Re: How do I separate 2 DHCP ?

Sat Oct 26, 2013 9:22 am

On AP or client just drop udp port 67-68 you can do that in bridge filter.
/interface bridge filter 
chain=forward action=drop in-interface=ether1 mac-protocol=ip dst-port=68 ip-protocol=udp 
chain=forward out-interface=ether1 action=drop mac-protocol=ip dst-port=68 ip-protocol=udp 

Who is online

Users browsing this forum: Ahrefs [Bot], raiser and 37 guests