Community discussions

MikroTik App
 
jjlit
just joined
Topic Author
Posts: 2
Joined: Tue Mar 18, 2014 12:41 pm

PTP link change to PTMP

Sun Jul 27, 2014 4:26 am

Hi guys,
I have the following config on a level 4 licensed Omnitik

# STEP 1: Set the Antenna Gain
# RBSXT, gain=16
# RB-SEXTANT, gain=18
# DuxLink Duo Kit (since May 2012), gain=25
# DuxLink Duo Kit (pre May 2012), gain=19
#
global antennagain 16
#
# STEP 2: set the SSID
#
global ssid DuxLink
#
# STEP 3: substitute your own password below
#
global sharedkey duxtel
#
# STEP 4: substitute your own password below
#
global password duxtel
#
# Optional: select wireless channel
# - select from: 5825, 5805, 5785, 5745, 5700, 5680, 5660, 5580, 5660, 5540, 5520, 5500
#
global channel 5825
#
# OPTIONAL: substitute your own device name
#
global devicename duxLinkA
#
/interface bridge
add l2mtu=1598 name=bridge1 protocol-mode=rstp

/interface wireless
set 0 antenna-gain=$antennagain band=5ghz-a/n channel-width=20/40mhz-ht-below \
country=australia dfs-mode=none disabled=no frequency=$channel \
frequency-mode=regulatory-domain ht-rxchains=0,1 ht-txchains=0,1 \
mode=bridge nv2-preshared-key=$sharedkey nv2-security=enabled ssid=$ssid \
wireless-protocol=nv2

/interface eoip
add name=eoip-tunnel1 remote-address=\
192.168.89.2 tunnel-id=1

/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=eoip-tunnel1

/interface bridge settings
set use-ip-firewall=yes

/ip address
add address=192.168.89.1/29 interface=wlan1

/ip dhcp-client
add default-route-distance=0 disabled=no interface=bridge1

/ip firewall mangle
add action=set-priority chain=input new-priority=from-dscp

/system identity
set name=$devicename

/user
set admin password $password



And the following config on a level 3 licensed SXT Lite:

# STEP 1: Set the Antenna Gain
# RBSXT, gain=16
# RB-SEXTANT, gain=18
# DuxLink Duo Kit (since May 2012), gain=25
# DuxLink Duo Kit (pre May 2012), gain=19
#
global antennagain 16
#
# STEP 2: set the SSID
#
global ssid DuxLink
#
# STEP 3: substitute your own password below
#
global sharedkey duxtel
#
# STEP 4: substitute your own password below
#
global password duxtel
#
# Optional: select wireless channel
# - select from: 5825, 5805, 5785, 5745, 5700, 5680, 5660, 5580, 5660, 5540, 5520, 5500
#
global channel 5825
#
# OPTIONAL: substitute your own device name
#
global devicename duxLinkB
#
/interface bridge
add l2mtu=1598 name=bridge1 protocol-mode=rstp

/interface wireless
set 0 antenna-gain=$antennagain band=5ghz-a/n channel-width=20/40mhz-ht-below \
country=australia dfs-mode=none disabled=no frequency=$channel \
frequency-mode=regulatory-domain ht-rxchains=0,1 ht-txchains=0,1 \
nv2-preshared-key=$sharedkey nv2-security=enabled ssid=$ssid \
wireless-protocol=nv2

/interface eoip
add name=eoip-tunnel1 remote-address=\
192.168.89.1 tunnel-id=1

/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=eoip-tunnel1

/interface bridge settings
set use-ip-firewall=yes

/ip address
add address=192.168.89.2/29 interface=wlan1

/ip dhcp-client
add default-route-distance=0 disabled=no interface=bridge1

/ip firewall mangle
add action=set-priority chain=input new-priority=from-dscp

/system identity
set name=$devicename

/user
set admin password $password

The third device gets a very similar config to the second:

# STEP 1: Set the Antenna Gain
# RBSXT, gain=16
# RB-SEXTANT, gain=18
# DuxLink Duo Kit (since May 2012), gain=25
# DuxLink Duo Kit (pre May 2012), gain=19
#
global antennagain 16
#
# STEP 2: set the SSID
#
global ssid DuxLink
#
# STEP 3: substitute your own password below
#
global sharedkey duxtel
#
# STEP 4: substitute your own password below
#
global password duxtel
#
# Optional: select wireless channel
# - select from: 5825, 5805, 5785, 5745, 5700, 5680, 5660, 5580, 5660, 5540, 5520, 5500
#
global channel 5825
#
# OPTIONAL: substitute your own device name
#
global devicename duxLinkC
#
/interface bridge
add l2mtu=1598 name=bridge1 protocol-mode=rstp

/interface wireless
set 0 antenna-gain=$antennagain band=5ghz-a/n channel-width=20/40mhz-ht-below \
country=australia dfs-mode=none disabled=no frequency=$channel \
frequency-mode=regulatory-domain ht-rxchains=0,1 ht-txchains=0,1 \
nv2-preshared-key=$sharedkey nv2-security=enabled ssid=$ssid \
wireless-protocol=nv2

/interface eoip
add name=eoip-tunnel1 remote-address=\
192.168.89.1 tunnel-id=1

/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=eoip-tunnel1

/interface bridge settings
set use-ip-firewall=yes

/ip address
add address=192.168.89.3/29 interface=wlan1

/ip dhcp-client
add default-route-distance=0 disabled=no interface=bridge1

/ip firewall mangle
add action=set-priority chain=input new-priority=from-dscp

/system identity
set name=$devicename

/user
set admin password $password

This is for a link from two houses and now a third house wants to join the network. I am getting too many clients in the logs on the third device, which is trying to connect to the network, which is related to the wireless link because the thrid devices wlan1 interface never connects. Is there something obviousI am missing? I reset the configs on the devices with the No Default Configuration option ticked, and then ran the config.rsc file for each one.
 
User avatar
CyberTod
Long time Member
Long time Member
Posts: 510
Joined: Wed Jan 25, 2012 10:23 am

Re: PTP link change to PTMP

Wed Jul 30, 2014 2:00 pm

Change this on the AP :
mode=bridge
with this :
mode=ap-bridge

Who is online

Users browsing this forum: dido1236, dj23, truefriendcz and 39 guests