Community discussions

MikroTik App
 
horace
just joined
Topic Author
Posts: 5
Joined: Thu Oct 06, 2016 11:10 am

Launch script from notification don't work well

Mon Jan 09, 2017 10:50 am

Hi all.
I have created the following script to upload a file on a ftp server:

{
:global ftpserver
:global usrnme
:global passwd
:global src
:global dst

:set src ("myFile.txt")
:set dst ("myFile.txt")
:set ftpserver "192.168.1.100"
:set usrnme "user"
:set passwd "12345678"

/tool fetch address="$ftpserver" src-path="$src" user="$usrnme" password="$passwd" mode=ftp dst-path="$dst" upload=yes
}

If I launch script from RouterOS terminal do work correctly, but if I call this script from dude notification with the following command doesn't work

/system script run 1

I'm using dude version 6.38 and ftp server is a filezilla, which reply me with the following:

(000030)09/01/2017 09:35:36 - (not logged in) (192.168.1.1)> Connected on port 21, sending welcome message...
(000030)09/01/2017 09:35:36 - (not logged in) (192.168.1.1)> 220-FileZilla Server 0.9.59 beta
(000030)09/01/2017 09:35:36 - (not logged in) (192.168.1.1)> 220-written by Tim Kosse (tim.kosse@filezilla-project.org)
(000030)09/01/2017 09:35:36 - (not logged in) (192.168.1.1)> 220 Please visit https://filezilla-project.org/
(000030)09/01/2017 09:35:36 - (not logged in) (192.168.1.1)> disconnected.

Thanks in advance for support.

Best regards
H.
 
User avatar
PaulsMT
MikroTik Support
MikroTik Support
Posts: 282
Joined: Tue Feb 10, 2015 3:21 pm

Re: Launch script from notification don't work well

Mon Jan 09, 2017 11:03 am

Please test it with the latest Dude 6.39rc, there are fix related to tool fetch. Let us know if the problem is resolved.
 
horace
just joined
Topic Author
Posts: 5
Joined: Thu Oct 06, 2016 11:10 am

Re: Launch script from notification don't work well

Mon Jan 09, 2017 12:15 pm

Hi PaulsMT,
It's working with 6.39rc7! Thank you so much for your support.
H.

Who is online

Users browsing this forum: No registered users and 17 guests