How to autoupdate time in rb750?
RouterOS Scripting and API

4 posts   •   Page 1 of 1
jwelebd
Frequent Visitor
Frequent Visitor
 
Posts: 71
Joined: Wed May 31, 2006 12:20 am
Location: Dhaka

How to autoupdate time in rb750?

by jwelebd » Mon Feb 14, 2011 7:42 pm

I have a new rb750 in which i used to route my local broadband user.
I also use queue graphing. Clock is necessary for graphing.
But when its switched off then it's time goes back to factory default.
How can I auto update clock of rb750?

fewi
Forum Guru
Forum Guru
 
Posts: 7734
Joined: Tue Aug 11, 2009 3:19 am

Re: How to autoupdate time in rb750?

by fewi » Mon Feb 14, 2011 7:49 pm

http://wiki.mikrotik.com/wiki/Manual:System/Time
Use NTP. There is no battery on the board, so NTP is your only option.
Specific answers require specific questions. When in doubt, post the output of "/ip address print detail", "/ip route print detail", "/interface print detail", "/ip firewall export", and an accurate network diagram.

jwelebd
Frequent Visitor
Frequent Visitor
 
Posts: 71
Joined: Wed May 31, 2006 12:20 am
Location: Dhaka

Re: How to autoupdate time in rb750?

by jwelebd » Mon Feb 14, 2011 9:17 pm

I was telling about it. How can I activate it?

fewi
Forum Guru
Forum Guru
 
Posts: 7734
Joined: Tue Aug 11, 2009 3:19 am

Re: How to autoupdate time in rb750?

by fewi » Mon Feb 14, 2011 9:42 pm

Read the manual. From that link:
SNTP client

SNTP client is included in the system package. RouterOS implements SNTP protocol defined in RFC4330. Manycast mode is not supported. NTP server and a NTP client is included in the separate ntp package, that is not installed by default.

Client configuration is located in the /system ntp client console path, and the "System > NTP Client" WinBox window. This configuration is shared by the SNTP client implementation in the system package and the NTP client implementation in the ntp package. When ntp package is installed and enabled, the SNTP client is disabled automatically.

enabled (yes or no; default value: no)
mode (One of broadcast or unicast; default value: broadcast) : In broadcast mode, client does not send any requests, and listens for the broadcast messages sent by the NTP server. In unicast mode client periodically sends requests to the currently selected active server, and waits for a reply message from that server.
primary-ntp, secondary-ntp (IP address) : IP addresses of the NTP servers. These properties have effect only when mode=unicast. Value 0.0.0.0 is ignored. If both values are zero and mode is unicast then SNTP client is disabled. If both values are non-zero, then SNTP client will alternate between the two server addresses, switching to the other when request to the current server times out or when the "KoD" packet is received, indicating that server is not willing to respond to requiests from this client.


So, go to "/system ntp client", set primary and secondary NTP servers, and enable it.

To find servers, http://www.pool.ntp.org/en/ is a good starting point. Example of enabling servers in North America:
Code: Select all
/system ntp client
set primary-ntp=0.north-america.pool.ntp.org
set secondary-ntp=1.north-america.pool.ntp.org
set mode=unicast
set enabled=yes
Specific answers require specific questions. When in doubt, post the output of "/ip address print detail", "/ip route print detail", "/interface print detail", "/ip firewall export", and an accurate network diagram.

4 posts   •   Page 1 of 1

Who is online

Users browsing this forum: No registered users and 8 guests

It is currently Wed Nov 26, 2014 8:06 am