how to block website
If you installed RouterOS just now, and don't know where to start - ask here!

13 posts   •   Page 1 of 1
oo0026
just joined
 
Posts: 2
Joined: Fri Mar 13, 2009 1:42 am

how to block website

by oo0026 » Fri Mar 13, 2009 1:53 am

hi every body

i have RB 433AH
i wont to know how to block :( websites

thank you inadvance

QpoX
Member
Member
 
Posts: 387
Joined: Mon Mar 24, 2008 8:42 pm
Location: Lemvig, Denmark

Re: how to block website

by QpoX » Fri Mar 13, 2009 2:26 am

You can block an URL by using the Proxyserver in RouterOS...
Or just block the IP's of a website by using the firewall filter in RouterOS, and just drop trafic to that IP.

sanjeev
Frequent Visitor
Frequent Visitor
 
Posts: 87
Joined: Mon Oct 06, 2008 7:45 am

Re: how to block website

by sanjeev » Fri Mar 13, 2009 9:15 am

create addresslist of sites that you want to block.
now add dst-nat where dst-addresslist is the addresslist of the block sites and and in action choose dst-nat in, to address put 127.0.0.1
Code: Select all
;;; dstnat unwanted sites
chain=dstnat action=dst-nat to-addresses=127.0.0.1
dst-address-list=restricted sites

or you can also do that using the firewall filter in RouterOS as mentioned by QpoX
or you can also do via webproxy
hth

oo0026
just joined
 
Posts: 2
Joined: Fri Mar 13, 2009 1:42 am

Re: how to block website

by oo0026 » Mon Mar 16, 2009 1:31 pm

thank you for your replay friends
but i wont the proxy blocking
but could you kindly show me the steps with photo

Best Regards

User avatar
taglio
Frequent Visitor
Frequent Visitor
 
Posts: 97
Joined: Wed Nov 12, 2008 5:55 pm
Location: 34T, Barcelona, Spain

Re: how to block website

by taglio » Mon Mar 16, 2009 1:48 pm

[toor@extreme] /ip proxy access> export
# mar/16/2009 11:44:07 by RouterOS 3.20
# software id = 4H1M-LTT
#
/ip proxy access
add action=deny comment="" disabled=no dst-host=*porn*
add action=deny comment="" disabled=no dst-host=*sex*
add action=deny comment="" disabled=no dst-host=*xxx*
add action=deny comment="" disabled=no path=*porn*
add action=deny comment="" disabled=no dst-host=!*badoo* path=*sex*
add action=deny comment="" disabled=no path=*xxx*
[toor@extreme] /ip proxy access>

http://www.mikrotik.com/testdocs/ros/3. ... ent.php#.4 --> here you have explanetion of the sintax.

Remember that you have to do setup of the webproxy. [and trasparent mode if you want]
.mhavoc world

User avatar
dunga
Member Candidate
Member Candidate
 
Posts: 218
Joined: Fri Jan 23, 2009 10:51 am
Location: Nigeria

Re: how to block website

by dunga » Tue Nov 08, 2011 9:37 pm

After blocking the porn, sex sites in web proxy as indicated, i want a situation where anyone dat visits the forbidden site or blocked sites, it will display a custom message to the person.

ERROR: Forbidden

While trying to retrieve the URL http://www.google.com/search?q=xxx&ie=u ... =firefox-a:

* Access Denied.

Instead of displaying above, it will display like, please dont try such sits here, they will not open

fewi
Forum Guru
Forum Guru
 
Posts: 7734
Joined: Tue Aug 11, 2009 3:19 am

Re: how to block website

by fewi » Tue Nov 08, 2011 9:40 pm

http://wiki.mikrotik.com/wiki/Manual:IP/Proxy#Access_List
redirect-to (string; Default: ) In case access is denied by this rule, the user shall be redirected to the URL specified here
Specific answers require specific questions. When in doubt, post the output of "/ip address print detail", "/ip route print detail", "/interface print detail", "/ip firewall export", and an accurate network diagram.

User avatar
dunga
Member Candidate
Member Candidate
 
Posts: 218
Joined: Fri Jan 23, 2009 10:51 am
Location: Nigeria

Re: how to block website

by dunga » Thu Nov 10, 2011 11:35 am

fewi wrote:please dont try such sits here, they will not open


Thanks fewi for your response,
are u saying that if i just put this string "please dont try such sites here, they will not open. Thanks" in the redirect-to , it will display it as I put it there.

I need at least a best option to achieve this. Fewi, You can pm at obinna4god@yahoo.com so that I can ask you some other things are relate to MT.

Thanks

fewi
Forum Guru
Forum Guru
 
Posts: 7734
Joined: Tue Aug 11, 2009 3:19 am

how to block website

by fewi » Thu Nov 10, 2011 3:04 pm

No. As the manual clearly states you put a URL there. A URL is the kind of thing you would type into your browser address bar.

So the steps are:
1. Procure web server
2. Make website that displays whatever you want it to
3. Figure out URL to get to that website you created
4. Drop URL into proxy configuration
Specific answers require specific questions. When in doubt, post the output of "/ip address print detail", "/ip route print detail", "/interface print detail", "/ip firewall export", and an accurate network diagram.

User avatar
dunga
Member Candidate
Member Candidate
 
Posts: 218
Joined: Fri Jan 23, 2009 10:51 am
Location: Nigeria

Re: how to block website

by dunga » Thu Nov 10, 2011 3:21 pm

Thanks,
As sson as i get it will try to implement it

nmthaker
Member Candidate
Member Candidate
 
Posts: 143
Joined: Wed Jan 05, 2011 7:10 am

Re: how to block website

by nmthaker » Sun Nov 13, 2011 5:09 pm

Hi,

I want to block the Porn Sites and other Ports then 80 only for hotspot users, can any one suggest how it is possible?? The same user id and password sholuld require to work when they connect with PPPoE Dialer and allow all website also, suggest how can we impliment the same


Nishit

fewi
Forum Guru
Forum Guru
 
Posts: 7734
Joined: Tue Aug 11, 2009 3:19 am

Re: how to block website

by fewi » Sun Nov 13, 2011 5:12 pm

Blocking lots of sites via the proxy is unfeasible.

Use OpenDNS for DNS, and set up the account to not permit adult sites.

Then destination NAT all Hotspot DNS traffic to OpenDNS, and let PPPoE users use 'full view' DNS servers so they have access to everything.
Specific answers require specific questions. When in doubt, post the output of "/ip address print detail", "/ip route print detail", "/interface print detail", "/ip firewall export", and an accurate network diagram.

nmthaker
Member Candidate
Member Candidate
 
Posts: 143
Joined: Wed Jan 05, 2011 7:10 am

Re: how to block website

by nmthaker » Sun Nov 13, 2011 5:28 pm

Hi,

I created my open dns account and done require configuration, can you suggest how can i configure on Mikoritk.

13 posts   •   Page 1 of 1

Who is online

Users browsing this forum: rwrocket, vkisselyov and 10 guests

It is currently Mon Nov 24, 2014 9:35 am