Community discussions

MikroTik App

Search found 18 matches

by jamecollins
Fri Oct 19, 2018 10:52 am
Forum: Forwarding Protocols
Topic: Collect client url
Replies: 3
Views: 1298

Re: Collect client url

You kan look at my Splunk for Mikrotik project here: https://forum.mikrotik.com/viewtopic.php?t=137338 With this you can log all DNS request that every client does. (look at picture for DNS logs) Requesting DNS does not actually means that the client do visit a site, but gives a good idea of what i...
by jamecollins
Sun Oct 14, 2018 5:02 am
Forum: Forwarding Protocols
Topic: Collect client url
Replies: 3
Views: 1298

Collect client url

For monitor and checking my client, I want to log all website my client was access. How can I do that with mikrotik.?
Thanks.
by jamecollins
Fri Jun 01, 2018 4:51 am
Forum: Wireless Networking
Topic: How to install airodump-ng on mikroitk device
Replies: 4
Views: 2831

How to install airodump-ng on mikroitk device

Hi everyone, I want to count all enable wireless device around rb952 router. I have search some solution such as using airodump-ng, but I have problem can't install this on RouterOS. Is there anyway to install airodump-ng on mikrotik or have another solution for that case?
Thanks.
by jamecollins
Mon Oct 30, 2017 10:43 am
Forum: Scripting
Topic: Handle script error mikrotik
Replies: 4
Views: 1773

Re: Handle script error mikrotik

I have 2 script Script 1: importscript. That will be import from a config file [/import file-name="wifi.rsc"] Script 2: check the result of importscript :execute script="importscript" file="importresult" :delay 5s I try add an error on the config file and you can see th...
by jamecollins
Mon Oct 30, 2017 3:33 am
Forum: The Dude
Topic: How to add Device to Dude server with port
Replies: 4
Views: 2318

Re: How to add Device to Dude server with port

jamecollins, If I understand correctly, port you are trying to specify is used only for SNMP. Any another device probes are added inside a "Services" tab. Dude support this in the way described in the next post. Thank you! Thanks for your reply but I think you don't get my idea. Because m...
by jamecollins
Fri Oct 27, 2017 11:48 am
Forum: The Dude
Topic: How to add Device to Dude server with port
Replies: 4
Views: 2318

How to add Device to Dude server with port

Hi all,
How can I add my AccessPoint with port address? Because my devices behide the Router. I can access with port but can't add this to dude server.
Image
Thanks.
by jamecollins
Thu Oct 26, 2017 9:58 am
Forum: Scripting
Topic: Handle script error mikrotik
Replies: 4
Views: 1773

Re: Handle script error mikrotik

1. :foreach id in [/interface wireless find] do={ :put [/interface wireless get $id name] } 2. :foreach id in [/interface wireless find] do={ :put [/interface wireless get $id ssid] } 3. Absence of normal error processing in ROS script is general problem %) (due to try/catch/return codes usually ig...
by jamecollins
Thu Oct 26, 2017 6:13 am
Forum: Scripting
Topic: Handle script error mikrotik
Replies: 4
Views: 1773

Handle script error mikrotik

I'm new in mikrotik Script and I have some question. Please help me resolve this: 1/ How can I get all wireless interface name in my device? Like wlan1, wlan2 2/ How can I get all SSID on my device? 3/ I have small script to remote config by using import command. That mean my device will get script ...
by jamecollins
Thu Oct 12, 2017 11:06 am
Forum: Scripting
Topic: POST Request with fetch
Replies: 76
Views: 56760

Re: POST Request with fetch

You can do it this way: /tool fetch mode=https url="https://yoursite.com/link/5eu1a1kkypnypbyseqzsq1ao4w" http-method=post http-data="payload={\"text\": \"Test\"}" This was added in the latest RouterOS 6.39 RC versions fetch - added "http-data" and ...
by jamecollins
Tue Oct 10, 2017 10:21 am
Forum: General
Topic: Get list of domain client access
Replies: 0
Views: 549

Get list of domain client access

Hi everyone, I want to log all domain which my client access to on my mikrotik device. How can I do this. I see that Web proxy have this information but this still on device, how can I put this to my server to analyser this information. Thanks. If do this by web proxy, any problem about the performa...
by jamecollins
Thu May 11, 2017 10:39 am
Forum: Scripting
Topic: POST Request with fetch
Replies: 76
Views: 56760

Re: POST Request with fetch

You can do it this way: /tool fetch mode=https url="https://yoursite.com/link/5eu1a1kkypnypbyseqzsq1ao4w" http-method=post http-data="payload={\"text\": \"Test\"}" This was added in the latest RouterOS 6.39 RC versions fetch - added "http-data" and ...
by jamecollins
Thu May 11, 2017 5:57 am
Forum: Scripting
Topic: How to reset-configuration command with script
Replies: 1
Views: 33625

How to reset-configuration command with script

Hi everyone, I have try to run script to reset-configuration and load config from exits backup file. But I see that don't work. I think because when using /system rest-configuration command, the RouterOS confirm that action, like that [admin@MikroTik] > /system reset-configuration keep-users=yes no-...
by jamecollins
Wed Apr 19, 2017 5:06 am
Forum: Scripting
Topic: POST Request with fetch
Replies: 76
Views: 56760

POST Request with fetch

Hi everyone, I want create a script to get information on mikrotik device and post this to my server. I see fetch can create the request but I don't know how to create POST request with this. On the https://wiki.mikrotik.com/wiki/Manual:Tools/Fetch only tell that fetch can GET. How to create POST re...
by jamecollins
Fri Apr 14, 2017 4:19 am
Forum: Scripting
Topic: Upload file with fetch on mode http
Replies: 8
Views: 5829

Re: Upload file with fetch on mode http

how does the server support this? are you talking about an upload FORM element, or some HTTP POST request or what? You can't just upload files to any server. There has to be some specific method the server is expecting, and you must know which one. Thanks for your reply. Yes I want upload file via ...
by jamecollins
Thu Apr 13, 2017 4:24 am
Forum: Scripting
Topic: Upload file with fetch on mode http
Replies: 8
Views: 5829

Re: Upload file with fetch on mode http

How would that work exactly?
Thanks for your reply. I want upload file to my server via http, not by ftp protocol. And one more question about checking result of upload file. I follow this method but this not work. viewtopic.php?t=114626
Thanks
by jamecollins
Wed Apr 12, 2017 4:45 am
Forum: Scripting
Topic: Upload file with fetch on mode http
Replies: 8
Views: 5829

Upload file with fetch on mode http

I have try upload file with fetch on mode ftp, that okay. But how can I upload file with http mode? Thanks for your support.
by jamecollins
Wed Apr 12, 2017 4:16 am
Forum: Scripting
Topic: Get Mac Address first interface
Replies: 5
Views: 29204

Re: Get Mac Address first interface

:put [/interface ethernet get [/interface ethernet find default-name=ether1] mac-address ]
Very nice. Thanks for your support
by jamecollins
Tue Apr 11, 2017 1:05 pm
Forum: Scripting
Topic: Get Mac Address first interface
Replies: 5
Views: 29204

Get Mac Address first interface

Dear all,
I'm new with RouterOS script and I have some problem need help. How can I get mac-address the first interface on my router.
Image
Thanks for your support