Community discussions

Search found 26 matches

by vytuz
Wed Jul 17, 2019 2:30 pm
Forum: Scripting
Topic: int-to-string?
Replies: 10
Views: 745

Re: int-to-string?

It works if you use as decimal numbers, but I understand you want to work with hex numbers? If you declare :local int D8 , this is not number, this is string already. If you do :local int "72" , value 72 become as string, not number. Question is where do you get from this int value? But I see this i...
by vytuz
Wed Jul 17, 2019 12:07 pm
Forum: Scripting
Topic: int-to-string?
Replies: 10
Views: 745

Re: int-to-string?

As I understand, you want two things: change integer to string and add "\" to string.
:local int 72
:local str [:tostr "\\$int"]
variable str is string with added "\".
by vytuz
Fri Jul 12, 2019 12:24 pm
Forum: Scripting
Topic: bypass script errors/wrong commands
Replies: 15
Views: 793

Re: bypass script errors/wrong commands

Thanks! It is working also. Log messages could be also removed, used it to see what is happening. {} were used because of local variables. :if ([/interface ethernet get ether5]~"poe-out") do={ [:parse "/interface ethernet set [find default-name=ether5] poe-out=off"] } Finally we made it simple to by...
by vytuz
Fri Jul 12, 2019 9:53 am
Forum: Scripting
Topic: bypass script errors/wrong commands
Replies: 15
Views: 793

Re: bypass script errors/wrong commands

I found problem, simplier than I thought. Just missed : before log commands. Working code in booting is: { :local poe5 [/interface ethernet get ether5]; :local e5 [:parse "/interface ethernet set [find default-name=ether5] poe-out=off"]; :if ($poe5~"poe-out") do={ $e5; :log info "Ether5 POE disabled...
by vytuz
Fri Jul 12, 2019 9:22 am
Forum: Scripting
Topic: bypass script errors/wrong commands
Replies: 15
Views: 793

Re: bypass script errors/wrong commands

My code starts from waiting interfaces to appear and then executes the rest. I replaced line /interface ethernet set [ find default-name=ether5 ] poe-out=off with this code. So it is not the case. There is something else in code that fails when booting.
by vytuz
Thu Jul 11, 2019 3:13 pm
Forum: Scripting
Topic: bypass script errors/wrong commands
Replies: 15
Views: 793

Re: bypass script errors/wrong commands

Any ideas why this part is not working when I flash with netinstall? I put this code in {}, for local variables to work, but still nothing. It works as script in routeros, but not as a part of booting script, flashed with netinstall.
by vytuz
Thu Jul 11, 2019 12:20 pm
Forum: Scripting
Topic: bypass script errors/wrong commands
Replies: 15
Views: 793

Re: bypass script errors/wrong commands

I made with your examples something, that should work. I will test it with netinstall. Thanks a lot! :local poe5 [/interface ethernet get ether5] :local e5 [:parse "/interface ethernet set [find default-name=ether5] poe-out=off"]; :if ($poe5~"poe-out") do={ $e5 log info "Ether5 POE disabled" } else=...
by vytuz
Wed Jul 10, 2019 3:35 pm
Forum: Scripting
Topic: bypass script errors/wrong commands
Replies: 15
Views: 793

Re: bypass script errors/wrong commands

One way is to use "parse" command to execute command line based on parameters, which check if poe should exist on this router. As I imagine it is not an option if I want to flash script with netinstall, is it? As I mentioned, is it possible to use i.e. str1="poe-out=off" as variable and use in comm...
by vytuz
Wed Jul 10, 2019 2:26 pm
Forum: Scripting
Topic: bypass script errors/wrong commands
Replies: 15
Views: 793

Re: bypass script errors/wrong commands

To test or write poe-out in condition part is not the problem. Problem is to make routeros think, that executable line is not wrong if it is not executed. Maybe it is possible to make "poe-out=off" as string and put it in line then needed?
by vytuz
Wed Jul 10, 2019 11:49 am
Forum: Scripting
Topic: bypass script errors/wrong commands
Replies: 15
Views: 793

bypass script errors/wrong commands

Scripting in routeros is not optimized in some important cases. When error occurs, script just stops without logging when and why and further commands were not executed. Most noticed that. If script has error when flashing with netinstall, happens that entire script fails to load. These errors mostl...
by vytuz
Fri Feb 08, 2019 11:56 am
Forum: General
Topic: DHCP client script execution
Replies: 6
Views: 1026

Re: DHCP client script execution

Why interface change status can't change dhcp client status? I have example, then I connect Mikrotik (which had ip dhcp received) to switch, witch has ip-spoofing enabled, Mikrotik sends dhcp request, not discover. In this situation ip-spoofing table do not add this ip. Manually connect to Mikrotik ...
by vytuz
Mon Jul 02, 2018 11:32 am
Forum: RouterBOARD hardware
Topic: hAP ac2 model DHCP Client difference from mipsbe models
Replies: 7
Views: 1006

Re: hAP ac2 model DHCP Client difference from mipsbe models

We collected these strange fiber converters and will try to replace, because problem seems there. I can't test now what packets pass and fail. And I guess it is not hardware topic for this, but found that only this arm device model ac2 tries to send unicast flag. Is it possible to change this dchp c...
by vytuz
Thu Jun 28, 2018 2:57 pm
Forum: RouterBOARD hardware
Topic: hAP ac2 model DHCP Client difference from mipsbe models
Replies: 7
Views: 1006

Re: hAP ac2 model DHCP Client difference from mipsbe models

Firmware update makes no difference. dhcp server was cisco router, I was testing here with mikrotik rb952ui as dhcp server. Discover and offer could be seen here (no request and act appears): Frame 335: 342 bytes on wire (2736 bits), 342 bytes captured (2736 bits) on interface 0 Ethernet II, Src: cc...
by vytuz
Thu Jun 28, 2018 12:22 pm
Forum: RouterBOARD hardware
Topic: hAP ac2 model DHCP Client difference from mipsbe models
Replies: 7
Views: 1006

Re: hAP ac2 model DHCP Client difference from mipsbe models

I've tried few versions 6.41.3, 6.42.3 and newest 6.42.5, same result. Mipsbe routers like rb951g, rb952ui, rb951ui works fine. Possible arm package has different dhcp setup, but how to change it.
by vytuz
Thu Jun 28, 2018 12:14 pm
Forum: RouterBOARD hardware
Topic: hAP ac2 model DHCP Client difference from mipsbe models
Replies: 7
Views: 1006

hAP ac2 model DHCP Client difference from mipsbe models

We managed problem with ac2 model compatibility with some fiber media converters. There is problem with dhcp client packets. Ac2 router can't receive ip from dchp server. DHCP Broadcast discover and offer passes, but no more. All mipsbe routers works fine. I found that mipsbe routers sends broadcast...
by vytuz
Tue May 08, 2018 10:59 am
Forum: Wireless Networking
Topic: ANI with capsman?
Replies: 4
Views: 1113

Re: ANI with capsman?

Renewing topic, many objects are done with capsman configuration. Adaptive noise immunity helps to improve wifi signal, so it could be useful function to enable in capsman. Any possibility to have this function?
by vytuz
Fri May 04, 2018 10:21 am
Forum: Announcements
Topic: v6.42.1 [current]
Replies: 272
Views: 42412

Re: v6.42.1 [current]

RB2011UiAS-2HnD I get the Internet by DHCP After upgrade to 6.42.1 : On 6.42.0 work fine... if ISP (or router before this) dhcp lease is short (i guess it is 5minutes in Your case), with 6.42.1 version mikrotik asks for ip ~30seconds before lease (not ~2min). If there are many dhcp users, a lot bro...
by vytuz
Thu May 03, 2018 2:46 pm
Forum: Announcements
Topic: v6.42.1 [current]
Replies: 272
Views: 42412

Re: v6.42.1 [current]

DHCP client updates acting as not supposed normaly. With 6.40 version, DHCP request is send after 50% lease time. With 6.42.1 version i.e. lease time is 48h, request is send after 42h.
by vytuz
Thu May 03, 2018 10:31 am
Forum: Announcements
Topic: v6.42.1 [current]
Replies: 272
Views: 42412

Re: v6.42.1 [current]

Some new issues Ive discovered today. We have seen many international hAP AC with disappearing 5g We set all of them to to country="united states3" frequency-mode=regulatory-domain. We thought they were not following the country so we have been testing a manual scan-list Turns out there is a proble...
by vytuz
Thu Apr 26, 2018 3:52 pm
Forum: Announcements
Topic: v6.42.1 [current]
Replies: 272
Views: 42412

Re: v6.42.1 [current]

I guess new kid control function is not working full yet. Added device with MAC, kid, and nothing happening when pause or resume user. No firewall rules appears. When I Pause it shows Paused, when I Resume it shows Blocked, still full access from this MAC.
by vytuz
Wed Apr 25, 2018 3:21 pm
Forum: Announcements
Topic: v6.42.1 [current]
Replies: 272
Views: 42412

Re: v6.42.1 [current]

add led=sfp-led type=on input does not match any value of type Confirm, that type=on is not recognisable( 4 changed via winbox to type - on): /system leds> print Flags: X - disabled, * - default # TYPE INTERFACE 0 * interface-activity ether1 1 * interface-activity ether2 2 * interface-activity ethe...
by vytuz
Wed Apr 25, 2018 12:49 pm
Forum: Announcements
Topic: v6.42.1 [current]
Replies: 272
Views: 42412

Re: v6.42.1 [current]

improved compatibility with BCM chipset devices
Looks huge improvement for mobile devices. 2.4G speed increased from ~10-20Mbit to 2-3x more. We use as endpoint devices for consumers. 2.4G had poor perfomance if several devices use traffic, much more better now so far.
by vytuz
Tue Mar 20, 2018 3:11 pm
Forum: General
Topic: I want to buy MikroTik hAP ac2. I have a few questions.
Replies: 12
Views: 3040

Re: I want to buy MikroTik hAP ac2. I have a few questions.

I have one question too. LED 1-5 meanings can be changed in mibsbe devices, I suppose hAP ac2 do not have this possibility? There are no LED 1-5 settings in /system leds.
by vytuz
Tue Sep 19, 2017 5:03 pm
Forum: Announcements
Topic: v6.40.3 [current]
Replies: 95
Views: 25320

Re: v6.40.3 [current]

Still hoping You will solve Mikrotik 2.4G Band and Qualcomm chip based phones connection issue. Mikrotik transmission rate connects maximum 54Mbps, G-standard. Rx rate connects normally, as fast as phone supports. Mikrotik connects to other brand cards, samsung phones i.e. normally, but not qualcomm...
by vytuz
Tue Sep 19, 2017 3:09 pm
Forum: RouterOS v6 RC and v7 BETA
Topic: Feature requests
Replies: 1097
Views: 192314

Re: Feature requests

Do You maybe have in plans to make more detailed user group list? Different user access to i.e. wireless, firewall filter, nat rules, ip addresses, dhcp and etc. I imagine it may be hard to add databases and additional cunfiguration to every configuration field. Maybe any possibility to add at least...
by vytuz
Fri Sep 15, 2017 12:58 pm
Forum: Announcements
Topic: v6.40.3 [current]
Replies: 95
Views: 25320

Re: v6.40.3 [current]

Hello, I load custom scripts with netinstall and worked normally until 6.40.x. From version 6.40.x after reset, flashed scripts do not load. In some models script do not load after resetting with no default configuration, and reseting normally again. In some models (even same model and same script) ...