Community discussions

Search found 375 matches

  • 1
  • 2
by Letni
Wed Jul 04, 2018 4:41 pm
Forum: Beginner Basics
Topic: Router RB2011 impossible to upgrade to 6.42.5
Replies: 2
Views: 519

Re: Router RB2011 impossible to upgrade to 6.42.5

I had a similar issue yesterday. I had to use netinstall to get it upgraded.
by Letni
Wed May 31, 2017 4:24 pm
Forum: General
Topic: CCR1072 950 pppoe connection cpu overload when pppoe disconnected
Replies: 11
Views: 1828

Re: CCR1072 950 pppoe connection cpu overload when pppoe disconnected

Sounds like someone should have come to MUM. Good thing the MUM can come to you. Janis Megis addresses several common issues you may be experiencing with PPPoE. Please watch his talk. I know he would appreciate not getting one less support email. ;) Most underused and overused RouterOS tools and fea...
by Letni
Sun Sep 22, 2013 3:43 am
Forum: General
Topic: after upgrade to 6.3 cannot generate certificate-request
Replies: 33
Views: 26206

Re: after upgrade to 6.3 cannot generate certificate-request

Same here.

Guess I need to find another way.

-Louis
by Letni
Thu Jun 06, 2013 10:11 pm
Forum: RouterBOARD hardware
Topic: CCR - Replacement PSU
Replies: 0
Views: 737

CCR - Replacement PSU

I received a CCR1036-12G-4S with bad power supply. When you move the AC cable the unit reboots. I have tried several cables and have attributed this issue to a cold solder joint on the PSU. I am working with distributor on a resolution but do not have high hopes on a smooth RMA processes. Since I ha...
by Letni
Thu Jun 02, 2011 2:22 pm
Forum: SwOS
Topic: DHCP Snooping (feature request)
Replies: 8
Views: 20013

Re: DHCP Snooping (feature request)

I may be expecting to much out of this. But I did some reading and came up with this. http://wiki.mikrotik.com/wiki/Manual:Switch_Chip_Features My interpretation is that you can run rules in the switch chip therefore creating a rule that redirects boots packets from un-trusted ports to the CPU where...
by Letni
Tue May 31, 2011 3:08 am
Forum: General
Topic: Dual WAN with failover & without load balancing
Replies: 8
Views: 5581

Re: Dual WAN with failover & without load balancing

Not if it is bridged and he does PPPoE in the MT.

-Louis
by Letni
Mon May 30, 2011 7:27 pm
Forum: SwOS
Topic: DHCP Snooping (feature request)
Replies: 8
Views: 20013

Re: DHCP Snooping (feature request)

I would expect MT to say that you have not designed your network properly if this is a concern to you. *just saying* Please elaborate on how you would implement this and what functionality do you think MT is currently missing. Also, what it would do to help the community. Make a case not just a requ...
by Letni
Mon May 30, 2011 7:10 pm
Forum: Beginner Basics
Topic: Splitting VoIP with Internet
Replies: 12
Views: 2581

Re: Splitting VoIP with Internet

How much do you know about VoIP? First session of SIP is on 5060 (typically), but what about the voice streams of the call? Will your server have a private IP that is NATed by the MT or will you have Public IP on the server? Do you have any way of isolating all parts of the VoIP traffic from the ser...
by Letni
Mon May 30, 2011 6:28 pm
Forum: Beginner Basics
Topic: Complete newbie
Replies: 2
Views: 628

Re: Complete newbie

1: My definition of an Edge router is one that connects to another providers network. For example I may have 20 routers in my network. They will all have multiple routes so know where to get to different subnets in my network but I may only have one of them connected to AT&T. AT&T is a provider that...
by Letni
Mon May 30, 2011 6:23 pm
Forum: Beginner Basics
Topic: routing
Replies: 2
Views: 635

Re: routing

This sounds more like a switching setup then a routing one. In my experience the upstream provider will assign you a /30 for your internet side and route an additional /28 to your router where then you can break it up as needed. Sounds like you need to just set it up as a switch and assign static IP...
by Letni
Mon May 30, 2011 6:15 pm
Forum: Beginner Basics
Topic: Splitting VoIP with Internet
Replies: 12
Views: 2581

Re: Splitting VoIP with Internet

You need to find some way of matching your VOIP traffic. If you can send VOIP traffic from a unique IP on your server like 192.168.1.200 then you can set the MT to route all traffic from that IP out the VOIP gateway. Once you have a reliable way to tag what is VOIP and what is data then you send it ...
by Letni
Mon May 30, 2011 6:10 pm
Forum: SwOS
Topic: DHCP Snooping (feature request)
Replies: 8
Views: 20013

Re: DHCP Snooping (feature request)

I am not seeing what is missing? According to http://en.wikipedia.org/wiki/DHCP_snooping One of the primary concerns is ARP spoofing. In MT you can Add ARP for Leases and set ARP on the DHCP-Server interface to reply-only. The other key point is. Ensure that only authorized DHCP servers are accessib...
by Letni
Mon May 30, 2011 6:04 pm
Forum: General
Topic: Dual WAN with failover & without load balancing
Replies: 8
Views: 5581

Re: Dual WAN with failover & without load balancing

The check Gateway with ping does just that, pings the gateway address. It should not care what the dst-address is. With this setup. If the gateway of your primary internet connection fails to respond then route would disable itself. With a second route setup with the same dst-address but pointing to...
by Letni
Thu Dec 16, 2010 7:53 pm
Forum: RouterBOARD hardware
Topic: RB 411AH no boot with XR5
Replies: 0
Views: 670

RB 411AH no boot with XR5

I have a RB411AH 200 feet in the air. I lost Ethernet connectivity with it from the bottom. Changed everything at the bottom including the POE-24i and still got the same symptom. Sent a climber up to take a look. Board lights were on. Had him disconnect the Ethernet cable and we tested the line. It ...
by Letni
Wed Dec 15, 2010 5:13 pm
Forum: General
Topic: 5.0RC5 Ethernet ports flapping on two different RB-750s
Replies: 31
Views: 9079

Re: 5.0RC5 Ethernet ports flapping on two different RB-750s

I don't think that it is because of this software version that it is happening. I only think that this software version is actually reporting it is happening. The two primary symptoms that tip me off to look at the caps are all the lights come on when powering up and stay on. The other is wonky Ethe...
by Letni
Wed Dec 15, 2010 7:52 am
Forum: General
Topic: 5.0RC5 Ethernet ports flapping on two different RB-750s
Replies: 31
Views: 9079

Re: 5.0RC5 Ethernet ports flapping on two different RB-750s

Check to see if you have some green capictors on the board with an X on the top of them. It may be obvious that they have leaked fluid and or are swollen. Even if they do not show signs of this they are still probably your issue if your board has them. RB750BadCaps.jpg Mikrotik removed the capacitor...
by Letni
Tue Oct 12, 2010 7:51 pm
Forum: General
Topic: Manual for /file
Replies: 4
Views: 663

Re: Manual for /file

/file ? Files can be uploaded to router and downloaded from it using FTP, or sent via e-m ail attachment. Here a list of all files kept locally on router (such as exported configuration scripts) can be found. .. -- go up to root add -- Create a new item edit -- find -- Find items by value get -- Ge...
by Letni
Thu Sep 23, 2010 12:59 am
Forum: Beginner Basics
Topic: Can't connect from one LAN to another
Replies: 10
Views: 1490

Re: Can't connect from one LAN to another

Traceroute results would have shown that sooner. ;)
Glad you found your answer.

-Louis
by Letni
Mon Sep 06, 2010 11:43 pm
Forum: Beginner Basics
Topic: Can't connect from one LAN to another
Replies: 10
Views: 1490

Re: Can't connect from one LAN to another

Since you are not getting a response from 2.1 then your NAT rules are causing the issue. If you disable them then it should work as expected OR Option 2 is to add a couple more rules like /ip firewall nat chain=srcnat action=accept src-address=172.16.1.0/24 dst-address=172.16.2.0/24 /ip firewall nat...
by Letni
Mon Sep 06, 2010 11:11 pm
Forum: Beginner Basics
Topic: Can't connect from one LAN to another
Replies: 10
Views: 1490

Re: Can't connect from one LAN to another

From 172.16.1.2
ping 172.16.1.1. What the results?
ping 172.16.2.1. What are the results?
ping 172.16.2.2 What are the results?

What does a trace route show?

I am going to assume that you do not have any firewall rules that may be interfering since you did not include them before?

-Louis
by Letni
Mon Sep 06, 2010 10:58 pm
Forum: General
Topic: RDP
Replies: 9
Views: 1209

Re: RDP

This may be off the wall but how is your wireless link setup? Are you using WDS, MPLS, Pseudobridge?

-Louis
by Letni
Mon Sep 06, 2010 10:47 pm
Forum: Beginner Basics
Topic: Can't connect from one LAN to another
Replies: 10
Views: 1490

Re: Can't connect from one LAN to another

When this has happened to me in the past I did not have the default gateway set right on one/both the clients.

On device 172.16.1.2 make sure the default gateway is 172.16.1.1
On device 172.16.2.2 make sure the default gateway is 172.16.2.1

-Louis
by Letni
Sun Aug 22, 2010 5:11 pm
Forum: RouterBOARD hardware
Topic: 711 + V3.30+password reset
Replies: 10
Views: 9918

Re: 711 + V3.30+password reset

(1) can version 3.30 be used, You can find out what versions are supported for your model by going to http://www.mikrotik.com/download.html (2) without serial connector, if OS gets corrupted or password reset how can this be done, is there a netinstall equivalent method for the 711 These questions ...
by Letni
Sun Aug 08, 2010 3:03 am
Forum: RouterBOARD hardware
Topic: RB450 Capacitors problem?
Replies: 120
Views: 41647

Re: RB450 Capacitors problem?

We just replaced bad caps on 3 RB450's. Found a bad motherboard with comparable caps that we could re-use. It wasn't to bad to do just a PITA that we have to do it.... Seems as though there was some power hack for the RB100's as well? I really wish the RB line was a bit more hardened for longer MTBF...
by Letni
Sun Aug 08, 2010 2:58 am
Forum: General
Topic: RB??? usa or chinea
Replies: 7
Views: 904

Re: RB??? usa or chinea

AFAIK there are no _fake_ Routerboards.

-Louis
by Letni
Thu Jul 08, 2010 4:51 am
Forum: General
Topic: Issue with x86 platform
Replies: 7
Views: 968

Re: Issue with x86 platform

I was having this issue with RouterOS V4. V4 has been very unstable for us. A duplicate Supermicro router is running V3.30 without issue. I have reloaded the machine running V4 to V5Beta4 with good results so far.

-Louis
by Letni
Wed Jun 16, 2010 11:26 pm
Forum: Wireless Networking
Topic: Need help with 8km PTP
Replies: 16
Views: 2509

Re: Need help with 8km PTP

You could try pointing the dishes up toward the sky more so you are shooting over the tops of each other. Enough where you are minimizing how much is reflecting off the ground/water.

Still have not told us what version of RouterOS you are using.

-Louis
by Letni
Wed Jun 16, 2010 3:30 am
Forum: Wireless Networking
Topic: Need help with 8km PTP
Replies: 16
Views: 2509

Re: Need help with 8km PTP

Change frequency. Change Channel Size. Limiting Rates. Enable NStreame (Does wonders for us.) I know the recommendation is the leave power at default but you will probably want to lower it.
What RouterOS version are you using?

-Louis
by Letni
Mon Jun 14, 2010 9:48 pm
Forum: General
Topic: ftp backups
Replies: 6
Views: 1006

Re: ftp backups

What distro are you using?
Vsftpd is a ftp server not a client.
What about output for ftp -h ?
-Louis
by Letni
Mon Jun 14, 2010 8:15 pm
Forum: General
Topic: ftp backups
Replies: 6
Views: 1006

Re: ftp backups

I tested the script using CentOS/Redhat Enterprise Linux 5.4. See if doing an ftp -h give you any help. Maybe the command line options are different. Does the Mikrotik show the user logging in at all after running the script? Also, I do not know how familiar you are with *nix. Do you have ftp client...
by Letni
Mon Jun 14, 2010 6:45 am
Forum: Beginner Basics
Topic: distance covered with 31dbi grid antenna
Replies: 2
Views: 730

Re: distance covered with 31dbi grid antenna

Using this utility. http://www.afar.net/rf-link-budget-calculator/ You can plug in the TX power of your card: 23dB @ 54Mb You can plug in the Antenna gains: 31dB on both ends. Set the receive sensitive to -74 dB. Once this is done you can adjust the distance to match what you want for your Fade Marg...
by Letni
Mon Jun 14, 2010 6:06 am
Forum: General
Topic: ftp backups
Replies: 6
Views: 1006

Re: ftp backups

You need to turn off interactive prompting for multiple file downloads.
To do this change
ftp -n $FTP_HOST <<EOF
to
ftp -in $FTP_HOST <<EOF

You should also take out one of the H's in
FTP_HHOST=0
Just for the sake of clean code.

-Louis
by Letni
Sun Jun 13, 2010 8:46 pm
Forum: General
Topic: Simple https Question.
Replies: 4
Views: 546

Re: Simple https Question.

Can you do a redirect on http://www.mydomain.com to go to https://www.mydomain.com

I have done this before using PHP detecting if the client is connected via HTTPS or not.

-Louis
by Letni
Sun Jun 13, 2010 7:37 pm
Forum: General
Topic: Simple https Question.
Replies: 4
Views: 546

Re: Simple https Question.

It is doable.

This topic may be of help. http://forum.mikrotik.com/viewtopic.php?f=2&t=12063

-Louis
by Letni
Sun Jun 13, 2010 5:37 pm
Forum: General
Topic: Arp ping from console in v3.20
Replies: 2
Views: 1071

Re: Arp ping from console in v3.20

Hi KirillTs, I am using RouterOS 3.25 on an X86 box with 3.25 and able to arp ping using this command. /ping 10.30.0.253 interface=ether4 arp-ping=yes and get back response 10.30.0.253 with hw-addr 00:0C:42:07:2A:5B ping time<1 ms The link to the wiki you posted is for the older version of RouterOS....
by Letni
Sun May 23, 2010 3:47 pm
Forum: Wireless Networking
Topic: Problem. Solving 30km 11N wireless link issues.
Replies: 7
Views: 2720

Re: Problem. Solving 30km 11N wireless link issues.

Can you run the spectrum analyzer to see if there is noise on both sides?

-Louis
by Letni
Tue May 18, 2010 4:25 am
Forum: General
Topic: MikroTik RouterOS version 5.0beta2 released!
Replies: 139
Views: 44762

Re: MikroTik RouterOS version 5.0beta2 released!

When trying to upgrade RouterOS 4.9 on a XenServer 5.5 VM to RouterOS 5beta2, I get this error message. 21:29:19 system,info verified routeros-x86-5.0beta2.npk 21:29:19 system,info installed routeros-x86-5.0beta2 21:29:19 kvm,error no hardware virtualization support 21:29:19 system,info router reboo...
by Letni
Thu Dec 03, 2009 11:06 pm
Forum: General
Topic: RouterOS v4.3 released
Replies: 47
Views: 7117

Re: RouterOS v4.3 released

Anyone try 4.3 on RB411 w/ R52n at 2Ghz 5Mhz? I would love to know if it continually reboots on you. *SIGH*

-Louis
by Letni
Tue Nov 24, 2009 2:17 pm
Forum: General
Topic: Help With Monitor RouterOS 3.30 Interface With Cacti
Replies: 1
Views: 876

Re: Help With Monitor RouterOS 3.30 Interface With Cacti

For starts I would suggest of course upgrading to the latest version: 0.8.7e
Are you able to successfully graph anything?
The official site is http://www.cacti.net/
BTW. Google is your friend.
This may help: http://forums.cacti.net/viewtopic.php?t ... c4a1c7f05c

-Letni
by Letni
Sun Nov 22, 2009 8:56 am
Forum: General
Topic: How to display the exact minute of "log"---first column?
Replies: 4
Views: 822

Re: How to display the exact minute of "log"---first column?

upgrade to 3.30 and retest.
CLI = Command Line Interface. aka the console
-Letni
by Letni
Sun Nov 22, 2009 4:39 am
Forum: General
Topic: How to display the exact minute of "log"---first column?
Replies: 4
Views: 822

Re: How to display the exact minute of "log"---first column?

What RouterOS are you using?

Can you do it from CLI?
/log print
-Louis
by Letni
Mon Oct 26, 2009 2:35 am
Forum: General
Topic: virtual-ethernet
Replies: 7
Views: 1897

Re: virtual-ethernet

Would VLANs be of any use in this situation?

-Louis
by Letni
Mon Oct 12, 2009 4:00 am
Forum: RouterBOARD hardware
Topic: 433 poe passthrough
Replies: 3
Views: 1120

Re: 433 poe passthrough

While I have never done this before the premise would be to pass pins 4,5,7,8 from ether1 to ether2 in the same order. I would guess that you could not get 4,5 wrong since they are the middle pair and use a volt meter to find 7,8. Another way to check which side 7,8 is the side the brown pair goes i...
by Letni
Wed Sep 23, 2009 9:35 pm
Forum: General
Topic: How to limit PPPoE connection request attack?
Replies: 34
Views: 9760

Re: How to limit PPPoE connection request attack?

Has anyone come up with a solution for this?
Has Mikrotik added the options to limit PPPoE connection requests?

-Louis
by Letni
Fri Aug 21, 2009 4:08 am
Forum: General
Topic: Another medium access instead of CSMA/CA
Replies: 2
Views: 1022

Re: Another medium access instead of CSMA/CA

Is the "Disable CSMA" option on the Nstreame tab not what you are looking for?

-Louis
by Letni
Tue Aug 04, 2009 2:32 am
Forum: Wireless Networking
Topic: Benefits of using R52H for wireless g as compared to R52N?
Replies: 10
Views: 1794

Re: Benefits of using R52H for wireless g as compared to R52N?

To quote myself since you will not go back and read.
I would like to note that when using the R2N & R52N you must use 4.0Beta which has some considerable issues.
If it is for non critical link and you feel like you have to much time on your hands have at it.
-Louis
-Louis
by Letni
Thu Jul 23, 2009 7:18 pm
Forum: Wireless Networking
Topic: Benefits of using R52H for wireless g as compared to R52N?
Replies: 10
Views: 1794

Re: Benefits of using R52H for wireless g as compared to R52N?

I would like to note that when using the R2N & R52N you must use 4.0Beta which has some considerable issues.
If it is for non critical link and you feel like you have to much time on your hands have at it.
-Louis
by Letni
Tue Jul 21, 2009 4:22 am
Forum: Scripting
Topic: i want anti spam and anti virus for microtik
Replies: 4
Views: 5017

Re: i want anti spam and anti virus for microtik

Mikrotik has shown no interest in adding an Anti-Spam/Anti-Virus filter. As an ISP you will need a dedicated solution to this and I recomend you purchase a machine dedicated to this. Examples http://www.barracudanetworks.com/ns/products/spam_overview.php OR https://www.mailfoundry.com/store/category...
by Letni
Tue Jul 14, 2009 7:16 pm
Forum: General
Topic: r52n not recognised
Replies: 5
Views: 801

Re: r52n not recognised

Normis,

Are you telling us that V3.26 will recognize the R52N?

-Louis
by Letni
Tue Jul 14, 2009 2:33 pm
Forum: Beginner Basics
Topic: upgrading router OS problem
Replies: 8
Views: 1059

Re: upgrading router OS problem

If it does not upgrade as expected check the log for a reason.
What version are you current using and what version are you upgrading to?

-Louis
by Letni
Tue Jul 14, 2009 2:25 pm
Forum: Scripting
Topic: opendns with dynamic ip
Replies: 30
Views: 13140

Re: opendns with dynamic ip

This can _not_ directly be done on RouterOS because the fetch command does not support HTTPS.

-Louis
by Letni
Tue Jul 07, 2009 10:53 pm
Forum: RouterBOARD hardware
Topic: my radio hangs at "starting services"
Replies: 3
Views: 1063

Re: my radio hangs at "starting services"

It will re-use your license when you do the Netinstall.

-Louis
by Letni
Thu Jul 02, 2009 6:24 am
Forum: Forwarding Protocols
Topic: consensus of community re: best RouterOS for OSPF
Replies: 2
Views: 1062

Re: consensus of community re: best RouterOS for OSPF

I have had success intermingeling RB532+RB564 w/ V2.9.51 Routing-test and RB493AH w/ V3.23 Routing-test. We are in the process of upgrading our core ring from the RB500 series to the RB400AH series since we have reached the limits of the 500's.

-Louis
by Letni
Thu Jul 02, 2009 3:41 am
Forum: General
Topic: Powerouter 732 100% CPU Load High Latency
Replies: 11
Views: 1133

Re: Powerouter 732 100% CPU Load High Latency

Or maybe they figured with all the SMP issues RouterOS has experienced, it was safer on a production box to leave multi-cpu disabled.

-Louis
by Letni
Wed Jul 01, 2009 4:12 am
Forum: Forwarding Protocols
Topic: IP Blocking not working
Replies: 8
Views: 1696

Re: IP Blocking not working

Do you have an allow established or related rule before your drop?

-Louis
by Letni
Fri Jun 26, 2009 3:04 pm
Forum: General
Topic: VRRP not working properly
Replies: 6
Views: 1922

Re: VRRP not working properly

Take a look at this document. http://www.faqs.org/rfcs/rfc3768.html Specifically this section. If the Priority in the ADVERTISEMENT is equal to the local Priority and the primary IP Address of the sender is greater than the local primary IP Address, then: o Cancel Adver_Timer o Set Master_Down_Timer...
by Letni
Thu Jun 25, 2009 7:29 am
Forum: General
Topic: VRRP not working properly
Replies: 6
Views: 1922

Re: VRRP not working properly

I just tested VRRP on a pair of RB493's running 3.25 and it worked as expected. One thing that may be throwing off your results is having one of the routers have a priority of 255. Having a priority of 255 means that the router is the owner of the VRRP IP and will ALWAYS step in and preempt even whe...
by Letni
Wed Jun 24, 2009 2:30 pm
Forum: Beginner Basics
Topic: hdd not detected
Replies: 1
Views: 539

Re: hdd not detected

by Letni
Mon Jun 08, 2009 6:53 am
Forum: General
Topic: plz help i need only know how to download remotely to server
Replies: 5
Views: 617

Re: plz help i need only know how to download remotely to server

/tool fetch url=http://66.228.113.58/all_packages-x86-4.0beta3.zip
by Letni
Fri Jun 05, 2009 5:26 am
Forum: General
Topic: Ethernet duplex problems
Replies: 8
Views: 4978

Re: Ethernet duplex problems

We have to force 100/F on our X86 machines when connected to Cisco gear. I always took it as Cisco had a wierd auto-negotiate issue. http://en.wikipedia.org/wiki/Autonegotiation Interoperability section.

Also to show Ethernet errors in Winbox you will need to upgrade to at least 3.23.

-Louis
by Letni
Tue Jun 02, 2009 4:24 pm
Forum: General
Topic: v3.24 have Bug in IP Route Dynamic
Replies: 10
Views: 1000

Re: v3.24 have Bug in IP Route Dynamic

I am using YUJOBIKA's steps to recreate. Enable IP, wait 10-15s, disable IP (route will still be in winbox), wait 10-15s, enable IP(new identical route will appear in winbox), repeat. It appears to be a winbox issue though. Through CLI it is correct.
MTRouteIssue324ScreenShot2.jpg
-Louis
by Letni
Mon Jun 01, 2009 5:21 pm
Forum: General
Topic: v3.24 have Bug in IP Route Dynamic
Replies: 10
Views: 1000

Re: v3.24 have Bug in IP Route Dynamic

Packages:
advanced-tools
calea
ntp
routing - Disabled
routing-test
system

Intel Xeon 2.1Ghz
multi-cpu: yes
2G RAM
6 NIC: 2 onboard (intel), 1 RB44G

I have been using the box to test some BGP configurations and SMP stability.
MTRouteIssue324ScreenShot.jpg
-Louis
by Letni
Fri May 29, 2009 3:17 pm
Forum: General
Topic: v3.24 have Bug in IP Route Dynamic
Replies: 10
Views: 1000

Re: v3.24 have Bug in IP Route Dynamic

I am able to semi-repeat this on our X86, 3.24 Routing-Test. I was able to get the routing entry to show up twice. One of them being a stale record that would not update. I think the easier test is though. BUG: When you disable an IP address, the route still shows up in the routing table. Be sure to...
by Letni
Sun May 24, 2009 7:04 am
Forum: General
Topic: 8 symbol SoftID
Replies: 3
Views: 789

Re: 8 symbol SoftID

From the newsletter 18. http://www.mikrotik.com/pdf/news18.pdf
Starting with v4.0beta3 RouterOS now includes
support for these 802.11n cards, that is unlocked by
updating your RouterOS license with the new 8
digit SoftID.
Sounds like 8 digit SoftID's are not supported in V3.

-Louis
by Letni
Sat May 23, 2009 7:12 pm
Forum: Beginner Basics
Topic: winbox and bandwidth
Replies: 6
Views: 1864

Re: winbox and bandwidth

You can use torch to see how much bandwidth winbox is using.
Tools --> Torch.

Checking mine now I am seeing 46kbps Tx 5kbps Rx.

If you find that winbox uses to much bandwidth you have the option to use the CLI through Telnet/SSH.

-Louis
by Letni
Thu May 07, 2009 11:35 pm
Forum: General
Topic: Quick Conntrack question
Replies: 1
Views: 299

Re: Quick Conntrack question

For "some other rules" you will most certainly need connection tracking on.

-Louis
by Letni
Thu May 07, 2009 2:44 pm
Forum: RouterBOARD hardware
Topic: RB493 & Netinstall
Replies: 1
Views: 923

Re: RB493 & Netinstall

I recall seeing this issue once when the desktop I was using to netinstall from had 2 NICS. I believe disabling all other NIC's than the one that was connected to RB fixed the issue. If that does not take care of it, you could try upgrading the firmware first. MT has available 2.19 on the routerboar...
by Letni
Thu May 07, 2009 2:38 pm
Forum: General
Topic: [SOLVED] Kernel Oops when adding a comment to an interface
Replies: 10
Views: 2440

Re: Kernel Oops when adding a comment to an interface

What hardware are you running it on? (X86, RBXXX)
If it is X86, do you have multi-cpu turned on?

-Louis
by Letni
Thu May 07, 2009 2:20 pm
Forum: Beginner Basics
Topic: Firewall (basic rules) slow down routing performance?
Replies: 8
Views: 3541

Re: Firewall (basic rules) slow down routing performance?

The standard for measuring throughput for a mikrotik router is: Download the bandwidth test tool from this page http://www.mikrotik.com/download.html onto 2 computers that are directly connected to the router. Start one up and go into settings and check 'Server Enabled'. Then on the second machine, ...
by Letni
Thu May 07, 2009 6:17 am
Forum: Beginner Basics
Topic: Firewall (basic rules) slow down routing performance?
Replies: 8
Views: 3541

Re: Firewall (basic rules) slow down routing performance?

Add these to the top of your list. It should help with performance. /ip firewall filter add chain=forward connection-state=established comment="allow established connections" add chain=forward connection-state=related comment="allow related connections" add chain=forward connection-state=invalid act...
by Letni
Mon May 04, 2009 5:39 pm
Forum: Beginner Basics
Topic: regret i can't access till now
Replies: 3
Views: 548

Re: regret i can't access till now

http://wiki.mikrotik.com/wiki/Upgrading_RouterOS

To have Routers show up in the [...] list they need to be on the same broadcast domain as the computer.

-Louis
by Letni
Mon May 04, 2009 5:25 pm
Forum: Beginner Basics
Topic: regret i can't access till now
Replies: 3
Views: 548

Re: regret i can't access till now

Upgrade to 2.9.51
Check your cabling.
Can you log into it via console? (serial, KVM)

-Louis
by Letni
Mon May 04, 2009 5:27 am
Forum: General
Topic: Problems with Winbox MAC 2.2.4 in ROS 3.23
Replies: 3
Views: 520

Re: Problems with Winbox MAC 2.2.4 in ROS 3.23

works fine for me with Winbox 2.2.14 to 3.23.
I tried MAC connection to a RB500 and X86 series boards.

-Louis
by Letni
Tue Apr 28, 2009 2:41 pm
Forum: RouterBOARD hardware
Topic: RB493AH @ 800Mhz
Replies: 8
Views: 2115

Re: RB493AH @ 800Mhz

These are plain boards. No add-on cards. I took one straight out of the box. Hooked it up with a serial cable. Changed the CPU speed to 800Mhz and it did _not_ boot RouterOS. This indicates to me that these boards are _not_ being properly tested by Mikrotik. If anyone else has access to the RB493AH,...
by Letni
Sat Apr 25, 2009 6:42 am
Forum: RouterBOARD hardware
Topic: RB493AH @ 800Mhz
Replies: 8
Views: 2115

Re: RB493AH @ 800Mhz

Roc,

Even your site advertises using these at 800Mhz
http://www.roc-noc.com/product.php?productid=118

These are straight out of the box. It is certainly not a heat issue.
MT has a history of not testing things fully. I should not be surprised that they state factory tested and lie about it.

-Louis
by Letni
Sat Apr 25, 2009 1:22 am
Forum: RouterBOARD hardware
Topic: RB493AH @ 800Mhz
Replies: 8
Views: 2115

RB493AH @ 800Mhz

I just purchased 5 RB493's. Mikrotik's website states that these units will do 800Mhz (Factory tested!?). Out of the 5 I can only get 1 of them to boot at 800Mhz. I have even tried upgrading the BIOS from 2.18 to 2.20 as well as upgrading the RouterOS to 3.23. Any suggestions? Think I should be able...
by Letni
Wed Apr 15, 2009 2:35 pm
Forum: Beginner Basics
Topic: bonding
Replies: 6
Views: 721

Re: bonding

In Winbox you can go to 'System --> License' to find out what you can upgrade to.

Here is some info on how to upgrade.
http://wiki.mikrotik.com/wiki/Upgrading_RouterOS

-Louis
by Letni
Wed Apr 15, 2009 12:30 am
Forum: Beginner Basics
Topic: bonding
Replies: 6
Views: 721

Re: bonding

MLPPP is not supported in V2.9. Please upgrade to V3.

-Louis
by Letni
Wed Apr 15, 2009 12:20 am
Forum: General
Topic: Please Help with MK3 firewall
Replies: 2
Views: 370

Re: Please Help with MK3 firewall

Do you have the proxy service enabled and running on port 8080?

-Louis
by Letni
Mon Apr 13, 2009 10:05 pm
Forum: General
Topic: Feature Suggestion: GARP/GVRP
Replies: 4
Views: 4173

Re: Feature Suggestion: GARP/GVRP

I am throwing my vote in for GVRP.

-Louis
by Letni
Mon Apr 06, 2009 6:13 am
Forum: General
Topic: Disappearing Ether
Replies: 2
Views: 427

Re: Disappearing Ether

I submitted the info to support. They replied that they knew about the issue but recommended I do a reset-configuration and restore from an export. What a hassle! MT backup/restore system has always been a failure and should be redone.

-Louis
by Letni
Sun Mar 22, 2009 4:54 pm
Forum: General
Topic: Batch script
Replies: 2
Views: 639

Re: Batch script

If you are using V3 you can grab one of the API scripts from the WIKI.

http://wiki.mikrotik.com/wiki/Category:API

-Louis
by Letni
Sun Mar 08, 2009 3:42 pm
Forum: General
Topic: Most stable BGP version?
Replies: 37
Views: 3519

Re: Most stable BGP version?

@Perit Are you running IBGP in any of those circumstances? I have been trying to mix V2.9.51 Routing-test, V3.20 Routing, and an upstream providers Cisco together with-out success using IBGP. Some of the issues I have experienced are: I have to close out winbox because it will become unresponsive af...
by Letni
Sun Mar 08, 2009 6:14 am
Forum: General
Topic: Help Me please MT confusing me
Replies: 1
Views: 400

Re: Help Me please MT confusing me

Read this
http://wiki.mikrotik.com/wiki/Load_Balancing_Persistent
and
http://wiki.mikrotik.com/wiki/Load_Bala ... e_Gateways

The first one is easier and probably will work for you.

-Louis
by Letni
Thu Mar 05, 2009 11:37 pm
Forum: General
Topic: DHCP Server gives out old DNS info
Replies: 8
Views: 1316

Re: DHCP Server gives out old DNS info

Make sure "Obtain DNS server address automatically" is selected under TCP/IP for your workstation NIC.

-Louis
by Letni
Tue Mar 03, 2009 2:47 pm
Forum: Beginner Basics
Topic: Save my sanity!!!
Replies: 11
Views: 1174

Re: Save my sanity!!!

I believe you will need to setup a security profile or modify default and apply it to the wireless interface.
http://www.mikrotik.com/testdocs/ros/3. ... ontent.php
http://wiki.mikrotik.com/wiki/Wireless

-Louis
by Letni
Tue Mar 03, 2009 2:23 pm
Forum: General
Topic: Very strange case (need help)
Replies: 2
Views: 481

Re: Very strange case (need help)

Check logs for anything unusual.

Upgrade to the latest version of RouterOS.
Disable/Remove any packages you do not need.

If it still happens then make a supout and send it to support as well as setup watchdog

-Louis
by Letni
Tue Mar 03, 2009 2:13 pm
Forum: Wireless Networking
Topic: Need some help setting up a transparent bridge.
Replies: 4
Views: 782

Re: Need some help setting up a transparent bridge.

Since you are unable to establish a wireless connection we will start there. Look at your logs to see if you have any error messages that may be useful. If using Nstreame make sure it is turned checked on both sides. On the AP side use bridge since you will only have 1 client. Make sure you have WDS...
by Letni
Tue Mar 03, 2009 6:50 am
Forum: Wireless Networking
Topic: RB411 Log help needed
Replies: 2
Views: 528

Re: RB411 Log help needed

Check the first thread in the wireless networking section! It is sticky so that everyone see's it. It is called Wireless disconnection messages explained!
No really, you should look.

-Louis
by Letni
Tue Mar 03, 2009 6:45 am
Forum: Wireless Networking
Topic: Need some help setting up a transparent bridge.
Replies: 4
Views: 782

Re: Need some help setting up a transparent bridge.

The skinny is to make a bridge interface. Add other interfaces into the bridge interface to get them on the same layer 2 network.
Can you be more specific on what you want to accomplish, what you have done, and what you have done to show it is not working as expected?

-Louis
by Letni
Tue Mar 03, 2009 2:56 am
Forum: Wireless Networking
Topic: UBNT SR71 series
Replies: 10
Views: 2871

Re: UBNT SR71 series

The word from Ubiquity is "MikroTik's lack of willingness to support these cards"
http://ubnt.com/forum/viewtopic.php?p=28097

-Louis
by Letni
Mon Mar 02, 2009 7:08 pm
Forum: General
Topic: Disappearing Ether
Replies: 2
Views: 427

Disappearing Ether

X86 RouterOS 2.9.51 with integrated gigE and RB44G.

After doing a restore from a backup a couple of weeks ago I noticed ether4 was no longer in the interface list.
I needed to do another restore this morning from friday's backup and now ether3 has disappeared.
Has anyone else seen this issue?

-Louis
by Letni
Fri Jan 30, 2009 12:51 am
Forum: General
Topic: ROS - Show Interface CRC error
Replies: 7
Views: 4394

Re: ROS - Show Interface CRC error

A lot of us have wanted this for a long time. MT answer is you can get it through SNMP and they show no interest in enhancing there error reporting. After 3 years of waiting I finally gave up.

-Louis
by Letni
Wed Jan 28, 2009 2:54 am
Forum: Beginner Basics
Topic: LAN MAC Filter?
Replies: 7
Views: 8622

Re: LAN MAC Filter?

After putting some more thought into it, I am thinking what you want is _not_ doable because PPPoE does a broadcast that gets sent out on the interface. Since you have your dsl-modems on the same switch, the broadcast goes to both of them. No way to filter that. I recommend you restate what your tru...
by Letni
Tue Jan 27, 2009 5:15 pm
Forum: Beginner Basics
Topic: LAN MAC Filter?
Replies: 7
Views: 8622

Re: LAN MAC Filter?

Your picture did not come out so well.

Are you trying to achieve bonding or redundancy?

If redundancy then only have one mikrotik connected to one modem and on your lan side use VRRP.
-Louis
by Letni
Tue Jan 27, 2009 5:05 pm
Forum: General
Topic: New IP range
Replies: 6
Views: 1073

Re: New IP range

What about upgrading the software? When pinging anything else on the second subnet do you see the high latency or is just the camera? Since it is _urgent_ you may want to hire a Mikrotik Consultant. We participate on the forum at our leisure. Here is the list. http://www.mikrotik.com/consultants.htm...
by Letni
Mon Jan 26, 2009 6:43 pm
Forum: General
Topic: New IP range
Replies: 6
Views: 1073

Re: New IP range

You have it setup properly. Have you tried connecting to it from a different workstation on the network. You may want to try upgrading the latest ROS. Also from the router try pinging both devices. Does the latency show which side the problem is on? Try forcing ethernet speed and duplex for your cam...
by Letni
Mon Jan 26, 2009 2:25 am
Forum: General
Topic: help to find a solution
Replies: 1
Views: 327

Re: help to find a solution

Sounds like the wired network and your WDS are bridged together. You should try putting the WDS and the wired network on separate subnets and getting rid of the bridge.

-Louis
by Letni
Sun Jan 25, 2009 8:19 pm
Forum: Beginner Basics
Topic: LAN MAC Filter?
Replies: 7
Views: 8622

Re: LAN MAC Filter?

You are going to want to read up on Firewall rules. Here is a link for the manual. http://www.mikrotik.com/testdocs/ros/2.9/ip/filter.php Here is an example of specifically what you are looking for. Drops packets with that source mac address destined for somewhere else. /ip firewall filter add chain...
by Letni
Sun Jan 25, 2009 8:14 pm
Forum: General
Topic: New IP range
Replies: 6
Views: 1073

Re: New IP range

You would do it the same way you added the first.
In Winbox
IP --> Addresses; +; Address = 192.168.11.0/24, Interface = <the interface you want it on>; OK

-Louis
by Letni
Fri Jan 16, 2009 8:39 pm
Forum: General
Topic: Can we use 3com IP phones on Mikrotik RB 333
Replies: 6
Views: 832

Re: Can we use 3com IP phones on Mikrotik RB 333

We assign IP's via DHCP for our phones.

To disable SIP helper in V3 it is under Winbox: /IP --> Firewall (Service Ports)

-Louis
by Letni
Fri Jan 16, 2009 3:09 am
Forum: Beginner Basics
Topic: RB1000 Problem
Replies: 9
Views: 1028

Re: RB1000 Problem

Gaining access to the RB through the serial interface is the best way to diagnose the issue.
Check your settings and try again.
Use with a serial terminal program like Hyperterm. Serial port settings should be 115200,8,n,1.

-Louis
by Letni
Thu Jan 15, 2009 5:24 pm
Forum: General
Topic: Password Recovery - Ancient Install
Replies: 6
Views: 889

Re: Password Recovery - Ancient Install

Boot it up and check under /System License to find out what you can upgrade to.
-Louis
by Letni
Thu Jan 15, 2009 4:49 pm
Forum: General
Topic: is worth upgrade from pentium d 2.8ghz to Xeon 2.66?
Replies: 14
Views: 2225

Re: is worth upgrade from pentium d 2.8ghz to Xeon 2.66?

GustKiller
How much traffic are you passing on your bridge? Is it being used for bandwidth management? How many users?

Janis
Is Mikrotik working on a newer version of the IN/G44V that would maybe be PCI-x or PCIExpress?

-Louis
by Letni
Thu Jan 15, 2009 2:56 pm
Forum: General
Topic: Can we use 3com IP phones on Mikrotik RB 333
Replies: 6
Views: 832

Re: Can we use 3com IP phones on Mikrotik RB 333

You are going to need to be more specific on what the issue is exactly.

I have run both VoIP ATA's and Asterisk box through RB's NAT and Routed.

-Louis
by Letni
Thu Jan 15, 2009 2:52 pm
Forum: General
Topic: Cacti cant find mikrotik device
Replies: 3
Views: 1052

Re: Cacti cant find mikrotik device

Sounds like an issue with Cacti. Sounds like an issue with the poller. I had a difficult time when I set it up the first time. I found using there CactiEZ CD for setup was quick and worked perfect.

-Louis
by Letni
Thu Jan 15, 2009 6:53 am
Forum: General
Topic: How to using Serial0 interface on Mikrotik
Replies: 6
Views: 1183

Re: How to using Serial0 interface on Mikrotik

I have done this before to log into our managed switch. I think you have to first turn off the console running on serial0. That is what is keeping the port busy.

Go under /System Console and disable serial0.

Then try it again.

-Louis
by Letni
Thu Jan 15, 2009 6:39 am
Forum: Beginner Basics
Topic: Change Login Page?
Replies: 1
Views: 657

Re: Change Login Page?

http://www.mikrotik.com/testdocs/ros/2.9/ip/hotspot.php

The files are accessable either through winbox with the button on the left called Files or you can FTP/SFTP into the box and update the files in the Hotspot folder.

-Louis
by Letni
Thu Jan 15, 2009 6:27 am
Forum: General
Topic: Routing Subnets Help
Replies: 7
Views: 775

Re: Routing Subnets Help

Looking at the config your router is setup correct. This line confused me. Port 1 – 10.20.6.0/24 - (10.20.6.1 – 10.20.6.223) it didn't match your config. Your config would be Port 1 - 10.20.6.0/25 - (10.20.6.1-10.20.6.126) Example You have a client on port 1. The correct network settings would be IP...
by Letni
Thu Jan 15, 2009 5:50 am
Forum: General
Topic: Routing Subnets Help
Replies: 7
Views: 775

Re: Routing Subnets Help

Looking closer at your first post I see a discrepancy.
Port 1 – 10.20.6.0/24 - (10.20.6.1 – 10.20.6.223) != 2 10.20.6.1/25 10.20.6.0 10.20.6.127 ether1

Check your IP address for port 1, looks like you have the wrong netmask specified

-Louis
by Letni
Thu Jan 15, 2009 4:37 am
Forum: General
Topic: Cacti cant find mikrotik device
Replies: 3
Views: 1052

Re: Cacti cant find mikrotik device

Any firewall rules in your Mikrotik that would prevent SNMP?

-Louis
by Letni
Thu Jan 15, 2009 4:36 am
Forum: General
Topic: Can we use 3com IP phones on Mikrotik RB 333
Replies: 6
Views: 832

Re: Can we use 3com IP phones on Mikrotik RB 333

You may have some issues if you are running NAT. Try disabling the SIP helper.

-Louis
by Letni
Thu Jan 15, 2009 4:33 am
Forum: General
Topic: Advice on choosing Correct RouterBoard.
Replies: 2
Views: 505

Re: Advice on choosing Correct RouterBoard.

Use the PC you have already and put a 3rd NIC in it. Then you can get your 2nd DSL and setup the necessary rules for what you want.

-Louis
by Letni
Thu Jan 15, 2009 4:29 am
Forum: General
Topic: Routing Subnets Help
Replies: 7
Views: 775

Re: Routing Subnets Help

Does your connected equipment have a the correct subnet info and a default gateway defined?

-Louis
by Letni
Mon Jan 12, 2009 12:34 am
Forum: General
Topic: add chain error in 3.18, why?
Replies: 2
Views: 616

Re: add chain error in 3.18, why?

/ip firewall filter add chain=forward protocol=icmp action=jump jump-target=icmp works fine for me on RouterOS 3.18. You should try reseting your router back to defaults and test again or Could you please show a screen shot of the error you are receiving. Are you adding it through Winbox or CLI? -L...
by Letni
Mon Dec 29, 2008 5:39 am
Forum: Wireless Networking
Topic: can i change the OS on routerboard ?
Replies: 7
Views: 1644

Re: can i change the OS on routerboard ?

You can get the software ID by connecting via Winbox and going to
System --> License

-Louis
by Letni
Sat Dec 27, 2008 7:41 pm
Forum: Wireless Networking
Topic: can i change the OS on routerboard ?
Replies: 7
Views: 1644

Re: can i change the OS on routerboard ?

You would need to purchase a new license. You can _not_ upgrade license level. You can get a new license from any reseller or logging in to Mikrotik.com and purchase it. These should help you with any other licensing questions. http://www.mikrotik.com/pricelist.php http://wiki.mikrotik.com/wiki/Most...
by Letni
Thu Dec 25, 2008 10:22 pm
Forum: Scripting
Topic: script not working 3.17
Replies: 1
Views: 480

Re: script not working 3.17

Tested on 3.17
:for i from=2 to=254 do={/queue simple add name="192.168.0.$i" target-address="192.168.0.$i/32" max-limit="20000/64000"}
by Letni
Thu Dec 25, 2008 12:59 am
Forum: General
Topic: Winbox 2.2.14
Replies: 1
Views: 2599

Winbox 2.2.14

I noticed RouterOS 3.17 included Winbox 2.2.14.
The changelog does not show any updates to Winbox however.

Can we get the website updated with the new version of Winbox.

-Louis
by Letni
Wed Dec 24, 2008 4:54 am
Forum: RouterBOARD hardware
Topic: Omitting packages
Replies: 7
Views: 2698

Re: Omitting packages

You did not explain what you did to reach that error message or how you got that error message(pop up or log)?

Try uploading your "downgrade" and issuing
/system package downgrade
You may also find this handy.
http://www.mikrotik.com/testdocs/ros/2. ... ontent.php

-Louis
by Letni
Tue Dec 16, 2008 3:16 am
Forum: General
Topic: VLAN bridging question
Replies: 3
Views: 809

Re: VLAN bridging question

This can be done very easily with Mikrotik.

The skinny.
Create Bridge1, Bridge2, Bridge3
Create vlan2 on ether1, vlan3 on ether1
Assign ether1 and ether4 to Bridge1
Assign vlan2 and ether2 to Bridge2
Assign vlan3 and ether3 to Bridge3
Call it a day. ;)

-Louis
by Letni
Fri Dec 12, 2008 5:43 am
Forum: General
Topic: dns server
Replies: 4
Views: 3079

Re: dns server

DNS Server is already implemented.
In winbox look under: IP --> DNS
by Letni
Fri Dec 12, 2008 5:27 am
Forum: General
Topic: TFTP
Replies: 33
Views: 14218

Re: TFTP

1: Yes
2: Upgrading firmware on switches/legacy wireless radio's
2: Saving/restoring configurations for managed switches
2: Would look into TFTP booting servers
3: Some form of mac authentication
3: Read & Write access (maybe definable by MAC)
by Letni
Mon Dec 08, 2008 3:08 am
Forum: General
Topic: Default Transmit Power
Replies: 7
Views: 1421

Re: Default Transmit Power

They are fixed for the datarate it is using.

-Louis
by Letni
Mon Dec 08, 2008 3:03 am
Forum: Beginner Basics
Topic: RB 150 help
Replies: 1
Views: 504

Re: RB 150 help

create bridge2
add ether4 + ether5 to bridge2
move anything assigned to ether5 to bridge2. Example IP's, DHCP server, etc.

-Louis
by Letni
Sun Dec 07, 2008 1:44 am
Forum: Scripting
Topic: How to print the special IP address connection number?
Replies: 2
Views: 824

Re: How to print the special IP address connection number?

You can not retrieve just the IP. You would need to parse out the information you need. This would take a lot of CPU and RAM if you had a lot of connections. It would be nice to have this functionality out of the box from MT but I doubt we will ever see it. You should try solving your issue from a d...
by Letni
Sun Dec 07, 2008 1:34 am
Forum: Beginner Basics
Topic: Port forwarding problem
Replies: 4
Views: 1929

Re: Port forwarding problem

have you tried excluding your internal range from the port forward rule.
Try adding something like this to your rule. src-address=!192.168.1.0/24

-Louis
by Letni
Sun Dec 07, 2008 1:00 am
Forum: General
Topic: Certification Prerequistes
Replies: 1
Views: 429

Re: Certification Prerequistes

The only way I know of is to attend a training class and take the test.

http://training.mikrotik.com/

-Louis
by Letni
Sun Dec 07, 2008 12:37 am
Forum: Scripting
Topic: SCP Support
Replies: 4
Views: 1606

Re: SCP Support

I had thought about this for some time but had never tested it till today. V3.17 I was able to SFTP from my linux box to my home router and transfer a file. I was also able to SFTP from my Windows XP box to my home router and transferred a file using WinSCP from http://winscp.net/eng/download.php -L...
by Letni
Sat Dec 06, 2008 11:02 pm
Forum: General
Topic: A LOT OF PROBLEMS WITH FTP IN VERSION 3.14
Replies: 9
Views: 1995

Re: A LOT OF PROBLEMS WITH FTP IN VERSION 3.14

first stop SHOUTING. phew....

next. Make sure you have a firewall rule that allows related connections.
connection-state=related action=accept

oh. and always please upgrade to the latest version.

-Louis
by Letni
Sat Dec 06, 2008 6:42 pm
Forum: Scripting
Topic: How can I access a global variable on another router?
Replies: 8
Views: 1934

Re: How can I access a global variable on another router?

Simple answer is no.

Tedious answer is to export out your variable to a file on Router1.
Then on Router2 fetch the file and import it to load your variable.

There are many drawbacks to this method.
But it gets some information from Rtr1 to Rtr2

-Louis
by Letni
Sat Dec 06, 2008 5:52 pm
Forum: General
Topic: upgrading to new os
Replies: 1
Views: 462

Re: upgrading to new os

If you system is working properly then upgrade.

If you think RouterOS has gotten corrupted in some way or it does not boot normally then do a netinstall.

-Louis
by Letni
Fri Nov 14, 2008 4:18 pm
Forum: General
Topic: Feature Request - Basic Serial Interaction
Replies: 6
Views: 1781

Re: Feature Request - Basic Serial Interaction

Have you tried /system serial-terminal ?
http://www.mikrotik.com/testdocs/ros/2. ... serial.php
-Louis
by Letni
Fri Nov 14, 2008 2:45 pm
Forum: Wireless Networking
Topic: RouterOS 2.9.51 and 3.16 upgrade
Replies: 3
Views: 861

Re: RouterOS 2.9.51 and 3.16 upgrade

There would be no sensible reason to buy a 2.9 license.
Your V3 license will work on 2.9.
-Louis
by Letni
Wed Nov 05, 2008 2:18 pm
Forum: General
Topic: ARP Cache Timeout
Replies: 2
Views: 839

Re: ARP Cache Timeout

I have also wanted to know what the default is and how to change it.

-Louis
by Letni
Tue Oct 14, 2008 6:54 am
Forum: RouterBOARD hardware
Topic: Talking to RouterBoard via Serial Console won't work
Replies: 5
Views: 6575

Re: Talking to RouterBoard via Serial Console won't work

Some of your connection settings are wrong.
Take a look at the Quick Setup guide here. http://www.routerboard.com/pdf/rb433mA.pdf

-Louis
by Letni
Mon Oct 13, 2008 6:12 am
Forum: Beginner Basics
Topic: [3.14][dhcp-server]how to get alerts variable
Replies: 4
Views: 1546

Re: [3.14][dhcp-server]how to get alerts variable

OMG. No way. Maybe you MISSPELLED something. :P
I took the time to post. You should take the time to read and understand.

-Louis
by Letni
Mon Oct 13, 2008 1:31 am
Forum: Beginner Basics
Topic: [3.14][dhcp-server]how to get alerts variable
Replies: 4
Views: 1546

Re: [3.14][dhcp-server]how to get alerts variable

You have misspelled unknown-server

Tested with the correct spelling on my router (3.14) and returned correct result.

-Louis
by Letni
Mon Oct 13, 2008 1:18 am
Forum: Beginner Basics
Topic: Saving open dialog boxes in RouterOS
Replies: 5
Views: 900

Re: Saving open dialog boxes in RouterOS

Follow parrini's advice here: http://forum.mikrotik.com/viewtopic.php?f=2&t=26168

-Louis
by Letni
Sat Oct 04, 2008 6:18 pm
Forum: Beginner Basics
Topic: log Error
Replies: 2
Views: 664

Re: log Error

That is someone trying to brute force login via SSH. If you do not use SSH you should shut the service down. IP --> Services

-SLA
by Letni
Wed Sep 24, 2008 3:13 pm
Forum: Beginner Basics
Topic: How to remove empty Address List?
Replies: 4
Views: 1940

Re: How to remove empty Address List?

If they are empty and still showing up in the Address List drop down then you are referencing them from a firewall rule. The simplest way I know of to clean it up is to export your firewall configuration. /ip firewall export file=firewall Transfer the created firewall.rsc file to your pc and do a fi...
by Letni
Tue Sep 23, 2008 2:48 pm
Forum: RouterBOARD hardware
Topic: ros 3.14 torrent is out but no seed since friday :P
Replies: 27
Views: 2721

Re: ros 3.14 torrent is out but no seed since friday :P

After re-downloading ALL file my torrent client is giving me this.
rejected by tracker - Torrent not registered with this tracker.

-Louis
by Letni
Tue Sep 23, 2008 6:31 am
Forum: Scripting
Topic: Script to 'tarpit' ip on failed login attempts?
Replies: 5
Views: 2200

Re: Script to 'tarpit' ip on failed login attempts?

Here is one way of doing it. Very inefficient, but does the job. Tested on V3.13 :global ListName SSHAttack :global NumFailures 10 :global bad "" :foreach i in=[/log find topics=system,error,critical] do={ :local message [/log get $i message] :local pos1 ([:find $message "from"]+5) :local pos2 ([:fi...
by Letni
Tue Sep 23, 2008 4:32 am
Forum: General
Topic: Where is the CHANGE_LOG file?
Replies: 3
Views: 931

Re: Where is the CHANGE_LOG file?

I want to see the changes of v.3.14 but couldnt find the change_log file anywhere.
http://www.mikrotik.com/download/CHANGELOG_rc

-Louis
by Letni
Mon Sep 22, 2008 8:14 am
Forum: Beginner Basics
Topic: concept bridge in mikrotik
Replies: 2
Views: 1032

Re: concept bridge in mikrotik

Bridge is used to take multiple interfaces and put them on the same layer 2. http://www.mikrotik.com/testdocs/ros/2.9/interface/bridge.php There are a lot of uses for bridge. One such use would be the RB153 where I have Ether1 connected to my Internet provider. Ether2-5 added to bridge called LAN Wl...
by Letni
Mon Sep 22, 2008 2:26 am
Forum: Scripting
Topic: please please!!! I can not operate this script
Replies: 2
Views: 892

Re: please please!!! I can not operate this script

How do I schedule this script and operation(run) ? ? I using V3.13
http://www.mikrotik.com/testdocs/ros/2. ... eduler.php

-Louis
by Letni
Fri Sep 19, 2008 2:54 pm
Forum: Scripting
Topic: filtering leases by print (DHCP-SERVER)
Replies: 6
Views: 1007

Re: filtering leases by print (DHCP-SERVER)

I think I understand now. You are looking for this.
Tested on 3.13
:global IpRoot 10.10.1.
:for i from=1 to= 254 do={
  :if ([/ip dhcp-server lease find address="$IpRoot$i"] != "") do={
    :put "$IpRoot$i"
  }
}
-Louis
by Letni
Fri Sep 19, 2008 2:24 pm
Forum: Scripting
Topic: Ping script
Replies: 3
Views: 4646

Re: Ping script

What you are looking for is Netwatch
http://www.mikrotik.com/testdocs/ros/2. ... ontent.php

-Louis
by Letni
Fri Sep 19, 2008 4:01 am
Forum: Scripting
Topic: filtering leases by print (DHCP-SERVER)
Replies: 6
Views: 1007

Re: filtering leases by print (DHCP-SERVER)

You do not specify how you want them returned? E-mail / In log.

-Louis
by Letni
Fri Sep 19, 2008 2:58 am
Forum: Scripting
Topic: filtering leases by print (DHCP-SERVER)
Replies: 6
Views: 1007

Re: filtering leases by print (DHCP-SERVER)

This should get you started if it doesn't do all of what you want.

http://forum.mikrotik.com/viewtopic.php?f=9&t=19389

-Louis
by Letni
Sun Sep 14, 2008 12:31 am
Forum: Beginner Basics
Topic: MT 3.13 & AnitPortScan & RB112
Replies: 2
Views: 686

Re: MT 3.13 & AnitPortScan & RB112

First
Change your action to add-src-to-address-list.

Second
Is the CPU being maxed out?
I have heard disabling/uninstalling unneeded packages may help with your speed issue.

-Louis
by Letni
Tue Sep 09, 2008 3:07 pm
Forum: General
Topic: SIP one way audio issues
Replies: 3
Views: 1814

Re: SIP one way audio issues

A simple search turns this up.
http://forum.mikrotik.com/viewtopic.php?f=2&t=17400

-Louis
by Letni
Sun Sep 07, 2008 5:08 am
Forum: General
Topic: Long day - Need help
Replies: 2
Views: 653

Re: Long day - Need help

Some things to try.
Upgrade to the latest RouterOS. Currently 3.13 http://www.mikrotik.com/download.html
Upgrade the firmware. Currently 2.16
/system routerboard upgrade
Try a port other than ether1 for your internet uplink.

Hope it helps.
-Louis
by Letni
Sun Sep 07, 2008 1:20 am
Forum: Scripting
Topic: how to do :foreach in 3.x
Replies: 3
Views: 3505

Re: how to do :foreach in 3.x

:set hostcomp [:toarray comp1,comp2,comp3,comp4]

-Louis
by Letni
Sun Aug 31, 2008 1:14 am
Forum: General
Topic: ROS 3.13 cannot store settings in simple queues
Replies: 3
Views: 790

Re: ROS 3.13 cannot store settings in simple queues

Please verify that you are using the latest version of winbox. It can downloaded from here. http://www.mikrotik.com/download.html

Also, when connecting with winbox, make sure the "Load Previous Session" box is checked.

-Louis
by Letni
Mon Aug 25, 2008 2:24 am
Forum: Wireless Networking
Topic: Where to buy supperchannel
Replies: 2
Views: 999

Re: Where to buy supperchannel

You will need to contact who ever sold you the RouterOS license.

If the RouterOS came pre-installed on your Router Board then you will need to contact who ever sold you the Router Board.

-Louis
by Letni
Sun Aug 24, 2008 11:50 pm
Forum: Scripting
Topic: Please can anybody make script?
Replies: 3
Views: 1109

Re: Please can anybody make script?

If you could please give more detail and when you would use such a script.

-Louis
by Letni
Tue Jun 10, 2008 3:21 am
Forum: Scripting
Topic: Problem with DNS update script on 2.9.51
Replies: 6
Views: 1895

Re: Problem with DNS update script on 2.9.51

Do you have primary and secondary DNS server specified in your MT?

From CLI can you resolve domains?
by Letni
Sat Jun 07, 2008 8:19 pm
Forum: Scripting
Topic: Scripts to remove customers who have with H in Flags of hots
Replies: 12
Views: 3470

Re: Scripts to remove customers who have with H in Flags of hots

Try something like this for v2
/ip hotspot host remove [/ip hotspot host find DHCP=yes authorized=no]
by Letni
Sat Jun 07, 2008 7:21 pm
Forum: RouterBOARD hardware
Topic: RB 600 wtih CF
Replies: 1
Views: 845

Re: RB 600 wtih CF

Try connecting to it via serial cable and see what error you get. You may need to adjust what the boot device is in the BIOS.
by Letni
Sat Jun 07, 2008 7:15 pm
Forum: Scripting
Topic: Scripts to remove customers who have with H in Flags of hots
Replies: 12
Views: 3470

Re: Scripts to remove customers who have with H in Flags of hots

Which version are you using. I am on v3.9
by Letni
Sat Jun 07, 2008 6:59 pm
Forum: Scripting
Topic: Scripts to remove customers who have with H in Flags of hots
Replies: 12
Views: 3470

Re: Scripts to remove customers who have with H in Flags of hots

Try with just the DCHP and !AUTHORIZED arguments.
by Letni
Sat Jun 07, 2008 6:56 pm
Forum: Scripting
Topic: Upload script on multimple RB's as file
Replies: 2
Views: 1373

Re: Upload script on multimple RB's as file

There is an auto execute for ftp'd scripts. Check out the MT newsletter.
http://www.mikrotik.com/download/Mikrotik_no002.pdf
by Letni
Sat Jun 07, 2008 6:49 pm
Forum: RouterBOARD hardware
Topic: RB 150, bandwith questions
Replies: 6
Views: 1563

Re: RB 150, bandwith questions

You need more speed on your bridged ports? If true then this has already been discussed
http://forum.mikrotik.com/viewtopic.php?f=1&t=18695
by Letni
Sat Jun 07, 2008 6:39 pm
Forum: Wireless Networking
Topic: Bridging Wireless Interfaces - Help!
Replies: 2
Views: 961

Re: Bridging Wireless Interfaces - Help!

This was a good resource when I first started out. It should help you as well.
http://www.wi-pipe.com/userfiles/File/D ... 0Setup.pdf

Also take a look around the wiki for more examples.
http://wiki.mikrotik.com
by Letni
Sat Jun 07, 2008 6:19 pm
Forum: Scripting
Topic: Scripts to remove customers who have with H in Flags of hots
Replies: 12
Views: 3470

Re: Scripts to remove customers who have with H in Flags of hots

Try this then
/ip hotspot host remove [/ip hotspot host find DHCP !STATIC !DYNAMIC !AUTHORIZED !BYPASSED]
by Letni
Sat Jun 07, 2008 6:48 am
Forum: Scripting
Topic: Scripts to remove customers who have with H in Flags of hots
Replies: 12
Views: 3470

Re: Scripts to remove customers who have with H in Flags of hots

I believe you want something like this
/ip hotspot host remove [/ip hotspot host find DHCP]
by Letni
Fri May 16, 2008 6:01 am
Forum: Scripting
Topic: script to save logs and send via email
Replies: 27
Views: 25901

Re: script to save logs and send via email

Modify this line :set body ("$body\r\n" . [/log get $int]) to :set body ("$body\r\n" . [/log get $int message]) I have a 153 at my house with v3.9. When I ran my original script my CPU went to 100%, then the routerboard would reboot after a couple of seconds. Modifying it with the message option see...
by Letni
Tue May 13, 2008 3:05 am
Forum: Beginner Basics
Topic: MAC Redirection
Replies: 3
Views: 1076

Re: MAC Redirection

I have thought about using this option with the Canopy Translation Bridging. This way it doesn't matter if the customer changes mac and gets a new IP. Then on the NAT list do a dst-nat and specify the src-mac-address and redirect them to the IP address of the web server running the I am sending Guid...
by Letni
Mon May 12, 2008 3:36 am
Forum: RouterBOARD hardware
Topic: RB411 restart
Replies: 7
Views: 1766

Re: RB411 restart

According to the manual

http://www.routerboard.com/pdf/rb411ugA.pdf

NOTE: that RB411 currently does not support Senao 8602 cards, Atheros
AR5211 or older chipset and Prism chipset based cards.

There was a thread where someone was using an older card and it was rebooting on them.

-Louis
by Letni
Mon May 12, 2008 2:50 am
Forum: Scripting
Topic: Broken script since 2.9 to 3.9 upgrade
Replies: 5
Views: 1000

Re: Broken script since 2.9 to 3.9 upgrade

is your 0.0.0.0/0 route dynamic or static?

Do you get an error message when you try to change it from CLI?

You can only set/edit static routes.

-Louis
by Letni
Sun May 11, 2008 9:21 pm
Forum: Scripting
Topic: Broken script since 2.9 to 3.9 upgrade
Replies: 5
Views: 1000

Re: Broken script since 2.9 to 3.9 upgrade

Try something like this
/ip route set [/ip route find dst-address="0.0.0.0/0"] gateway="192.168.15.254"

-Louis
by Letni
Fri May 09, 2008 5:02 pm
Forum: RouterBOARD hardware
Topic: RB150 firmware upgrade problem
Replies: 8
Views: 3122

Re: RB150 firmware upgrade problem

Could the reset button be stuck?

What do you get for
/system routerboard print

-Louis
by Letni
Thu May 08, 2008 2:25 pm
Forum: Beginner Basics
Topic: how to block a multiple connection to a specific dst address
Replies: 4
Views: 1130

Re: how to block a multiple connection to a specific dst address

That rule is for every client to be able to make one connection. That is what the 32 stands for.

-Louis
by Letni
Thu May 08, 2008 6:00 am
Forum: Wireless Networking
Topic: Lowest Tx Power setting?
Replies: 4
Views: 1209

Re: Lowest Tx Power setting?

Possibly down to -30 according to CLI.
TxPower ::= [-]Num
Num ::= -30..30 (integer number)
YMMV, play with it and let us know.

-Louis
by Letni
Thu May 08, 2008 5:50 am
Forum: Wireless Networking
Topic: Help fine-tuning XR2 TxPower
Replies: 6
Views: 1499

Re: Help fine-tuning XR2 TxPower

The XR2 has a 10db offset in MT. Here is the link to show you
http://ubnt.com/downloads/ubi_mtik_power.pdf

To get the desired 20 db output you would want to set it to 10 db.

-Louis
by Letni
Thu May 08, 2008 5:38 am
Forum: Wireless Networking
Topic: Wireless and DNS / Name resolution
Replies: 7
Views: 1171

Re: Wireless and DNS / Name resolution

What are you trying to accomplish with your firewall and why do you not think it will work?

-Louis
by Letni
Thu May 08, 2008 2:38 am
Forum: Beginner Basics
Topic: Booting up Problem
Replies: 9
Views: 1042

Re: Booting up Problem

Does your new machine have sata ports? Try turning them off in the BIOS.

-Louis
by Letni
Thu May 08, 2008 2:37 am
Forum: RouterBOARD hardware
Topic: upgrading firmware on RB 133C3
Replies: 2
Views: 2156

Re: upgrading firmware on RB 133C3

You should reload a version of MT OS that worked previously. Once loaded you can then ftp up the fwf and flash the firmware.

-Louis
by Letni
Thu May 08, 2008 2:34 am
Forum: RouterBOARD hardware
Topic: How do I detect platform?
Replies: 8
Views: 1301

Re: How do I detect platform?

/system resource get cpu

-Louis
by Letni
Thu May 08, 2008 2:30 am
Forum: Beginner Basics
Topic: Booting up Problem
Replies: 9
Views: 1042

Re: Booting up Problem

Does your BIOS specify booting to the HD?
What version are you trying to install(Have you tried a different version?)?
What type of HD(IDE/SATA)?

If you are doing it just for testing I would suggesting a Virtual machine like VMWare.

-Louis
by Letni
Thu May 08, 2008 2:27 am
Forum: Scripting
Topic: Auto Run Script
Replies: 1
Views: 1851

Re: Auto Run Script

You can use the scheduler to run scripts automatically.

-Louis
by Letni
Thu May 08, 2008 2:21 am
Forum: Wireless Networking
Topic: Wireless and DNS / Name resolution
Replies: 7
Views: 1171

Re: Wireless and DNS / Name resolution

Create a bridge interface and then add your ethernet and wireless interfaces you want bridged. Check your config to make sure you will not have 2 DHCP servers running on the same lan. I just found this on the net, it should help you. http://www.wi-pipe.com/userfiles/File/Database/MikroTik%20AP%20Set...
by Letni
Thu May 08, 2008 2:09 am
Forum: Beginner Basics
Topic: how to block a multiple connection to a specific dst address
Replies: 4
Views: 1130

Re: how to block a multiple connection to a specific dst address

This rule would only allow one TCP connection at a time to IP 1.2.3.4. It would be nice to do this for UDP but MT does not support it. UDP needs to be controlled by queues. /ip firewall filter add action=drop chain=forward comment="Only allow 1 connection to 1.2.3.4" connection-limit=1,32 disabled=n...
by Letni
Tue May 06, 2008 1:59 pm
Forum: Beginner Basics
Topic: Gateway Failover with Ping
Replies: 6
Views: 1771

Re: Gateway Failover with Ping

I believe the equivalent to your example is (Tested on v3.7)
:local test [/ping [:resolve www.yahoo.com] count="2" interface="ether1"]
:if ($test = 0) do={:log info "No connectivity on ether1"}

-Louis
by Letni
Tue May 06, 2008 5:56 am
Forum: Beginner Basics
Topic: Gateway Failover with Ping
Replies: 6
Views: 1771

Re: Gateway Failover with Ping

You will want to try something along these lines
http://wiki.mikrotik.com/wiki/ECMP_Failover_Script

The only thing I see missing in the wiki for your situation is to specify an interface when doing the ping tests.

-Louis
by Letni
Mon May 05, 2008 5:34 am
Forum: Scripting
Topic: [CONTRIB] DHCP Pool usage
Replies: 6
Views: 4253

Re: [CONTRIB] DHCP Pool usage

Thank you for noticing that hilton. Here is my revised script that fixes that issue as well as adds the ability to use the script when running multiple dhcp servers. Tested on v3.7 # WarnAt needs to be at what percentage you want to be warned you are running out of IP addresses. :local WarnAt 10 #Na...
by Letni
Sun Apr 06, 2008 7:08 am
Forum: Scripting
Topic: Variable Variable... But.. In Mikrotik..??
Replies: 2
Views: 979

Re: Variable Variable... But.. In Mikrotik..??

When you initialize the variable you can set it in one shot.
ex:
:local a "Hello"

Then if later in the script you want to change the value of a you use set.
:set a "What's Up"

Demo (Tested on V3.6)
:local a "Hello"
:log info "a is: $a"
:set a "What's Up"
:log info "a is: $a"
-Louis
by Letni
Sun Mar 30, 2008 6:08 pm
Forum: Scripting
Topic: Problem with local variable in console (v3.6)
Replies: 3
Views: 1130

Re: Problem with local variable in console (v3.6)

[admin@Louis] > {
{... :local test 1
{... :if ($test=1) do={:set test 2; :put $test}
{... :put $test                                
{... }         
2
2
-Louis
by Letni
Tue Mar 25, 2008 7:32 am
Forum: Scripting
Topic: Basic Script Loop Question
Replies: 3
Views: 5967

Re: Basic Script Loop Question

V3.4 had some scripting bugs so you should upgrade to 3.6.

Also one major change in V3 is you need to have quotes around your values. So change max-limit=32000/64000 to max-limit="32000/64000" and try again.

-Louis
by Letni
Thu Mar 20, 2008 4:00 am
Forum: Beginner Basics
Topic: Forwarding Port 80 to Web Server
Replies: 10
Views: 19449

Re: Forwarding Port 80 to Web Server

1 X chain=dstnat in-interface=internet1 dst-address=67.143.224.198
protocol=tcp dst-port=80 action=dst-nat to-addresses=192.168.0.1
to-ports=0-65535
change to-ports=80 and enable this rule.

-Louis
by Letni
Tue Mar 18, 2008 12:12 pm
Forum: General
Topic: Forwarding port 80 to local web server
Replies: 7
Views: 1407

Re: Forwarding port 80 to local web server

try modifying to-ports=0-65535 to to-ports=80

-Louis
by Letni
Tue Mar 18, 2008 2:00 am
Forum: Wireless Networking
Topic: RB133c Wireless CPE Auth problem
Replies: 5
Views: 3353

Re: RB133c Wireless CPE Auth problem

Thank your for posting this. Helped me diagnose a bad XR5 I received recently.

-Louis
by Letni
Mon Mar 17, 2008 1:15 am
Forum: Scripting
Topic: CLI Local Variables V3
Replies: 2
Views: 1189

Re: CLI Local Variables V3

Thank you mrz for clearing that up.
Looks like there are a couple of things to still figure out from the transition from 2.9.

-Louis
by Letni
Sun Mar 16, 2008 7:30 pm
Forum: Scripting
Topic: Scripts - 3.4 - MT support
Replies: 7
Views: 1464

Re: Scripts - 3.4 - MT support

Here Here! Someone buy these gentlemen a beer.
Where did I put that baseball bat... :lol:

-Louis
by Letni
Sun Mar 16, 2008 7:24 pm
Forum: Scripting
Topic: Problem with enable ARP Script ROS 3.4
Replies: 3
Views: 842

Re: Problem with enable ARP Script ROS 3.4

You need to putt " around your values.
example:
disabled="no"

Make this change to your script and try again.

-Louis
by Letni
Sun Mar 16, 2008 7:15 pm
Forum: Scripting
Topic: bandwith qos is 2.9.x ok,but is 3.4 not work,please help me!
Replies: 1
Views: 925

Re: bandwith qos is 2.9.x ok,but is 3.4 not work,please help me!

. style concatenation is broken in 3.4
Try this
:for aaa from 2 to 254 do={
/queue simple add name="queue$aaa" dst-address="192.168.0.$aaa" limit-at="0/0" max-limit="1000000/2000000"
}
-Louis
by Letni
Sun Mar 16, 2008 7:08 pm
Forum: Scripting
Topic: 3.4 scripting, any changes????
Replies: 9
Views: 1905

Re: 3.4 scripting, any changes????

After doing some testing I found that netwatch does _not_ have access to the global variables even if you declare them at the beginning of the script. This would appear to be a bug, you should e-mail support@mikrotik.com with your issue. I also worked out a workaround for you until they get that fix...
by Letni
Sun Mar 16, 2008 3:20 am
Forum: Scripting
Topic: 3.4 scripting, any changes????
Replies: 9
Views: 1905

Re: 3.4 scripting, any changes????

I just tested this on v3.4 in both CLI and script with success. /tool e-mail send server="xx.xx.xx.xx" to="me@mydomain.com" from="me@mydomain.com" subject="ip address changed" body=[/ip address get [/ip address find interface="ether1"] address] I would also like to add that V3.4 has several scriptin...
by Letni
Sat Mar 15, 2008 10:45 pm
Forum: Scripting
Topic: 3.4 scripting, any changes????
Replies: 9
Views: 1905

Re: 3.4 scripting, any changes????

For RouterOS v3 you need to declare any variables before you use them in the script. Otherwise the script will not be aware of them.

-Louis
by Letni
Sat Mar 15, 2008 9:37 pm
Forum: General
Topic: Router OS 3.4 and PPPoE Problem
Replies: 7
Views: 1221

Re: Router OS 3.4 and PPPoE Problem

by Letni
Sat Mar 15, 2008 8:50 pm
Forum: Scripting
Topic: I need a script changeip for mikrotik 3.4 please
Replies: 3
Views: 1092

Re: I need a script changeip for mikrotik 3.4 please

To prevent the error message you need to use " around your values. However there still appears to be a larger bug. When adding the active option it does not return the proper results. [admin@Louis] /ip route> print Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - b...
by Letni
Sat Mar 15, 2008 8:38 pm
Forum: Scripting
Topic: 3.4 scripting, any changes????
Replies: 9
Views: 1905

Re: 3.4 scripting, any changes????

You need to redefine it to access the variable from the script.

Make your script look like this.
#Links to global variable and make the variable usable in the script
:global sw

#Sets the variable sw to 1
:set sw 1
Then recheck in CLI. It works successfully for me.

-Louis
by Letni
Sat Mar 15, 2008 6:36 pm
Forum: Scripting
Topic: CLI Local Variables V3
Replies: 2
Views: 1189

CLI Local Variables V3

Declaring local variables from CLI is broken. I have tested this with V3.0 up to 3.4 with the same results. /system script add name="Variables" policy=ftp,reboot,read,write,policy,test,winbox,password,sniff source=" :global global YES :local local YES :put "global is: $global" :put "local is: $local...
by Letni
Sat Mar 15, 2008 5:54 pm
Forum: Scripting
Topic: Hot to check if variable is defined
Replies: 1
Views: 1085

Re: Hot to check if variable is defined

You must declare all variables before you use them in V3.

This will make the global variable called my_variable available to the script.
:global "my_variable"
-Louis
by Letni
Sat Mar 15, 2008 12:31 am
Forum: RouterBOARD hardware
Topic: RB600 Serial Cable issue
Replies: 2
Views: 1121

Re: RB600 Serial Cable issue

I have had this issue with several MT boards. The solution for me is:
/port set serial0 flow-control=none
Then all works as expected.
-Louis
by Letni
Fri Mar 14, 2008 1:31 pm
Forum: Wireless Networking
Topic: any one have this kind of experience?
Replies: 5
Views: 1155

Re: any one have this kind of experience?

Can you successfully do a netinstall?
Could there be a BootP server hijacking the boot up? You may want to set the nand as the first boot device instead of the network card after you have completed the netinstall.

-Louis
by Letni
Fri Mar 14, 2008 4:42 am
Forum: RouterBOARD hardware
Topic: rb600 make reboot every day
Replies: 106
Views: 17701

Re: rb600 make reboot every day

I just reported one of my RB600 came in with a DOA POE. The board worked with DC jack.. but this board was destined for the top of a tower.

Now the hassle of RMA. *sigh*
-Louis
by Letni
Fri Mar 14, 2008 3:09 am
Forum: Wireless Networking
Topic: any one have this kind of experience?
Replies: 5
Views: 1155

Re: any one have this kind of experience?

Have you tried formating the nand first? The BIOS should have an option to do this. Then try a netinstall again. Also it may be wise to do a memtest (m)... which I think is also included in the BIOS.

-Louis
by Letni
Fri Mar 14, 2008 1:01 am
Forum: Beginner Basics
Topic: Getting Signal Strength over ENET
Replies: 5
Views: 1169

Re: Getting Signal Strength over ENET

You should be able to retrieve the the values you want through SNMP.

-Louis
by Letni
Fri Mar 14, 2008 12:57 am
Forum: Beginner Basics
Topic: how can I use to use a stable Mikrotik version: 2.9.x
Replies: 1
Views: 805

Re: how can I use to use a stable Mikrotik version: 2.9.x

RouterOS 2.9.x does not support the RB333 hardware.
You will need to use v3 or newer.

-Louis
by Letni
Fri Mar 14, 2008 12:47 am
Forum: General
Topic: btest suggestions
Replies: 0
Views: 1042

btest suggestions

Can we get btest application to also show an average bandwidth as well as PPS plus PPS average.

-Louis
by Letni
Thu Mar 13, 2008 2:12 pm
Forum: Scripting
Topic: script change
Replies: 6
Views: 1155

Re: script change

I am running 3.4 at my house.
I tested this snippet of code and it works as expected.
:local address 10.20.30.40
/ip firewall nat remove [/ip firewall nat find src-address="$address"]
You may want to double check your script again or post it to have it reviewed.

-Louis
by Letni
Thu Mar 13, 2008 6:05 am
Forum: Scripting
Topic: script change
Replies: 6
Views: 1155

Re: script change

MT has not confirmed it yet, but general consensus is that they introduced some bugs in scripting with 3.4. If you rely on scripting I would recommend rolling back to 3.3 until 3.5 comes out.

-Louis
by Letni
Thu Mar 13, 2008 6:02 am
Forum: Wireless Networking
Topic: with money as no object, I need a real MT backhaul solution
Replies: 42
Views: 7722

Re: with money as no object, I need a real MT backhaul solution

I am getting really excited to put together a RB600 and an Ubiquity SR71-5 with Dual polarity PTP dishes. Wish April would hurry up and get here for Ubiquity to release the card. Here's to hoping MT is on top of this. Especially since they were sporting a 802.11n MIMO card at MUM in FL last year. ;)...
by Letni
Thu Mar 13, 2008 5:55 am
Forum: Beginner Basics
Topic: IP Firewall Filter basic question
Replies: 9
Views: 2340

Re: IP Firewall Filter basic question

Even though it is connectionless, RouterOS putts an entry in the firewall connection table. IP --> Firewall: Connections
The timeout settings for UDP is through the Tracking button.

-Louis
by Letni
Thu Mar 13, 2008 4:15 am
Forum: Beginner Basics
Topic: IP Firewall Filter basic question
Replies: 9
Views: 2340

Re: IP Firewall Filter basic question

Try something along these lines. /ip firewall filter add chain=forward action=accept connection-state=established dst-address=208.208.208.208 comment="Accept Established" disabled=no add chain=forward action=accept dst-port=25 protocol=tcp comment="Allow SMTP" disabled=no add chain=forward action=lo...
by Letni
Mon Mar 10, 2008 12:53 am
Forum: Beginner Basics
Topic: Web-Proxy Max-object-zise
Replies: 8
Views: 1457

Re: Web-Proxy Max-object-zise

Follow the instructions on the link I posted for you. Look up.. You even quoted me with it. :)

-Louis
by Letni
Mon Mar 10, 2008 12:50 am
Forum: General
Topic: How does the L4 limitation work?
Replies: 11
Views: 1603

Re: How does the L4 limitation work?

The company started out 8 years ago as a dial-up provider. So we have all the software and servers in place for authentication. We currently do _not_ use PPPoE for auth on our wireless network but if I had it to do all over again I would have started with it. Why? * I am totally capable of developin...
by Letni
Mon Mar 10, 2008 12:24 am
Forum: Beginner Basics
Topic: how can I upgrade it?
Replies: 9
Views: 16800

Re: how can I upgrade it?

The BIOS Firmware is rolled in with the RouterOS upgrades. You can check what version is installed and what version is ready to be programmed with /system routerboard print To flash the new firmware if it is newer than the one you are using /system routerboard upgrade and of course a reboot will the...
by Letni
Sun Mar 09, 2008 10:27 pm
Forum: General
Topic: The Most powerfull hardware you tried with Mikrotik v2.9.X
Replies: 7
Views: 1130

Re: The Most powerfull hardware you tried with Mikrotik v2.9.X

I know this one will work. http://www.supermicro.com/products/syst ... 5M-MF+.cfm
We purchased a Xeon 3Ghz and RB44GV as well. This system has been very stable with 2.9. I am planning on purchasing a backup router and testing V3 on it soon.

-Louis
by Letni
Sun Mar 09, 2008 10:13 pm
Forum: Beginner Basics
Topic: how can I upgrade it?
Replies: 9
Views: 16800

Re: how can I upgrade it?

The command to upgrade after uploading the file is:..............
/system reboot
You may want to have a look at the documentation to become more familiar with RouterOS
http://www.mikrotik.com/documentation.html

-Louis
by Letni
Sun Mar 09, 2008 10:09 pm
Forum: General
Topic: How does the L4 limitation work?
Replies: 11
Views: 1603

Re: How does the L4 limitation work?

We are in the situation to try and make things automated. Right now the bosses don't like that they have to hand me a list of ~20 or so customers to redirect them to notify them they are overdue. OK, that´s an argument. But is it not a bit complicated? If one of my customers not pays I just stop tra...
by Letni
Sun Mar 09, 2008 8:29 pm
Forum: General
Topic: How does the L4 limitation work?
Replies: 11
Views: 1603

Re: How does the L4 limitation work?

The advantage of PPPoE is being able to authenticate you customers. This makes it easy to cut someone off when they do not pay there bill.

-Louis
by Letni
Sun Mar 09, 2008 8:19 pm
Forum: Wireless Networking
Topic: Bridge in station mode
Replies: 13
Views: 2341

Re: Bridge in station mode

I can not recall the exact details but I think 802.11 does not support bridged networking only routed networking. That is why WDS was created, to allow bridged networks like you wanted. V3 added support for bridge without wds(station-pseudobridge). I have not tested this yet but plan to in the near ...
by Letni
Sun Mar 09, 2008 7:56 pm
Forum: Beginner Basics
Topic: Web-Proxy Max-object-zise
Replies: 8
Views: 1457

Re: Web-Proxy Max-object-zise

By default the proxy will cache everything it can including all those file types you mentioned. You will need to complete the first 3 sections. The rest is optional.

-Louis
by Letni
Sun Mar 09, 2008 11:53 am
Forum: General
Topic: connection limit on a port
Replies: 5
Views: 894

Re: connection limit on a port

/ip firewall filter add action=drop chain=forward comment="" connection-limit=13,32 disabled=no dst-port=411 protocol=tcp src-address=10.100.10.16 tcp-flags=syn

-Louis
by Letni
Sun Mar 09, 2008 10:48 am
Forum: Beginner Basics
Topic: Web-Proxy Max-object-zise
Replies: 8
Views: 1457

Re: Web-Proxy Max-object-zise

This will show you what you need to have plus a bit more if you want to block some content.
http://wiki.mikrotik.com/wiki/How_to_Bl ... sing_Proxy

-Louis
by Letni
Sun Mar 09, 2008 10:23 am
Forum: Beginner Basics
Topic: Couldn't do WAN Port
Replies: 27
Views: 2135

Re: Couldn't do WAN Port

I would suggest using the DHCP client so that you do not have to worry about mistypings.

If you need more help, you will need to be more specific on what you can not do and what tests you have done to diagnose the issue. ex. Your config, ping results, etc.

-Louis
by Letni
Sun Mar 09, 2008 10:18 am
Forum: Scripting
Topic: FTP Monitoring script
Replies: 1
Views: 892

Re: FTP Monitoring script

It can be done. Here is an outline /ip firewall mangle chain=prerouting action=add-src-to-address-list address-list=FTPList address-list-timeout=0s layer7-protocol=ftp time=0s-6h,sun,mon,tue,wed,thu,fri,sat Create a script that parses the FTPList and post the IP's using the fetch tool and finally de...
by Letni
Sun Mar 09, 2008 9:58 am
Forum: Beginner Basics
Topic: Mapping ip's
Replies: 2
Views: 964

Re: Mapping ip's

Just put your proxy rule before your 1:1 mappings.

-Louis
by Letni
Sun Mar 09, 2008 9:50 am
Forum: The Dude
Topic: Problem with oid_raw function in 3.0b7
Replies: 2
Views: 1326

Re: Problem with oid_raw function in 3.0b7

Upgrade to v3.3 and let us know if you are still having issues.

-Louis
by Letni
Sun Mar 09, 2008 9:47 am
Forum: Scripting
Topic: backup a PPP client connection
Replies: 2
Views: 1004

Re: backup a PPP client connection

I would recommend using the netwatch tool.
You can put in the IP address of the remote primary VPN server to watch. Then on down you would enable the backup and disable the primary and on up you would disable the backup and enable the primary.

-Louis
by Letni
Sun Mar 09, 2008 9:41 am
Forum: Scripting
Topic: FUP script
Replies: 3
Views: 2549

Re: FUP script

V3.4 introduced a scripting bug.
http://forum.mikrotik.com/viewtopic.php?f=9&t=22362

-Louis
by Letni
Sun Mar 09, 2008 9:39 am
Forum: General
Topic: Existing OID's for SNMP poll ?
Replies: 2
Views: 579

Re: Existing OID's for SNMP poll ?

To find out what OID's are available..
/interface print oid

-Louis
by Letni
Sun Mar 09, 2008 9:36 am
Forum: Beginner Basics
Topic: Couldn't do WAN Port
Replies: 27
Views: 2135

Re: Couldn't do WAN Port

Does your ISP require PPPoE authentication?
http://wiki.mikrotik.com/wiki/How_to_Co ... _xDSL_Line

Or do you just need to setup DHCP Client?
/ip dhcp-client add interface=ether1 disabled=no

-Louis
  • 1
  • 2