Community discussions

Search found 28 matches

by brixo
Mon Nov 12, 2018 4:27 pm
Forum: General
Topic: AWS CHR - "userdata" script on first boot
Replies: 2
Views: 406

Re: AWS CHR - "userdata" script on first boot

Shameless bump!!

I have looked all over the internet for direction, but nothing!
by brixo
Sat Nov 10, 2018 12:18 am
Forum: General
Topic: AWS CHR - "userdata" script on first boot
Replies: 2
Views: 406

AWS CHR - "userdata" script on first boot

I have seen the feature in the release notes to "run startup scripts on the first boot on AWS and Google Cloud installations", however, I cannot find instructions on how to do this. I have various CHR in AWS and would like to fully automate them using AWS CloudFormation or similar, and would like to...
by brixo
Mon Apr 23, 2018 4:50 pm
Forum: General
Topic: GRE/IPIP inside a VRF
Replies: 1
Views: 410

GRE/IPIP inside a VRF

Hi all, I have a MIK and Cisco device that have IP connectivity between them. I have a GRE tunnel configured between them and they have full connectivity on the outside and inside the tunnels. Everything pings fine. On the MIK end, I need the GRE tunnel to be inside a VRF as I am expecting lots of o...
by brixo
Mon Apr 23, 2018 4:36 pm
Forum: Beginner Basics
Topic: IPIP tunnel in VRF
Replies: 1
Views: 602

Re: IPIP tunnel in VRF

I am having the very same issue. GRE in the "main" routing table works fine. When I put the main interface and the GRE interface into the VRF, everything drops.

Is there something with pre-routing or post-routing to kick this into life?

Thanks.
by brixo
Tue Dec 05, 2017 4:28 pm
Forum: General
Topic: CRS317-1G-16S+ v6.41rc56 - adding vlan switch issue
Replies: 6
Views: 1444

Re: CRS317-1G-16S+ v6.41rc56 - adding vlan switch issue

Well, that seems to have worked. More importantly, the interfaces are using HW-OFFLOAD which was the reason for me moving to the RC. Still, I am confused about similar (if not same) configurations in both SWITCH and BRIDGE with regards to VLAN and PORTS/INTERFACES. Surely I am not the only one confu...
by brixo
Tue Dec 05, 2017 3:45 pm
Forum: General
Topic: CRS317-1G-16S+ v6.41rc56 - adding vlan switch issue
Replies: 6
Views: 1444

Re: CRS317-1G-16S+ v6.41rc56 - adding vlan switch issue

Aha. Thanks very much. I shall give this a go after backing everything up and reverting to ROS. ROS seems very powerful for L3, but complex (too complex for simple tasks) for L2. Saying that, I am only comparing to many years of Cisco where the configuration takes care of a lot under the hood! Will ...
by brixo
Tue Dec 05, 2017 3:39 pm
Forum: General
Topic: CRS317-1G-16S+ v6.41rc56 - adding vlan switch issue
Replies: 6
Views: 1444

Re: CRS317-1G-16S+ v6.41rc56 - adding vlan switch issue

Aha. Thanks very much. I shall give this a go after backing everything up and reverting to ROS. ROS seems very powerful for L3, but complex (too complex for simple tasks) for L2. Saying that, I am only comparing to many years of Cisco where the configuration takes care of a lot under the hood! Will ...
by brixo
Tue Dec 05, 2017 2:47 pm
Forum: General
Topic: CRS317-1G-16S+ v6.41rc56 - adding vlan switch issue
Replies: 6
Views: 1444

Re: CRS317-1G-16S+ v6.41rc56 - adding vlan switch issue

Thanks for the reply. I have read those particular documents several times which has helped me get this far with L2 on the CRS317. However, there is nothing that jumps out at me that says that I would not be able to add a new VLAN to specific ports on the RC. Is there something in particular you can...
by brixo
Tue Dec 05, 2017 1:54 pm
Forum: General
Topic: v6.41rc56 - where has the LCD config gone?!
Replies: 0
Views: 364

v6.41rc56 - where has the LCD config gone?!

Hi all,

Testing out v6.41rc56 for L2 capabilities, but need to turn the LCD off (as per our standards and all other Mik devices), but seems to have disappeared!

Any ideas on how to disable the LCD in this version?

Thanks.
by brixo
Tue Dec 05, 2017 1:35 pm
Forum: General
Topic: CRS317-1G-16S+ v6.41rc56 - adding vlan switch issue
Replies: 6
Views: 1444

CRS317-1G-16S+ v6.41rc56 - adding vlan switch issue

Running a CRS317-1G-16S+ just doing simple L2 VLAN trunking. Having issues with adding VLANs to interfaces (only trunks). I cannot add new VLANs to interfaces. The only way I managed to get the first lot (101-504) working was to cut/paste the config in the "stable" version, then change to the RC. Th...
by brixo
Wed Nov 22, 2017 2:14 pm
Forum: General
Topic: Open/Scannable Ports (slight concern)
Replies: 5
Views: 553

Re: Open/Scannable Ports (slight concern)

Permit. Just moved all of my intended rules to the INPUT chain and everything works fine... (a) doesn't show in a port scan and (b) didn't kill BGP and lock myself out of the router!!

Many thanks, Neil
by brixo
Wed Nov 22, 2017 1:46 pm
Forum: General
Topic: Open/Scannable Ports (slight concern)
Replies: 5
Views: 553

Re: Open/Scannable Ports (slight concern)

The IMPLICIT_DENY is on the FORWARD chain.

I am thinking (after reading the documentation a few times), that I need add these DENY rules to the INPUT chain as this is targeting and IP *on* the router itself. Is this correct?
by brixo
Wed Nov 22, 2017 1:10 pm
Forum: General
Topic: Open/Scannable Ports (slight concern)
Replies: 5
Views: 553

Open/Scannable Ports (slight concern)

I am a little concerned/confused by results from a simple port scan on my internet facing ROS box. I have firewall rules "dropping" pretty much everything but I can still see the following when doing a portscan (nmap -sS xx.xx.xx.xx) and there is nothing showing up on my IMPLICIT_DENY firewall rule ...
by brixo
Wed Nov 22, 2017 1:04 pm
Forum: RouterBOARD hardware
Topic: SWOS 2.6 (CRS) and 10G
Replies: 1
Views: 561

Re: SWOS 2.6 (CRS) and 10G

Unashamed BUMP here.

Any update? I understand other people are having the same issue.
by brixo
Wed Nov 22, 2017 1:02 pm
Forum: Beginner Basics
Topic: CRS317 - want SwOS, but won't boot
Replies: 17
Views: 3073

Re: CRS317 - want SwOS, but won't boot

Glad I am not going crazy!

I have had to settle for 1G as I needed to install it quickly and didn't have time to boot into RouterOS and explore the minefield of doing L2 on it! Not ideal and a bit disappointing.
by brixo
Wed Nov 01, 2017 5:12 pm
Forum: RouterBOARD hardware
Topic: SWOS 2.6 (CRS) and 10G
Replies: 1
Views: 561

SWOS 2.6 (CRS) and 10G

Hi all, Just recently started to use Mik gear. I bought them purely for the 10G capability. If I run my CRS in ROS, I can hard fix to 10G no problem. If I boot in SWOS (which I want as it seems infinitely easier if you only want L2 capability), it will not do 10G - either with or without auto-neg. T...
by brixo
Wed Nov 01, 2017 5:10 pm
Forum: RouterBOARD hardware
Topic: MikroTik SFP+ DAC 1m cable - does it support 10G?
Replies: 19
Views: 4501

Re: MikroTik SFP+ DAC 1m cable - does it support 10G?

Hi all, Just recently started to use Mik gear. I bought them purely for the 10G capability and am seeing this very same issues. If I run my CRS in ROS, I can hard fix to 10G no problem. If I boot in SWOS (which I want as it seems infinitely easier if you only want L2 capability), it will not do 10G ...
by brixo
Wed Oct 25, 2017 7:15 pm
Forum: Beginner Basics
Topic: VLAN/TRUNK - Cisco equiv commands
Replies: 1
Views: 359

VLAN/TRUNK - Cisco equiv commands

Hi all, Trying to get to grips with Mik after 20 years of Cisco. I appreciate that the capabilities of the Mik are probably as good as some of Cisco's kit, and probably more configurable, however, for a newbie this is quite difficult. How about some simple starters... Cisco Access Port into vlan 102...
by brixo
Wed Oct 25, 2017 6:48 pm
Forum: Beginner Basics
Topic: VRFs, ROUTING-TABLEs, ROUTE-MARKERs
Replies: 1
Views: 301

VRFs, ROUTING-TABLEs, ROUTE-MARKERs

Hi all, I am trying to get various things to work on CCRs but struggling. I am trying to translate my knowledge of CIsco into Mikrotik and trying to find the equivalent! Objective: 1. Use a single CCR device 2. Have 4 completely separate routing domains (equiv of VRF-lite on Cisco) - which permit ov...
by brixo
Wed Oct 25, 2017 6:39 pm
Forum: Beginner Basics
Topic: CRS317 - want SwOS, but won't boot
Replies: 17
Views: 3073

Re: CRS317 - want SwOS, but won't boot

That is correct. If everything uses ROS, it works. If you have any device with SwOS, you cannot get 10G. I have tried several S+DACs too, as well as reboot, enable/disable. I will get you the serial numbers of everything next week (just left the office for a long weekend). It's been a painful (but s...
by brixo
Tue Oct 24, 2017 5:38 pm
Forum: Beginner Basics
Topic: CRS317 - want SwOS, but won't boot
Replies: 17
Views: 3073

Re: CRS317 - want SwOS, but won't boot

UPDATE:

If *all* devices are running RouterOS, the 10G comes up immediately.

Should SwOS 2.6 support 10G? If so, it doesn't appear to.
by brixo
Tue Oct 24, 2017 5:26 pm
Forum: Beginner Basics
Topic: CRS317 - want SwOS, but won't boot
Replies: 17
Views: 3073

Re: CRS317 - want SwOS, but won't boot

Sadly not :( We now have the CRS317 running SwOS 2.6, and the CCR1072 running RouterOS 6.41.rc47. On the CCR1072 we have tried auto-neg *and* manually setting (in console only, as there is not 10G option in the Webfig) to 10G... still not working. There is no option to FORCE the CRS317 to 10G on tha...
by brixo
Tue Oct 24, 2017 4:43 pm
Forum: Beginner Basics
Topic: CRS317 - want SwOS, but won't boot
Replies: 17
Views: 3073

Re: CRS317 - want SwOS, but won't boot

Many thanks. We were expecting something in the console to tell us that "you are now in SwOS". Only problem now is that we cannot set any interface to 10G! We have upgraded to 2.6 also. Using S+DA0001 between a CRS317 and CCR1072; the CRS317 does not recognise the SFPs and it only allows you to set ...
by brixo
Tue Oct 24, 2017 3:46 pm
Forum: Beginner Basics
Topic: CRS317 - want SwOS, but won't boot
Replies: 17
Views: 3073

Re: CRS317 - want SwOS, but won't boot

We have tried to XMODEM SwOS 2.6 to it, still complains and will not boot into SwOS. **** BootROM 1.41 Booting from SPI flash BootROM: Image checksum verification PASSED RouterBOOT booter 3.43 CRS326-24G-2S+ CPU frequency: 800 MHz Memory size: 512 MiB Storage size: 16 MiB Press any key within 2 seco...
by brixo
Tue Oct 24, 2017 3:42 pm
Forum: Beginner Basics
Topic: CRS317 - want SwOS, but won't boot
Replies: 17
Views: 3073

Re: CRS317 - want SwOS, but won't boot

BootROM 1.41 Booting from SPI flash BootROM: Image checksum verification PASSED RouterBOOT booter 3.43 CRS326-24G-2S+ CPU frequency: 800 MHz Memory size: 512 MiB Storage size: 16 MiB Press any key within 2 seconds to enter setup.. SwOS v2.0p mac address: 64:D1:54:C6:AF:00 ip address: 192.168.88.1 bo...
by brixo
Tue Oct 24, 2017 3:32 pm
Forum: Beginner Basics
Topic: CRS317 - want SwOS, but won't boot
Replies: 17
Views: 3073

Re: CRS317 - want SwOS, but won't boot

We have EXACTLY the same issue with a CRS326-24G-2S+RM - we ask it to boot into SwOS, but it ignores us!
by brixo
Tue Oct 24, 2017 3:27 pm
Forum: Beginner Basics
Topic: CRS317 - want SwOS, but won't boot
Replies: 17
Views: 3073

Re: CRS317 - want SwOS, but won't boot

We have tried via the console cable and via the WebGUI (when booted into RouterOS)... but on reboot, it appears to loop... then on the console there is no option to boot permanently to SwOS.

Basically, it never boots into SwOS!
by brixo
Mon Oct 23, 2017 9:54 pm
Forum: Beginner Basics
Topic: CRS317 - want SwOS, but won't boot
Replies: 17
Views: 3073

CRS317 - want SwOS, but won't boot

Hi all, Just taken hold of various Mik kit - one being a CRS317 as I want to use the 10G interface capability. I have no requirement for any L3 services, I just want switching. I have taken it out of the box, booted up, plugged into eth1, logged in via the GUI to 192.168.88.1, selected next boot to ...