Community discussions

MikroTik App

Search found 22 matches

by palii
Wed Sep 09, 2020 2:44 am
Forum: General
Topic: Log File Dates & Times seem to be incorrect
Replies: 8
Views: 1662

Re: Log File Dates & Times seem to be incorrect

I can confirm that "/log print" produces wrong timestamps after midnight. For a few hours it swaps the date format of today's and yesterday's log entries. Very serious (script breaking) bug. Here is part of the output of "/log print" on sep/09 01:14:00 sep/07 23:41:02 script,info test1 - sept 07 sep...
by palii
Mon Sep 07, 2020 12:08 pm
Forum: General
Topic: Feature Request: SNMP-GET output to variable
Replies: 10
Views: 2320

Re: Feature Request: SNMP-GET output to variable

Without variable output it is almost useless. Unfinished. I could image tons of usages as well.

Mikrotik devs please finish this feature.

I completely agree with millenium7. It is a vicious circle.
by palii
Wed Oct 23, 2019 11:56 am
Forum: General
Topic: [Feature Request] Scheduler start-time=shutdown
Replies: 0
Views: 601

[Feature Request] Scheduler start-time=shutdown

- The ability to run a scheduled script just before the router shuts down.
- This would allow us to delay shut down and shut down other devices too.
by palii
Fri Oct 04, 2019 1:34 am
Forum: General
Topic: Feature Request: SNMP-GET output to variable
Replies: 10
Views: 2320

Re: Feature Request: SNMP-GET output to variable

Yes, indeed the Dude is a viable solution. But I would only need SNMP-GET for a few minor things and thus installing something as robust as the Dude would be overkill in my case. I'm still hoping the devs will give this function a fix up.
by palii
Fri Oct 04, 2019 12:37 am
Forum: General
Topic: How to NAT external Wake-On-Lan packet into specific VLAN
Replies: 2
Views: 818

Re: How to NAT external Wake-On-Lan packet into specific VLAN

Thanks for the reply and information. You made a few things much clearer.

I figured it out finally.

I had to turn the ARP entry into static.
by palii
Mon Sep 30, 2019 10:01 pm
Forum: General
Topic: How to NAT external Wake-On-Lan packet into specific VLAN
Replies: 2
Views: 818

How to NAT external Wake-On-Lan packet into specific VLAN

I can't seem to NAT an incoming wake-on-lan packet from the internet to a specific vlan. I'm using routerOS rb750gr3. As such this NAT rule doesn't work: add action=dst-nat chain=dstnat dst-port=9 in-interface-list=WAN protocol=udp to-addresses=10.0.1.10 to-ports=9 How can I add a vlan tag to this p...
by palii
Sat May 25, 2019 1:06 am
Forum: General
Topic: Feature Request: SNMP-GET output to variable
Replies: 10
Views: 2320

Re: Feature Request: SNMP-GET output to variable

This is a must. +1 for feature request

Unfortunately the result needs serious string cleaning as well!

Result from my UPS charge level:
OID                             TYPE             VALUE                           
1.3.6.1.4.1.318.1.1.1.2.2.1.0   gauge            97  
by palii
Mon Apr 29, 2019 4:22 pm
Forum: Scripting
Topic: Array Push Function
Replies: 9
Views: 6458

Re: Array Push Function

Awesome! Thanks for that. I didn't know, you could add to arrays like that (even merge other arrays!)
by palii
Sun Apr 28, 2019 2:04 am
Forum: Scripting
Topic: Array Push Function
Replies: 9
Views: 6458

Re: Array Push Function

Good job guys. It seems pushing values into arrays is much simpler now. For example:
:local myarray {1;2;3;4}
:set ($myarray->[:len $myarray]) 5
:log info $myarray

Outputs: 1;2;3;4;5

Just posting in case someone finds this thread.
by palii
Sat Apr 20, 2019 8:06 pm
Forum: Scripting
Topic: To retain variable's values after reboot
Replies: 7
Views: 4083

Re: To retain variable's values after reboot

13 years later. Well, I wrote a function that reads and writes persistent variables as layer7-protocols. :global persist do={ :local varName $1 :local varValue $2 :local varID [/ip firewall layer7-protocol find name="$varName"] :if ([:typeof $varValue] = "nothing") do={ :if ($varID != "") do={ :set ...
by palii
Thu Apr 18, 2019 11:51 am
Forum: Announcements
Topic: v6.45beta [testing] is released!
Replies: 305
Views: 99709

Re: v6.45beta [testing] is released!

The command ssh-exec with rsa key pairs works like a charm shutting down my Synology now. Thanks a million!
by palii
Thu Apr 18, 2019 11:46 am
Forum: Scripting
Topic: how i can send ssh command through script
Replies: 4
Views: 1862

Re: how i can send ssh command through script

Since version 6.45beta27 you can use ssh-exec.
by palii
Thu Apr 18, 2019 11:42 am
Forum: General
Topic: [BUG] SSH client does not works from background script
Replies: 11
Views: 2716

Re: [BUG] SSH client does not works from background script

Since version 6.45beta27 you can use ssh-exec.
by palii
Mon Mar 25, 2019 10:20 pm
Forum: Beginner Basics
Topic: Connecting two routers in two buildings with cable
Replies: 8
Views: 1257

Re: Connecting two routers in two buildings with cable

Thanks for all the wonderful suggestions. The RB760iGS arrived, I will start testing in-house with copper first, then a manufactured mikrotik sfp optical cable. AlainCasault: I'm assuming that the /16s are just to summarize local subnets and you don't have such a big network. Otherwise, break the su...
by palii
Tue Mar 12, 2019 12:25 pm
Forum: Beginner Basics
Topic: Connecting two routers in two buildings with cable
Replies: 8
Views: 1257

Re: Connecting two routers in two buildings with cable

What would be the purpose of ether5 on both routers, in other words what does the connectivity allow..... To provide faster connectivity than ipsec between the two buildings. Forget UTP cable, ethernet over UTP is limited to 100 metres. For anything longer one has to use optical fibre ... I may hav...
by palii
Sat Mar 02, 2019 5:46 pm
Forum: Beginner Basics
Topic: Connecting two routers in two buildings with cable
Replies: 8
Views: 1257

Connecting two routers in two buildings with cable

Hi Everyone, We have 2 buildings, 2 routers, 2 internet connections Each has is own dhcp and vlans Currently the networks are bridged with an ipsec tunnel, which works well Since the buildings aren't that far apart, I would like to connect the routers on their ETH5 by running a CAT6 cable Preferably...
by palii
Tue Aug 21, 2018 8:45 pm
Forum: Beginner Basics
Topic: DNS Madness (why resolving to 0.0.0.0?)
Replies: 0
Views: 500

DNS Madness (why resolving to 0.0.0.0?)

Since the last 2 month I'm trying to fix our DNS resolving bug. There is a domain and some of its subdomains sometimes resolve fine, sometimes resolve to 0.0.0.0 as unknown type with N flag. I changed the router to a TP-Link one and the problem was gone. While using bitdefender VPN the problem was g...
by palii
Mon Jun 18, 2018 8:59 pm
Forum: General
Topic: Bridge VLAN filtering and VLAN isolation
Replies: 3
Views: 2117

Re: Bridge VLAN filtering and VLAN isolation

Alright. Then if I use firewall rules to isolate VLANs, do I need VLAN filtering at all?

All my VLANS pass through one or more trunk port(s) to the managed switch.
by palii
Mon Jun 18, 2018 8:23 pm
Forum: General
Topic: Bridge VLAN filtering and VLAN isolation
Replies: 3
Views: 2117

Bridge VLAN filtering and VLAN isolation

Hi Guys, I'm struggling with vlan filtering and vlan isolation with the new bridge. My rb750gr3 config: ether1: pppoe wan port ether2-5 are bridged together ether2-5 are trunk ports that can carry VLANS to the managed switch PVID1 is untagged for bridge, ether2-5 all other vlan ids are tagged for br...
by palii
Fri Jun 08, 2018 12:12 pm
Forum: General
Topic: Mikrotik detecting all traffic to Synology as invalid connections
Replies: 7
Views: 1742

Re: Mikrotik detecting all traffic to Synology as invalid connections

Any updates or solutions? I'm having the same problem. Mikrotik's invalid rule is dropping some of my synology packets.
by palii
Sun Nov 19, 2017 11:28 pm
Forum: General
Topic: Mapping static local IP to external dynamic IP
Replies: 3
Views: 691

Re: Mapping static local IP to external dynamic IP

If there is no other solution, then I will use microtik routers for both networks.

Both networks have dynamic IP with dyndns, that won't be a problem?
by palii
Sun Nov 19, 2017 7:08 pm
Forum: General
Topic: Mapping static local IP to external dynamic IP
Replies: 3
Views: 691

Mapping static local IP to external dynamic IP

I need help mapping a fixed IP address to an external dynamic IP address. I'm trying: - Access Synology NAS from Samsung TV via internet connection - The TV is on a local network and can only connect to a fixed IP address - The NAS is on an external network, that has dynamic IP with dyndns configure...