Community discussions

MikroTik App

Search found 21 matches

by kcarhc
Thu Jan 21, 2021 2:48 am
Forum: RouterOS v7 BETA
Topic: Anyone with TCP staus issue like fin wait/last ack/mtu , use this magic code will fix
Replies: 1
Views: 274

Anyone with TCP staus issue like fin wait/last ack/mtu , use this magic code will fix

Anyone with TCP staus issue like fin wait/last ack/mtu , use this magic code will fix on RouterOS 7.1beta 3 in firewall mangle set mss = interface mtu - 40 not working well. so pppoe-client on RouterOS 7.1beta 3 maybe have tcp fin wait/last ack/ mtu issue, in /ip firewall connctions, it show tcp con...
by kcarhc
Wed Aug 26, 2020 12:34 am
Forum: RouterOS v7 BETA
Topic: FEATURE REQUEST: BBR(Bottleneck Bandwidth and Round-trip propagation time) Congestion Control
Replies: 6
Views: 1380

Re: FEATURE REQUEST: BBR(Bottleneck Bandwidth and Round-trip propagation time) Congestion Control

+1 but still needs a modern/smarter queuing disc like CAKE or fq_codel to keep latency low with different kinds of traffic not just TCP Edit: I don't think we need BBR, TCP congestion control algorithms can do very little to improve the user experience and the overall network quality. SQM gives bet...
by kcarhc
Sun Aug 23, 2020 2:49 pm
Forum: RouterOS v7 BETA
Topic: FEATURE REQUEST: BBR(Bottleneck Bandwidth and Round-trip propagation time) Congestion Control
Replies: 6
Views: 1380

FEATURE REQUEST: BBR(Bottleneck Bandwidth and Round-trip propagation time) Congestion Control

Bottleneck Bandwidth and Round-trip propagation time, or BBR, is a congestion control algorithm that powers traffic from google.com and YouTube. The algorithm was developed by Google, and it can produce higher throughput, and lower latency for traffic from your VPS. RouterOS 7.1 beta X –> it support...
by kcarhc
Sat Aug 22, 2020 1:02 am
Forum: RouterOS v7 BETA
Topic: routing-mark and table and mangle in RouterOS v7 BETA 7
Replies: 15
Views: 4524

Re: routing-mark and table and mangle in RouterOS v7 BETA 7

ok thanks. it's work.

/routing table add name=IRT-TEST fib

/ip route
add check-gateway=ping distance=10 dst-address=0.0.0.0/0 gateway=10.10.66.70@main routing-table=IRT-TEST
by kcarhc
Tue Aug 18, 2020 4:25 am
Forum: RouterOS v7 BETA
Topic: routing-mark and table and mangle in RouterOS v7 BETA 7
Replies: 15
Views: 4524

Re: routing-mark and table and mangle in RouterOS v7 BETA 7

!!!!!! /routing table add name=IRT-TEST fib !!!!! here is my code and this line is work, I known /routing table add name=IRT-TEST fib ########################### this line is not work on ROS 7.1 Beat, it works on ROS 7.0 Beta. I need this line. /ip route add check-gateway=ping distance=10 dst-addre...
by kcarhc
Tue Aug 18, 2020 4:22 am
Forum: RouterOS v7 BETA
Topic: FEATURE REQUEST: full cone NAT
Replies: 7
Views: 2196

Re: FEATURE REQUEST: full cone NAT

deploy ipv6 and free of headache
PS4/PC Games like MONSTER HUNTER: WORLD not support IPv6

and you cannot make all players use IPv6
by kcarhc
Mon Aug 17, 2020 9:29 am
Forum: RouterOS v7 BETA
Topic: FEATURE REQUEST: full cone NAT
Replies: 7
Views: 2196

FEATURE REQUEST: full cone NAT

Please support full cone NAT Gaming with full cone NAT router, we can running multi PC/PS4 Games in same LAN as multi Teams Master in Games, games like "Monster Hunter: World" Now, with Symmetric NAT or uPNP or DNAT-static and other, we can only create One Teams Master. https://tools.ietf....
by kcarhc
Mon Aug 17, 2020 2:57 am
Forum: RouterOS v7 BETA
Topic: routing-mark and table and mangle in RouterOS v7 BETA 7
Replies: 15
Views: 4524

Re: routing-mark and table and mangle in RouterOS v7 BETA 7

@mrz, please help me translate my code to work on RouterOS 7.1Beta 1. not 7.0 Beta 9 ====================code==================== /ip firewall mangle add action=mark-connection chain=prerouting connection-mark=no-mark new-connection-mark=CON-TEST passthrough=yes dst-address=4.2.2.1 add action=mark-r...
by kcarhc
Thu Aug 13, 2020 7:40 pm
Forum: RouterOS v7 BETA
Topic: routing-mark and table and mangle in RouterOS v7 BETA 7
Replies: 15
Views: 4524

Re: routing-mark and table and mangle in RouterOS v7 BETA 7

############################ /routing table add name=IRT-TEST fib /ip route add check-gateway=ping distance=10 dst-address=0.0.0.0/0@IRT-TEST gateway=10.10.66.70@main ########################### it works on 7.0 Beta 8 it don't work on v7.1 BETA 1 show this invalid or unexpected vrf or routing table ...
by kcarhc
Thu Jun 18, 2020 8:06 am
Forum: RouterOS v7 BETA
Topic: Bonding with EoIP Tunnels not work on RouterOS v7 Beta 8, on Beta 3/5 is working
Replies: 0
Views: 608

Bonding with EoIP Tunnels not work on RouterOS v7 Beta 8, on Beta 3/5 is working

same config in different RouterOS v7 Beta Bonding with two or three EoIP Tunnels not work, RouterOS v7 Beta 8 <=> Bonding EoIP Tunnels <=> RouterOS v7 Beta 8 not work, RouterOS v7 Beta 8 <=> Bonding EoIP Tunnels <=> RouterOS v7 Beta 3 not work, RouterOS v7 Beta 8 <=> Bonding EoIP Tunnels <=> RouterO...
by kcarhc
Thu Jun 04, 2020 5:25 pm
Forum: RouterOS v7 BETA
Topic: routing-mark and table and mangle in RouterOS v7 BETA 7
Replies: 15
Views: 4524

Re: routing-mark and table and mangle in RouterOS v7 BETA 7

OK, Thanks, Works well on RouterOS 7
by kcarhc
Thu Jun 04, 2020 5:09 pm
Forum: RouterOS v7 BETA
Topic: v7.0beta8 [development] is released!
Replies: 180
Views: 68982

Re: v7.0beta8 [development] is released!

router was rebooted without proper shutdown on RouterOS v7.0 Beta 7 and Beta 8

Every 10 minutes, router auto reboot.
I think maybe some scheduler Interval 10 minutes on RouterOS v7.0 Beta 7 and Beta 8 crash the kernel
by kcarhc
Thu Jun 04, 2020 4:51 pm
Forum: RouterOS v7 BETA
Topic: v7.0beta8 [development] is released!
Replies: 180
Views: 68982

Re: v7.0beta8 [development] is released!

IPsec Policies say no phase2 on PH2 no phase2 When Upgrade from RouterOS v7.0beta3 and v7.0beta5 to RouterOS v7.0beta7 or v7.0beta8 IPsec Policies say no phase2 on PH2 State You need goto Identities and remove all and add the Identities for peers again That's will make IPsec works again. When Downgr...
by kcarhc
Thu Jun 04, 2020 4:44 pm
Forum: RouterOS v7 BETA
Topic: v7.0beta8 [development] is released!
Replies: 180
Views: 68982

Re: v7.0beta8 [development] is released!

router was rebooted without proper shutdown on RouterOS v7.0 beta 7

When it on RouterOS Beta 5, it's work well.

I have config some EoIP Tunnels and some IP Tunnels and Bonding Tunnels with EoIP Tunnels.
by kcarhc
Thu Jun 04, 2020 4:40 pm
Forum: RouterOS v7 BETA
Topic: routing-mark and table and mangle in RouterOS v7 BETA 7
Replies: 15
Views: 4524

Re: routing-mark and table and mangle in RouterOS v7 BETA 7

@mrz, please help me translate my code to RouterOS 7. ====================code==================== /ip firewall mangle add action=mark-connection chain=prerouting connection-mark=no-mark new-connection-mark=CON-TEST passthrough=yes dst-address=4.2.2.1 add action=mark-routing chain=prerouting connect...
by kcarhc
Thu Jun 04, 2020 2:58 pm
Forum: RouterOS v7 BETA
Topic: routing-mark and table and mangle in RouterOS v7 BETA 7
Replies: 15
Views: 4524

routing-mark and table and mangle in RouterOS v7 BETA 7

here is the code in RouterOS v6, how to make it work in RouterOS v7. /ip firewall mangle add action=mark-connection chain=prerouting connection-mark=no-mark new-connection-mark=CON-TEST passthrough=yes dst-address=4.2.2.1 add action=mark-routing chain=prerouting connection-mark=CON-TEST new-routing-...
by kcarhc
Tue Dec 10, 2019 10:35 am
Forum: RouterOS v7 BETA
Topic: [ROS 7.0beta4] PPPoE Client, Peer DNS, random lost.
Replies: 0
Views: 2107

[ROS 7.0beta4] PPPoE Client, Peer DNS, random lost.

PPPoE Client running above 10 hours, maybe 1 hours. random hours.
the /ip dns dynamic-servers will gone.
You can get it again, only by dial PPPoE Client.
by kcarhc
Mon Dec 09, 2019 5:51 pm
Forum: RouterOS v7 BETA
Topic: [ROS 7.0beta4] boot loop, kernel crash. with many Tunnels.
Replies: 1
Views: 2297

[ROS 7.0beta4] boot loop, kernel crash. with many Tunnels.

I have upgrade my server ROS 6.4x to 7.0beta4 It boot loop, I think it's kernel crash. I have 132 IP Tunnels and 115 EoIP Tunnel in this Server. So I make a new ROS 7.0beta4 and add tunnels in code , one by one. when ROS 7.0beta4 have 31 Tunnels add another one, Now, the ROS restart itself, and boot...
by kcarhc
Mon Dec 09, 2019 5:42 pm
Forum: RouterOS v7 BETA
Topic: [ROS 7.0beta4] PPP[PPPoE/PPTP/L2TP/SSTP] interface no rx traffic, and mss need change by mangle.
Replies: 1
Views: 2173

[ROS 7.0beta4] PPP[PPPoE/PPTP/L2TP/SSTP] interface no rx traffic, and mss need change by mangle.

PPP Interface rx is always 0. /interface pppoe-client add name=pppoe-out1 disabled=no \ add-default-route=yes default-route-distance=1 use-peer-dns=yes \ interface=ether1 max-mru=1492 max-mtu=1492 \ password=pass user=user /ip firewall nat add action=masquerade chain=srcnat out-interface=pppoe-out1 ...
by kcarhc
Mon Dec 09, 2019 5:31 pm
Forum: RouterOS v7 BETA
Topic: [ROS 7.0beta4] multiple route tables, route rule not work
Replies: 0
Views: 2156

[ROS 7.0beta4] multiple route tables, route rule not work

I have read topic "Cannot set routing-mark or table for routing rule" and "how add multiple route tables, route rules in v7 beta" and with following codes, I try to make multiple route work, but failed. ------------------------------ /interface/pppoe-client add name=pppoe-out1 di...
by kcarhc
Wed Sep 19, 2018 10:37 am
Forum: General
Topic: Add VirtIO-SCSI driver to CHR 6.40.9 (LONG-TERM)
Replies: 1
Views: 495

Add VirtIO-SCSI driver to CHR 6.40.9 (LONG-TERM)

Plese Add VirtIO-SCSI driver to CHR 6.40.9 (LONG-TERM). maybe in CHR 6.40.10 (LONG-TERM). I don't like the 6.42.x, the 6.40.9 is perfect, it just do not have the VirtIO-SCSI driver. I want use the LONG-TERM verion for LONG-LONG-LONG-TERM. Now I can't run it on some VPS with VirtIO-SCSI like Google C...