Community discussions

Search found 97 matches

by victorsoares
Wed Sep 18, 2019 11:58 pm
Forum: General
Topic: Winbox 64bit Version
Replies: 33
Views: 3836

Re: Winbox 64bit Version

>> As the acronym states "Wine Is Not an Emulator" and thus if the OS kernel doesn't allow 32-bit code execution nothing AFAIK can be done. Codeweavers is working on a Crossover version that executes 32bit. But it seems to be hard. https://www.codeweavers.com/about/blogs/jschmid/2019/9/10/so-we-don...
by victorsoares
Tue Sep 17, 2019 9:08 pm
Forum: General
Topic: Winbox 64bit Version
Replies: 33
Views: 3836

Re: Winbox 64bit Version

Finally some light on this subject. Winbox is great, but unfortunately it's days are counted as it is now. I really hope that a 64bit version is close to us.
by victorsoares
Thu Sep 12, 2019 9:21 pm
Forum: General
Topic: [Feature Request] Winbox and netinstall 64 Bit versions - URGENT
Replies: 21
Views: 3414

Re: [Feature Request] Winbox and netinstall 64 Bit versions - URGENT

Well, right now I'm running macOS Catalina with a VM running Windows 7 just with Winbox running. It seems like a huge waste of resources, but it's the only way I found to run this application without having to ditch my beloved OS. If Codeweavers or Mikrotik could find a way to make this work it woul...
by victorsoares
Sun Sep 08, 2019 8:08 pm
Forum: General
Topic: Winbox 64bit Version
Replies: 33
Views: 3836

Re: Winbox 64bit Version

Well, end of the line for me. I just updated my MacOS to Catalina and said good bye to Winbox running on Wine. Tried installing the beta version of winehq 64 but had no success. If anyone here is in the same situation and had more luck than me please share your solution. Right now I'm using a VM to ...
by victorsoares
Mon Aug 26, 2019 7:55 pm
Forum: Beginner Basics
Topic: NAT problems - Xbox One and Nintendo Switch
Replies: 31
Views: 3177

Re: NAT problems - Xbox One and Nintendo Switch

Well, from my experience the only sure way to get videogames to work without any NAT problems is using IPv6 or giving the client a valid and public IP address. My guess is that whoever designed this network used NAT to distribute the connections but forgot that the connections also arrive there on ...
by victorsoares
Wed Aug 21, 2019 5:21 pm
Forum: General
Topic: New to mikrotik, forward chain help needed
Replies: 3
Views: 430

Re: New to mikrotik, forward chain help needed

I agree with Anumrak, default firewall is the best solution for 90% of the cases, on the other 10% it's a solid base as well. So unless you have some specific needs on your firewall, default will do you just fine.
by victorsoares
Wed Aug 21, 2019 5:18 pm
Forum: General
Topic: High Traffic Graphing Problem
Replies: 2
Views: 383

Re: High Traffic Graphing Problem

Yep, that's an old thing with Winbox. It works fine on the web GUI, but not on Winbox. I usually do the graphing on an external solution, like Zabbix or Observium, and that's what I think it's the best solution.
by victorsoares
Mon Aug 19, 2019 6:37 pm
Forum: General
Topic: Mikrotik CCR-1072 router
Replies: 4
Views: 369

Re: Mikrotik CCR-1072 router

I use 4 of them for BGP. If I could choose now I would use 1036`s instead, for the processing capabilities regarding BGP. I've seen people using full route on them, but I found, at least with my experience, that this usually is not a good idea with mikrotiks. I run an average of two BGP sessions on ...
by victorsoares
Tue Aug 13, 2019 4:12 pm
Forum: Beginner Basics
Topic: Automatic Failover
Replies: 2
Views: 565

Re: Automatic Failover

One way to solve this is using NetWatch, and set a ping to 8.8.8.8 or some other address that you want. Then set the script to change de default route to the second ISP if the ping fails. If possible ask your internet provider to set your routers on bridge, this way you can avoid double NAT and also...
by victorsoares
Fri Aug 09, 2019 4:31 pm
Forum: SwOS
Topic: Remotely reboot router on SWOS
Replies: 6
Views: 789

Re: Remotely reboot router on SWOS

My solution for this was to set the alarm systems that I have on my remote switches to be able to turn the electrical plugs on or off. That way I can set routines on the alarm or just do it from my mobile phone, plus, I can monitor current and all other sort of things in the environment, such as A/C...
by victorsoares
Wed Aug 07, 2019 10:35 pm
Forum: General
Topic: Detect Internet feature does not work on RB3011
Replies: 2
Views: 288

Re: Detect Internet feature does not work on RB3011

I honestly don't care much for this feature, never had any luck with it. I know that there is a post here somewhere and they explained how they define if there is internet connection or not. I just turned this off on my routers.
by victorsoares
Mon Aug 05, 2019 7:44 pm
Forum: General
Topic: Winbox 64bit Version
Replies: 33
Views: 3836

Re: Winbox 64bit Version

Let's not leave this post to die. I'm pretty sure that a lot of us use either MAC or Linux, and a "MACbox" or "Linuxbox" would be of great use for lots of us. I don't think that it's too much to ask for our dear developers.
by victorsoares
Fri Aug 02, 2019 7:01 pm
Forum: Forwarding Protocols
Topic: question about bgp full table from 2 different provider
Replies: 7
Views: 674

Re: question about bgp full table from 2 different provider

From my experience you better of without full route on mikrotiks, or try a different solution like the colleague said. I personally like VyOS, it works very well, is open source and very smart with resources.
by victorsoares
Thu Aug 01, 2019 4:17 pm
Forum: General
Topic: Winbox login: authentication failed, maybe due to bad blocks?
Replies: 5
Views: 343

Re: Winbox login: authentication failed, maybe due to bad blocks?

My guess is that your Winbox version is too recent to authenticate on 3.19. As the colleagues said, upgrading your ROS should be the first step, but just to login you should be fine with an older version of Winbox.
by victorsoares
Tue Jul 30, 2019 4:18 pm
Forum: General
Topic: User password issue while upgrading
Replies: 4
Views: 556

Re: User password issue while upgrading

This looks to be a common problem with this version, at least for what I've seen. I myself didn't have this problem on my RB750GR3, but also didn't have the balls to upgrade my CCRs on the ISPs that I run. I think that next steps for you would be to put a static IP on your PC and try to connect dire...
by victorsoares
Mon Jul 29, 2019 3:50 pm
Forum: General
Topic: Login or password error after upgrade 6.45.2
Replies: 1
Views: 402

Re: Login or password error after upgrade 6.45.2

What version of Winbox are you using? Try the latest one (3.19). If that doesn't work, there is always NetInstall.
by victorsoares
Fri Jul 26, 2019 5:59 pm
Forum: General
Topic: PPPOE Disconnect Client
Replies: 2
Views: 394

Re: PPPOE Disconnect Client

Can you post your ppp server settings and interfaces so we have a better understanding of what might be going on?
by victorsoares
Mon Jul 22, 2019 9:36 pm
Forum: General
Topic: Winbox 64bit Version
Replies: 33
Views: 3836

Re: Winbox 64bit Version

Same concern here, I use Mac and rely heavily on two 32bit applications, Winbox and Google Earth. Both of them will not work with the next update for Macs, therefore upgrading my machine is not possible for me at this moment. I really hope that Mikrotik will eventually make an UNIX based Winbox that...
by victorsoares
Tue Jul 16, 2019 8:34 pm
Forum: RouterBOARD hardware
Topic: Legal mikrotiks for Brazil ?
Replies: 4
Views: 660

Re: Legal mikrotiks for Brazil ?

You may want to check this information with official Mikrotik distributors in Brazil. Here you can find them: https://mikrotik.com/buy/latinamerica/brazil I work with ISP`s in Brazil that use Mikrotik heavily and never had any problems with ANATEL. And I've been visited by them, so I don't think its...
by victorsoares
Mon Jun 10, 2019 7:51 pm
Forum: General
Topic: Bare Metal installation
Replies: 6
Views: 598

Re: Bare Metal installation

Tank you so much @normis, the biggest concern is the possible performance issues, but coming from someone from the inside makes it easier for me to argument with the executives about the best solution.
by victorsoares
Tue Jun 04, 2019 5:35 pm
Forum: General
Topic: Bare Metal installation
Replies: 6
Views: 598

Re: Bare Metal installation

UPDATE

Ok, new error now. I managed to make the .img file bootable using dd command. I get a message that says "Initializing" and then another one saying "Starting with initdr". And then the server shuts down.
by victorsoares
Mon Jun 03, 2019 9:54 pm
Forum: General
Topic: Bare Metal installation
Replies: 6
Views: 598

Re: Bare Metal installation

I tried the ISO, I used Unetbootin and Rufus to make a bootable USB stick but when I try to start the installation I get a CD-ROM error.
by victorsoares
Sat Jun 01, 2019 5:12 pm
Forum: General
Topic: Bare Metal installation
Replies: 6
Views: 598

Bare Metal installation

Hi, I've been working with mikrotiks for a couple of years now, and I'm most used to CCR`s. Recently one of my clients asked me to put a new PPPoE concentrator on his network, given that the other ones are starting to suffer from the high processing demand. He has a PowerEdge server, that I think it...
by victorsoares
Fri May 24, 2019 11:40 pm
Forum: General
Topic: [Hardware Request] MikroTik OLT
Replies: 4
Views: 592

Re: [Hardware Request] MikroTik OLT

I would definitely want to check a MikroTik OLT, but I don't know if I would trade my Fiberhome for a company that's new to the market. When it comes to ISP grade equipment, it's really hard for new players to enter the game. Companies will prefer to invest in brands that had proven over the years t...
by victorsoares
Tue Apr 23, 2019 3:39 pm
Forum: Beginner Basics
Topic: internet not working despite pingable addresses
Replies: 10
Views: 454

Re: internet not working despite pingable addresses

Had you check your DNS servers?
by victorsoares
Mon Apr 22, 2019 4:23 pm
Forum: Beginner Basics
Topic: NAT problems - Xbox One and Nintendo Switch
Replies: 31
Views: 3177

Re: NAT problems - Xbox One and Nintendo Switch

Well, from my experience the only sure way to get videogames to work without any NAT problems is using IPv6 or giving the client a valid and public IP address. My guess is that whoever designed this network used NAT to distribute the connections but forgot that the connections also arrive there on a...
by victorsoares
Wed Apr 17, 2019 3:59 pm
Forum: General
Topic: Can't backup
Replies: 9
Views: 624

Re: Can't backup

Well, just an update. I managed to get the equipment back and running after upgrading the firmware to the latest version. After a week or so problems started again. I'm sending the equipment to repair now.
by victorsoares
Sun Apr 07, 2019 6:27 pm
Forum: General
Topic: Can't backup
Replies: 9
Views: 624

Re: Can't backup

Another thing I just noticed is that the users I created to administrate the router get deleted. I can't find anything on logs about who did it, but only default user with default password was kept, and I had disabled it and changed its password when I did the netinstall on it.
by victorsoares
Sun Apr 07, 2019 6:16 pm
Forum: General
Topic: Can't backup
Replies: 9
Views: 624

Re: Can't backup

I have the export of the equipment, it was just after a netinstall that the problem appeared. I might try this, but since its a production equipment with about 2000 clients on it. I`ll better make sure its the on the red eye shift.
by victorsoares
Fri Apr 05, 2019 9:23 pm
Forum: General
Topic: Can't backup
Replies: 9
Views: 624

Can't backup

Hello everyone, recently my CCR 1036 decided to restart constantly. I managed to do a NetInstall with the latest RoS and everything went back do normal. But I noticed that I cannot save or create any files on the router. I'm now sending daily backups to an ftp server just to make sure I don't loose ...
by victorsoares
Wed Apr 03, 2019 3:26 pm
Forum: General
Topic: Mikrotik works smootly but sites don't work
Replies: 3
Views: 305

Re: Mikrotik works smootly but sites don't work

Hard to say without configs, but thinking here maybe related to redirecting http access on other routers through WAN? In this case all you would get is a login screen of some MK in your network.
by victorsoares
Thu Mar 14, 2019 9:37 pm
Forum: General
Topic: HOTSPOT and NAT in the same RB
Replies: 3
Views: 257

Re: HOTSPOT and NAT in the same RB

I think he meant this because of processing, depending on what kind of equipment you are using and how much users are hanging in this router. And if you have fast track and queues on the same box, queues wouldn't work properly.
by victorsoares
Tue Mar 12, 2019 5:17 pm
Forum: Beginner Basics
Topic: Can Mikrotik / RouterOS do multiple PPPOE trough same WAN cable ?
Replies: 23
Views: 1222

Re: Can Mikrotik / RouterOS do multiple PPPOE trough same WAN cable ?

I'm from Brazil actually. The thing is that being that all connections go to the same place, it doesn't matter how many fibers you have there if they come from the same PON port on their OLT, because that port will only deliver 2,5Gbps to all clients on it. Now if you don't plan on using the full ca...
by victorsoares
Tue Mar 12, 2019 2:52 pm
Forum: Forwarding Protocols
Topic: BGP AS Path Prepending
Replies: 1
Views: 349

Re: BGP AS Path Prepending

Basically yes, prepend is going to do the job, of course you have to check other methods just to be on the safe side. There is a lot of detailed information on https://wiki.mikrotik.com/wiki/Manual:S ... link_setup if you want.
by victorsoares
Tue Mar 12, 2019 2:45 pm
Forum: Beginner Basics
Topic: Can Mikrotik / RouterOS do multiple PPPOE trough same WAN cable ?
Replies: 23
Views: 1222

Re: Can Mikrotik / RouterOS do multiple PPPOE trough same WAN cable ?

Just so you know, one fiber is not going to be enough for 3x 1Gbps connections, because most OLT`s are 2,5Gbps (2,35Gbps + headers) per PON maximum. Just make sure you confirm that information with your ISP before expending money on an equipment that is not going to give you the end result that you ...
by victorsoares
Fri Mar 01, 2019 8:20 pm
Forum: Forwarding Protocols
Topic: Force single IP through one BGP
Replies: 1
Views: 288

Force single IP through one BGP

Hello everyone! I come here today because I can't think of nothing else. I have 3 BGP sessions, 2 from other link providers and 1 that connects our prefixes to the next city, where we have another base. In one of the cities I have 3 CMTS (coaxial) connected, and I wanted them to use a specific BGP s...
by victorsoares
Mon Dec 03, 2018 2:30 pm
Forum: Announcements
Topic: Tik App, MikroTik android utility ALPHA test
Replies: 424
Views: 142470

Re: Tik App, MikroTik android utility ALPHA test

Hi, I just bought a new phone with the android one thing, a Xiaomi MI A2 Lite, running android 8.1.0, on my last phone the app was working great, but on this one I'm able to log in to any equipment except CCR's. It gets stuck on "Downloading plugins" and if I check the log it says that I successfull...
by victorsoares
Mon Nov 26, 2018 4:01 pm
Forum: General
Topic: Hacked or Forgotten Password
Replies: 2
Views: 283

Re: Hacked or Forgotten Password

Depending on the version that these mikrotiks are running, you might want to try an older version of winbox too.
by victorsoares
Wed Nov 14, 2018 8:02 pm
Forum: General
Topic: Static IP on single interface which is member of a bridge
Replies: 3
Views: 401

Re: Static IP on single interface which is member of a bridge

It sounds to me that you have a second equipment on port 5, if you just want to communicate with that equipment you can create a static route to this equipment. Again, I don't know your layout, but maybe you can change the 192.168.254.254/30 IP to something in your DHCP range as well? There are many...
by victorsoares
Wed Nov 07, 2018 5:16 pm
Forum: General
Topic: VPN with Linux
Replies: 4
Views: 982

Re: VPN with Linux

I had the same issue a while ago. I managed to get it working installing on my (Linux Mint Tara) strongswan with network-manager-l2tp. I'm using L2TP with IPSEC, just make sure to insert on your Linux what encryption algorithms you are using.
by victorsoares
Mon Nov 05, 2018 1:52 pm
Forum: General
Topic: Firmware upgrade?
Replies: 3
Views: 395

Re: Firmware upgrade?

Usually I do the firmware upgrade first, since it waits for you to reboot, and then I do the software upgrade. Only after that I'll reboot the system. I never had any problems doing this, but I'm not sure if it is the correct way.
by victorsoares
Wed Oct 24, 2018 7:27 pm
Forum: Beginner Basics
Topic: Choosing the right router for the job
Replies: 5
Views: 581

Re: Choosing the right router for the job

As you mentioned on your post, you are from a third world country. I'm too from a third world country, and in my case it's pretty easy to find used quality mikrotiks on the internet. I had a similar case to yours, and a RB2011 iLS was more than enough horsepower to pull through all the queues, firew...
by victorsoares
Mon Oct 15, 2018 10:20 pm
Forum: Beginner Basics
Topic: [ASK]Can't access some website "this site can't be reached"
Replies: 14
Views: 1177

Re: [ASK]Can't access some website "this site can't be reached"

It looks like you get your internet through PPPoE. In that case MTU varies between 1480 and 1492 normally. Also, try clamping your mss with your pmtu with a simple rule like this: /ip firewall mangle add action=change-mss chain=forward new-mss=clamp-to-pmtu out-interface="WAN" passthrough=yes protoc...
by victorsoares
Mon Oct 08, 2018 7:09 pm
Forum: Scripting
Topic: Script to change SimpleQueues target addresses
Replies: 2
Views: 425

Re: Script to change SimpleQueues target addresses

I think the easiest solution would be to export your queues to a file and, with a good text editor, just select and substitute whatever you might want to change. Then just delete your queues and import the edited ones.
by victorsoares
Wed Oct 03, 2018 2:39 pm
Forum: General
Topic: Please Urgent : Need Help with Vlans and DHCP on RB with 6.43
Replies: 3
Views: 260

Re: Please Urgent : Need Help with Vlans and DHCP on RB with 6.43

I'm not seeing an "/ip dhcp-server configuration" in your export. Do you have one?
by victorsoares
Tue Oct 02, 2018 10:50 pm
Forum: Beginner Basics
Topic: Routing problems
Replies: 4
Views: 401

Re: Routing problems

tumblr is not a good example, it blocks ping requests, as some other sites do too. can you navigate on those sites? Also, please put your firewall rules (ip firewall filter export hide-sensitive) so we have a better idea of what might be going on.
by victorsoares
Fri Sep 28, 2018 10:11 pm
Forum: Beginner Basics
Topic: BGP route filters
Replies: 6
Views: 648

Re: BGP route filters

Nevermind the BGP AS Patch field, you will set this on your BGP Peers, as for the local pref, Mikrotik works only with positive numbers, it does not understand negatives or positives. You might want to go with something like 100 for your main ISP and 10 to your secondary, if there is any. If there i...
by victorsoares
Tue Sep 25, 2018 4:08 pm
Forum: Beginner Basics
Topic: Newbie question about bridge mode and management of the device in that mode. [SOLVED]
Replies: 8
Views: 809

Re: Newbie question about bridge mode and management of the device in that mode. [SOLVED]

I'm not quite sure if I understood exactly your setup, but if you want to access both equipment you will need to set different IP's for them, or else you will only see the first device next to you.
by victorsoares
Tue Sep 25, 2018 3:40 pm
Forum: Beginner Basics
Topic: How to Monitor specific Ip
Replies: 5
Views: 622

Re: How to Monitor specific Ip

Well if this is a site that contains only one host IP it's easy, but if it is something like facebook, with multiple hosts, just mark the connection and then create a log rule on firewall over this connection mark, like so: /ip firewall mangle add chain=forward action=mark-connection new-connection-...
by victorsoares
Mon Sep 24, 2018 10:08 pm
Forum: General
Topic: I am Not a Robbot
Replies: 17
Views: 1222

Re: I am Not a Robbot

Do you get a public IP from your ISP? Use something like iptracker on that IP to check if it really belongs to your internet provider. My guess is that your ISP is doing some messed up NAT and that might cause this issue. Just to be clear, most sites will think that you are a robot if there are too ...
by victorsoares
Mon Sep 24, 2018 1:49 am
Forum: Beginner Basics
Topic: Xbox One NAT woes
Replies: 5
Views: 3586

Re: Xbox One NAT woes

Is this solved? I myself got a headache with this, being a certified MK consultant with years of experience I was starting to doubt my abilities. What solved for me was a simple rule. The big problem with this thing is that Microsoft doesn't show on it's support page the correct ports to be redirect...
by victorsoares
Thu Aug 30, 2018 10:02 pm
Forum: General
Topic: How to downgrade the ROS below the factory version?
Replies: 5
Views: 628

Re: How to downgrade the ROS below the factory version?

May I ask why downgrade to such a vulnerable version? Wouldn't be better to upgrade the other equipment if having the same version on all hardware is important? I wouldn't have any of my mk's on anything below the latest bugfix these days.
by victorsoares
Wed Aug 29, 2018 4:32 pm
Forum: Beginner Basics
Topic: DNS issue
Replies: 6
Views: 1830

Re: DNS issue

Do you have any ICPM rules? Try posting your /ip firewall here so we can help you.
by victorsoares
Mon Aug 27, 2018 4:54 pm
Forum: Forwarding Protocols
Topic: HELP - BGP dynamic route flickering [SOLVED]
Replies: 6
Views: 765

Re: HELP - BGP dynamic route flickering [SOLVED]

Still not sure of what was going on there, but today I re enabled the filter that gave me the dynamic route 0.0.0.0/0 and everything is working fine. Link provider told me everything was good on their end, but I still think that they found something like redrawn error and fixed, and now they won't a...
by victorsoares
Fri Aug 24, 2018 8:21 pm
Forum: Forwarding Protocols
Topic: HELP - BGP dynamic route flickering [SOLVED]
Replies: 6
Views: 765

Re: HELP - BGP dynamic route flickering [SOLVED]

@Vooray You use multihop for bgp - is route to peer address stable? Yes, it's stable. You use update source vlan_nip_ubatuba. Is it stable? Yes, stable too. Do you have anything interensting in your logs? Yes! time=14:13:38 topics=route,bgp,debug,packet message=" WithdrawnRoutes=0.0.0.0/0" time=14:1...
by victorsoares
Fri Aug 24, 2018 5:03 pm
Forum: Forwarding Protocols
Topic: HELP - BGP dynamic route flickering [SOLVED]
Replies: 6
Views: 765

HELP - BGP dynamic route flickering [SOLVED]

Hi everyone and sorry for the capital letters on the post, but I really don't know what to do now. It's been two days since the dynamic route of one of my BGP connections appears and disappears constantly. I have a static route for this too, but still this is causing me some trouble, since this BGP ...
by victorsoares
Wed Aug 22, 2018 9:15 pm
Forum: General
Topic: Netwatch through specific interface
Replies: 0
Views: 299

Netwatch through specific interface

Hi everyone,

Is it possible to make Netwatch ping an IP through an especific interface, like we can do with /ping interface=eher1 10.1.1.1?
by victorsoares
Tue Aug 14, 2018 2:55 pm
Forum: General
Topic: Migrating to IPv6
Replies: 3
Views: 390

Re: Migrating to IPv6

Thanks so much for the answer, it really helped me. I do not work with NAT now, only public IPv4's for all my clients, and I want to keep it that way, that's why I don't want to go the CGNAT route. My traffic providers already work with IPv6, so that's pretty much covered. Now what is left for me is...
by victorsoares
Tue Aug 14, 2018 2:13 pm
Forum: General
Topic: Migrating to IPv6
Replies: 3
Views: 390

Migrating to IPv6

Hello! I currently have about 2000 pppoe clients in a CCR 1036+ and two BGP sessions on a CCR1072. All is fine and working, but the time to migrate from IPv4 to IPv6 is upon us, and I wonder what kind of moddifications are in place to go this way. Is the equipment going to be able to handle IPv6? Is...
by victorsoares
Mon Aug 13, 2018 3:47 pm
Forum: Forwarding Protocols
Topic: BGP Failover issues
Replies: 6
Views: 732

Re: BGP Failover issues

Thank you for your help. I already tried prepending, and it got me to a certain point, but I think that the de-aggregation might be the best way. I'll try this and see how it works. Thanks again for the help!
by victorsoares
Sun Aug 12, 2018 12:34 am
Forum: Forwarding Protocols
Topic: BGP Failover issues
Replies: 6
Views: 732

Re: BGP Failover issues

Traffic coming upstream, downstream is pretty much sorted at this point. I just want that RX on my links goes to BGP 1 (superimagem)
by victorsoares
Fri Aug 10, 2018 6:05 pm
Forum: Forwarding Protocols
Topic: BGP Failover issues
Replies: 6
Views: 732

Re: BGP Failover issues

I'm sorry, completely forgot to talk about the issue itself. The thing is that when both sessions are up, BGP 2 (NIP) gets more traffic that BGP 1, and it should be the opposite.
by victorsoares
Fri Aug 10, 2018 5:44 pm
Forum: Forwarding Protocols
Topic: BGP Failover issues
Replies: 6
Views: 732

BGP Failover issues

Hello everyone. Let me try to explain my scenario. I have two BGP sessions from two different AS coming to my CCR1072-1G-8S+. Both of them are active and working. They both have the same speeds (3Gbps full). I want to make BGP 1 (superimagem) primary and BGP 2 (nip) secondary. I have set BGP weight,...
by victorsoares
Thu Aug 02, 2018 3:03 pm
Forum: General
Topic: Can't transmit more then 600MB
Replies: 0
Views: 228

Can't transmit more then 600MB

Hi everyone, I have a VLAN that goes through two CCR1072+ on a SFP+ 10Gb fiber. This is for a failover that I have and it works great, I can push 10Gb with no problem when I need to. The thing is that I can see in live production working, but I can't do a bandwith test that shows this. I tried nPerf...
by victorsoares
Mon Jul 30, 2018 2:22 pm
Forum: General
Topic: Mikrotik PPPOE SERVER WAN Addresses
Replies: 10
Views: 724

Re: Mikrotik PPPOE SERVER WAN Addresses

I think CGNAT would be the way to go, or try setting up manually different IP ranges and srcnat them with each one of your public IP's.
by victorsoares
Thu Jul 26, 2018 3:09 pm
Forum: Beginner Basics
Topic: Good firewall practices
Replies: 1
Views: 370

Good firewall practices

Hi everyone and thank you for reading this, I have two routers in an ISP that I control. The first one is a border router, an CCR1072 and after that one I have a CCR1036+ that handles my pppoe clients. My doubt is, witch of the routers has to have firewall rules? Both? Are they going to be the same ...
by victorsoares
Thu Jul 26, 2018 2:51 pm
Forum: General
Topic: CCR1072 doesn't ping [SOLVED]
Replies: 2
Views: 309

Re: CCR1072 doesn't ping [SOLVED]

Well, anyway. Problem solved by scheduling a reboot during the night. Everything working fine now. Thanks again.
by victorsoares
Wed Jul 25, 2018 4:23 pm
Forum: General
Topic: CCR1072 doesn't ping [SOLVED]
Replies: 2
Views: 309

CCR1072 doesn't ping [SOLVED]

Hi everyone. Something strage happened this morning with my CCR1072-1G-8S+ running RoS 6.37.4. No changes were made in anyway, and everything seems to work fine as usual, but I can't ping any IP unless I use ARP ping. I tried disabling my firewall rules and changing my DNS but had no success. Has an...
by victorsoares
Thu Jul 19, 2018 3:08 pm
Forum: Scripting
Topic: Copy dynamic pppoe interfaces
Replies: 0
Views: 352

Copy dynamic pppoe interfaces

Hi everyone, I'm trying to make a script that copies all my pppoe interfaces and make them static, so I can monitor them on a Zabbix server. So far I had no success doing it, but I'm not very good with it anyway... This script should do that only for connections that have not been copied already, so...
by victorsoares
Wed Jul 18, 2018 3:36 pm
Forum: General
Topic: No response on snmpwalk
Replies: 0
Views: 277

No response on snmpwalk

Hello again everyone, I'm setting up a Zabbix server here, and everything is working fine. I have two CCR1036+ and two CCR1072. I'm running the same templates on everyone of them but with one CCR1072 I'm not having any response to snmp. Community is set to the default public and I already tried disa...
by victorsoares
Mon Jul 02, 2018 3:11 pm
Forum: Beginner Basics
Topic: Change external IP
Replies: 1
Views: 276

Re: Change external IP

Do you have this virtual machine set to dynamic ip? if so, then you need to change de value on ip-addresses set on your mikrotik. If you have a range of IP's on your mikrotik (assuming you have one) set to the interface that your physical machine is connected, then you need to change the ip on the a...
by victorsoares
Thu Jun 28, 2018 2:41 pm
Forum: The Dude
Topic: SNMP in SwOs doesn't work
Replies: 2
Views: 594

Re: SNMP in SwOs doesn't work

Have you tried v2c public?
by victorsoares
Thu Jun 28, 2018 2:40 pm
Forum: The Dude
Topic: SNMP not responce
Replies: 2
Views: 528

Re: SNMP not responce

Can you post your snmp settings and firewall settings?
by victorsoares
Thu Jun 28, 2018 2:38 pm
Forum: RouterBOARD hardware
Topic: Password retrieval for RB951i-2HnD
Replies: 3
Views: 439

Re: Password retrieval for RB951i-2HnD

It might be possible if you find an unencrypted backup of this RB somewhere.
by victorsoares
Wed Jun 27, 2018 3:34 pm
Forum: General
Topic: Remove script action from log
Replies: 0
Views: 197

Remove script action from log

Hello everyone. Maybe you guys can shine a light on this for me. It isn't exactly a problem, it's more of an annoying thing. I have a script that runs every 30 sec on my CCR 1072. It's just pinging an IP and spitting a enable=yes ou no depending on the result. It works fine, but I get the memory log...
by victorsoares
Tue Jun 19, 2018 5:47 pm
Forum: Forwarding Protocols
Topic: BGP Bonding
Replies: 5
Views: 816

Re: BGP Bonding

I'll try that, thanks for the help!
by victorsoares
Fri Jun 15, 2018 2:48 pm
Forum: General
Topic: MTU correct size
Replies: 1
Views: 279

MTU correct size

Hello, I've put together a setup in my house for testing, and it's working, but I think it could be better. It's basically a dedicated IP that comes from the ISP where I work at. It comes home throught an ONU and then to a RB2011. After this I have a simple router in bridge mode to provide a wireles...
by victorsoares
Fri Jun 15, 2018 2:33 pm
Forum: Forwarding Protocols
Topic: BGP Bonding
Replies: 5
Views: 816

Re: BGP Bonding

I've tried routing, but for some reason when I enabled full route with BGP CPU usage on my CCR went up and eventually crashed. I found that having two BGP's running full route at the same time is too much for the poor thing.
by victorsoares
Thu Jun 14, 2018 6:06 pm
Forum: General
Topic: Passing public IPs to some PPPoE Users
Replies: 4
Views: 653

Re: Passing public IPs to some PPPoE Users

The basic setup would to set the /27 public IP on the mikrotik, and then put this IP's on the pppoe pool. I don't know how to set this on your radius server, but the main thing is to get MK to receive those IP addresses so they can be used.
Can you post your NAT rules?
by victorsoares
Thu Jun 14, 2018 5:51 pm
Forum: Forwarding Protocols
Topic: BGP Bonding
Replies: 5
Views: 816

BGP Bonding

Hello everyone, and thanks in advance for any help. I have two BGP sessions on my CCR 1072 for redundancy. Right now I have a script working that deactivates BGP-2 if BGP-1 has ping. I don't like this solution because it screws with my history. And I don't think that is the way to go anyway. Is it p...
by victorsoares
Wed Jun 13, 2018 10:55 pm
Forum: General
Topic: Cannot access some sites [SOLVED]
Replies: 6
Views: 666

Re: Cannot access some sites [SOLVED]

Finally I found out what was going on. I was missing a rule to change mss. After the rule was applied everything started working fine. Here is how I put the rule. /ip firewall mangle print detail Flags: X - disabled, I - invalid, D - dynamic 0 chain=forward action=change-mss new-mss=clamp-to-pmtu pa...
by victorsoares
Wed Jun 13, 2018 2:18 pm
Forum: General
Topic: Cannot access some sites [SOLVED]
Replies: 6
Views: 666

Re: Cannot access some sites [SOLVED]

Is there a way to analyze that? I tried creating a change MSS rule but had no success either.
by victorsoares
Tue Jun 12, 2018 10:24 pm
Forum: General
Topic: Cannot access some sites [SOLVED]
Replies: 6
Views: 666

Re: Cannot access some sites [SOLVED]

I'm using Google's DNS, 8.8.8.8 and 8.8.4.4. Tried Cloudflare's DNS too, but no success.
by victorsoares
Tue Jun 12, 2018 8:51 pm
Forum: General
Topic: Cannot access some sites [SOLVED]
Replies: 6
Views: 666

Re: Cannot access some sites [SOLVED]

Another thing, I can ping to websites like www.crucial.com from the RB and from my desktop, but cannot access the website never or less.
by victorsoares
Tue Jun 12, 2018 8:37 pm
Forum: General
Topic: Cannot access some sites [SOLVED]
Replies: 6
Views: 666

Cannot access some sites [SOLVED]

Hi everyone, I'm testing a rB2011 iLS with a dedicated IP address that the company I'm working with is going to provide to some customers. Everything works fine, but I can't access some websites like netflix.com and clarin.com. I have no ideia of what is going on. I have no rules set on my firewall....
by victorsoares
Tue May 08, 2018 4:48 pm
Forum: Forwarding Protocols
Topic: Force proxy traffic with BGP
Replies: 1
Views: 393

Force proxy traffic with BGP

Hi everyone, Let me explain my scenario, I'll put the diagram below for better understanding. I have two cities connected. City 1 has a link connected to a CCR1036-8G-2S+ (BGP) City 1 has a BGP to City 2 City 2 has a proxy that can be turned into a link when requested (BGP as well) City 2 has a CCR1...
by victorsoares
Tue May 08, 2018 4:11 pm
Forum: The Dude
Topic: Link Full
Replies: 4
Views: 1061

Re: Link Full

"Full Link" means that you have the same Tx and Rx speed on the interface.
by victorsoares
Wed Apr 25, 2018 3:46 pm
Forum: Beginner Basics
Topic: PPPoE clients disappear
Replies: 0
Views: 257

PPPoE clients disappear

Hi everyone, how are you? I'm having a problem in the last few days where some PPPoE clients are created and after a while they disappear. In history and in the log nothing is shown, so I don't actually have a way of knowing what exactly is going on. This are my configs, I'm using a CCR1036-12G-4S r...
by victorsoares
Tue Apr 24, 2018 11:00 pm
Forum: Beginner Basics
Topic: 200mb-3km configuration(noob)
Replies: 3
Views: 353

Re: 200mb-3km configuration(noob)

I think he meant RBSXT-5nDr2, that thing should be good for 10km, I personally never gave it a try, but by the specifications and by some posts here it seems possible. I would use CPE for this.
Maybe this will help you: viewtopic.php?t=48885
by victorsoares
Fri Apr 20, 2018 8:40 pm
Forum: RouterBOARD hardware
Topic: 1Gb SFP failing in SPF+ slots
Replies: 4
Views: 914

Re: 1Gb SFP failing in SPF+ slots

Have you tried to use another fiber? I've had problems with brand new fiber cords already, where for some reason they atenuate randomly. Check the temperatures and voltages on the doors too.
by victorsoares
Tue Mar 27, 2018 11:52 pm
Forum: Scripting
Topic: Send message to Winbox user on login
Replies: 2
Views: 536

Re: Send message to Winbox user on login

The thing is I'm not in the company very long, and I don't know who exactly uses the Mikrotik, neither my bosses are 100% sure (there are several people and several MK's in different parts of the country). That's why I needed to inform the user when he logged in.
by victorsoares
Tue Mar 27, 2018 11:34 pm
Forum: Beginner Basics
Topic: E-mail timeout
Replies: 1
Views: 250

E-mail timeout

Hi everyone, I was told by my bosses to set an automatic backup daily for our MK's. I configured an GMail account and it works fine. Then I moved to the scripts. It seems like everything is working fine, but I only get sucess in 1 out of 10 tries. The other times I get an timeout error while sending...
by victorsoares
Tue Mar 27, 2018 3:50 pm
Forum: Scripting
Topic: Send message to Winbox user on login
Replies: 2
Views: 536

Send message to Winbox user on login

Hi everyone, I have a situation where a CCR1036 is used by a lot of people, but there is only one user. That makes reading a log and finding out who did what almost impossible. The simple solution is to create users for everyone, but some of the people that use this MK aren't exactly "reachable", in...
by victorsoares
Mon Mar 19, 2018 8:26 pm
Forum: Beginner Basics
Topic: Prevent PPPoE from doing brute force
Replies: 3
Views: 644

Prevent PPPoE from doing brute force

Hello everyone, I tried to find out more about it but couldn't find much information. I have a CCR1036-8G-2S+ that I use for my PPPoE clients. Everything works fine, but I'm having some security issues with some of my clients lately. I think that a couple of my PPPoE clients are infected and are now...
by victorsoares
Thu Mar 15, 2018 7:41 pm
Forum: General
Topic: btest - Where Is
Replies: 7
Views: 44071

Re: btest - Where Is

I've downloaded btest a week ago from Mikotik's website, yesterday I tried to download the exe again in a client and didn't find it. Softpedia still has it available. I hope that this isn't the end of the application.
by victorsoares
Thu Feb 15, 2018 6:37 pm
Forum: General
Topic: Interface graphing cuts off at 2Gbps
Replies: 0
Views: 309

Interface graphing cuts off at 2Gbps

Hi everyone, I was wondering if anyone could help me. I have a RouterOS 6.39.1 that takes our 3Gbps link and distributtes to the PPP clients and other things. The 'problem' is that we usually have a graphing on the interface opened up so we can see if we need to buy more bandwith or not. The graphin...