Community discussions

MikroTik App

Search found 18 matches

by hugues
Thu Jun 25, 2020 12:11 am
Forum: RouterBOARD hardware
Topic: CCR2004 : BGP Benchmarks
Replies: 41
Views: 9806

Re: CCR2004 : BGP Benchmarks

No, sorry, my 2004 is in production now :)
by hugues
Thu Jun 04, 2020 8:23 pm
Forum: RouterBOARD hardware
Topic: CCR2004 : BGP Benchmarks
Replies: 41
Views: 9806

Re: CCR2004 : BGP Benchmarks

My 2004 is already in production, but i still have the CCR100X and the 4011 to lab the v7... For the moment, i'm trying to understand the new CLI...
by hugues
Thu Jun 04, 2020 7:13 pm
Forum: RouterOS v7 BETA
Topic: Enable BGP on ROSv7
Replies: 14
Views: 4382

Re: Enable BGP on ROSv7

So, you need BGP into ROS7 to peer to a virtual IXP (a bit useless to me) behind NAT ? You are running a multihomed network behind NAT ? That's crappy !

Btw VxLAN in ROS7 only supports Multicast IIRC, so, it will not work, even with BGP.
by hugues
Thu Jun 04, 2020 4:28 pm
Forum: RouterOS v7 BETA
Topic: v7.0beta8 [development] is released!
Replies: 180
Views: 64235

Re: v7.0beta8 [development] is released!

A basic ibgp configuration :

/routing bgp template
add as=65534 name=lab
/routing bgp connection
add local.role=ibgp remote.address=10.X.X.X template=lab
by hugues
Mon May 25, 2020 5:13 pm
Forum: RouterBOARD hardware
Topic: CRS326--CRS326, SFP+ only ~700mbit via 10gbit link. Slow performance or bottleneck?
Replies: 7
Views: 1522

Re: CRS326--CRS326, SFP+ only ~700mbit via 10gbit link. Slow performance or bottleneck?

Or you can read the test results on the MikroTik Website and see that the switch is benched for ~1Gbit/s of L3 traffic.
by hugues
Fri May 15, 2020 12:21 am
Forum: Forwarding Protocols
Topic: BGP, unexplained behavior
Replies: 4
Views: 959

Re: BGP, unexplained behavior

Huh, no. The selection is done in random if all the other attributes used by the bgp path selection are the same or does not exist !
by hugues
Thu May 14, 2020 6:08 pm
Forum: RouterBOARD hardware
Topic: CCR2004 : BGP Benchmarks
Replies: 41
Views: 9806

Re: CCR2004 : BGP Benchmarks

Same here, around 30 CCRs 1072&1036 in production, around 5Gbps in peak, no reboot issues...
by hugues
Tue May 12, 2020 9:17 pm
Forum: RouterBOARD hardware
Topic: CCR2004 : BGP Benchmarks
Replies: 41
Views: 9806

Re: CCR2004 : BGP Benchmarks

You can reach 80gbps of unrealistic traffic with a 1072, but with real traffic, it begins to lost packets with a fraction of the max throughput. :?
by hugues
Tue May 12, 2020 5:09 pm
Forum: RouterBOARD hardware
Topic: CCR2004 : BGP Benchmarks
Replies: 41
Views: 9806

Re: CCR2004 : BGP Benchmarks

I simulated a big bgp flap (2 sessions reset + 1 added). It is better than a Tilera, but still miles above a decent router : it took about 40 minutes to process all the routes to the CCR2004 it took about 1h23 to process all the routes to the CCR1016 It took about 2 minutes to process all the routes...
by hugues
Tue May 12, 2020 3:03 pm
Forum: RouterBOARD hardware
Topic: CCR2004 : BGP Benchmarks
Replies: 41
Views: 9806

Re: CCR2004 : BGP Benchmarks

BGP Benchmarks are much better with a lower amount of routes : 1 Full (800k routes): * Insertion : 47 seconds * Removal : 7 seconds 2 Full (1,6M routes): * Insertion : 1 minute 9 seconds * Removal : 39 seconds 3 Full (2,4M routes) : * Insertion : 1 minute 29 seconds * Removal : 3 minutes 4 Full (3,2...
by hugues
Tue May 12, 2020 2:21 pm
Forum: RouterBOARD hardware
Topic: CCR2004 : BGP Benchmarks
Replies: 41
Views: 9806

Re: CCR2004 : BGP Benchmarks

I didn't run any bandwith tests for now, i trust the Mikrotik's Datasheet :)

A bit better with 6.46.6 :

BGP Insertion (4xFullviews, ~3,2M routes) :
CCR2004 : 1m50s

BGP Removal (4xFullviews, ~3,2M routes) :
CCR2004 : 7m30s

But still slower than a 1009 :(
by hugues
Tue May 12, 2020 12:51 pm
Forum: RouterBOARD hardware
Topic: CCR2004 : BGP Benchmarks
Replies: 41
Views: 9806

Re: CCR2004 : BGP Benchmarks

Yes, i am aware of it, i am the author of this topic. You can also see that this current topic is earlier than the answers in the other topic ;)
by hugues
Tue May 12, 2020 3:34 am
Forum: RouterBOARD hardware
Topic: CCR2004 : BGP Benchmarks
Replies: 41
Views: 9806

CCR2004 : BGP Benchmarks

Hello, I just received my new CCR2004 and I couldn't wait to put it in the grill For the record, i also tested few other devices : - CCR1009 (7g-1c-1s+) v6.47b60 - CCR1016 (12s-1s+) v6.47b60 - RB4011 (igs-rm) v6.47b60 The CCR2004 runs its factory version 6.46.3 since there is no other package availa...
by hugues
Tue May 12, 2020 3:12 am
Forum: General
Topic: CCR2004 w/ARM64 : Where to download packages ? [SOLVED]
Replies: 7
Views: 1779

Re: CCR2004 w/ARM64 : Where to download packages ? [SOLVED]

i don't want to risk to brick my new router since the factory version is not downloadable neither :)

The problem is that the router is now available since almost 2 weeks, and in 2 weeks, we should have access to stable or even testing !
by hugues
Mon May 11, 2020 8:45 pm
Forum: General
Topic: CCR2004 w/ARM64 : Where to download packages ? [SOLVED]
Replies: 7
Views: 1779

CCR2004 w/ARM64 : Where to download packages ? [SOLVED]

Hello,

i just received my new fancy CCR2004, but there is a little problem :

Image

You can't download any image, except long term, which is prior to the factory version (wtf ?)

Same thing on the Mikrotik Downloads page...

Hugues
by hugues
Thu Apr 25, 2019 10:18 am
Forum: General
Topic: Feature request: Virtual Extensible LAN (VXLAN)
Replies: 30
Views: 15436

Re: Feature request: Virtual Extensible LAN (VXLAN)

+1 for vxlan, it's a must have in 2019 ! (but it was in 2017 too...)
by hugues
Sun Mar 17, 2019 2:33 am
Forum: General
Topic: v6 RC and v7 BETA
Replies: 126
Views: 31819

Re: v6 RC and v7 BETA

Don't hope any BGP Multithreading, because it is useless (bgp is slow because of Tilera cores, and multithreading route injection in FIB is a mess), i just hope for better routing filters, i have sooooo many problems with the current implementation...
by hugues
Wed Feb 28, 2018 5:48 pm
Forum: General
Topic: New router OS
Replies: 46
Views: 15401

Re: New router OS

BGP4-MIB support on SNMP would be great too...