Community discussions

MikroTik App

Search found 39 matches

by iredden
Sat Jun 09, 2018 4:36 pm
Forum: General
Topic: Need recommendations on a FAST mikrotik box (1Gb link)
Replies: 8
Views: 2279

Need recommendations on a FAST mikrotik box (1Gb link)

I've come to the realization, I need more speed! REF: https://forum.mikrotik.com/viewtopic.php?f=2&t=132537 REF: https://forum.mikrotik.com/viewtopic.php?f=2&t=135434 REF: https://forum.mikrotik.com/viewtopic.php?f=2&t=135425 Providers Modem: http://www.dslreports.com/speedtest/34420003.png * note t...
by iredden
Sat Jun 09, 2018 3:28 pm
Forum: General
Topic: port forwarding help needed - 2 WAN's
Replies: 13
Views: 1240

Re: port forwarding help needed - 2 WAN's

Thx Sindy, I gathered that as well. I put a sniffer on 'devbox' (my secondary pppoe interface), and performed a ping. I see the ping (dst 8.8.8.8, src 174.xx.83.83). This tells me the connection marking and routing is working. I also see the nat rule (Outbound NAT for 192.168.2.4) working. However, ...
by iredden
Sat Jun 09, 2018 12:24 am
Forum: General
Topic: USB 3.0 Ethernet
Replies: 0
Views: 427

USB 3.0 Ethernet

Which USB 3.0 ethernet adapters work with RouterOS?

I have an Intel NUC that I'd like to use as my router. When I boot from netinstall, I get the no network adapters found error.

Thanks!
by iredden
Fri Jun 08, 2018 10:45 pm
Forum: General
Topic: port forwarding help needed - 2 WAN's
Replies: 13
Views: 1240

Re: port forwarding help needed - 2 WAN's

Still similar behavior even with routes added. I was 'adding default route' on the pppoe client. Route /ip route add distance=1 gateway=devbox routing-mark=devbox-rm add distance=1 gateway=synology routing-mark=synology-rm add distance=1 gateway=pppoe-out1 /ip firewall filter add action=accept chain...
by iredden
Fri Jun 08, 2018 8:07 pm
Forum: General
Topic: port forwarding help needed - 2 WAN's
Replies: 13
Views: 1240

Re: port forwarding help needed - 2 WAN's

That only half works. Here is my configuration: /ip firewall filter add action=accept chain=input protocol=icmp add action=accept chain=input connection-state=established add action=accept chain=input connection-state=related add action=drop chain=input in-interface-list=!LAN log=yes add action=fast...
by iredden
Fri Jun 08, 2018 5:25 pm
Forum: General
Topic: port forwarding help needed - 2 WAN's
Replies: 13
Views: 1240

Re: port forwarding help needed - 2 WAN's

this works, but is not 100% what I want: /ip firewall nat add action=masquerade chain=srcnat comment="main nat" dst-address=!192.168.2.1 out-interface-list=WAN src-address=192.168.2.0/24 add action=masquerade chain=srcnat comment=PORT-FORWARD-80-INTERNAL dst-address=192.168.2.10 dst-port=80 out-inte...
by iredden
Fri Jun 08, 2018 5:13 pm
Forum: General
Topic: port forwarding help needed - 2 WAN's
Replies: 13
Views: 1240

port forwarding help needed - 2 WAN's

Hi Mikrotik Forums! I need help with NAT/Hairpin NAT. /ip firewall nat add action=masquerade chain=srcnat comment="main nat" dst-address=!192.168.2.1 out-interface-list=WAN src-address=192.168.2.0/24 add action=dst-nat chain=dstnat comment=PORT-FORWARD-80 protocol=tcp dst-port=80 dst-address=!192.16...
by iredden
Thu Mar 29, 2018 8:54 pm
Forum: General
Topic: Slow speeds on Gigabit Fiber (MTU/MSS Issue?)
Replies: 2
Views: 1874

Re: Slow speeds on Gigabit Fiber (MTU/MSS Issue?)

dude! Fixed.
by iredden
Thu Mar 29, 2018 4:22 pm
Forum: General
Topic: Slow speeds on Gigabit Fiber (MTU/MSS Issue?)
Replies: 2
Views: 1874

Slow speeds on Gigabit Fiber (MTU/MSS Issue?)

Hi Forums! I have a Routerboard HAP-AC with a fairly vanilla configuration. For Internet, I am using a PPPOE client attached to VLAN 35. I connect, my machines behind the unit have Internet access and everything seems fine. However, the speed is considerably less than what I get directly connected t...
by iredden
Thu Feb 22, 2018 12:18 am
Forum: General
Topic: CALEA/TZSP/Sniffing
Replies: 0
Views: 703

CALEA/TZSP/Sniffing

Hi There! Hopefully someone can help me figured this one out. I have a CRS125 that has no configuration on it other than a single bridge (bridge1) that all ports belong to it. It also has a dhcp-client for obtaining an IP configuration from the LAN - 192.168.1.246. It's named 'switch'. I setup a pac...
by iredden
Tue Jan 31, 2017 4:37 am
Forum: General
Topic: Need IPv6 help getting DHCP v6 working
Replies: 6
Views: 1397

Re: Need IPv6 help getting DHCP v6 working

You could add DHCPv6 server on RouterOS and configure it to hand out prefixes (with /56, you have enough to do it). Then on another machine you'd use DHCPv6 client to get prefix and then finally DHCPv6 server to give out addresses. Do you have an example? I have 2 hAP AC's back to back. One is the ...
by iredden
Tue Jan 31, 2017 12:18 am
Forum: General
Topic: Need IPv6 help getting DHCP v6 working
Replies: 6
Views: 1397

Re: Need IPv6 help getting DHCP v6 working

How would I get the pool into a separate dhcp v6 server to supply my hosts?

I added the addresses to the interfaces.
by iredden
Mon Jan 30, 2017 4:04 pm
Forum: General
Topic: Need IPv6 help getting DHCP v6 working
Replies: 6
Views: 1397

Need IPv6 help getting DHCP v6 working

Hi All, My ISP finally is giving out IPv6 addresses and a /56!! My hAP AC test box gets an address, throw the /56 to the pool and does not serve clients addresses. [admin@Router] /ipv6 pool> print detail Flags: D - dynamic 0 D name="rogers-ipv6" prefix=AAAA:AAAA:AAAA:A00::/56 prefix-length=56 expire...
by iredden
Thu Apr 17, 2014 8:20 pm
Forum: General
Topic: Routerboard w/ VPN Client to IPSEC/L2TP Server
Replies: 0
Views: 742

Routerboard w/ VPN Client to IPSEC/L2TP Server

Hello, I am interested in RouterBoard products as I have used them in the past and always were reliable routers packed with tons of features. The router I am interested in is the cloud core router. The infrastructure looks like: -[ INTRANET CLOUD ]---[ CCR ROUTER AND GATEWAY ]----------[ GIGANEWS VY...
by iredden
Fri Apr 26, 2013 1:59 am
Forum: General
Topic: Problem load balancing (PCC) with IP's assigned by DHCP
Replies: 0
Views: 736

Problem load balancing (PCC) with IP's assigned by DHCP

Here is the scenario: WAN1 IP: 1.114.229.3/22 Gateway: 1.114.228.1 WAN2 IP: 1.230.160.168/27 Gateway: 1.230.160.161 I have DHCP-client setup the following: /ip dhcp-client add add-default-route=yes default-route-distance=1 disabled=no host-name=router interface=WAN1 use-peer-dns=no use-peer-ntp=no a...
by iredden
Sat Jan 07, 2006 6:30 pm
Forum: General
Topic: Argh, MAC Address mangling / queue
Replies: 7
Views: 2451

I'll give that a try, but might take some time to script/implement.

Thanks.

--Ian.
by iredden
Sat Jan 07, 2006 7:12 am
Forum: General
Topic: Argh, MAC Address mangling / queue
Replies: 7
Views: 2451

Yes you can, but what would stop someone from changing their IP to a static IP to have full speed?
by iredden
Sat Jan 07, 2006 1:57 am
Forum: General
Topic: Argh, MAC Address mangling / queue
Replies: 7
Views: 2451

Argh, MAC Address mangling / queue

We require to be able to shape on our system by MAC address and have separate differing upload and download speeds. However, the current rules I have grabbed from the documentation to tag packets by MAC, appear to treat all traffic as both rather than upload and download. Here are the rules we are c...
by iredden
Fri Jan 06, 2006 8:29 am
Forum: Scripting
Topic: [CONTRIB] php/snmp wireless signal levels
Replies: 4
Views: 3032

Works on 2.9.10.

email me at razorjack at gmail dot com
I'll give ya a hand getting it working.
by iredden
Thu Dec 22, 2005 5:20 am
Forum: Scripting
Topic: [CONTRIB] php/snmp wireless signal levels
Replies: 4
Views: 3032

[CONTRIB] php/snmp wireless signal levels

Wrote this for fun! Wanting to graph signal levels externally in RRDTOOL. Enjoy! ps -- Mikrotik 2.8.28, PHP 4.4.1, and NET-SNMP 5.1 <pre> <?php # /-----------------------------------\ # | Written By: Ian Redden | # | Date: December 21st, 2005 | # \-----------------------------------/ # # $host = ip ...
by iredden
Mon Dec 19, 2005 10:12 pm
Forum: Scripting
Topic: Add Simple Queues from MySQL Table
Replies: 2
Views: 1657

For a small fee (im a starving student) I can coding one up for ya.

razorjack at gmail {dot) com
by iredden
Mon Nov 28, 2005 4:27 am
Forum: Wireless Networking
Topic: 2.9.XXX nightmares.
Replies: 4
Views: 2078

nov/15/2005 22:43:07 system started nov/15/2005 22:43:08 Prism firmware loading: OK nov/15/2005 22:43:08 omni-wireless: 00:12:17:CD:BA:47 connected nov/15/2005 22:43:09 omni-wireless: 00:0C:41:3A:3E:9C connected nov/15/2005 22:43:09 home-link: unauth or missing data sender, 00:02:6F:39:65:14 > nov/1...
by iredden
Mon Nov 28, 2005 1:06 am
Forum: Wireless Networking
Topic: 2.9.XXX nightmares.
Replies: 4
Views: 2078

2.9.XXX nightmares.

What card FULLY supports 2.9 with no side-effects? We are currently using 2.9 with Prism Cards, and also the Netgear WGT311 (which with more than 15 users, has severe lag or packet loss problems). The issues on the netgear is almost like someone has skewed the MSS/MTU setting on the Mikrotik. Our am...
by iredden
Sat Sep 03, 2005 7:22 am
Forum: Wireless Networking
Topic: 2.9/Prism AP problems
Replies: 14
Views: 4890

We are having the exact same issues. Our CPE devices are everything from OpenWRT WRT54G's, Tranzeo CPE's, Mikrotik CPE's, to YDI EtherAnt 2's & 3's. If Mikrotik CPE's are having issues, I know its 2.9 and now any kind of hardware. Because our mikrotik is the heart and soul of our business (WISP), we...
by iredden
Wed Jul 20, 2005 6:27 pm
Forum: Scripting
Topic: [CONTRIB] ssh perl script - automate batch commands *UPDATED
Replies: 41
Views: 24914

bump, for all the people emailing me asking for this.
by iredden
Wed Jun 15, 2005 10:19 pm
Forum: General
Topic: 802.11i / WPA2
Replies: 1
Views: 1201

Anybody?


echo.....
by iredden
Tue Jun 07, 2005 6:07 am
Forum: General
Topic: 802.11i / WPA2
Replies: 1
Views: 1201

802.11i / WPA2

Will Mikrotik RouterOS support 802.11i / WPA2 ?

I see support for WPA-PSK in the current 2.9.
by iredden
Tue May 31, 2005 9:11 pm
Forum: General
Topic: WDS Setup on MT 2.8.26
Replies: 5
Views: 1571

My understand of WDS was it immediately cut every WDS link's throughput in half. Using 802.11b, and given its half duplex, that wouldnt be much more than 3Mbps.

Am I missing something?
by iredden
Tue May 31, 2005 9:05 pm
Forum: General
Topic: Shaping users on the same radio...
Replies: 4
Views: 1672

All at the same speed? Using PCQ (Per Connection Queueing). I wrote a script that generates the Mikrotik console commands from a MySQL database and then connects via SSH to the box, and sends the commands. First it create an IP Firewall Mangle rule based on their MAC address, then associates flow to...
by iredden
Tue May 31, 2005 9:01 pm
Forum: General
Topic: Routerboard 230 with Demarc 300mw Card
Replies: 6
Views: 1703

I modified an ssh/cron that looks for duplicates. Right now it just reports as its only an IDS, but was looking at authenticating our wireless into a real radius database (not just using the access-list) and only allowing one login at a time. There are times when I have left our access-list off for ...
by iredden
Fri May 20, 2005 12:13 am
Forum: The Dude
Topic: "The Dude"
Replies: 55
Views: 24621

Very Cool utility. Been looking for something like this for awhile. Why? I dunno. :P

Why the name, "The Dude" ?
by iredden
Tue Mar 15, 2005 4:33 am
Forum: General
Topic: 2.8.25 update question
Replies: 5
Views: 1565

Having serious throughput issues with 2.8.24. The AP in question is running approximately 30-40 customers using a dual DSL backhaul link for approximately 5-6MBps. None of the customers see any issues with latency, etc ... but the perfectionist I am, I notice it. Connected to a Netgear WG311T Athero...
by iredden
Tue Mar 15, 2005 4:25 am
Forum: General
Topic: Going to SHOT MY SELF over this HotSpot
Replies: 5
Views: 1375

Weird. Try setting up a proxy server, relay to it through the mikrotik, then see if it works.

Also, what browser on Mac OS?
by iredden
Sun Feb 13, 2005 10:12 am
Forum: General
Topic: Shaper not support napster?
Replies: 2
Views: 1092

Have already spoken to them, and they are looking at adding Napster support. However, the packets that are originating from our network appear to be a mass exploitation attempt. The data being sent (roughly decoded) "GET xxxxxxxxx C:\Documents and Settings\". The header of the packet is also mangled...
by iredden
Fri Feb 11, 2005 12:29 am
Forum: General
Topic: Help! Hacking Attempt on Hotpost How to Block?
Replies: 2
Views: 1284

Studying digital forensics at the college level, I could easily ramble on all day on things to try, however here are a few: - setup a linux box on the same network as your hotspot, and use a free IDS software such as snort - fork the traffic from the mikrotik sniffer to a pc running ethereal, tcpdum...
by iredden
Fri Feb 11, 2005 12:17 am
Forum: Scripting
Topic: [CONTRIB] ssh perl script - automate batch commands *UPDATED
Replies: 41
Views: 24914

Another update.
by iredden
Fri Feb 11, 2005 12:09 am
Forum: General
Topic: Shaper not support napster?
Replies: 2
Views: 1092

Shaper not support napster?

The following is a user hammering our system with napster. 17:47:10.479959 xx-153-hse.wireless.xxxxxxx.xx.xx.62296 > SA-Lib50-165.xxxxxx.edu.6699: . ack 2193203501 win 63974 (DF) 17:47:10.479979 xx-153-hse.wireless.xxxxxxx.xx.xx.62296 > SA-Lib50-165.xxxxxx.edu.6699: . ack 1 win 63974 (DF) 17:47:10.5...
by iredden
Mon Jan 31, 2005 4:00 am
Forum: Scripting
Topic: [CONTRIB] ssh perl script - automate batch commands *UPDATED
Replies: 41
Views: 24914

I did an update on the ssh-cmd. I noticed a bug when I was coding my dhcp push and bandwidth shaper push from my mysql database. My scripts would write all the correct commands to the text file, but the ssh-cmd would only half the time send half the cmds then quit mysteriously. Its fixed now and wor...
by iredden
Fri Jan 28, 2005 9:23 am
Forum: Scripting
Topic: [CONTRIB] ssh perl script - automate batch commands *UPDATED
Replies: 41
Views: 24914

[CONTRIB] ssh perl script - automate batch commands *UPDATED

I hacked away at this based on someone elses code. I found this script on the Internet with no credit to it! Thanks to whoever wrote the original script. EDIT: http://www.dysan.net/Perl/lg.php -- Original script. You put a file named monitor.passwd in your etc directory.... /etc/monitor.passwd: admi...