Community discussions

MikroTik App

Search found 36 matches

by petertosh
Mon Apr 20, 2020 12:36 am
Forum: RouterOS v7 BETA
Topic: Feature Request - Wireguard Protocol
Replies: 86
Views: 22076

Re: Feature Request - Wireguard Protocol

While I could use WG on a raspberrypi4, it would be so nice to have it in my CCR1009. Current experience with WG is extremely positive, compared to OpenVPN for LAN-LAN-connections.
by petertosh
Sun Feb 23, 2020 1:16 am
Forum: General
Topic: 3CX NAT when using 2 Servers
Replies: 18
Views: 4128

Re: 3CX NAT when using 2 Servers

Hm, I only run one 3CX server behind a Mikrotik router, but your nat and filter settings look fine. You did disable the sip alg, did you?
ip firewall service-port disable sip
by petertosh
Tue Feb 04, 2020 10:49 am
Forum: Scripting
Topic: SPDNS Update Script
Replies: 4
Views: 2856

Re: SPDNS Update Script

I don't know what changed, but lately the script from above failed to update. This is what I changed it to, it works at the moment: :global currentIP; :local password "XXXXXX"; :local hostname "XXXXXX"; :local tmpIP [/ip address get [find interface="pppoe-out1"] address]; :local myIP [:pick $tmpIP 0...
by petertosh
Wed Nov 20, 2019 12:35 pm
Forum: Beginner Basics
Topic: Telekom ONT + hAP ac lite: PPPoE problems?
Replies: 2
Views: 620

Re: Telekom ONT + hAP ac lite: PPPoE problems?

Hey I am not an expert, but have managed to configure a CCR as router with a Fritz!Box as DSL-modem/bridge and PPPoe. Could you please check that you have a default route pointing at the PPPoe-Interface? What does "ip route print" show? I have an entry like this 1 A S 0.0.0.0/0 pppoe-out1 1 Then in ...
by petertosh
Thu Oct 31, 2019 3:40 pm
Forum: General
Topic: I've Tried (almost) everything: IPSEC IKEv2 11.5 Mbps on 100Mbps Connection Hap AC2
Replies: 11
Views: 2148

Re: I've Tried (almost) everything: IPSEC IKEv2 11.5 Mbps on 100Mbps Connection Hap AC2

RDP doesn't need much bandwidth. It's working happily with a 10Mbps connection here, too. Maybe you should check for unusual high latency and maybe packet loss. 10Mbps is more than enough for RDP...
by petertosh
Thu Oct 24, 2019 10:34 am
Forum: RouterOS v7 BETA
Topic: 7.0beta3 available in testing?
Replies: 40
Views: 9296

Re: 7.0beta3 available in testing?

Old RouterOS versions don't (can't) know the newer naming scheme, so upgrade manually please. hEX, 6.46beta55. i tried manually, but failed.. hEX working here nicely on beta3. Disable and uninstall all packages except system, upgrade firmware to 6.46beta. Then upload Beta3.npk to filesystem. Reboot...
by petertosh
Tue Oct 01, 2019 11:05 pm
Forum: General
Topic: Winbox x64 / Winbox for MAC
Replies: 1
Views: 1729

Re: Winbox x64 / Winbox for MAC

by petertosh
Sun Sep 15, 2019 9:57 pm
Forum: The User Manager
Topic: user manager usb disk not found
Replies: 7
Views: 3129

Re: user manager usb disk not found

Yep I bought and tested the same Sandisk drive but I had random remounts. And then I had a nice Intel 80GB SSD in an USB-enclosure and this works perfectly.
by petertosh
Sat Sep 14, 2019 9:04 pm
Forum: The User Manager
Topic: user manager usb disk not found
Replies: 7
Views: 3129

Re: user manager usb disk not found

yep. That works. But you should be careful, the USB-port on the CCR is rather delicate. Bend or pull the OTG-cable a little to the left or right and the disc gets remounted. And the paths will change, therefore userman will complain. But if you leave it in a cabinet where no one touches the cables, ...
by petertosh
Sat Sep 14, 2019 6:53 pm
Forum: The User Manager
Topic: user manager usb disk not found
Replies: 7
Views: 3129

Re: user manager usb disk not found

I use userman with an external USB-SSD with OTG-Cable without problems for two years now. Before that I had tried internal memory (not good, too much wear, random errors) and an external USB-drive with micro-usb port (not good, drive often remounted with another name). Since I put the USB-SSD on the...
by petertosh
Mon Aug 19, 2019 7:09 pm
Forum: Beginner Basics
Topic: Learning RouterOS
Replies: 8
Views: 1196

Re: Learning RouterOS

Re-discovered how to search Amazon for books (so long since i bought a book) and I ended up at this book: https://www.amazon.co.uk/RouterOS-Example-2nd-Stephen-Discher/dp/0692777083/ref=sr_1_1?keywords=routeros&qid=1566152590&s=books&sr=1-1 I am not a network technician, just a small business admin...
by petertosh
Thu Aug 15, 2019 10:25 pm
Forum: General
Topic: Winbox 64bit Version
Replies: 80
Views: 23081

Re: Winbox 64bit Version

Ok, I fully agree. Haven't tested Catalina. Although it would be the easiest way for Mikrotik to just use the code of the iOS client for a native MacOC client, I hope that they release a 64Bit winbox.exe. I have configured a couple of sessions to different routers with hotspot, log, resources, inter...
by petertosh
Thu Aug 15, 2019 7:52 pm
Forum: General
Topic: Winbox 64bit Version
Replies: 80
Views: 23081

Re: Winbox 64bit Version

With macOS Catalina and Apples Catalyst it would be an easy step to port the newly introduced iOS Version of Winbox to macOS. Even if the GUI Concept of the iOS Version is much different it would offer 64Bit Support and a native Application for macOS. I hope MT will use this opportunity. This. I th...
by petertosh
Tue Aug 13, 2019 6:31 pm
Forum: Scripting
Topic: SPDNS Update Script
Replies: 4
Views: 2856

Re: SPDNS Update Script

User is the same as hostname, see
user=$hostname
in the second script. The password is the token that you can create at the SPDYN user backend.
by petertosh
Fri Aug 09, 2019 2:02 pm
Forum: General
Topic: ios ikev2 client disconnected after 8mins
Replies: 1
Views: 509

Re: ios ikev2 client disconnected after 8mins

What do you have in /ip ipsec proposal ? In my case:
0  * name="default" auth-algorithms=sha1 enc-algorithms=aes-256-cbc,aes-128-cbc lifetime=8h pfs-group=none 
by petertosh
Mon Aug 05, 2019 10:36 pm
Forum: General
Topic: Winbox 64bit Version
Replies: 80
Views: 23081

Re: Winbox 64bit Version

Maybe I am too dumb but the latest Google Earth Pro seems to be 64bit and I am running Wine 4.0 stable on MacOS 10.14.6 and if I start winbox.exe with "wine64" I get the following in Activity Monitor:
Screenshot Wine Winbox 64.png
So, that would not be enough in 10.15 ?
by petertosh
Wed Jun 19, 2019 1:10 pm
Forum: The User Manager
Topic: User Manager wears out flash Mikrotik or not?
Replies: 2
Views: 1826

Re: User Manager wears out flash Mikrotik or not?

Yes it does and is not recommended. I had problems running UserManager on CCR internal flash. From time to time the database would be unreadable and all users/passwords would be blocked until restart. Since I moved the DB to an external USB-SSD everything is ok. Search the forum, there are a lot of ...
by petertosh
Fri Feb 15, 2019 4:40 pm
Forum: RouterBOARD hardware
Topic: Passive PoE: MikroTik and Ubiquiti
Replies: 6
Views: 2272

Re: Passive PoE: MikroTik and Ubiquiti

Hi, it‘s passive mode. In the hEX the POE is „forced-on“. All of my devices Support 24V passive POE. And the hEX POE comes with a 24V power source.
by petertosh
Fri Feb 15, 2019 3:32 pm
Forum: RouterBOARD hardware
Topic: Passive PoE: MikroTik and Ubiquiti
Replies: 6
Views: 2272

Re: Passive PoE: MikroTik and Ubiquiti

Hi, can‘t speak for the CRS328 but I am powering a UBNT G3 Dome Camera, a UAP-AC-LR and a UAP-AC-M by a hEX-POE (RB960PGS). No Problems so far since 6 months.

Best.
by petertosh
Fri Jan 18, 2019 9:00 pm
Forum: Scripting
Topic: Basic Notifications System with Telegram
Replies: 5
Views: 8873

Re: Basic Notifications System with Telegram

Hi,

I use this call:
/tool fetch url="https://api.telegram.org/YourBotid/sendmessage\?chat_id=YourChatid&text=MESSAGE" keep-result=no;>


And currently following policies: ftp,reboot,read,write,policy,test,password,sniff,sensitive

Maybe the policies are not set correctly in your case?
by petertosh
Thu Jan 17, 2019 11:02 pm
Forum: Scripting
Topic: SPDNS Update Script
Replies: 4
Views: 2856

Re: SPDNS Update Script

Ok, this is late, but I used another script from the forum and this works right now: # Set needed variables :local password "YOUR-PASSWORD" :local hostname "YOUR-HOSTNAME" :global dyndnsForce :global previousIP # print some debug info :log info ("UpdateDynDNS: hostname = $hostname") :log info ("Upda...
by petertosh
Thu Jan 17, 2019 1:03 pm
Forum: General
Topic: hex router and 3cx
Replies: 6
Views: 873

Re: hex router and 3cx

@16again - thank you sir! I couldn't find out what's going wrong for days until I found your answer. Thank's a lot!
by petertosh
Mon Oct 29, 2018 7:56 pm
Forum: Beginner Basics
Topic: Running Netinstall from MacOs using Wine
Replies: 5
Views: 3112

Re: Running Netinstall from MacOs using Wine

Try: sudo -H -u root "/Applications/Wine Stable.App/Contents/MacOS/wine" /path/to/netinstall.exe Use your Wine, the path above is only an example. I managed to use it once this way. But haven't done it for a while.... A tutorial in German can be found here: https://blog.effenberger.org/2017/06/05/to...
by petertosh
Sun Oct 28, 2018 9:44 pm
Forum: RouterBOARD hardware
Topic: License Lost when change Nand
Replies: 1
Views: 839

Re: License Lost when change Nand

Hi, did you see this: viewtopic.php?f=3&t=123015&p=629591&hil ... st#p629591

BTW, on what devices did you change the NAND? Where there CCR among them?

Best.
by petertosh
Tue Oct 09, 2018 11:16 am
Forum: RouterBOARD hardware
Topic: CCRs Failing
Replies: 2
Views: 675

Re: CCRs Failing

Maybe NAND failures? Symptoms are similar, although my unit got back ok, when I rebooted it. It has an uptime of 20 days right now on 6.43.1 and writing userman etc to a USB-SSD. See: viewtopic.php?f=2&t=139391
by petertosh
Thu Sep 20, 2018 10:58 am
Forum: General
Topic: CCR1009 reset admin password and dont write in files
Replies: 9
Views: 1928

Re: CCR1009 reset admin password and dont write in files

On my CCR I have a userman DB, several recurrent scripts writing backups and other files, one recurrent download from external websites and so on. All of these tasks I moved to the external USB-SSD. The SSD was formatted in ext3, then following commands moved the DB to USB: [admin@MikroTik] > /tool ...
by petertosh
Wed Sep 19, 2018 9:06 pm
Forum: General
Topic: CCR1009 reset admin password and dont write in files
Replies: 9
Views: 1928

Re: CCR1009 reset admin password and dont write in files

pe1chl, thanks for the answer. Am I right in thinking that a change of the flash-chip would work? Basically I am thinking of replacing the flash-chip, then NAND-format using the serial-console, then netinstall. I can export the license before changing chips and later import it back. Would that work?...
by petertosh
Wed Sep 19, 2018 3:16 pm
Forum: Scripting
Topic: LogParser+Action script newbie
Replies: 0
Views: 503

LogParser+Action script newbie

Hi, I would like a router to send me messages when certain things appear in the log. I tried as good as I can to adapt the example given in the wiki. The problem is that if the scripts run as they are now, they fire the message right away, every time. Something is wrong with the variables I guess. B...
by petertosh
Wed Sep 19, 2018 12:20 pm
Forum: General
Topic: CCR1009 reset admin password and dont write in files
Replies: 9
Views: 1928

Re: CCR1009 reset admin password and dont write in files

You should have done that from the beginning! Well, I use userman since last year and my DB is about 10 MB. At this site there is a maximum of about 50 active users at any time, so I thought that the flash should handle it. And I had tried previously with a SanDisk SDDD3-032G-G46 Ultra 32GB Dual US...
by petertosh
Wed Sep 19, 2018 12:14 pm
Forum: Scripting
Topic: Basic Notifications System with Telegram
Replies: 5
Views: 8873

Re: Basic Notifications System with Telegram

Just what I needed. Thanks a lot.
by petertosh
Wed Sep 19, 2018 9:15 am
Forum: General
Topic: CCR1009 reset admin password and dont write in files
Replies: 9
Views: 1928

Re: CCR1009 reset admin password and dont write in files

There have been multiple times that this behavior was reported, going back at least to 2014, you can search the forum for admin reset or "failed to commit transaction: disk I/O error". I experienced something like this, too: https://forum.mikrotik.com/viewtopic.php?f=2&t=136578 Mikrotik support advi...
by petertosh
Sun Sep 16, 2018 12:47 pm
Forum: General
Topic: Userman does not work and the administrator's account is changed in the mikrotik
Replies: 3
Views: 958

Re: Userman does not work and the administrator's account is changed in the mikrotik

Mikrotik support told me to netinstall the router. That's what I did. Today the same thing happened. "failed to commit transaction: disk I/O error" in the log and userman not working. Reboot fixes the situation. Apparently there is some problem with CCR and userman on flash? There are reports going ...
by petertosh
Sun Aug 12, 2018 3:28 pm
Forum: General
Topic: Userman does not work and the administrator's account is changed in the mikrotik
Replies: 3
Views: 958

Re: Userman does not work and the administrator's account is changed in the mikrotik

Hey, I had the same problem today with a CCR1009, userman and hotspot. CCR is running 6.42.6. However I was able to login as admin with no password using winbox. Then I set a new password, created a second admin account and rebooted the router. The router came up fine, everything seems to run again....
by petertosh
Tue Jul 03, 2018 11:56 am
Forum: Announcements
Topic: v6.42.5 [current]
Replies: 124
Views: 29304

Re: v6.42.5 [current]

We are sorry for any issues caused by the previous package, we uploaded new packages, that will work fine on any router. Package updated 07/02/2018 To fix storage issue on your router, use package from the link, https://www.mikrotik.com/download/share/fix_space.npk - upload package to your router; ...
by petertosh
Mon May 07, 2018 10:00 pm
Forum: Scripting
Topic: CCR Health Monitoring
Replies: 5
Views: 4442

Re: CCR Health Monitoring

Thank you very much!