Community discussions

Search found 326 matches

  • 1
  • 2
  • 3
  • 4
  • 5
  • 7
by Inssomniak
Tue Jun 25, 2019 1:34 am
Forum: Forwarding Protocols
Topic: MPLS over GRE MTU question
Replies: 8
Views: 621

Re: MPLS over GRE MTU question

But there is a physical L2MTU, depending on the parent interface that the traffic is leaving from, correct? When does GRE start fragmenting the L2 stuff? It's long before 65535, obviously. GRE is 24 bytes overhead - assuming your GRE tunnel is running over 1500 IP MTU, subtract 24 bytes for the GRE...
by Inssomniak
Tue Jun 25, 2019 12:56 am
Forum: Forwarding Protocols
Topic: MPLS over GRE MTU question
Replies: 8
Views: 621

Re: MPLS over GRE MTU question

Well it seems to work ok, and I asked around about it first before trying, and many others said it works fine. Just unsure about the MTU. MPLS works fine over GRE or EoIP. Only the L2MTU matters, and for GRE the L2MTU is 65535 and you can't change it. The only disadvantage of GRE vs EoIP for MPLS i...
by Inssomniak
Sat Jun 22, 2019 5:18 pm
Forum: Forwarding Protocols
Topic: MPLS over GRE MTU question
Replies: 8
Views: 621

Re: MPLS over GRE MTU question

Well it seems to work ok, and I asked around about it first before trying, and many others said it works fine. Just unsure about the MTU.
by Inssomniak
Sat Jun 22, 2019 7:28 am
Forum: Forwarding Protocols
Topic: MPLS over GRE MTU question
Replies: 8
Views: 621

MPLS over GRE MTU question

So if Im using MPLS over a GRE Tunnel, do I adjust the GRE MTU to match the MPLS MTU ? or does it use the L2MTU like any other interface? I need 1522 byte MPLS MTU over a GRE tunnel without fragmentation, which states the L2MTU at 65535. So How do I know the GRE Tunnel isn't fragmenting the MPLS pac...
by Inssomniak
Fri Jan 20, 2017 9:34 pm
Forum: Forwarding Protocols
Topic: OSPF PtMP and route distribution
Replies: 0
Views: 679

OSPF PtMP and route distribution

I was testing out using the PtMP setting in OSPF for some added robustness on a couple of wireless links. But the route distribution is weird. I have a link, between 2 routers, say 10.50.49.0/29, with router A and B with .1 and .4, and in between those routers, a wireless link .2 and .3. OSPF would ...
by Inssomniak
Thu Jan 19, 2017 9:36 pm
Forum: General
Topic: Upload on simple queue/PPPoE not working?
Replies: 4
Views: 615

Upload on simple queue/PPPoE not working?

6.37.2

Anyone having issues with simple queues and PPPoE interfaces not controlling the upload traffic (traffic coming from the customer?)
No changes to any settings, download direction still works, doesn't matter if its dynamic or static queue., does not affect non PPPoE interfaces.
by Inssomniak
Thu Nov 10, 2016 4:26 pm
Forum: The Dude
Topic: Metal9 Spectral Scan support
Replies: 1
Views: 602

Metal9 Spectral Scan support

Asking for Metal9 support in Spectral Scan tool in the Dude.

Thanks!
by Inssomniak
Thu Oct 27, 2016 12:13 am
Forum: RouterBOARD hardware
Topic: Metal9 Wireless Capabilities
Replies: 0
Views: 428

Metal9 Wireless Capabilities

Does the Metal9 unit allow for custom channel widths and centre frequencies?

Thanks
by Inssomniak
Wed Sep 28, 2016 5:37 pm
Forum: The Dude
Topic: Graph Number of PPPoE Logins
Replies: 2
Views: 875

Re: Graph Number of PPPoE Logins

Yes thanks last night this is how I got it to work!

Thanks
by Inssomniak
Mon Sep 26, 2016 8:19 pm
Forum: The Dude
Topic: Graph Number of PPPoE Logins
Replies: 2
Views: 875

Graph Number of PPPoE Logins

Is there an OID for the currently logged in PPPoE Clients?


I found this from a bunch of years ago but I couldn't adapt this to the new dude.
http://mum.mikrotik.com/presentations/CZ09/schaub.pdf

Any help ?

Thanks
by Inssomniak
Sun Sep 25, 2016 5:10 pm
Forum: The Dude
Topic: The Dude, v6.36 [current] release.
Replies: 48
Views: 11567

Re: The Dude, v6.36 [current] release.

How do you upload files to the version 6.37 Dude?
Seems I cant add files.
by Inssomniak
Thu Apr 21, 2016 11:31 pm
Forum: General
Topic: CCR Mikrotik
Replies: 0
Views: 320

CCR Mikrotik

Im not familiar with the CCR line of Mikrotiks in terms of power.

500 Megabits, Firewall, 1000+ PPPoE sessions, Queues, etc.

What should I be looking at? Will a CCR 9 core be OK or do I need 16 or more model?
I know I stress out a dual core X86 i3 machine doing all this.
by Inssomniak
Wed Feb 17, 2016 9:01 pm
Forum: General
Topic: Transparent traffic shaping Traffic leaving VPLS tunnel.
Replies: 1
Views: 342

Re: Transparent traffic shaping Traffic leaving VPLS tunnel.

Never mind I think I got it.

bridge settings Use IP Firewall for PPPoE checked.
mangle rule out-bridge-port is one of the ethernet ports.
mark traffic leaving.

and then PCQ.
by Inssomniak
Wed Feb 17, 2016 7:37 pm
Forum: General
Topic: Transparent traffic shaping Traffic leaving VPLS tunnel.
Replies: 1
Views: 342

Transparent traffic shaping Traffic leaving VPLS tunnel.

Hello I have 4 ethernet interfaces connected to different wireless radios bridged to a VPLS tunnel. Is there a way to transparent traffic shape as the traffic leaves the VPLS tunnel and exits one of the ethernet ports? For example I have one of the ethernet ports connected to a 900mhz radio that suf...
by Inssomniak
Wed Feb 17, 2016 12:16 am
Forum: The Dude
Topic: The Dude, work continues: v6.35rc test builds.
Replies: 103
Views: 34554

Re: The Dude, work continues: v6.35rc test builds.

I run dude in wine on OSX, and new version presents an error like this: when going to "tools, web", but it still opens safari and works as normal. 6.35rc10
by Inssomniak
Fri May 08, 2015 11:00 pm
Forum: RouterBOARD hardware
Topic: RB433 MTU change after upgrade to 6.27 Bug ???
Replies: 1
Views: 464

Re: RB433 MTU change after upgrade to 6.27 Bug ???

Yes same problem!!

Lost 4 bytes on the RB493AH!!

Was so confused on what happened!
by Inssomniak
Thu Jan 08, 2015 10:58 pm
Forum: General
Topic: Disconnect winbox sessions after set time?
Replies: 0
Views: 438

Disconnect winbox sessions after set time?

Im looking for a script that could disconnect active winbox sessions after a set time.
Ive gone over my ISP caps twice now because I leave winbox connected for days on end by mistake to a remote router.
Thanks.
by Inssomniak
Fri Aug 01, 2014 1:10 am
Forum: Forwarding Protocols
Topic: Is there a bug in MPLS and older hardware?
Replies: 3
Views: 1176

Is there a bug in MPLS and older hardware?

So Ive been pulling my hair out, trying to fix a network that was always working fine on 5.26. I have older hardware with RB750s and RB433s, RB493s that only support 1522 MTU on some interfaces. So my MPLS MTU is set to 1522 across the board network wide, but I moved the RB750s to 6.13 or 6.17 and a...
by Inssomniak
Tue Jun 03, 2014 6:04 pm
Forum: SwOS
Topic: Rb260GS Help
Replies: 1
Views: 1967

Rb260GS Help

Im trying to configure an RB260GS with one vlan. I need all the Layer 2 MTU I can spare so I just want to add a VLAN ID=10 on the router board 493, then send that traffic to the switch port 2, and when the switch sees the ID=10, sent it out port 4, strip the vlan header. reverse the process for inco...
by Inssomniak
Tue May 27, 2014 3:56 am
Forum: RouterBOARD hardware
Topic: RB750UP - Issue
Replies: 260
Views: 54372

Re: RB750UP - Issue

Just to add..

I did add the capacitor to 2 different RB750UPs with resetting POE ports, and both are perfectly fine afterwards.

100-140 feet cat5 on POE port. Long cable set to yes, forced on.

Its funny I stole the capacitors from RB411s with dead ethernet ports.

:)
by Inssomniak
Thu May 22, 2014 8:49 am
Forum: The Dude
Topic: Cant fix glitch
Replies: 1
Views: 1224

Cant fix glitch

My router that has the dude shut down improperly after UPS died.

But now I have a glitch I can't fix on a link.
It has this extra info afterwards
Ive tried resetting it, import/export, etc..
can't figure this one out?
by Inssomniak
Wed May 21, 2014 2:15 am
Forum: RouterBOARD hardware
Topic: RB750UP - Issue
Replies: 260
Views: 54372

Re: RB750UP - Issue

There seems to be 2 different RB750 boards.

Mine doesn't look like the picture.
Anyone know where to solder the cap on the other (perhaps old) model?
by Inssomniak
Tue Dec 17, 2013 4:45 am
Forum: Forwarding Protocols
Topic: MPLS MTU Setting of *all still broken?
Replies: 1
Views: 657

Re: MPLS MTU Setting of *all still broken?

To reply to myself.

In the terminal /mpls interface, the setting *all was disabled (X), I didn't even know it could be disabled, as you can't do it in winbox at least in 5.24.
by Inssomniak
Tue Dec 17, 2013 4:30 am
Forum: Forwarding Protocols
Topic: MPLS MTU Setting of *all still broken?
Replies: 1
Views: 657

MPLS MTU Setting of *all still broken?

I thought this issue was fixed but I ran into a router (mipsbe) that would not take the MPLS MTU I was putting in until I added each interface specifically.
5.24.

"ALL" Did not work at my MTU I entered.
by Inssomniak
Wed Nov 27, 2013 5:09 am
Forum: General
Topic: Improved PPP package for v6.x
Replies: 45
Views: 16517

Re: Improved PPP package for v6.x

Never really had problem with pppoe on 5.x. Haven't moved to v6 on core/edge.
I have 700 pppoe sessions and on core i3 not too much CPU usage even moving 130-140 megabit.
Each customer gets advertised speed

I'm not sure how it could get better? Is this more geared for tile?
My CPU is only 2 cores.
by Inssomniak
Tue Nov 26, 2013 6:47 pm
Forum: Forwarding Protocols
Topic: L2MTU and things breaking (mpls)
Replies: 18
Views: 6431

Re: L2MTU and things breaking (mpls)

I replaced the card in a 2am maintenance window last night With the RB44Ge pci-express card. And it worked. So goes to show not even the good cards are perfect? or the drivers aren't. The card I removed was a PCI-express 1x pro/1000 PT server adapter. Again the card would send out the large frames, ...
by Inssomniak
Mon Nov 25, 2013 3:12 am
Forum: Forwarding Protocols
Topic: VPLS Tunnel not working - L2MTU on bridge wrong
Replies: 2
Views: 1561

Re: VPLS Tunnel not working - L2MTU on bridge wrong

The bridge interface inherits the lowest supported MTU so 1500 is right. Also if you have the ethernet interface that mpls/VPLS is running on in a bridge I don't think this works. Looks like you have 3 devices all trying to be a part of the same VPLS tunnel? I've never tried having a VPLS tunnel wit...
by Inssomniak
Sun Nov 17, 2013 10:28 pm
Forum: Forwarding Protocols
Topic: MPLS issue need immediate help if you can offer any
Replies: 14
Views: 4595

Re: MPLS issue need immediate help if you can offer any

There is a vlan on the ethernet interface but it also reported L2MTU 9014-4=9010 vlan L2MTU. Nothing else fancy. Then it should work no problem. Feel free to start a new topic with your issues, I will try to help. This is an age old problem for me, but see the last few posts near the end of : http:...
by Inssomniak
Sun Nov 17, 2013 4:49 pm
Forum: Forwarding Protocols
Topic: MPLS issue need immediate help if you can offer any
Replies: 14
Views: 4595

Re: MPLS issue need immediate help if you can offer any

I have an issue on an x86 mikrotik router that DID report an L2MTU of 9014 but still didn't work. It's an intel pci-e card. It transmitted the larger frames but doesn't receive them. I have bought the rb44ge card to see if that works but haven't installed it yet. Hoping a mikrotik supported card wo...
by Inssomniak
Sun Nov 17, 2013 3:46 pm
Forum: Forwarding Protocols
Topic: MPLS issue need immediate help if you can offer any
Replies: 14
Views: 4595

Re: MPLS issue need immediate help if you can offer any

I have an issue on an x86 mikrotik router that DID report an L2MTU of 9014 but still didn't work. It's an intel pci-e card. It transmitted the larger frames but doesn't receive them. I have bought the rb44ge card to see if that works but haven't installed it yet. Hoping a mikrotik supported card wor...
by Inssomniak
Wed Nov 06, 2013 4:15 pm
Forum: General
Topic: l2tp 20% Packet Loss
Replies: 4
Views: 2072

Re: l2tp 20% Packet Loss

What happens if you ping with a higher interval? Considering a packet lost after 5ms?
It takes time to encapsulate into l2tp and send it down a tunnel, add some time for that?

Try it at 15ms.
by Inssomniak
Mon Nov 04, 2013 3:47 am
Forum: General
Topic: 2 vlans on 1 port
Replies: 8
Views: 1280

Re: 2 vlans on 1 port

Setting the ip on the computer to the desired network is the easiest way.
by Inssomniak
Sun Nov 03, 2013 2:57 pm
Forum: General
Topic: Ideas for bonding
Replies: 0
Views: 427

Ideas for bonding

I have a location with 2 DSL lines each with statip ip and using pppoe I also control a data Center mikrotik router and looking for the most efficient way I could do a VPN bonding. Can bonding be done with l2tp? I know it can be done with EOIP but it's not very efficient. Perhaps some way to connect...
by Inssomniak
Sun Nov 03, 2013 2:54 am
Forum: Forwarding Protocols
Topic: L2MTU and things breaking (mpls)
Replies: 18
Views: 6431

Re: L2MTU and things breaking (mpls)

To add to this thread and possibly mark as solved? The issue after hours of testing and troubleshooting is the network adapter or its drivers in mikrotik 5.24 and probably other versions? The card reports an L2MTU of 9014 (not changeable) Its an Intel 82572EI Gigabit Ethernet Controller (Copper) (re...
by Inssomniak
Sat Nov 02, 2013 10:31 pm
Forum: General
Topic: X86 and PCI-E Intel possibly not allowing jumbo frames?
Replies: 0
Views: 379

X86 and PCI-E Intel possibly not allowing jumbo frames?

Im trying to troubleshoot an issue Ive had for well, months or even more than a year. I have an x86 router with a PCI express NIC that reports an L2MTU of 9014, my switch is capable of jumbo frames up to 9216 and is configured as such. But for the life of me I CAN NOT get a packet from this router, ...
by Inssomniak
Wed Oct 16, 2013 4:51 pm
Forum: Forwarding Protocols
Topic: L2MTU and things breaking (mpls)
Replies: 18
Views: 6431

Re: L2MTU and things breaking (mpls)

Hi inssomniak. It sounds like you have a mismatch somewhere. Set the vpls mtu to 1500. Allow CW for vpls. Set the physical interface to the max l2mtu it supports that is also supported by the remote end. Set the mpls mtu per ldp carrying interface and set it the same as the l2mtu for that interface...
by Inssomniak
Wed Oct 16, 2013 6:12 am
Forum: Forwarding Protocols
Topic: L2MTU and things breaking (mpls)
Replies: 18
Views: 6431

Re: L2MTU and things breaking (mpls)

Why are you setting MPLS MTU at 1501? Set it at 1522 if that's the highest L2 MTU you have.

I have, it doesnt work :(

only 1500 works.

1501 and higher does not.
Ive been working on this issue for months.

If My MPLS MTU is 1522, what should the VPLS MTU/advertised L2MTU be set to?
by Inssomniak
Wed Oct 16, 2013 6:02 am
Forum: Forwarding Protocols
Topic: L2MTU and things breaking (mpls)
Replies: 18
Views: 6431

Re: L2MTU and things breaking (mpls)

Right now I think I have bigger problems.

I cant make MPLS work with the MPLS MTU setting even at 1501 despite knowing the L2MTU is 1522 at least.
by Inssomniak
Wed Oct 16, 2013 1:01 am
Forum: Forwarding Protocols
Topic: L2MTU and things breaking (mpls)
Replies: 18
Views: 6431

Re: L2MTU and things breaking (mpls)

As far as MPLS mtu goes, here are the numbers you need for 1500 bytes frames. 1526 - To run untagged VPLS 1530 - To run tagged VPLS If you cannot run any higher than 1522 then you will need to write a mangle rule to do a TCP MSS adjust. It will solve most of the performance issues. Ultimately you n...
by Inssomniak
Tue Oct 15, 2013 2:26 am
Forum: Forwarding Protocols
Topic: L2MTU and things breaking (mpls)
Replies: 18
Views: 6431

Re: L2MTU and things breaking (mpls)

Actually you should not run like this :D Run in full frame mode. :D I canged all my net, to support l2mtu minimum 1600. If you don't have mtu enough, you will run into troble. Let a Ethernet be 1500, and pppoe 1492. If you start fragment, you will have about 1/2 the possible maximum speed. A packag...
by Inssomniak
Mon Oct 14, 2013 4:59 am
Forum: Forwarding Protocols
Topic: L2MTU and things breaking (mpls)
Replies: 18
Views: 6431

Re: L2MTU and things breaking (mpls)

Ok. Thanks.

I'd love to run an MTU that allows a full frame, but much of my equipment does not have an l2mtu higher than 1522.

I have VPLS tunnels carrying pppoe traffic back to my concentrator
No vlans
So. Math trick of the night ?
What's the PPPoE MTU I should run ? I came up with 1484.
by Inssomniak
Mon Oct 14, 2013 1:33 am
Forum: Forwarding Protocols
Topic: L2MTU and things breaking (mpls)
Replies: 18
Views: 6431

Re: L2MTU and things breaking (mpls)

1522 is to low to run MPLS.
That depends on your application and That's not what I asked though.
by Inssomniak
Sun Oct 13, 2013 4:43 pm
Forum: Forwarding Protocols
Topic: L2MTU and things breaking (mpls)
Replies: 18
Views: 6431

L2MTU and things breaking (mpls)

So if I have calculated that the smallest l2MTU in all of my network is 1522, that's what I set my MPLS MTU to?

I can't seem to get it to work if that is the case.. The only way mpls works properly is if mpls MTU is set to 1500.
by Inssomniak
Sat Aug 31, 2013 2:29 am
Forum: General
Topic: Transfer license?
Replies: 1
Views: 513

Transfer license?

What's the procedure to transfer a x86 level 6 license to another user?
I have one I do not use anymore. Is there a way for me to transfer it so he can request a replacement key? The hard drive has long died and I just bought a new level 6 license.
by Inssomniak
Wed Aug 07, 2013 7:33 pm
Forum: General
Topic: Mikrotik Router SIP Connection Blocked.
Replies: 76
Views: 36905

Re: Mikrotik Router SIP Connection Blocked.

Just to add, I have about 50 PPPoE clients with SIP boxes, no nat, only routing. I dont have any complaints of any issues and I dont run any scripts to refresh any connections. I have the SIP registration to 60 seconds. BUT I have seen this issue in the linux world, and in some legacy CPE by ubiquit...
by Inssomniak
Wed Jun 26, 2013 5:41 am
Forum: Wireless Networking
Topic: OS 6.1 Wireless Advance Channel
Replies: 5
Views: 1962

Re: OS 6.1 Wireless Advance Channel

Where is that?

I've emailed support, got a form to fill out that I never got around to doing.

Is this the next step after filling out the form?
Oh yea forgot about the form but yea after that your account gets enabled for the extras.
by Inssomniak
Wed Jun 26, 2013 1:42 am
Forum: Wireless Networking
Topic: OS 6.1 Wireless Advance Channel
Replies: 5
Views: 1962

Re: OS 6.1 Wireless Advance Channel

Log into your mikrotik account and upgrade the router OS to allow custom widths. It's free.
by Inssomniak
Mon Mar 18, 2013 6:52 pm
Forum: General
Topic: Mikrotik and Dude on USB stick
Replies: 0
Views: 364

Mikrotik and Dude on USB stick

Anyone use mikrotik and Dude from a USB drive?

I have been for quite a while but I believe the USB stick to have failed, its not even a year old.
It did have high sector writes, like 70 million every 10 days.
by Inssomniak
Sat Mar 16, 2013 5:10 am
Forum: General
Topic: slow thoughput
Replies: 9
Views: 1196

Re: slow thoughput

Did you ever figure this out?

I think I have a similar issue.

Router to 100mb fibre using BW test to another router gets me 50+ megabit.

Customer to router over backbone gets 20 megabit with btest.exe

Customer to fibre BTEST.exe to same off site router gets 3.4 megabit.
by Inssomniak
Fri Jan 25, 2013 2:50 am
Forum: Wireless Networking
Topic: Can anyone confirm static ack not working?
Replies: 0
Views: 377

Can anyone confirm static ack not working?

Anyone with a ptmp operation with 30+ customers confirm that setting a static distance breaks all the registered clients? (No traffic passes).

R52hn with rts enabled on all clients
802.11 BGN mode
Hardware retries =4
Frame lifetime =2
  • 1
  • 2
  • 3
  • 4
  • 5
  • 7