Community discussions

MikroTik App

Search found 52 matches

by Zetera
Tue Oct 01, 2019 11:08 pm
Forum: General
Topic: MikroTik ignoring DHCP Discover Requests from devices
Replies: 11
Views: 1914

Re: MikroTik ignoring DHCP Discover Requests from devices

Sadly it doesn't appear that adjusting the authoritative delay in any direction made a difference. Do we happen to have any other suggestions that I can test out? A temporary fix appears to be sending a boot request via DHCP using he IP-Scan tool on the MikroTik then rebooting the device. But I'm de...
by Zetera
Mon Sep 30, 2019 9:13 pm
Forum: General
Topic: MikroTik ignoring DHCP Discover Requests from devices
Replies: 11
Views: 1914

Re: MikroTik ignoring DHCP Discover Requests from devices

Im sorry - i have missed your configuration. It looks like you have set "authorative=after-2sec-delay" to your client vlans. This means the router will ignore all dhcp-requests from a device if the requests are not coming in smaller time intervals than 2 seconds. If we look at your screenshots it s...
by Zetera
Mon Sep 30, 2019 8:18 pm
Forum: General
Topic: MikroTik ignoring DHCP Discover Requests from devices
Replies: 11
Views: 1914

Re: MikroTik ignoring DHCP Discover Requests from devices

From an external view your setup is relatively complex. This means without seeing your configuration it would be just a guess into the blue. And that does not help at all since it just wastes your and our time ;-) If you expect help - post your complete configuration. Please see the attached files ...
by Zetera
Mon Sep 30, 2019 7:50 pm
Forum: General
Topic: MikroTik ignoring DHCP Discover Requests from devices
Replies: 11
Views: 1914

Re: MikroTik ignoring DHCP Discover Requests from devices

In our deployments, we are experiencing significant DHCP issues. These usually occur after RADIUS outages; we can’t be entirely sure, but the common symptom is that the DHCP server function of our MikroTiks ceases to work as intended. The most common method to initiate communication between the devi...
by Zetera
Tue Sep 24, 2019 9:49 pm
Forum: General
Topic: MikroTik ignoring DHCP Discover Requests from devices
Replies: 11
Views: 1914

Re: MikroTik ignoring DHCP Discover Requests from devices

I'm experiencing some peculiar issues on 6.40.9 (we haven't upgraded just yet. We definitely plan to.) Surely the above should be the first step before asking help? We've upgraded it on a few MikroTiks. It possibly fixed it; as the problem disappeared. But so has rebooting the equipment in other ca...
by Zetera
Fri Sep 20, 2019 9:38 pm
Forum: General
Topic: MikroTik ignoring DHCP Discover Requests from devices
Replies: 11
Views: 1914

MikroTik ignoring DHCP Discover Requests from devices

I'm experiencing some peculiar issues on 6.40.9 (we haven't upgraded just yet. We definitely plan to.) But as it stands MikroTiks are ignoring DHCP discovers. Granted the devices don't even bother asking for DHCP until we run an IP scan via the MikroTik (BOOTP Request.) Any ideas as to why the Mikro...
by Zetera
Tue Jun 11, 2019 4:03 pm
Forum: Beginner Basics
Topic: Auto.rsc Pushes [SOLVED]
Replies: 3
Views: 573

Re: Auto.rsc Pushes [SOLVED]

Does anyone have any suggestions? My expect script is recovering most of these but some don't have their RSA keys (and their passwords are all different.) Which is making things difficult to recover the last few.
by Zetera
Fri Jun 07, 2019 10:37 pm
Forum: Beginner Basics
Topic: Auto.rsc Pushes [SOLVED]
Replies: 3
Views: 573

Re: Auto.rsc Pushes [SOLVED]

I would've not used copy paste if it weren't for the lack of memory on the MikroTik. uptime: 5w3d14h16m21s version: 6.40.9 (bugfix) build-time: Aug/20/2018 07:46:49 factory-software: 6.34.2 free-memory: 16.1MiB total-memory: 64.0MiB cpu: MIPS 74Kc V5.0 cpu-count: 1 cpu-frequency: 720MHz cpu-load: 3%...
by Zetera
Fri Jun 07, 2019 10:36 pm
Forum: Beginner Basics
Topic: Auto.rsc Pushes [SOLVED]
Replies: 3
Views: 573

Re: Auto.rsc Pushes [SOLVED]

0 eleven.auto.rsc script 0 jun/07/2019 13:41:11 1 flash disk dec/31/1969 20:00:00 2 push.auto.rsc script 334 may/02/2019 21:42:42 3 push.auto.log .log file 16.0MiB may/03/2019 03:56:35 4 flash/skins directory dec/31/1969 20:00:01 5 flash/hotspot directory jan/01/1970 20:15:51 6 flash/hotspot/alogin....
by Zetera
Fri Jun 07, 2019 10:33 pm
Forum: Beginner Basics
Topic: Auto.rsc Pushes [SOLVED]
Replies: 3
Views: 573

Auto.rsc Pushes [SOLVED]

So I've seemingly made a terrible mistake. I assumed that the RAM was anything outside of the Flash folder. I had a log file outside of the Flash folder which managed to fill up the remaining memory. Now I can no longer send auto.rsc files to certain MikroTiks under my purview. I've been testing SSH...
by Zetera
Wed May 15, 2019 7:52 pm
Forum: Beginner Basics
Topic: Multiple Entries for same IPs in ARP table? [SOLVED]
Replies: 2
Views: 563

Re: Multiple Entries for same IPs in ARP table? [SOLVED]

That certainly was it... Wish I noticed that sooner. Thanks!
by Zetera
Wed May 15, 2019 4:00 pm
Forum: Beginner Basics
Topic: Multiple Entries for same IPs in ARP table? [SOLVED]
Replies: 2
Views: 563

Multiple Entries for same IPs in ARP table? [SOLVED]

Attached is an issue I've been experiencing with some of our pieces of MikroTik equipment. It seems that there are multiple entries in the ARP table for the same IP addresses. I've also added it below. What would be the reasons that this might occur? The reason this is an issue is that it often caus...
by Zetera
Tue May 07, 2019 8:01 pm
Forum: General
Topic: Discovering the MAC of a modem plugged into a Mikrotik [SOLVED]
Replies: 2
Views: 371

Re: Discovering the MAC of a modem plugged into a Mikrotik [SOLVED]

Bump (don't really want this to get forgotten
by Zetera
Tue May 07, 2019 3:48 pm
Forum: General
Topic: Discovering the MAC of a modem plugged into a Mikrotik [SOLVED]
Replies: 2
Views: 371

Discovering the MAC of a modem plugged into a Mikrotik [SOLVED]

I am trying to find out if there is a tool or command that would allow a mikrotik to see the MAC address of a modem that it is using as its WAN connection. Here is a printout of its ARP table showing the LAN facing MAC address of the modem. # ADDRESS MAC-ADDRESS INTERFACE 0 DC 184.153.32.1 00:17:10:...
by Zetera
Thu Apr 04, 2019 11:25 pm
Forum: Beginner Basics
Topic: CCR MikroTik configuration [SOLVED]
Replies: 7
Views: 841

Re: CCR MikroTik configuration [SOLVED]

thanks sob! This helped loads! :)
by Zetera
Wed Apr 03, 2019 7:06 pm
Forum: General
Topic: CCR MikroTik Bridge Configuration Question [SOLVED]
Replies: 3
Views: 497

Re: CCR MikroTik Bridge Configuration Question [SOLVED]

This is my current configuration. # apr/03/2019 11:49:21 by RouterOS 6.44.1 # software id = IF8Y-2BLH # # model = CCR1036-8G-2S+ # serial number = 6AAE05716373 /interface bridge add name=bridge1 /interface list add name=WAN add name=LAN /ip pool add name=dhcp ranges=192.168.88.2-192.168.89.254 /ip d...
by Zetera
Wed Apr 03, 2019 6:55 pm
Forum: Beginner Basics
Topic: CCR MikroTik configuration [SOLVED]
Replies: 7
Views: 841

Re: CCR MikroTik configuration [SOLVED]

This is my current configuration. # apr/03/2019 11:49:21 by RouterOS 6.44.1 # software id = IF8Y-2BLH # # model = CCR1036-8G-2S+ # serial number = 6AAE05716373 /interface bridge add name=bridge1 /interface list add name=WAN add name=LAN /ip pool add name=dhcp ranges=192.168.88.2-192.168.89.254 /ip d...
by Zetera
Wed Apr 03, 2019 6:17 pm
Forum: Beginner Basics
Topic: CCR MikroTik configuration [SOLVED]
Replies: 7
Views: 841

Re: CCR MikroTik configuration [SOLVED]

Is there an example config to work from that you'd be able to send my way please? If not that's fine I can probably move from here. Thanks either way.
by Zetera
Wed Apr 03, 2019 4:59 pm
Forum: Beginner Basics
Topic: CCR MikroTik configuration [SOLVED]
Replies: 7
Views: 841

Re: CCR MikroTik configuration [SOLVED]

Any possible assistance on this? Or can anyone point me in the right direction?
by Zetera
Wed Apr 03, 2019 2:48 pm
Forum: General
Topic: CCR MikroTik Bridge Configuration Question [SOLVED]
Replies: 3
Views: 497

Re: CCR MikroTik Bridge Configuration Question [SOLVED]

Currently, yes.
by Zetera
Wed Apr 03, 2019 1:28 am
Forum: General
Topic: CCR MikroTik Bridge Configuration Question [SOLVED]
Replies: 3
Views: 497

CCR MikroTik Bridge Configuration Question [SOLVED]

Need to configure a mikrotik to reflect the following: What is needed is one port as a WAN uplink thru which one can assign a static public to the Mikrotik, and a second port that is also "connected" to the circuit to which will connect to a switch to be used to connect devices that will use a stati...
by Zetera
Tue Apr 02, 2019 9:31 pm
Forum: Beginner Basics
Topic: CCR MikroTik configuration [SOLVED]
Replies: 7
Views: 841

CCR MikroTik configuration [SOLVED]

Need to configure a mikrotik to reflect the following: What is needed is one port as a WAN uplink thru which one can assign a static public to the Mikrotik, and a second port that is also "connected" to the circuit to which will connect to a switch to be used to connect devices that will use a stati...
by Zetera
Tue Apr 02, 2019 5:24 pm
Forum: Scripting
Topic: OS Update Script - What am I doing wrong? [SOLVED]
Replies: 1
Views: 428

Re: OS Update Script - What am I doing wrong? [SOLVED]

Figured it out. The settings needed to be contained in a string
/system package update
:do { set channel="bugfix" } on-error={ set channel="long-term" }
check-for-updates
:delay 3s;
:if ( [get status] = "New version is available") do={ install }
by Zetera
Tue Apr 02, 2019 5:07 pm
Forum: Scripting
Topic: OS Update Script - What am I doing wrong? [SOLVED]
Replies: 1
Views: 428

OS Update Script - What am I doing wrong? [SOLVED]

/system package update :do { set channel=bugfix } on-error={ [] } :do { set channel=long-term } on-error={ [] } check-for-updates :delay 3s; :if ( [get status] = "New version is available") do={ install } The purpose of this script is to update both MikroTiks that are at 6.40.9 and at 6.42.x indisc...
by Zetera
Thu Jan 17, 2019 11:46 pm
Forum: General
Topic: Attempting to get a MikroTik Powerbox Pro to act as a pure switch for hundreds of VLANs [SOLVED]
Replies: 1
Views: 538

Attempting to get a MikroTik Powerbox Pro to act as a pure switch for hundreds of VLANs [SOLVED]

So I have a network where I want AP management on VLAN 11, switch management on VLAN 10 and several other hundred VLANs for residents that are dynamically assigned by other equipment and software. Our typical brocade configuration that functions is the following but we are looking to replace them wi...
by Zetera
Thu Jan 17, 2019 6:40 pm
Forum: General
Topic: MikroTik cannot be pinged unless it is pinging the target device [SOLVED]
Replies: 4
Views: 454

Re: MikroTik cannot be pinged unless it is pinging the target device [SOLVED]

I didn't want to give you all redundant information so I trimmed the config down in the previous config but it does include the following vlans that I am pasting here. I ran a show mac-address command on a brocade switch that the MikroTik is uplinking to and discovered the following. MAC-Address Por...
by Zetera
Thu Jan 17, 2019 4:41 pm
Forum: General
Topic: MikroTik cannot be pinged unless it is pinging the target device [SOLVED]
Replies: 4
Views: 454

MikroTik cannot be pinged unless it is pinging the target device [SOLVED]

Currently whenever I need to ping a mikrotik on this network it only receives pings if it is directly pinging the device. For example the router cannot even see the mikrotik unless the mikrotik is actively pinging said router. Here is the config of the mikrotik acting as a switch. Please let me know...
by Zetera
Wed Jan 16, 2019 4:47 pm
Forum: General
Topic: Mikrotik Vlan Switch command [SOLVED]
Replies: 0
Views: 376

Mikrotik Vlan Switch command [SOLVED]

-----------------
by Zetera
Thu Jan 03, 2019 7:32 pm
Forum: General
Topic: Cannot remotely connect via WinBox. [SOLVED]
Replies: 13
Views: 1574

Re: Cannot remotely connect via WinBox. [SOLVED]

Edited that to reflect disabled=no.

No joy. the problem persists.
by Zetera
Thu Jan 03, 2019 5:38 pm
Forum: General
Topic: Cannot remotely connect via WinBox. [SOLVED]
Replies: 13
Views: 1574

Re: Cannot remotely connect via WinBox. [SOLVED]

Also check PC Firewall. Connection Profile might be public instead of private then windows firewall will be more restrictive My outgoing firewall has connected to thousands of MikroTiks before. I'm not entirely sure what you might mean by 'PC' in this case; and there is no receiving PC on the other...
by Zetera
Thu Jan 03, 2019 5:35 pm
Forum: General
Topic: Cannot remotely connect via WinBox. [SOLVED]
Replies: 13
Views: 1574

Re: Cannot remotely connect via WinBox. [SOLVED]

/interface ethernet set [ find default-name=ether1 ] name=ether1-wan-master /interface ethernet set [ find default-name=ether4 ] master-port=ether1-wan-master /interface ethernet set [ find default-name=ether5 ] name="ether5 trunk" /ip neighbor discovery set ether1-wan-master discover=no /interface...
by Zetera
Thu Jan 03, 2019 4:32 pm
Forum: General
Topic: Cannot remotely connect via WinBox. [SOLVED]
Replies: 13
Views: 1574

Re: Cannot remotely connect via WinBox. [SOLVED]

Winbox is not limited to any range via IP service or the firewall rules that isn't mirrored (I've triple-checked) on other ports that are accessible. Didn't know that you could limit users to certain ranges (good to know) also the user was not limited to any ranges either. I've done a Masscan and co...
by Zetera
Thu Jan 03, 2019 4:05 pm
Forum: General
Topic: Cannot remotely connect via WinBox. [SOLVED]
Replies: 13
Views: 1574

Re: Cannot remotely connect via WinBox. [SOLVED]

Connecting via WAN. Winbox is enabled as a service on port 8291. It does allow me to connect via port 80 into the MikroTik and Yes I created an allow all firewall rule and it still does not allow me access. /ip firewall filter add action=accept chain=input dst-port=8291 in-interface=ether1-wan-maste...
by Zetera
Thu Jan 03, 2019 3:55 pm
Forum: General
Topic: Cannot remotely connect via WinBox. [SOLVED]
Replies: 13
Views: 1574

Cannot remotely connect via WinBox. [SOLVED]

Cannot remotely connect via WinBox. Winbox service is enabled on port 8291 Firewall Rules should allow it through. (I literally created an allow all input firewall rule and it still would not allow it.) I can connect to several other MikroTiks via WinBox just fine. The offending MikroTik allows HTTP...
by Zetera
Mon Sep 17, 2018 11:20 pm
Forum: Scripting
Topic: Infinitely Generating Hotspot Firewall Filter rules [SOLVED]
Replies: 1
Views: 454

Infinitely Generating Hotspot Firewall Filter rules [SOLVED]

Attached is a screenshot of the filter rules we keep seeing whenever we turn our hotspot server on. Does anyone have an inkling as to why this is occuring?
by Zetera
Thu Aug 23, 2018 1:10 am
Forum: General
Topic: MikroTiks Blocking Functionality on certain websites [SOLVED]
Replies: 3
Views: 515

Re: MikroTiks Blocking Functionality on certain websites [SOLVED]

Got this reply ten minutes after my last reply. Darn should've checked here. I discovered this for myself. This did happen to be the case. Thanks though!
by Zetera
Wed Aug 22, 2018 11:40 pm
Forum: General
Topic: MikroTiks Blocking Functionality on certain websites [SOLVED]
Replies: 3
Views: 515

Re: MikroTiks Blocking Functionality on certain websites [SOLVED]

The error one of the tenants gets when they try to connect to nsecu.org is "The requested url was rejected. Please consult with your administrator" id 10250750231298463641
by Zetera
Wed Aug 22, 2018 7:53 pm
Forum: General
Topic: MikroTiks Blocking Functionality on certain websites [SOLVED]
Replies: 3
Views: 515

MikroTiks Blocking Functionality on certain websites [SOLVED]

/ip firewall filter :do { add chain=input action=accept protocol=tcp src-address-list=Placeholder in-interface=ether1-WAN dst-port=80 comment="allow webfig" }\ on-error={ add chain=input action=accept protocol=tcp src-address-list=Placeholder in-interface=all-ethernet dst-port=80 comment="allow web...
by Zetera
Thu Aug 02, 2018 9:18 pm
Forum: Scripting
Topic: Commands run perfect in terminal, run perfectly as a script. But refuse to run as a .rsc startup script. [SOLVED]
Replies: 5
Views: 2950

Commands run perfect in terminal, run perfectly as a script. But refuse to run as a .rsc startup script. [SOLVED]

As stated in the title the following line does not run on reset in a MikroTik :if ([/system resource get board-name] = "RB750GL" ) do={ :do { certificate import file-name=AddTrustExternalCARoot.CRT passphrase="" }\ on-error={ certificate import file-name=AddTrustExternalCARoot.crt passphrase=""} } e...
by Zetera
Wed May 09, 2018 4:15 pm
Forum: Scripting
Topic: If, then, else Scripting difficulties. Please Help! [SOLVED]
Replies: 6
Views: 1351

Re: If, then, else Scripting difficulties. Please Help! [SOLVED]

Normally the only safe way to handle things like this in scripting is to use the do { statements } on-error={ statements } construct. Otherwise when an error occurs during expression evaluation the script simply stops, so you cannot test for conditions like nonexisting items safely. Wish I knew thi...
by Zetera
Wed May 09, 2018 4:03 pm
Forum: Scripting
Topic: If, then, else Scripting difficulties. Please Help! [SOLVED]
Replies: 6
Views: 1351

Re: If, then, else Scripting difficulties. Please Help! [SOLVED]

I got it to work!
:if ( [ :len [ /file find name~"flash" ] ] >0 ) do={ /certificate import file-name=flash/example.crt passphrase="" } else={ /certificate import file-name=example.crt passphrase="" }
by Zetera
Wed May 09, 2018 3:16 pm
Forum: Scripting
Topic: If, then, else Scripting difficulties. Please Help! [SOLVED]
Replies: 6
Views: 1351

Re: If, then, else Scripting difficulties. Please Help! [SOLVED]

It seems to work just fine on R1s (my old script worked on R1s. But on R2s and newer it can't seem to find the file at all.
by Zetera
Wed May 09, 2018 1:47 am
Forum: General
Topic: [6.42.1] DHCP does not send log to remote syslog
Replies: 6
Views: 1184

Re: [6.42.1] DHCP does not send log to remote syslog

Hey Chupaka. I would really appreciate your help on a script I was trying to run. I made a topic in the script topic for the forums. Please help!
by Zetera
Tue May 08, 2018 11:10 pm
Forum: Scripting
Topic: If, then, else Scripting difficulties. Please Help! [SOLVED]
Replies: 6
Views: 1351

Re: Scripting difficulties. Please Help! [SOLVED]

Basically "If flash folder exists; do 'this set of commands'; else 'this set of commands'.

any way to get this to work will be much appreciated. (An explanation would be awesome as well!
by Zetera
Tue May 08, 2018 10:59 pm
Forum: Scripting
Topic: If, then, else Scripting difficulties. Please Help! [SOLVED]
Replies: 6
Views: 1351

If, then, else Scripting difficulties. Please Help! [SOLVED]

:if ( [/file find flash] = yes) do={ certificate import file-name=flash/placeholder passphrase="placeholder" certificate import file-name=flash/placeholder passphrase="placeholder" certificate import file-name=flash/placeholder passphrase="placeholder" certificate import file-name=flash/placeholder ...
by Zetera
Mon Apr 30, 2018 7:41 pm
Forum: General
Topic: MikroTik Security Advisory Workaround? [SOLVED]
Replies: 6
Views: 688

Re: MikroTik Security Advisory Workaround? [SOLVED]

Is there any guides on remotely accessing them, that you can link me?
by Zetera
Mon Apr 30, 2018 7:08 pm
Forum: General
Topic: MikroTik Security Advisory Workaround? [SOLVED]
Replies: 6
Views: 688

Re: MikroTik Security Advisory Workaround? [SOLVED]

Can you use NetInstall remotely?
by Zetera
Mon Apr 30, 2018 6:04 pm
Forum: General
Topic: MikroTik Security Advisory Workaround? [SOLVED]
Replies: 6
Views: 688

Re: MikroTik Security Advisory Workaround? [SOLVED]

Again. Any help would be great.
by Zetera
Sat Apr 21, 2018 7:02 pm
Forum: General
Topic: MikroTik Security Advisory Workaround? [SOLVED]
Replies: 6
Views: 688

MikroTik Security Advisory Workaround? [SOLVED]

I have a few affected MikroTiks that I cannot remotely access due to the malicious program that hit anything with a RouterOS version of lower than 6.38.5 . I was wondering if there was any way I could get into them if it will not allow me to use WinBox or the WebFig. It will allow me to remote into ...