Community discussions

MikroTik App

Search found 21 matches

by Kurosudo
Tue Aug 18, 2020 8:54 pm
Forum: General
Topic: Radius PAM not want authorize user using PAM
Replies: 0
Views: 193

Radius PAM not want authorize user using PAM

Hello Folks, Today i bought a yubikey, it's great working nice with radius using PAM but i found a problem. Mikrotik doesn't want to authorize user, in every request it got error message "pam: Attribute "User-Password" is required for authentication" I'm using PAM authentication Debug output from fr...
by Kurosudo
Mon Jul 01, 2019 2:15 pm
Forum: Scripting
Topic: Mikrotik API call not working [SOLVED]
Replies: 35
Views: 18737

Re: Mikrotik API call not working [SOLVED]

Not true. See how it is done in our api example client: https://wiki.mikrotik.com/wiki/Manual:API#Example_client Yea, i basically did same thing in my patch i just wrote "how it fastly fix". Infact i don't see any advantage to use old style API because having unpatched ROS (pre-6.43) is big securit...
by Kurosudo
Mon Jul 01, 2019 1:48 pm
Forum: Scripting
Topic: Mikrotik API call not working [SOLVED]
Replies: 35
Views: 18737

Re: Mikrotik API call not working [SOLVED]

It is possible to fix it via little dirty hack in API. Just change login sequence. But This will make API usable only 6.43 higher
by Kurosudo
Mon Jul 01, 2019 12:41 pm
Forum: Scripting
Topic: Mikrotik API call not working [SOLVED]
Replies: 35
Views: 18737

Re: Mikrotik API call not working [SOLVED]

Same problem, i'm using same API class like you and all my systems died
by Kurosudo
Mon Mar 25, 2019 10:39 am
Forum: Forwarding Protocols
Topic: MPLS MTU questions
Replies: 1
Views: 1968

MPLS MTU questions

Hello, i'm implementing MPLS in my network and i have some questions about MTU in MPLS.

If i change MPLS MTU for example to 1550 in /mpls interface do i need change MTU size on ports in /interface ethernet from 1500 to 1550?

Thanks for answer
by Kurosudo
Fri Mar 22, 2019 10:42 pm
Forum: Beginner Basics
Topic: RB951G doesn't have gigabit ethernet all the time
Replies: 9
Views: 1812

Re: RB951G doesn't have gigabit ethernet all the time

Hello, what device shows you 100mbit?
If you seen 100mbit again try disable auto-negotiation and force speed 1Gbps and full-duplex and test if device work without auto-negotiation
by Kurosudo
Fri Mar 22, 2019 10:35 pm
Forum: General
Topic: Getting IPv6 only through SLAAC (without DHCP) [SOLVED]
Replies: 15
Views: 3117

Re: Getting IPv6 only through SLAAC (without DHCP) [SOLVED]

Did you tried enable router advertisements?
/ipv6 settings set accept-router-advertisements=yes
by Kurosudo
Fri Mar 22, 2019 10:26 pm
Forum: SwOS
Topic: Is possible to boot into ROS in CSS326-24G-2S+RM
Replies: 3
Views: 2869

Re: Is possible to boot into ROS in CSS326-24G-2S+RM

Hello k6ccc,
Thanks so much for answer. But what means Dual Boot? What ROS features have this switch after booting into this mode.
by Kurosudo
Fri Mar 22, 2019 5:45 pm
Forum: SwOS
Topic: Is possible to boot into ROS in CSS326-24G-2S+RM
Replies: 3
Views: 2869

Is possible to boot into ROS in CSS326-24G-2S+RM

Hello, My old Cisco switch blow up and i'm looking for new switch. I'm long time using Mikrotik's routerboards as main routers in my networks but i never tried any Mikrotik switch because i was kinda scared from switchos. I found CSS326-24G-2S+RM as very good switch with awesome price, but it have S...
by Kurosudo
Tue Feb 26, 2019 2:41 pm
Forum: Scripting
Topic: wol, ping and mail [SOLVED]
Replies: 1
Views: 681

Re: wol, ping and mail [SOLVED]

:local HOST "IPADDRESSOFYOURPC"
:local MAC "MACADDRESSOFYOURPC"
/tool wol mac=$MAC

# WAIT 2 minutes to boot
:delay 120

:if ([/ping $HOST interval=1 count=15] != 0) do={
	/tool e-mail send to=my@mail.tld subject="$HOST IS ONLINE" body="HOST $HOST IS ONLINE NOW" start-tls=yes
}
by Kurosudo
Tue Feb 26, 2019 2:34 pm
Forum: General
Topic: Unauthorized access to MikroTiK
Replies: 20
Views: 4139

Re: Unauthorized access to MikroTiK

I found this "malware" too in one of my customers RB. Routerboard was updated and management ports was blocked to internet. But they had hacked CCTV system.
by Kurosudo
Tue Sep 18, 2018 9:31 am
Forum: Scripting
Topic: If traffic is lower than 1Mbps run script
Replies: 1
Views: 512

Re: If traffic is lower than 1Mbps run script

I found how done it
/interface monitor-traffic ether1 once do={
:local up (tx-bits-per-second /1000 );
:local down (rx-bits-per-second /1000 );

:if ( $up < 1024 ) do={
:put "DOWN LINK"
}

:if ( $up > 1024 ) do={
:put "UP LINK"
}

}
by Kurosudo
Tue Sep 18, 2018 9:09 am
Forum: Scripting
Topic: If traffic is lower than 1Mbps run script
Replies: 1
Views: 512

If traffic is lower than 1Mbps run script

Hello, i m trying make few scripts for my network and i found little problem. Is there any way to monitor traffic if it is lower than 1Mbps? For example if traffic from ether2 is for example 512kbps run script. I tried traffic-monitor but it will run script only if traffic peak 1Mbps. Is there any e...
by Kurosudo
Mon Aug 13, 2018 3:03 pm
Forum: Beginner Basics
Topic: RB2011 Setup
Replies: 3
Views: 737

Re: RB2011 Setup

did you have NAT correctly setuped? Can you please post your export?
by Kurosudo
Mon Aug 13, 2018 2:58 pm
Forum: Wireless Networking
Topic: Best LTE Router (based on your experience)
Replies: 10
Views: 2218

Re: Best LTE Router (based on your experience)

few days ago my customer have very interesting order. He has LTE sim card and have one cisco 2960G. For this setup i used rb912UAG-5HPnD. And then i made on ethernet port vlans/firewall. I prefer make shaping directly on switch. This configuration was cheap and it is still mikrotik
by Kurosudo
Sat Aug 04, 2018 10:40 am
Forum: Beginner Basics
Topic: Where can i see all used IPv6 configured via advert
Replies: 1
Views: 618

Where can i see all used IPv6 configured via advert

Hello, i'm playing with IPv6 but i can't find used IPv6. I have /64 in interface and enabled Advertising. But i want see used IPs.
Where can i find it?

Thanks
by Kurosudo
Thu Aug 02, 2018 9:29 am
Forum: Beginner Basics
Topic: Bridge port loop
Replies: 3
Views: 725

Re: Bridge port loop

Try open your bridge interface, loop protect and set Loop Protect to on. I do this for every interface. I had similiar problem few weeks ago and loop protect doesn't help. If loop protect doesn't help try downgrade to bugfix.
by Kurosudo
Thu Aug 02, 2018 9:23 am
Forum: Beginner Basics
Topic: Set vlan interface as DHCP server [SOLVED]
Replies: 12
Views: 6239

Re: Set vlan interface as DHCP server [SOLVED]

Out of interest - what would be use for VLANs on a home network? Except of course specifically learning about the technology, but otherwise at home network I have yet to find use for VLANs therefore I am happy to have avoided the complication so far. Vlan in home network is really good. For example...
by Kurosudo
Wed Aug 01, 2018 4:04 pm
Forum: Virtualization
Topic: GNS3 + Mikrotik = no wlan
Replies: 2
Views: 2762

Re: GNS3 + Mikrotik = no wlan

I think wireless is not supported on CHR, i never seen it. And i think GNS3 doesn't supports wireless links too.
by Kurosudo
Wed Aug 01, 2018 3:45 pm
Forum: Beginner Basics
Topic: Set vlan interface as DHCP server [SOLVED]
Replies: 12
Views: 6239

Re: Set vlan interface as DHCP server [SOLVED]

Ops.. didn't even know.. may be a silly question but how do i configure vlans on my pc?
Depends on you NIC. Many "integrated" NIC doesn't support VLAN tag. It will be better to use switch with vlan support.
by Kurosudo
Wed Aug 01, 2018 1:28 pm
Forum: Beginner Basics
Topic: Set vlan interface as DHCP server [SOLVED]
Replies: 12
Views: 6239

Re: Set vlan interface as DHCP server [SOLVED]

You set IP for ether6 not for vlan. This is your problem. Set 172.17.81.1/24 to vlan81 interface and then create DHCP server via DHCP SETUP it will be easier than making pools etc.