Community discussions

MikroTik App

Search found 47 matches

by Sarel0092
Wed Aug 26, 2020 2:11 pm
Forum: General
Topic: kill immediately and block ip/mac
Replies: 3
Views: 390

Re: kill immediately and block ip/mac

Do you want to block specific services or block Internet access for specific devices?
by Sarel0092
Tue Jun 23, 2020 4:31 pm
Forum: Scripting
Topic: Telegram notification
Replies: 3
Views: 1769

Re: Telegram notification

I use the following to send notifications via Telegram in a script:
/tool fetch url="https://api.telegram.org/botxxxxxxxx/sendMessage\?chat_id=-xxxx&text=Test" keep-result=no;
Edit:
Used with version 6.46.6.
by Sarel0092
Mon May 04, 2020 6:43 pm
Forum: Beginner Basics
Topic: CISCO ACL TO MIKROTIK?
Replies: 4
Views: 1310

Re: CISCO ACL TO MIKROTIK?

It should look something like this: /ip firewall filter add chain=forward action=accept src-address=192.168.2.0/24 dst-address=192.168.4.0/24 add chain=forward action=accept src-address=192.168.4.0/24 dst-address=192.168.2.0/24 add chain=forward action=drop src-address=192.168.2.0/24 dst-address=192...
by Sarel0092
Wed Dec 11, 2019 11:44 am
Forum: Beginner Basics
Topic: DNS Issue on Hap AC2 [SOLVED]
Replies: 5
Views: 2237

Re: DNS Issue on Hap AC2 [SOLVED]

Do the host names/website addresses show up in your DNS cache?
by Sarel0092
Tue Dec 10, 2019 3:10 pm
Forum: General
Topic: Blocking Torrent and P2P on RouterOS 6.44 and above
Replies: 5
Views: 9533

Re: Blocking Torrent and P2P on RouterOS 6.44 and above

The following worked for me in the past: /ip firewall layer7-protocol add name=torrents regexp="^.*(get|GET).+(torrent|thepiratebay|isohunt|entertane|\ demonoid|btjunkie|mininova|flixflux|vertor|h33t|zoozle|bitnova|bitsoup|megan\ ova|fulldls|btbot|fenopy|gpirate|commonbits|1337x|bitlord|rarbg|y...
by Sarel0092
Tue Dec 10, 2019 2:48 pm
Forum: Scripting
Topic: nat
Replies: 1
Views: 1794

Re: nat

What exactly do you want to do?

Port forward to a specific private IP address?
by Sarel0092
Tue Dec 10, 2019 2:46 pm
Forum: Beginner Basics
Topic: DNS Issue on Hap AC2 [SOLVED]
Replies: 5
Views: 2237

Re: DNS Issue on Hap AC2 [SOLVED]

Is "allow remote requests" enabled under IP DNS?
by Sarel0092
Sun Oct 20, 2019 12:33 pm
Forum: Announcements
Topic: Winbox v3.20 released!
Replies: 42
Views: 29488

Re: Winbox v3.20 released!

Keep getting the following error when trying to connect to any router:

"ERROR: no roteros.jg found"

Was working fine on version 3.19.

Routers are on version 6.45.6.

Any ideas of what it could be?
by Sarel0092
Wed Mar 06, 2019 4:24 pm
Forum: General
Topic: VPN router inside Mikrotik LAN
Replies: 4
Views: 527

Re: VPN router inside Mikrotik LAN

Can you ping a PC on your local network from the VPN router?
by Sarel0092
Wed Mar 06, 2019 4:21 pm
Forum: General
Topic: PPTP VPN
Replies: 2
Views: 539

Re: PPTP VPN

Can you ping the remote PC?
by Sarel0092
Wed Mar 06, 2019 4:18 pm
Forum: Beginner Basics
Topic: Can we create the PPPoE user pool for 500 or 1000?
Replies: 10
Views: 1622

Re: Can we create the PPPoE user pool for 500 or 1000?

Can you export the rest of your config?
/export hide-sensitive
by Sarel0092
Wed Mar 06, 2019 8:52 am
Forum: Beginner Basics
Topic: Problems with port forwarding with nasBox ftp [SOLVED]
Replies: 3
Views: 815

Re: Problems with port forwarding with nasBox ftp [SOLVED]

Can you access the FTP server in your local network?

Can you export your NAT config?
/ip firewall nat export file=ip-firewall-nat
by Sarel0092
Wed Mar 06, 2019 8:45 am
Forum: General
Topic: How to get on mikrotik list of arp records at port.
Replies: 3
Views: 842

Re: How to get on mikrotik list of arp records at port.

Is the port you want to see the arp records from in a bridge or is it standalone?

If its standalone you can use:
/ip arp print where interface=<interface name>
by Sarel0092
Wed Mar 06, 2019 8:42 am
Forum: Beginner Basics
Topic: Can we create the PPPoE user pool for 500 or 1000?
Replies: 10
Views: 1622

Re: Can we create the PPPoE user pool for 500 or 1000?

What is the model number of the router you are using?

What is the license level on the router?

The below link show the limitations of each license level.
https://wiki.mikrotik.com/wiki/Manual:License
by Sarel0092
Tue Mar 05, 2019 4:22 pm
Forum: Beginner Basics
Topic: Public ip port forward through pptp vpn
Replies: 2
Views: 1607

Re: Public ip port forward through pptp vpn

Can you ping the PC you want to access from the MikroTik router on site A? If you can then you should just have to setup port forwarding as follow: /ip firewall nat add chain=dst-nat in-interface=<wan interface> protocol=<tcp or udp> dst-port=<port> action=dst-nat to-addresses=<remote pc> to-ports=<...
by Sarel0092
Tue Mar 05, 2019 4:16 pm
Forum: Beginner Basics
Topic: Problem without going net
Replies: 2
Views: 531

Re: Problem without going net

Have to managed to resolve the problem?

If not can you export the config?
/export hide-sensitive
by Sarel0092
Tue Mar 05, 2019 4:14 pm
Forum: General
Topic: VPN & 2 pppoe issue
Replies: 3
Views: 691

Re: VPN & 2 pppoe issue

Is the OpenVPN working?
by Sarel0092
Tue Mar 05, 2019 4:10 pm
Forum: General
Topic: Issue about pppoe quotes
Replies: 1
Views: 431

Re: Issue about pppoe quotes

For this you most likely have to look at a RADIUS server.

You can look at the MikroTik user manager:
https://wiki.mikrotik.com/wiki/Manual:User_Manager
https://wiki.mikrotik.com/wiki/User_Manager/Limiting
by Sarel0092
Tue Mar 05, 2019 4:06 pm
Forum: Beginner Basics
Topic: problem connecting to cctv from my local wifi network
Replies: 2
Views: 567

Re: problem connecting to cctv from my local wifi network

Do you use a domain/hostname in your mobile CCTV application to access your CCTV remotely?
by Sarel0092
Tue Mar 05, 2019 4:01 pm
Forum: Forwarding Protocols
Topic: How do I route a WAN IP to a PPPOE Client connected to an Edge router?
Replies: 2
Views: 1884

Re: How do I route a WAN IP to a PPPOE Client connected to an Edge router?

From my understanding you should just have to use a NAT rule to forward all traffic for the WAN to the IP of the pppoe client then a NAT rule to translate all traffic from pppoe client to the specific WAN IP. /ip firewall nat add chain=dstnat dst-address=45.45.45.2 action=dst-nat to-addresses=10.2.0...
by Sarel0092
Tue Mar 05, 2019 3:52 pm
Forum: General
Topic: VPN router inside Mikrotik LAN
Replies: 4
Views: 527

Re: VPN router inside Mikrotik LAN

On your VPN router do you have any NAT rules specifying what IP ranges can be translated?
by Sarel0092
Tue Mar 05, 2019 3:48 pm
Forum: General
Topic: PPTP client not getting correct local IP
Replies: 1
Views: 338

Re: PPTP client not getting correct local IP

I would suggest looking at the default profiles for your PPP connections.

By default the PPTP client connection will use the "default-encryption" profile.

You can use the following command or just go to PPP > Profiles
/ppp profile print
by Sarel0092
Tue Mar 05, 2019 3:44 pm
Forum: Wireless Networking
Topic: Block PC to access local LAN on Mikrotik
Replies: 3
Views: 1392

Re: Block PC to access local LAN on Mikrotik

Have you tried using a different IP range for the Ubuntu PC then blocking that range from accessing your local network?
by Sarel0092
Tue Mar 05, 2019 3:42 pm
Forum: Beginner Basics
Topic: Webfig
Replies: 7
Views: 800

Re: Webfig

Has your problem been resolved?

If not can you export the config of your MikroTik router that's on 192.168.0.30?
by Sarel0092
Tue Mar 05, 2019 3:33 pm
Forum: Beginner Basics
Topic: Can we create the PPPoE user pool for 500 or 1000?
Replies: 10
Views: 1622

Re: Can we create the PPPoE user pool for 500 or 1000?

Thanks for the config. Try with the following changes: /ip pool set POOL-10.11.2 next-pool=POOL-10.11.5 set POOL-10.11.5 next-pool=none Are you linking each user to the "2M_Plan@10" or the "2M_NN_Plan@10" profile? Is there any specific reason why you are also running the followin...
by Sarel0092
Tue Mar 05, 2019 1:27 pm
Forum: Beginner Basics
Topic: Can we create the PPPoE user pool for 500 or 1000?
Replies: 10
Views: 1622

Re: Can we create the PPPoE user pool for 500 or 1000?

Can you export your config?
by Sarel0092
Tue Mar 05, 2019 1:11 pm
Forum: General
Topic: Hello, the bridge doesn't work without link
Replies: 1
Views: 435

Re: Hello, the bridge doesn't work without link

It depends what you want to use the bridge for. If you just want a loopback interface you can create the bridge without any ports assigned to it, you'll just assign the bridge an IP address. For a normal setup where the router provides DHCP for all the LAN ports (except the port connected to the WAN...
by Sarel0092
Tue Mar 05, 2019 12:45 pm
Forum: Scripting
Topic: mikrotik as a manageable switch
Replies: 8
Views: 1395

Re: mikrotik as a manageable switch

Your config should look something like this: Note: Before you can use this config you'll have to reset the router to factory default with no config. You can use the following command: system reset-configuration no-defaults=yes skip-backup=yes Config after resetting the router: /interface ethernet se...
by Sarel0092
Mon Mar 04, 2019 7:22 pm
Forum: Beginner Basics
Topic: Setup OpenVPN in ethernet mode and assign static public IP addresses to clients
Replies: 3
Views: 1389

Re: Setup OpenVPN in ethernet mode and assign static public IP addresses to clients

1. Listen on both IPv4 and IPv6 for incoming client connections; 2. Listen on both UDP 1194 and TCP 443 ports And push the following setup to clients: 1. Run in ethernet (tap) mode (layer 2); 2. Assign one static public IPv4 address per client (the server has its own /24 public IPv4 prefix); 3. Ass...
by Sarel0092
Mon Mar 04, 2019 7:05 pm
Forum: General
Topic: IPSec VPN Stops Working - Ready To Send
Replies: 5
Views: 3846

Re: IPSec VPN Stops Working - Ready To Send

For the L2TP server problem I found that simply disabling and re-enabling it resolved the problem.

/interface l2tp-server server set enabled=no
/interface l2tp-server server set enabled=yes
by Sarel0092
Mon Mar 04, 2019 6:57 pm
Forum: Beginner Basics
Topic: Route netflix traffic only via VPN
Replies: 2
Views: 1200

Re: Route netflix traffic only via VPN

It should be possible. You can look at the following link for the OpenVPN Client setup on a MikroTik router: https://wiki.mikrotik.com/wiki/Manual:Interface/OVPN
by Sarel0092
Mon Mar 04, 2019 6:48 pm
Forum: General
Topic: ROS 6.44 - VPN L2TP not working
Replies: 27
Views: 15479

Re: ROS 6.44 - VPN L2TP not working

I found that simply disabling and re-enabling the L2TP server resolved the problem.

/interface l2tp-server server set enabled=no
/interface l2tp-server server set enabled=yes
by Sarel0092
Mon Mar 04, 2019 3:27 pm
Forum: Scripting
Topic: mikrotik as a manageable switch
Replies: 8
Views: 1395

Re: mikrotik as a manageable switch

You should be able to just bridge the ports and set queues with the bandwidth limits on each interface going to the customers router.
by Sarel0092
Mon Mar 04, 2019 1:53 pm
Forum: Scripting
Topic: mikrotik as a manageable switch
Replies: 8
Views: 1395

Re: mikrotik as a manageable switch

Did you have a specific MikroTik router in mind?
by Sarel0092
Mon Mar 04, 2019 1:33 pm
Forum: Scripting
Topic: remove active ppp number with find...
Replies: 1
Views: 1644

Re: remove active ppp number with find...

If you have assigned a static IP address for each PPTP connection then you can just use the following: :local IP1 "192.168.188.5" :local IP2 "192.168.188.6" :local IP3 "192.168.188.7" :if ([/ping $IP1 count=2]=0) do={/ppp active remove number=[/ppp active find where add...
by Sarel0092
Mon Mar 04, 2019 12:17 pm
Forum: General
Topic: Need help in Network and VPN
Replies: 3
Views: 758

Re: Need help in Network and VPN

Can you export your routers PPP and Wireless configs? To export the PPP settings: ppp export hide-sensitive To export the Wireless settings: interface wireless export hide-sensitive You can also export the full configuration of your router: export hide-sensitive The "hide-sensitive" part w...
by Sarel0092
Mon Mar 04, 2019 12:09 pm
Forum: General
Topic: help for sxt lte VPN from android cliet
Replies: 5
Views: 1156

Re: help for sxt lte VPN from android cliet

Is your PPTP VPN using a different IP range as your local network?

If it is then you need to add a rule in NAT to translate that IP range to your public IP address for Internet access.
by Sarel0092
Mon Mar 04, 2019 12:06 pm
Forum: Beginner Basics
Topic: VPN server on sxt lte setup
Replies: 7
Views: 2260

Re: VPN server on sxt lte setup

I would suggest trying to login into your router remotely using the public IP address.

Go to https://www.whatsmyip.org/ to see what your current Public IP address is.

If you can log into the router remotely. Then you have to decide what VPN protocol your want to use.
by Sarel0092
Fri Mar 01, 2019 3:15 pm
Forum: General
Topic: Need help in Network and VPN
Replies: 3
Views: 758

Re: Need help in Network and VPN

If you setup the VPN connection on your PC do you still get the 2MB?
by Sarel0092
Tue Jan 29, 2019 2:57 pm
Forum: Scripting
Topic: Presence detection for domotics
Replies: 2
Views: 1147

Re: Presence detection for domotics

You can try the below code: import paramiko ssh = paramiko.SSHClient() ip_0 = 'router ip address' user_0 = 'username' pass_0 = 'password' com_0 = 'ip dhcp-server lease print' #com_0 = 'ip dhcp-server lease print where mac-address=XX:XX:XX:XX:XX:XX' # Add the MAC address of the device com_1 = 'ip arp...
by Sarel0092
Tue Jan 29, 2019 2:42 pm
Forum: Scripting
Topic: Ampersand in Password
Replies: 1
Views: 637

Re: Ampersand in Password

I use the below code, this works with special characters in the password: import paramiko ssh = paramiko.SSHClient() ip1 = 'X.X.X.X' u1 = 'user2' p1 = '#$!@%&' ssh.set_missing_host_key_policy(paramiko.AutoAddPolicy()) ssh.connect(ip1, port=5252, username=u1, password=p1) stdin, stdout, stderr = ...
by Sarel0092
Tue Jan 29, 2019 2:10 pm
Forum: Beginner Basics
Topic: VPN Gateway help
Replies: 2
Views: 535

Re: VPN Gateway help

Do you have any firewall rules in place for the VPN connection?
by Sarel0092
Tue Jan 29, 2019 2:06 pm
Forum: Beginner Basics
Topic: SIP Trunks and registration packets
Replies: 2
Views: 1248

Re: SIP Trunks and registration packets

Under "ip > firewall > service ports" is sip or siphelper enabled?
by Sarel0092
Tue Jan 29, 2019 1:55 pm
Forum: General
Topic: Don't buy Mikrotik hardware! NO SUPPORT
Replies: 15
Views: 2459

Re: Don't buy Mikrotik hardware! NO SUPPORT

DON'T buy any hardware from Mikotik, NO SUPPORT AT ALL. I agree, but only when it comes to their RBSXTLTE3-7 and RBwAPR-2nD&R11e-LTE. I've been talking to their support about the routers loosing LTE connection and can't reconnect. All their support stopped end of 2018. Makes me wonder if its th...
by Sarel0092
Tue Jan 29, 2019 1:42 pm
Forum: General
Topic: SXT LTE not reconnecting
Replies: 8
Views: 2786

Re: SXT LTE not reconnecting

I've been talking to MikroTik support since September last year. I'm currently on v6.43.8 and I've also tested v6.42.11, but still experience the same problem.

Now they aren't responding to email.

It doesn't seem like they will fix this problem.
by Sarel0092
Tue Aug 07, 2018 8:49 am
Forum: General
Topic: SXT LTE not reconnecting
Replies: 8
Views: 2786

SXT LTE not reconnecting

Hi All, Has anyone had the below problems with the SXT LTE? Can't automatically reconnect if connection is dropped. No traffic can passthrough the LTE connection then you have to disable the interface and enable it again. When this happens I can see the LTE interface got a IP address. Currently I'm ...