Community discussions

Search found 22 matches

by Zoolander06
Wed Aug 07, 2019 1:25 pm
Forum: General
Topic: How to set priority code on vlan (for pppoe)
Replies: 9
Views: 866

Re: How to set priority code on vlan (for pppoe)

Yes but some equipements won't process Ethernet frames with 802.1q added bytes, I think... I managed to get it working by matching mac address. Actually, I know mac address cause even without the priority code set, PPPoE works, the only thing is that upstream bandwith is quite limited. So, I have to...
by Zoolander06
Tue Jul 30, 2019 7:00 pm
Forum: General
Topic: How to set priority code on vlan (for pppoe)
Replies: 9
Views: 866

Re: How to set priority code on vlan (for pppoe)

I will try with src mac address.
If I tag everything with priority code 2, I think it will break my local network too...
by Zoolander06
Tue Jul 30, 2019 5:59 pm
Forum: General
Topic: How to set priority code on vlan (for pppoe)
Replies: 9
Views: 866

Re: How to set priority code on vlan (for pppoe)

Thank you Sindy for this explanation :)

I don't understand how the MAC address matching work.
Do I have to match on the MAC address of the SDSL modem ?

Joris
by Zoolander06
Tue Jul 30, 2019 3:07 pm
Forum: General
Topic: How to set priority code on vlan (for pppoe)
Replies: 9
Views: 866

Re: How to set priority code on vlan (for pppoe)

Yes you're right, but my problem is that I have to set a priority code on the VLAN, and I want to be sure I do it the right way.
by Zoolander06
Tue Jul 30, 2019 12:16 pm
Forum: General
Topic: How to set priority code on vlan (for pppoe)
Replies: 9
Views: 866

Re: How to set priority code on vlan (for pppoe)

I reply myself :)

What if I do that ?
/interface ethernet switch rule
add new-vlan-priority=2 ports=ether1 switch=switch1
/interface ethernet switch vlan
add independent-learning=no ports=ether1 switch=switch1 vlan-id=2900
Is that correct ? I'm not sure how vlan works on switch level...
by Zoolander06
Tue Jul 30, 2019 12:08 pm
Forum: General
Topic: How to set priority code on vlan (for pppoe)
Replies: 9
Views: 866

How to set priority code on vlan (for pppoe)

Hello folks, I have a SDSL access, and my ISP ask me to set a pppoe session over the vlan2900, with the priority code 2. Before I was working with Zyxel, and I just had to specify priority code in vlan settings. Now I work with Mikrotik (and I love the freedom they offer), and I don't know how to do...
by Zoolander06
Thu Jul 11, 2019 6:49 pm
Forum: General
Topic: No traffic in lan attached queue trees
Replies: 0
Views: 207

No traffic in lan attached queue trees

Hello, I usually use queue trees to prioritize VoIP traffic, and it works well. But I have an issue with a rb2011 : there is absolutely no traffic going through queue trees attached to my lan interfaces. I had this issue in the past because there was a "fast path" default rule, but on this router, I...
by Zoolander06
Mon Apr 29, 2019 12:18 pm
Forum: General
Topic: Routing mangle rule block output traffic
Replies: 2
Views: 217

Re: Routing mangle rule block output traffic

Hey,

I just solved my problem : I haven't specified a in. interface in my mangle rule, so I assume that incoming packets from the wan were be routed by my output route, and that's why it didn't work...

Joris
by Zoolander06
Mon Apr 29, 2019 12:07 pm
Forum: General
Topic: Routing mangle rule block output traffic
Replies: 2
Views: 217

Re: Routing mangle rule block output traffic

Plus, I don't know if it's related, but probably, my dst-nat rules don't work at all.

Joris
by Zoolander06
Mon Apr 29, 2019 11:56 am
Forum: General
Topic: Routing mangle rule block output traffic
Replies: 2
Views: 217

Routing mangle rule block output traffic

Hello folks, I have a weird problem with a RB2011 router : I have two WAN interface, and two LAN interfaces, I wanted to force each LAN interface to go out from a specific WAN interface, as I often do without any problem. So I created mangle rules to mark connections, then to mark routes, and I crea...
by Zoolander06
Fri Mar 22, 2019 3:56 pm
Forum: Announcements
Topic: v6.45beta [testing] is released!
Replies: 305
Views: 71354

Re: v6.45beta [testing] is released!

You can specify DHCP option set per DHCP network. You're right, but I usually need all my phones to be on the same network. I think I could make some subnets, maybe it would work, but it would be easier and more logical to set the options in the vendor class identifier matcher, or in the pool. Than...
by Zoolander06
Wed Mar 20, 2019 4:37 pm
Forum: Announcements
Topic: v6.45beta [testing] is released!
Replies: 305
Views: 71354

Re: v6.45beta [testing] is released!

So I gave a try to the new vendor class identifier matcher feature, it works well but it's quite limited : one can only reserve a pool of IPs to a certain type of devices. It would be nice to be able to send different options to certain devices. Example : I have Yealink and Cisco IP phones on my net...
by Zoolander06
Mon Mar 18, 2019 6:06 pm
Forum: Announcements
Topic: v6.45beta [testing] is released!
Replies: 305
Views: 71354

Re: v6.45beta [testing] is released!


*) dhcpv4-server - added "vendor-class-id" matcher (CLI only);
Hi,

Is there a documentation somewhere about this new feature ?

Joris
by Zoolander06
Tue Jan 15, 2019 12:16 pm
Forum: Beginner Basics
Topic: VoIP traffic shaping doesn't works
Replies: 22
Views: 1156

Re: VoIP traffic shaping doesn't works

Yes I figured it out :) So, I will do that : on disconnect (of pppoe-out1) : /queue tree set download max-limit=[/queue tree get MAISON-download max-limit] on connect (of pppoe-out1) : /interfaces pppoe-client monitor pppoe-out2 once do={ if ($status= "connected") do={ /queue tree set download max-l...
by Zoolander06
Mon Jan 14, 2019 6:14 pm
Forum: Beginner Basics
Topic: VoIP traffic shaping doesn't works
Replies: 22
Views: 1156

Re: VoIP traffic shaping doesn't works

Thanks for showing me my mistake.
I understand the problem in case of one link down, maybe I can resolve that particular issue with a few lines of script somewhere...
But I can't find a simple way to execute script on ppp events...
by Zoolander06
Mon Jan 14, 2019 11:09 am
Forum: Beginner Basics
Topic: VoIP traffic shaping doesn't works
Replies: 22
Views: 1156

Re: VoIP traffic shaping doesn't works

Few remarks: * I assume your pppoe's are asymmetric, with download speed >> upload speed? if so max on download doesn't reflect this. Actually, yes, it's asymmetric, 800k upload, and 1600k download on each link. * define priority (>2) on maison-* queues Ok I will. * (unrelated to this thread: that'...
by Zoolander06
Fri Jan 11, 2019 5:52 pm
Forum: Beginner Basics
Topic: VoIP traffic shaping doesn't works
Replies: 22
Views: 1156

Re: VoIP traffic shaping doesn't works

Here is my config, I use protocol and port as criterias to mark connections. # jan/11/2019 09:15:05 by RouterOS 6.43.8 # software id = 3USJ-9ZE1 # # model = 2011UiAS # serial number = 7DD5080FB8A6 /interface bridge add name=bridge /interface pppoe-client add allow=chap disabled=no interface=ether1 k...
by Zoolander06
Fri Jan 11, 2019 4:40 pm
Forum: Beginner Basics
Topic: VoIP traffic shaping doesn't works
Replies: 22
Views: 1156

Re: VoIP traffic shaping doesn't works

That should work. It's a bit after the fact, as it already passed the isp pipe, but by controlling the internal "gate" one can also shape the overall throughput. So you just need to make sure your classification is working. What I do: * connection-mark all VOIP related connection (which are not alr...
by Zoolander06
Fri Jan 11, 2019 4:06 pm
Forum: Beginner Basics
Topic: VoIP traffic shaping doesn't works
Replies: 22
Views: 1156

Re: VoIP traffic shaping doesn't works

Well, it's not, it seems that the mangle rule which mark the connection only see outgoing packets (I only have 80kbps going through it, it should be 160kbps). I think that I must miss something about how RouterOS handle this.
by Zoolander06
Fri Jan 11, 2019 3:32 pm
Forum: Beginner Basics
Topic: VoIP traffic shaping doesn't works
Replies: 22
Views: 1156

Re: VoIP traffic shaping doesn't works

Where is that "downstream queue" attached to? What is it's parent?
I have a "download" queue attached to my ethernet bridge (so my LAN), and a "voip_download" queue attached to the "download" queue.
I basically copied what is done in the "QoS best practices" found on the Mikrotik website.
by Zoolander06
Fri Jan 11, 2019 11:40 am
Forum: Beginner Basics
Topic: VoIP traffic shaping doesn't works
Replies: 22
Views: 1156

Re: VoIP traffic shaping doesn't works

Thank you both for helping me ! @pcunite : I carefully read the post, and it seems that this is basically what I've done on my router, but I will check it :) @pe1chl : I understand that I can't control what is going on on the isp side, but I still should see an activity when monitoring my voip downs...
by Zoolander06
Thu Jan 03, 2019 5:44 pm
Forum: Beginner Basics
Topic: VoIP traffic shaping doesn't works
Replies: 22
Views: 1156

VoIP traffic shaping doesn't works

Hello folks, I'm a beginner with Mikrotik, and I try to do VoIP traffic shaping, so I read this document : https://mum.mikrotik.com/presentations/US16/presentation_3004_1462512668.pdf , and I tried to apply that to my configuration. It kinda works, when I make a call, I have about 80kbps flowing thr...