Community discussions

MUM Europe 2020

Search found 15 matches

by creatin
Tue Jan 07, 2020 3:18 am
Forum: Scripting
Topic: [ask] Auto detect public ip and generate dstnat rule
Replies: 7
Views: 932

Re: [ask] Auto detect public ip and generate dstnat rule

For me it worked only once during initial setup and nothing after.
by creatin
Fri Jan 03, 2020 2:20 pm
Forum: Wireless Networking
Topic: Sxt LTE 4g+ Cat6>
Replies: 32
Views: 3043

Re: Sxt LTE 4g+ Cat6>

For this specific device, DL speed is up to 300 mbps but ethernet port can handle only 100 mbit, what's the point in purchasing this device then? Easy, all person who are not in city who are happy when reach 20/5Mb. For them and me a limit of 100Mb is not problem. I have R11e-LTE6 with 2xCA and now...
by creatin
Thu Jan 02, 2020 5:59 pm
Forum: Wireless Networking
Topic: Sxt LTE 4g+ Cat6>
Replies: 32
Views: 3043

Re: Sxt LTE 4g+ Cat6>

For this specific device, DL speed is up to 300 mbps but ethernet port can handle only 100 mbit, what's the point in purchasing this device then?
by creatin
Mon Dec 30, 2019 2:36 pm
Forum: Scripting
Topic: [ask] Auto detect public ip and generate dstnat rule
Replies: 7
Views: 932

Re: [ask] Auto detect public ip and generate dstnat rule

MikroTik DDNS service didn't work for me, each time ISP changed the address, MTiK service didn't update it. I created a script (below), it's running every 5 minutes and sending an email with OLD and NEW IP address delay 5; :if ([:len [/file find name=currentIP.txt]] = 0) do={ :local myfile "currentI...
by creatin
Wed Dec 18, 2019 11:31 am
Forum: Beginner Basics
Topic: access MT router over the internet [SOLVED]
Replies: 2
Views: 389

Re: access MT router over the internet [SOLVED]

Hi, maybe you don't have to use portforward. My cable modem/router has portforward option but it doesn't work. I added IP address of my Mikrotik to DMZ of the modem/router so it's entirely exposed to the internet. I've closed all services and ports on Mikrotik which I don't need. Before you continue...
by creatin
Sat Dec 14, 2019 4:00 am
Forum: Scripting
Topic: List number of connections per IP
Replies: 13
Views: 1401

Re: List number of connections per IP

Using src-address~"$adr" is not exact enough because it will also count IP addresses in one go like 192.168.88.1 192.168.88.11-19 and 192.168.88.100-199 To avoid this you need to add a 'separator' the first character after the last digit of IP address and that is here the ":" in front of the port-n...
by creatin
Sat Dec 14, 2019 3:58 am
Forum: Scripting
Topic: List number of connections per IP
Replies: 13
Views: 1401

Re: List number of connections per IP

Thanks, I'd like to avoid writing to a file. Right, run my solution. It prints to the screen the way you wanted. added additional lines to remove garbage :) :put ("\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\...
by creatin
Sat Dec 14, 2019 2:31 am
Forum: Scripting
Topic: List number of connections per IP
Replies: 13
Views: 1401

Re: List number of connections per IP

Thanks, I'd like to avoid writing to a file. Still a new user and red a lot on how not to use local storage as much as possible, although I'm creating a backup of router each day in a file, anyway.... I came up with following: { /ip dhcp-server lease :foreach i in=[find] do={ :local adr "$[get value...
by creatin
Sat Dec 14, 2019 1:02 am
Forum: Scripting
Topic: List number of connections per IP
Replies: 13
Views: 1401

Re: List number of connections per IP

This lines although it should be a variable, it prints number of connections:

:local con [/ip firewall connection print count-only where src-address~"$adr"];


trying to figure out how to bypass it
by creatin
Sat Dec 14, 2019 12:14 am
Forum: Scripting
Topic: List number of connections per IP
Replies: 13
Views: 1401

Re: List number of connections per IP

Unfortunately, same output, still not sure why
by creatin
Fri Dec 13, 2019 10:50 pm
Forum: Scripting
Topic: List number of connections per IP
Replies: 13
Views: 1401

Re: List number of connections per IP

Not sure I understand, probably doing something wrong, changed the code: { /ip dhcp-server lease :foreach i in=[find] do={ :local adr "$[get value-name=address $i]"; :local con [/ip firewall connection print count-only where src-address~"$adr"]; :put "connections:$con"; } } and now results is, I'm d...
by creatin
Fri Dec 13, 2019 9:46 pm
Forum: Scripting
Topic: List number of connections per IP
Replies: 13
Views: 1401

List number of connections per IP

Hi, new to Mikrotik, browsed through forum last couple of weeks, learned a lot about scripting (and still learning). One of complaints from different users is Mikrotik lacks list of number of connections per each IP. "/ip firewall connection print count-only" will show number of connections for all ...
by creatin
Fri Dec 06, 2019 2:56 pm
Forum: Scripting
Topic: How to detect slow speed or if ether1 exceed limit of 50 gb?
Replies: 1
Views: 615

Re: How to detect slow speed or if ether1 exceed limit of 50 gb?

Hi,

I know it's an old thread, is this information still needed?
Do you have a quota of 50 gb on your download only or on total traffic (download + upload)
by creatin
Wed Dec 04, 2019 12:54 am
Forum: Scripting
Topic: Find External IP ?
Replies: 16
Views: 40605

Re: Find External IP ?

This one works: before you run the script create a file in Windows called currentIP.txt , write inside some IP address like 1.1.1.1 , save file and upload it to your router. Run script below: :local filename "currentIP.txt" :local ip [file get currentIP.txt contents]; delay 1 :local cip ([:resolve m...
by creatin
Tue Dec 03, 2019 1:00 am
Forum: Scripting
Topic: Find External IP ?
Replies: 16
Views: 40605

Re: Find External IP ?

Or:

:put [:resolve myip.opendns.com server=208.67.222.222]