Community discussions

MikroTik App

Search found 33 matches

by FRANKMUNOZ
Wed Jul 01, 2020 12:32 am
Forum: General
Topic: Schedule to enable and disable interface in mikrotik
Replies: 14
Views: 8190

Re: Schedule to enable and disable interface in mikrotik

Can someone please correct my scritpt. I am trying to turn off wifi at night, which i recommend to everyone who has a wifi in their house, while they are sleeping, and turn it on automatically in the morning. I have followed the forums but unless i turn it off manually by using the "run script" com...
by FRANKMUNOZ
Wed Jun 24, 2020 5:52 pm
Forum: General
Topic: NTP server with GMT DST
Replies: 12
Views: 1401

Re: NTP server with GMT DST

Time zone is always set on the device. NTP just helps to correct the time.
How is DST activated in the mikrotik?
by FRANKMUNOZ
Sat Jun 20, 2020 8:04 pm
Forum: Scripting
Topic: Release dhcp client when rx rate = —-
Replies: 1
Views: 389

Re: Release dhcp client when rx rate = —-

Good Night
I need a script to automaticlly
Release dhcp client when rx rate = —-
And wan is connected
Thank
:if ( [/ping 8.8.8.8 interface= "ETHERT 1" count=6 ] = 0) do={/ip dhcp-client release numbers=0}

ETHERT 1 is my WAN
by FRANKMUNOZ
Sat Jun 20, 2020 12:36 am
Forum: General
Topic: Block pornographic pages
Replies: 5
Views: 1362

Block pornographic pages

Friends,
I would like to block all pornography on my network, what would be the best method?


ELDONCITO
by FRANKMUNOZ
Sat Jun 13, 2020 7:56 pm
Forum: General
Topic: WEB PROXY CACHE.
Replies: 1
Views: 443

WEB PROXY CACHE.

Friends,
It is recommended to make a web proxy cache in an RB 750GL, what do you recommend?

Thank you for your answers.

ELDONCITO
by FRANKMUNOZ
Wed Jun 10, 2020 7:17 pm
Forum: General
Topic: UPDATE FIRMWARE [SOLVED]
Replies: 3
Views: 850

UPDATE FIRMWARE [SOLVED]

Friends,
Every time a firmware update comes out in mikrotik, is it recommended to do it to the RB? Another thing is what type of firmware is more advisable to update, stable or testing?.

Thank you for your recommendations.


ELDONCITO.
by FRANKMUNOZ
Sat Jun 06, 2020 12:59 am
Forum: General
Topic: DNS DoH [SOLVED]
Replies: 6
Views: 1354

Re: DNS DoH [SOLVED]

You can only block pornographic sites.

The problem is, DoH seems to be invented to able you to visit pornographic sites and no one can stop you doing so.


Well let me tell you dear friend that it can be done and I already did it.
by FRANKMUNOZ
Fri Jun 05, 2020 7:45 pm
Forum: General
Topic: DNS DoH [SOLVED]
Replies: 6
Views: 1354

DNS DoH [SOLVED]

Cheers.
How can I block pronographic pages using DNs DoH, I would appreciate if someone can help me.

El DONCITO.
by FRANKMUNOZ
Thu Jun 04, 2020 2:27 am
Forum: Scripting
Topic: Script not Running
Replies: 5
Views: 887

Re: Script not Running

this is:
add disabled=yes interval=10s name=schedule1 on-event=\
"/ip firewall filter move 2 destination=11;" policy=\
ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-date=\
jun/03/2020 start-time=19:25:10
by FRANKMUNOZ
Sun May 24, 2020 7:50 pm
Forum: General
Topic: DHCP Client Script when provider renews lease
Replies: 8
Views: 1458

Re: DHCP Client Script when provider renews lease

hello friend, try this script

:if ( [/ping 8.8.8.8 interface= "ETHERT 1" count=6 ] = 0) do={/ip dhcp-client release numbers=0}




ETHERT 1 = WAN
by FRANKMUNOZ
Sun May 17, 2020 5:51 pm
Forum: Scripting
Topic: Script to control uptime [SOLVED]
Replies: 36
Views: 4408

Re: Script to control uptime [SOLVED]

I am very new to the forum, is there something where they explain the use of the forum? How can I send private messages? For PM click on the user: if the user allows PM (in his profile settings) then there will be a link for sending. Have a look at your own profile page below, right-bottom side. On...
by FRANKMUNOZ
Sun May 17, 2020 3:14 pm
Forum: General
Topic: Manual to use this forum page
Replies: 1
Views: 406

Manual to use this forum page

Hello everyone,
there is a manual or something similar to read it and use all the tools that this page of this prestigious forum has, I thank you.
by FRANKMUNOZ
Sat May 16, 2020 3:40 pm
Forum: Scripting
Topic: Script to control uptime [SOLVED]
Replies: 36
Views: 4408

Re: Script to control uptime [SOLVED]

I am very new to the forum, is there something where they explain the use of the forum?


How can I send private messages?
by FRANKMUNOZ
Fri May 15, 2020 6:04 pm
Forum: Scripting
Topic: Script to control uptime [SOLVED]
Replies: 36
Views: 4408

Re: Script to control uptime [SOLVED]

ARMANDO, How can I leave this topic as resolved?
by FRANKMUNOZ
Fri May 15, 2020 12:58 pm
Forum: Scripting
Topic: Script to control uptime [SOLVED]
Replies: 36
Views: 4408

Re: Script to control uptime [SOLVED]

I don't understand what you are asking. There is nothing to put on layer7. Use the solution that I gave you with reply #13 on this message, where I used the persistent variable in layer7. Friend ARMANDO, if the two scripts worked for me, the one for layer 7 and the one for text in the file, very gr...
by FRANKMUNOZ
Thu May 14, 2020 10:39 pm
Forum: Scripting
Topic: Script to control uptime [SOLVED]
Replies: 36
Views: 4408

Re: Script to control uptime [SOLVED]

I just tested it and it does not overwrite the data, it creates the file yes, but it does not overwrite the data every minute. So I guess we can conclude that our routers are behaving differently. Now it's up to you what solution you will adopt. I gave you all the help possible, now it's on you. Ta...
by FRANKMUNOZ
Thu May 14, 2020 5:16 pm
Forum: Scripting
Topic: Script to control uptime [SOLVED]
Replies: 36
Views: 4408

Re: Script to control uptime [SOLVED]

Dear ARMANDO, the text is created in the file, but it is not overwritten every minute, which will happen there. Thank you. Dear Frank, are you sure ? Please check better, because the text inside the file is overwritten every minute. Let it run for few minutes and check at the end when you will rebo...
by FRANKMUNOZ
Thu May 14, 2020 3:54 pm
Forum: Scripting
Topic: Script to control uptime [SOLVED]
Replies: 36
Views: 4408

Re: Script to control uptime [SOLVED]

that was the script dear brother. Thank you. just out of curiosity, is there a way that instead of layer protocol 7 it's copied to a file If you want to write the info to a file instead of layer7 protocol, you can use this version. However you should read this info about writing to disk, which depe...
by FRANKMUNOZ
Thu May 14, 2020 12:28 am
Forum: Scripting
Topic: Script to control uptime [SOLVED]
Replies: 36
Views: 4408

Re: Script to control uptime [SOLVED]

that was the script dear brother. Thank you.



just out of curiosity, is there a way that instead of layer protocol 7 it's copied to a file
by FRANKMUNOZ
Tue May 12, 2020 11:32 pm
Forum: Scripting
Topic: Script to control uptime [SOLVED]
Replies: 36
Views: 4408

Re: Script to control uptime [SOLVED]

ARMANDO, thanks for the scripts, but the first one doesn't work since when restarted the RB takes the same time as the second script
by FRANKMUNOZ
Tue May 12, 2020 5:12 pm
Forum: Scripting
Topic: Script to control uptime [SOLVED]
Replies: 36
Views: 4408

Re: Script to control uptime [SOLVED]

ARMANDO, it is very difficult for me to make this script could you help me. Thank you. This script will write into firewall -> layer7 protocol a value of val_uptime with the uptime from your router. You can start from here and change it to your needs. :global persistVar do={ :local varName $1; :loc...
by FRANKMUNOZ
Mon May 11, 2020 9:15 pm
Forum: Scripting
Topic: Script to control uptime [SOLVED]
Replies: 36
Views: 4408

Re: Script to control uptime [SOLVED]

ARMANDO, it is very difficult for me to make this script could you help me. Thank you.
by FRANKMUNOZ
Mon May 11, 2020 3:32 pm
Forum: Scripting
Topic: Script to control uptime [SOLVED]
Replies: 36
Views: 4408

Re: Script to control uptime [SOLVED]

To retrieve the uptime: /system resource> :put [get uptime]; And in into a variable: { :local getUptime [/system resource get uptime] :put $getUptime } thank you my friend, but with this script is the moment when the equipment is turned off due to the power cut and also when the electricity is rest...
by FRANKMUNOZ
Mon May 11, 2020 12:49 am
Forum: Scripting
Topic: Script to control uptime [SOLVED]
Replies: 36
Views: 4408

Re: Script to control uptime [SOLVED]

To retrieve the uptime: /system resource> :put [get uptime]; And in into a variable: { :local getUptime [/system resource get uptime] :put $getUptime } thank you my friend, but with this script is the moment when the equipment is turned off due to the power cut and also when the electricity is rest...
by FRANKMUNOZ
Sun May 10, 2020 2:19 pm
Forum: Scripting
Topic: Script to control uptime [SOLVED]
Replies: 36
Views: 4408

Script to control uptime [SOLVED]

Greetings,
friends, it will be possible to make a script so that I can know at what time the electric service is interrupted and resumed in my equipment, it could be done using the uptime of my RB.
by FRANKMUNOZ
Fri May 01, 2020 3:33 am
Forum: Scripting
Topic: SCRIPT to research all the mangrove counters
Replies: 1
Views: 729

SCRIPT to research all the mangrove counters

friends, how do I make a script to reset all the counters in ip mangle?
by FRANKMUNOZ
Sun Apr 19, 2020 4:21 pm
Forum: General
Topic: Edit console logo in MIKROTIK
Replies: 2
Views: 1048

Edit console logo in MIKROTIK

Hello friends, is there a way to edit the name MIKROTIK that brings the RB by default in the console.
by FRANKMUNOZ
Wed Apr 01, 2020 3:56 pm
Forum: Scripting
Topic: Script to free memory on my RB
Replies: 2
Views: 1765

Script to free memory on my RB

Greetings dear friends, I want to know if there is the possibility of creating a script that automatically releases the memory of my RB?
I do not know if they understood me
by FRANKMUNOZ
Tue Mar 31, 2020 6:02 pm
Forum: Scripting
Topic: how clear Mikrotik Log ?
Replies: 20
Views: 15459

Re: how clear Mikrotik Log ?

/file remove [find name~"log\\..*\\.txt"] Is that easier or harder? You can script any of these, you know, then just /system script run NameOfScript Friend, I tried your script and it doesn't work, how would the script to delete everything that is registered in the "log". Thank you for your collabo...
by FRANKMUNOZ
Wed Mar 25, 2020 5:33 pm
Forum: Scripting
Topic: SCRIPT MANUAL IN SPANISH
Replies: 0
Views: 1679

SCRIPT MANUAL IN SPANISH

friends
Where can I get an online manual in Spanish to learn how to configure scrpts in mikrotik?

thanks
by FRANKMUNOZ
Mon Mar 23, 2020 5:39 pm
Forum: Scripting
Topic: Enable a rule just for specific time
Replies: 6
Views: 2021

Re: Enable a rule just for specific time

/system scheduler add disabled=yes interval=30s name="Scheduler10" on-event=\ "/ip firewall filter disable 2\r\ \ndelay 10;\r\ \n/ip firewall filter enable 2" policy=\ ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-date=dec/01/2018 start-time=00:00:00 there you have another s...
by FRANKMUNOZ
Mon Mar 23, 2020 4:12 pm
Forum: Scripting
Topic: Enable a rule just for specific time
Replies: 6
Views: 2021

Re: Enable a rule just for specific time

/system scheduler add interval=31s name=schedule1 on-event="/ip firewall filter disable 2" policy=\ ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-time=startup add interval=14s name=schedule2 on-event="/ip firewall filter enable 2" policy=\ ftp,reboot,read,write,policy,test,p...
by FRANKMUNOZ
Mon Feb 24, 2020 2:55 pm
Forum: General
Topic: Facebook packet marking
Replies: 2
Views: 1393

Re: Facebook packet marking

Friends, how do you mark the FACEBOOK package in mangrove, can you publish your rules?
Hi buddy, that is possible how far I know.

Regards,
V. Smith
Aas you mark your friend?