Community discussions

MikroTik App

Search found 22 matches

by al3xeezer
Wed Nov 11, 2020 1:08 pm
Forum: General
Topic: LTE Firmware Format
Replies: 1
Views: 250

LTE Firmware Format

Hi, does anyone know how the LTE Firmware name is formatted? (what does each part of the name mean)
 revision: "MikroTik_CP_2.160.000_v018"

  • Mikrotik_CP_2: ?
  • 160: ?
  • 000_v018: version, I guess.
by al3xeezer
Thu Oct 01, 2020 4:02 pm
Forum: Scripting
Topic: Need help picking Array Values []
Replies: 2
Views: 411

Re: Need help picking Array Values []

I've tested your code (setting $logEntryMessage to "<110.54.203.170>: user ppp1 authentication failed") and seems ok to me... ¿Maybe $logEntryMessage doesn't have that format?
by al3xeezer
Wed Sep 23, 2020 6:02 pm
Forum: General
Topic: [FEATURE REQUEST] Speedtest tool src-address parameter
Replies: 0
Views: 203

[FEATURE REQUEST] Speedtest tool src-address parameter

Hello everyone! In the v6.47.4 stable release, Mikrotik added (fixed actually) the "src-address" parameter to SFTP requests via /tool fetch. Seeing that is becoming more and more common (it is available for tools like ping, fetch or traceroute), I think it would be very useful to have this...
by al3xeezer
Tue Sep 22, 2020 2:11 pm
Forum: General
Topic: mikrotik scp/sftp client to transfer file between MT
Replies: 16
Views: 18747

Re: mikrotik scp/sftp client to transfer file between MT

Has anyone tried to upload a file (Mikrotik router to remote server) using the src-address parameter? I'm using the following command: /tool fetch upload=yes url="sftp://serverIP/path/file" user=$user password=$password src-path=$file src-address=$ip But it seems there's a bug or somethin...
by al3xeezer
Mon Sep 21, 2020 5:48 pm
Forum: Scripting
Topic: SFTP src-address parameter [SOLVED]
Replies: 1
Views: 331

Re: SFTP src-address parameter [SOLVED]

Solved in v6.47.4 viewtopic.php?f=21&t=166428
by al3xeezer
Mon Sep 21, 2020 5:45 pm
Forum: Announcements
Topic: v6.47.4 [stable] is released!
Replies: 68
Views: 16672

Re: v6.47.4 [stable] is released!

*) fetch - fixed "src-address" usage for SFTP;
Seems to be fixed, ty!

However, I've done a couple of tests trying to upload/download some files to/from a server and I'm getting really low transfer speeds (~100KiB/s). Has anyone experienced the same type of behavior?
by al3xeezer
Mon Sep 21, 2020 2:22 pm
Forum: Scripting
Topic: Need help in array!
Replies: 3
Views: 414

Re: Need help in array!

With :local month ($months->[:pick $date 0 3] ); you are correctly obtaining the content of the array. The problem is the :if statement. If I'm right, what you are trying to do is check if the month is set and, if so, set $newPassword with the selected value. You can do it like this: if ([:typeof ($...
by al3xeezer
Fri Sep 18, 2020 2:48 pm
Forum: General
Topic: How to copy log items in WinBox?
Replies: 3
Views: 342

Re: How to copy log items in WinBox?

I think you can copy logs by opening a new terminal window and printing them with /log print.
by al3xeezer
Wed Sep 16, 2020 12:12 pm
Forum: General
Topic: Scripting/Testing workflow
Replies: 1
Views: 200

Scripting/Testing workflow

Hi everyone! I've been using MT for a couple of months now and, since the moment I coded my first script, I've improved (rather optimized) quite a bit my workflow... Even so, I still think there is room to improve. At the moment, my workflow is: Coding the desired script in VSCode (with the ROS exte...
by al3xeezer
Fri Sep 11, 2020 10:30 am
Forum: General
Topic: Serial Number in IP Discovery
Replies: 1
Views: 275

Re: Serial Number in IP Discovery

Would be pretty neat tbh. +1
by al3xeezer
Thu Sep 10, 2020 4:39 pm
Forum: Scripting
Topic: How to get members of interface list [SOLVED]
Replies: 4
Views: 554

Re: How to get members of interface list [SOLVED]

Did a bit of testing and I came up with this:
:foreach interface in=[/interface list member print as-value where list=WAN] do={:put ($interface->"interface")}
by al3xeezer
Thu Sep 10, 2020 1:42 pm
Forum: Scripting
Topic: How to get members of interface list [SOLVED]
Replies: 4
Views: 554

Re: How to get members of interface list [SOLVED]

If you want to get the interface's names you can do this:
:local interfaces [/interface list member find list=WAN];
:foreach interface in=$interfaces do={
	:put [/interface get $interface name]
}

In the code I only print them, but you can store the values in a second array or so.
by al3xeezer
Fri Sep 04, 2020 12:35 pm
Forum: Scripting
Topic: syntax to wildcard the rest of path
Replies: 3
Views: 353

Re: syntax to wildcard the rest of path

Thank you for your quick reply. this is my script but why did not run? :foreach filename in=[/file find name ~ "routeros-mipsbe.*"] do={ /tool fetch mode=ftp upload=no address=x.x.x.x port=xx user="x" password="x" src-path=[/file get $filename name] dst-path=[/file get...
by al3xeezer
Fri Sep 04, 2020 11:42 am
Forum: Scripting
Topic: syntax to wildcard the rest of path
Replies: 3
Views: 353

Re: syntax to wildcard the rest of path

You may be able to do this by using regex. Try something like this:
:foreach filename in=[/file find name ~ "routeros-mipsbe.*"] do={
	/tool fetch mode=ftp ... src-path=[/file get $filename name]
}
by al3xeezer
Thu Sep 03, 2020 5:09 pm
Forum: Announcements
Topic: v6.47.3 [stable] is released!
Replies: 50
Views: 11411

Re: v6.47.3 [stable] is released!

Hi, I'm experiencing the same behaviour as in previous versions at trying to upload files via SFTP from Mikrotik to a remote server. /tool fetch upload=yes url="sftp://server/path/file" user=example password=example src-path=file src-address=ip failure: only http[s]/sftp supports src-addre...
by al3xeezer
Thu Aug 20, 2020 11:15 am
Forum: Announcements
Topic: v6.47.2 [stable] is released!
Replies: 90
Views: 18404

Re: v6.47.2 [stable] is released!

Is this a bug? (Uploading file via SFTP from Mikrotik Router to remote server)
/tool fetch upload=yes url="sftp://server/path/file" user=example password=example src-path=file src-address=ip
failure: only http[s]/sftp supports src-address
by al3xeezer
Tue Aug 18, 2020 12:35 pm
Forum: General
Topic: Feature requests
Replies: 1302
Views: 311888

Re: Feature requests

Would be very useful to have the src-address parameter available for /tool speedtest (as it is for fetch, traceroute, ping...)

Have you consider adding it?
by al3xeezer
Mon Aug 17, 2020 2:29 pm
Forum: General
Topic: mikrotik scp/sftp client to transfer file between MT
Replies: 16
Views: 18747

Re: mikrotik scp/sftp client to transfer file between MT

Has anyone tried to upload a file (Mikrotik router to remote server) using the src-address parameter? I'm using the following command: /tool fetch upload=yes url="sftp://serverIP/path/file" user=$user password=$password src-path=$file src-address=$ip But it seems there's a bug or something...
by al3xeezer
Tue Jul 28, 2020 6:20 pm
Forum: Scripting
Topic: How to get LTE uptime?
Replies: 1
Views: 469

Re: How to get LTE uptime?

To get the uptime value just use:
:local uptime ([/interface lte info [find name=lte1] once as-value]->"session-uptime")
by al3xeezer
Tue Jul 28, 2020 5:36 pm
Forum: General
Topic: Add src-address param to /tool speedtest
Replies: 2
Views: 786

Re: Add src-address param to /tool speedtest

Indeeed, +1
by al3xeezer
Tue Jul 28, 2020 4:35 pm
Forum: General
Topic: Feature Request: IPerf
Replies: 57
Views: 16653

Re: Feature Request: IPerf

Indeed, +1!
by al3xeezer
Thu Jul 23, 2020 12:45 pm
Forum: Scripting
Topic: SFTP src-address parameter [SOLVED]
Replies: 1
Views: 331

SFTP src-address parameter [SOLVED]

Hi, I'm trying to upload some files via SFTP to a remote server using the following command: /tool fetch upload=yes url="sftp://$SERVERIP/path_to/file" user=$USER password=$PASSWORD src-path=$FILE src-address=$IP The thing is, if I remove the "src-address" parameter, it works as ...