Community discussions

MikroTik App

Search found 18 matches

by ccmks
Tue Feb 23, 2021 3:34 pm
Forum: General
Topic: Auto Throttle During Congestion
Replies: 14
Views: 712

Re: Auto Throttle During Congestion

Thanks for helping me out. I couldn't get it to work, for some reason, it only read the first if condition and action (in this case, it disable the queue). What do you think if we separate into 2 scripts and run at same time and same interval? Only 1 script will be applied no matter which condition ...
by ccmks
Mon Feb 22, 2021 3:59 am
Forum: General
Topic: Auto Throttle During Congestion
Replies: 14
Views: 712

Re: Auto Throttle During Congestion

/system script add name=throttle source=":local onThreshold 45000000\ \n:local offThreshold 40000000\ \n:local wanRate 0\ \n:for i from=0 to=54 do={\ \n :set wanRate (\$wanRate+([/interface monitor-traffic CCARENET once as-value]->\"rx-bits-per-second\"))\ \n}\ \n:set wanRate (\$wanR...
by ccmks
Sun Feb 21, 2021 4:52 pm
Forum: General
Topic: Auto Throttle During Congestion
Replies: 14
Views: 712

Re: Auto Throttle During Congestion

Is this script look good? /system script add name=throttle source=":local onThreshold 45000000\ \n:local offThreshold 40000000\ \n:local wanRate 0\ \n:for i from=0 to=54 do={\ \n :set wanRate (\$wanRate+([/interface monitor-traffic LAN once as-value]->\"rx-bits-per-second\"))\ \n}\ \n...
by ccmks
Sun Feb 21, 2021 3:58 pm
Forum: General
Topic: Auto Throttle During Congestion
Replies: 14
Views: 712

Re: Auto Throttle During Congestion

I was assuming that the queue in the tree matches on some packet-mark value, hence not assigning that packet-mark value in mangle (because the mangle rule assigning the packet-mark doesn't match if the address-list it refers to is empty) effectively inactivates the queue. But if you want to disable...
by ccmks
Sun Feb 21, 2021 2:17 pm
Forum: General
Topic: Auto Throttle During Congestion
Replies: 14
Views: 712

Re: Auto Throttle During Congestion

Thank you for providing me the script. If we just checking on bandwidth usage on interface periodically every 1 minutes, would you think that it would trigger the throttle too early? What I mean is when the script is checking the interface bandwidth and the interface might happen to reach the thresh...
by ccmks
Sat Feb 20, 2021 8:35 pm
Forum: General
Topic: Auto Throttle During Congestion
Replies: 14
Views: 712

Re: Auto Throttle During Congestion

Thank you for answering. I don't know how to make script.

Can you tell me how to make one or give me the script example? I am not good at making script.

Thank you
by ccmks
Sat Feb 20, 2021 3:02 pm
Forum: General
Topic: Auto Throttle During Congestion
Replies: 14
Views: 712

Re: Auto Throttle During Congestion

Anyone?
by ccmks
Fri Feb 19, 2021 9:16 pm
Forum: General
Topic: options for connecting two locations [SOLVED]
Replies: 13
Views: 686

Re: options for connecting two locations [SOLVED]

EoIP requires both location to have Public IP which some case people don't have public IP on both location, whereas L2TP only requires public IP on server site. In terms of performance, EoIP isn't that great (at least from what I have tested so far, the throughput wasn't impressive at all). L2TP is ...
by ccmks
Fri Feb 19, 2021 6:07 pm
Forum: General
Topic: options for connecting two locations [SOLVED]
Replies: 13
Views: 686

Re: options for connecting two locations [SOLVED]

Well, Your situation doesn't seem to be complicated than it sound. There are 3 option you can go 1. You can deploy L2TP/IPsec and use BCP to bridge between 2 sites as if they are in the same network 2. You can use EOIP strictly for voice only which you can bridge EOIP to voice VLAN and the rest of t...
by ccmks
Fri Feb 19, 2021 4:28 pm
Forum: General
Topic: Auto Throttle During Congestion
Replies: 14
Views: 712

Auto Throttle During Congestion

Hello, I am not sure if this can be achieve. I am living in one of the developing country where bandwidth is a very precious thing there. My total bandwidth is 60 Mbps, so during night time is the most congested period and it is always hitting its bandwidth capacity. After doing some analysis on tra...
by ccmks
Mon Feb 08, 2021 8:38 pm
Forum: General
Topic: Multiple tunnel vpn load balancing
Replies: 16
Views: 3859

Re: Multiple tunnel vpn load balancing

I know this thread is too old, but I have solution for this that for those who might still need it

You can create L2TP tunnel for each public IP and do OSPF routing, OSPF will do load balancing automatically
by ccmks
Fri Sep 04, 2020 3:02 pm
Forum: General
Topic: Mikrotik L2TP VPN IP Public Port Forward
Replies: 13
Views: 1435

Re: Mikrotik L2TP VPN IP Public Port Forward

/ip route add dst-address=0.0.0.0/0 gateway=<l2tp interface> routing-mark=vpn Tried this one too and doesn't work Can you test if it works when you change it to add-default-route=yes? It will route everything through VPN, but you'll see if it works or not. If it does, you can switch it back. Doesn'...
by ccmks
Fri Sep 04, 2020 4:21 am
Forum: General
Topic: Mikrotik L2TP VPN IP Public Port Forward
Replies: 13
Views: 1435

Re: Mikrotik L2TP VPN IP Public Port Forward

how much are you sure that your new public address does anything at all? It is working when I am using my TP-Link router WR840N and dial L2TP from there. It gets the public IP and I can get out to internet If you use Tools->Torch on L2TP interface, what do you see there? Any traffic to or from 129....
by ccmks
Thu Sep 03, 2020 6:47 pm
Forum: General
Topic: Mikrotik L2TP VPN IP Public Port Forward
Replies: 13
Views: 1435

Re: Mikrotik L2TP VPN IP Public Port Forward

/ip firewall mangle
add action=log chain=prerouting dst-address=129.129.129.10 protocol=icmp

No log appear on mangle (0 B)

Tried this one too
/ip route
add dst-address=8.8.8.8/32 gateway=1.0.0.1

And this one
/tool traceroute address=8.8.8.8

Can't ping, request time out
by ccmks
Wed Sep 02, 2020 3:53 pm
Forum: General
Topic: Mikrotik L2TP VPN IP Public Port Forward
Replies: 13
Views: 1435

Re: Mikrotik L2TP VPN IP Public Port Forward

Tried adding this one /ip firewall mangle add action=mark-routing chain=output connection-mark=from-vpn new-routing-mark=vpn Still doesn't work. And yes, gateway should be the address on their side. If it's really 1.0.0.1, then on one hand it's completely wrong, because it's public address that does...
by ccmks
Tue Sep 01, 2020 2:58 pm
Forum: General
Topic: Mikrotik L2TP VPN IP Public Port Forward
Replies: 13
Views: 1435

Re: Mikrotik L2TP VPN IP Public Port Forward

Tried and didn't work. I can't ping 2nd Public IP from internet. When you do this /ip route add dst-address=0.0.0.0/0 gateway=<IP address on the remote side of VPN tunnel> routing-mark=vpn Which IP should I put for gateway? Because when I dial L2TP, I am getting 1.0.0.1 as the remote address when it...
by ccmks
Fri Aug 28, 2020 4:37 pm
Forum: General
Topic: Mikrotik L2TP VPN IP Public Port Forward
Replies: 13
Views: 1435

Mikrotik L2TP VPN IP Public Port Forward

Hello, I am very new to Mikrotik, not much experience here. Please see the picture first! https://imgur.com/a/OFTV68D We live in a very remote place where LTE and satellite internet are the only internet source available. We need to access web server from outside internet and of course the internet ...
by ccmks
Sun May 31, 2020 8:13 pm
Forum: The User Manager
Topic: Display Expire Date on Hotspot Status Page
Replies: 1
Views: 945

Display Expire Date on Hotspot Status Page

Hello, I have setup hotpsot + user manager. After customizing the hotspot page, I am very satisfied with it overall, except I need to have a way to display user the expire date on status page. Currently, I have been looking on Google and the Mikrotik forum, and looks like everyone just only talked a...