Community discussions

MikroTik App

Search found 81 matches

by CTassisF
Thu Mar 21, 2024 6:41 pm
Forum: Announcements
Topic: v7.15beta [testing] is released!
Replies: 471
Views: 106889

Re: v7.15beta [testing] is released!

*) quicksest - only show LTE mode for devices without other wireless interfaces;

Small typo.
by CTassisF
Thu Feb 22, 2024 1:53 pm
Forum: Announcements
Topic: v7.14rc [testing] is released!
Replies: 176
Views: 48859

Re: v7.14rc [testing] is released!

I'm also having problems with USB stick disappearing on RB5009. I use the USB stick as storage for my containers, and after 3~4 days of uptime the usb1-part1 disk disappears from /file and garbage is shown in /disk. The weird part is that all containers continue to work, but after a while this seem...
by CTassisF
Wed Feb 21, 2024 3:31 pm
Forum: Announcements
Topic: v7.14rc [testing] is released!
Replies: 176
Views: 48859

Re: v7.14rc [testing] is released!

I'm also having problems with USB stick disappearing on RB5009. I use the USB stick as storage for my containers, and after 3~4 days of uptime the usb1-part1 disk disappears from /file and garbage is shown in /disk. The weird part is that all containers continue to work, but after a while this seems...
by CTassisF
Tue Jan 30, 2024 2:24 am
Forum: RouterOS beta
Topic: Custom Routing Table + Routing Mark not working
Replies: 8
Views: 7593

Re: Custom Routing Table + Routing Mark not working

I was able to make this work with custom routing tables (and even VRFs) using the following configuration: /ip firewall mangle add action=jump chain=prerouting comment="prerouting LAN" connection-mark=no-mark connection-state=new dst-address-list=!private dst-address-type=!local in-interfa...
by CTassisF
Thu Jan 25, 2024 7:10 pm
Forum: Announcements
Topic: v7.14beta [testing] is released!
Replies: 510
Views: 153653

Re: v7.14beta [testing] is released!

ROS 7.14 very nice. Now firewall for VPRN traffic to VRF on CPE mikrotik routers just completely and silently ignored . DNAT to VRF also don`t work. Well done. 1- v7.14 is still in beta 2- I'm having a similar problem with static routes in VRFs: https://forum.mikrotik.com/viewtopic.php?t=202612&...
by CTassisF
Thu Jan 25, 2024 12:02 am
Forum: Announcements
Topic: v7.14beta [testing] is released!
Replies: 510
Views: 153653

Re: v7.14beta [testing] is released!

I just noticed that the syntax gateway=example-interface@example-vrf in /ip(v6)/route/add dst-address=0.0.0.0/0 gateway=example-interface@example-vrf routing-table=example-vrf (together with /ip/vrf/add interfaces=example-interface name=example-vrf ) is not working properly since v7.14beta6 : - /ip(...
by CTassisF
Sat Dec 30, 2023 4:16 pm
Forum: Announcements
Topic: v7.14beta [testing] is released!
Replies: 510
Views: 153653

Re: v7.14beta [testing] is released!

Did /tool/graphing/resource stop recording container memory usage? Or has there actually been some serious reduction in memory usage on ARM64 devices? I'm seeing a lot more free memory in both my RB5009 and hAP ax3. Both run containers, and no settings have been changed. RB5009.png hAP ax3.png
by CTassisF
Wed Dec 20, 2023 6:40 pm
Forum: Announcements
Topic: v7.14beta [testing] is released!
Replies: 510
Views: 153653

Re: v7.14beta [testing] is released!

After updating to v7.14beta3, I noticed that my hAP ac3 is reverting vlan-mode settings in /interface/ethernet/switch/port to vlan-mode=disabled instead of the vlan-mode=fallback that was set before. This is happening on every reboot, even after setting to vlan-mode=fallback again.
by CTassisF
Wed Nov 29, 2023 10:50 pm
Forum: Containers
Topic: A question about ram-high Topic is solved
Replies: 5
Views: 5250

Re: A question about ram-high Topic is solved

I'm also interested to learn what exactly is controlled by the "ram-high" parameter. SUP-136073 I never got a proper answer to that question, but after experimenting a bit I think the correct answer is: "ram-high" limits the total RAM usage of all containers (not considering the...
by CTassisF
Mon Nov 27, 2023 2:18 pm
Forum: Announcements
Topic: v7.13beta [testing] is released!
Replies: 467
Views: 91844

Re: v7.13beta [testing] is released!

Upgraded to 7.13beta3 and noticed that if I reboot my CAPsMAN (RB5009), all the wireless interfaces of my CAPs (hAP ax3 and hAP ac3) will show as “busy” and not work.

Rebooting the CAPs after rebooting the CAPsMAN solves the issue.

SUP-135728
by CTassisF
Tue Nov 21, 2023 6:02 pm
Forum: Announcements
Topic: v7.13beta [testing] is released!
Replies: 467
Views: 91844

Re: v7.13beta [testing] is released!

In v7.13beta2, NAT PMP logs are too verbose: Screenshot 2023-11-21 at 12.56.27.png I hope this changes before the stable release. I also noticed that the comments of dynamically-generated NAT PMP firewall rules are mentioning the external (WAN) IPv4 address while UPnP comments show the internal (LAN...
by CTassisF
Tue Nov 14, 2023 8:22 pm
Forum: Announcements
Topic: v7.13beta [testing] is released!
Replies: 467
Views: 91844

Re: v7.13beta [testing] is released!

Upgraded my RB5009 (CAPsMAN), hAP ax3 (CAP) and hAP ac3 (CAP) from 7.12rc5 to 7.13beta1 using the "check for updates" and everything went fine . RB5009 had wifiwave2 package before, now it only has routeros (since WiFi menu + CAPsMAN feature is now bundled). hAP ax3 had wifiwave2 package b...
by CTassisF
Thu Sep 28, 2023 12:11 am
Forum: Announcements
Topic: v7.12beta [testing] is released!
Replies: 263
Views: 125217

Re: v7.12beta [testing] is released!

Since updating to 7.12beta9 I'm having issues with my hAP a c 3 that works as WifiWave2 CAP. After a few hours of uptime, some of the devices connected to hAP a c 3 stopped having internet connectivity. This issue does not happen to devices connected to my hAP a x 3 that is CAP to the same CAPsMAN. ...
by CTassisF
Thu Aug 24, 2023 8:35 pm
Forum: Announcements
Topic: v7.12beta [testing] is released!
Replies: 263
Views: 125217

Re: v7.12beta [testing] is released!

What is layer-dir in /container/config?

Edit: Looks like it's persistent storage for container layers to be reused (in case different containers share some/all layers).
by CTassisF
Sat Aug 19, 2023 6:51 pm
Forum: Containers
Topic: A question about ram-high Topic is solved
Replies: 5
Views: 5250

A question about ram-high Topic is solved

According to documentation , "this will soft limit RAM usage - if a RAM usage goes over the high boundary, the processes of the cgroup are throttled and put under heavy reclaim pressure". Here's my question: If I set ram-high=512.0MiB , will it mean that containers' processes will be throt...
by CTassisF
Tue Jul 18, 2023 6:44 pm
Forum: Announcements
Topic: v7.11beta [testing] is released!
Replies: 373
Views: 106936

Re: v7.11beta [testing] is released!

After updating to 7.11beta5 , all containers are showing 0.0.0.0 as their own IP in /etc/hosts . For example, here's my AdGuard container: [cesar-ro@RB5009] > /container/print 0 name="4736436b-e3cc-4f12-a794-7f128e0a26cf" tag="adguard/adguardhome:latest" os="linux" arch...
by CTassisF
Fri Jun 30, 2023 4:36 pm
Forum: Announcements
Topic: v7.11beta [testing] is released!
Replies: 373
Views: 106936

Re: v7.11beta [testing] is released!

My hAP ax3 with 10 WifiWave2 interfaces (open, owe, wpa2, wpa3) is quite stable in 7.11beta2. [cesar@hAP-ax3] > /system/resource/print uptime: 1w1d32m18s version: 7.11beta2 (development) build-time: Jun/21/2023 11:39:58 factory-software: 7.5 free-memory: 591.3MiB total-memory: 928.0MiB cpu: ARM64 cp...
by CTassisF
Thu May 25, 2023 5:58 am
Forum: Wireless Networking
Topic: WifiWave2 CAPsMAN Open AP with OWE transition mode
Replies: 3
Views: 2651

WifiWave2 CAPsMAN Open AP with OWE transition mode

Is it possible to have WifiWave2 CAPsMAN Open AP with OWE transition mode? security.owe-transition-interface expects an interface, so I guess it is not possible to have this as a provisioned configuration profile?

Thanks :)
by CTassisF
Mon Feb 27, 2023 3:33 am
Forum: General
Topic: RIPE Atlas Software Probe running on v7.1rc3 [development]
Replies: 7
Views: 3666

Re: RIPE Atlas Software Probe running on v7.1rc3 [development]

These images continue to work fine with my MikroTik devices (RB5009 (arm64) and hAP ac³ (arm)).

By the way, I recently updated the instructions above to reflect the new images available in Docker Hub.

Please let me know if you're still having issues with ctassisf/ripe-atlas-alpine.
by CTassisF
Wed Feb 22, 2023 2:32 pm
Forum: Announcements
Topic: v7.8rc is released!
Replies: 125
Views: 45252

Re: v7.8rc is released!

Still cant download dockers/containers... "error response getting manifests: 404" This has nothing to do with the new authentication feature that was implemented in v7.8. Basically Docker changed how images are created and stored and MikroTik will have to update its container implementati...
by CTassisF
Fri Feb 10, 2023 10:14 pm
Forum: Announcements
Topic: v7.8rc is released!
Replies: 125
Views: 45252

Re: v7.8rc is released!

Even after lots of fixes for certificates, still can't use IKEv2 EAP VPN tunnel to NordVPN servers . IIRC this has been happening since v7.7 betas. 20:01:45 info fetch: file "root.der" downloaded 20:02:45 system,info ipsec modecfg nordvpn added by cesar 20:03:40 system,info ipsec peer nord...
by CTassisF
Mon Jan 30, 2023 5:41 pm
Forum: Announcements
Topic: v7.8beta [testing] is released!
Replies: 307
Views: 75612

Re: v7.8beta [testing] is released!

I have the same problem with my own build, all newly pushed to docker hub are the same error. if you pull from other linux os and upload to routeros, it works. Same behavior here: not working on RouterOS, but on macOS with Docker it works fine. I've opened a ticket (SUP-105409) but it was closed by...
by CTassisF
Tue Jan 24, 2023 3:52 pm
Forum: General
Topic: mikrotik.com is broken, certificate chain is incomplete [SOLVED]
Replies: 4
Views: 826

Re: mikrotik.com is broken, certificate chain is incomplete [SOLVED]

Thank you! Fixed. Thanks! It is now fixed for mikrotik.com . But as @Larsa mentioned, there seems to be another issue with www.mikrotik.com . $ host -t A mikrotik.com mikrotik.com has address 159.148.172.205 $ host -t A www.mikrotik.com www.mikrotik.com has address 159.147.172.205 It seems that som...
by CTassisF
Mon Jan 23, 2023 7:43 pm
Forum: General
Topic: mikrotik.com is broken, certificate chain is incomplete [SOLVED]
Replies: 4
Views: 826

mikrotik.com is broken, certificate chain is incomplete [SOLVED]

Looks like mikrotik.com is broken for some clients. According to SSL Labs and Internet.nl the certificate chain is incomplete. Example using curl on Debian 11: $ curl --version curl 7.74.0 (x86_64-pc-linux-gnu) libcurl/7.74.0 OpenSSL/1.1.1n zlib/1.2.11 brotli/1.0.9 libidn2/2.3.0 libpsl/0.21.0 (+libi...
by CTassisF
Fri Jan 20, 2023 8:30 pm
Forum: Announcements
Topic: v7.8beta [testing] is released!
Replies: 307
Views: 75612

Re: v7.8beta [testing] is released!

Since updating to 7.8beta2 I'm having issues importing remote container image zabbix/zabbix-proxy-sqlite3:alpine-6.0-latest on my RB5009 (arm64). It was working fine on 7.7rc5 . 16:43:05 container,info,debug importing remote image: zabbix/zabbix-proxy-sqlite3, tag: alpine-6.0-latest 16:43:05 system,...
by CTassisF
Thu Jan 12, 2023 7:25 pm
Forum: Announcements
Topic: v7.7 [stable] is released!
Replies: 357
Views: 113933

Re: v7.7 [stable] is released!

I did not found on Winbox ou CLI the VRF attribute to l2tp-ether, eoip, ipip, gre.

https://help.mikrotik.com/docs/pages/vi ... edfeatures
by CTassisF
Thu Jan 12, 2023 12:36 am
Forum: Announcements
Topic: v7.7rc is released!
Replies: 259
Views: 90108

Re: v7.7rc is released!

The key type in the public key file is "ssh-ed25519" so I'm wondering if RouterOS is expecting something different. RouterOS added ed25519 support for *key exchange*. This can be set using KexAlgorithms option in OpenSSH. The key you can generate using ssh-keygen and you use to log in is ...
by CTassisF
Sat Jan 07, 2023 7:16 am
Forum: Announcements
Topic: v7.7rc is released!
Replies: 259
Views: 90108

Re: v7.7rc is released!

I'm not sure if this is related to any of the DNS issues reported above, but in 7.7rc4 I started getting intermittent "resolving error" while importing container images. If I try again it will eventually work. 05:06:53 container,info,debug importing remote image: zabbix/zabbix-proxy-sqlite...
by CTassisF
Thu Jan 05, 2023 5:19 pm
Forum: General
Topic: VRF OSPF routes leaking
Replies: 7
Views: 1491

Re: VRF OSPF routes leaking

what are you trying to achieve? I have a RB5009UG as my home router. I connect to the Internet via PPPoE and get my IPv6 block (/64) via DHCPv6-PD. I use NAT only for IPv4. All of this happens in the main VRF. I also have a Wireguard tunnel and I forward some traffic through this tunnel using a dif...
by CTassisF
Wed Jan 04, 2023 3:53 pm
Forum: General
Topic: VRF OSPF routes leaking
Replies: 7
Views: 1491

Re: VRF OSPF routes leaking

Hello @ggs331,

Did you manage to get this working?

I'm following the "Leaking routes between VRFs" instructions but it's not working for me, it never shows any neighbors.
by CTassisF
Sat Nov 26, 2022 12:31 am
Forum: Announcements
Topic: v7.7beta [testing] is released!
Replies: 322
Views: 124638

Re: v7.7beta [testing] is released!

My Samsung Galaxy S22 5G with Snapdragon 8 Gen 1 can't connect to my hAP ac3 running 7.7beta8 with WifiWave2 + WPA3 unless I set sae-pwe=hunting-and-pecking.

I thought this was fixed since v7.6 [stable], it is mentioned in the changelog, but still seems to be broken.

SUP-99820
by CTassisF
Tue Sep 13, 2022 4:37 am
Forum: Announcements
Topic: v7.6beta [testing] is released!
Replies: 226
Views: 62367

Re: v7.6beta [testing] is released!

What this quote was for? Removed

Thanks! Changing this config fixed the issue with iPhone + iOS 16 + WPA3.
by CTassisF
Mon Sep 12, 2022 11:07 pm
Forum: Announcements
Topic: v7.6beta [testing] is released!
Replies: 226
Views: 62367

Re: v7.6beta [testing] is released!

Anyone seeing issues with WPA3 and iOS 16 (released today)? After upgrading iPhone 12 to iOS 16.0 it was unable to connect to wpa2-psk,wpa3-psk networks I have on my hAP ac3 running RouterOS 7.6beta6 with WifiWave2 package. Before the upgrade (iOS 15.6) it was connecting fine. After changing the int...
by CTassisF
Thu Sep 08, 2022 6:13 pm
Forum: Announcements
Topic: v7.6beta [testing] is released!
Replies: 226
Views: 62367

Re: v7.6beta [testing] is released!

And, as I said before, it is working great on my RB5009UG+S+ using the configuration I shown.
it's a usb flash drive??
src=/disk1/

Yes. USB flash drive formatted as ext4.
by CTassisF
Wed Sep 07, 2022 5:59 pm
Forum: Announcements
Topic: v7.6beta [testing] is released!
Replies: 226
Views: 62367

Re: v7.6beta [testing] is released!

this post https://forum.mikrotik.com/viewtopic.php?p=955911#p955095 previously done as you suggested, result does not change. I guess this was a workaround for when it was not possible to create folders/directories inside container mounts. It was a restriction on RouterOS containers that was fixed ...
by CTassisF
Wed Sep 07, 2022 5:28 pm
Forum: Announcements
Topic: v7.6beta [testing] is released!
Replies: 226
Views: 62367

Re: v7.6beta [testing] is released!

Why are you creating duplicated, nested mounts for /opt/adguardhome/work and for /opt/adguardhome/work/data ? This might be your problem. Create just one mount for /opt/adguardhome/conf and another one for /opt/adguardhome/work and it should work. It is working here for me using this configuration: ...
by CTassisF
Fri Sep 02, 2022 5:47 pm
Forum: Announcements
Topic: v7.5 [stable] is released!
Replies: 219
Views: 69452

Re: v7.5 [stable] is released!

This issue was fixed some time ago in 7.5beta4 so I guess it won't happen from now on. So when can I expect the fix to kick in? I did a couple of reboots after installing 7.5 (if not for other things to bring routerboot version up) and the message is shown every time ... my feelingnis that this fix...
by CTassisF
Fri Sep 02, 2022 5:31 pm
Forum: Announcements
Topic: v7.5 [stable] is released!
Replies: 219
Views: 69452

Re: v7.5 [stable] is released!

Is this really so hard to fix? There is an option to retrieve the script being used at startup, I believe ? You should be able to see specifically what the error is about since the exact location has been mentioned ? It is probably the router trying to load the default configuration for /interface ...
by CTassisF
Fri Sep 02, 2022 5:21 pm
Forum: Announcements
Topic: v7.6beta [testing] is released!
Replies: 226
Views: 62367

Re: v7.6beta [testing] is released!

Upgraded RB5009 and hAP ac3 from 7.5rc2 to 7.6beta4. No issues so far.

Containers, USB flash drive as external disk, WifiWave2... Everything working as expected.
by CTassisF
Wed Aug 03, 2022 9:58 pm
Forum: Containers
Topic: v7.1rc3 adds container support
Replies: 493
Views: 162489

Re: v7.1rc3 adds Docker (TM) compatible container support

remote-image=zabbix/zabbix-proxy-sqlite3:alpine-6.0-latest imported on mine 5009 without any problems. Sorry, my mistake. I was trying to pull remote-image=zabbix-proxy-sqlite3:alpine-6.0-latest instead of the correct remote-image= zabbix/ zabbix-proxy-sqlite3:alpine-6.0-latest . That is why it was...
by CTassisF
Fri Jul 29, 2022 4:57 pm
Forum: Containers
Topic: v7.1rc3 adds container support
Replies: 493
Views: 162489

Re: v7.1rc3 adds Docker (TM) compatible container support

Are you sure you provided the URL for the router's architecture? Yes. I tried on a RB5009 and this zabbix/zabbix-proxy-sqlite3:alpine-6.0-latest tag has linux/arm64 in it: https://hub.docker.com/layers/zabbix-proxy-sqlite3/zabbix/zabbix-proxy-sqlite3/alpine-6.0-latest/images/sha256-44a5cdd64302b2a0...
by CTassisF
Fri Jul 29, 2022 2:49 am
Forum: Containers
Topic: v7.1rc3 adds container support
Replies: 493
Views: 162489

Re: v7.1rc3 adds Docker (TM) compatible container support

I'm seeing an error when trying to add a container using this remote image: zabbix-proxy-sqlite3:alpine-6.0-latest Logs: 23:25:41 container,info,debug importing remote image: zabbix-proxy-sqlite3, tag: alpine-6.0-latest 23:25:41 system,info item added by cesar 23:25:43 container,info,debug error res...
by CTassisF
Wed Jul 27, 2022 11:32 pm
Forum: Containers
Topic: v7.1rc3 adds container support
Replies: 493
Views: 162489

Re: v7.1rc3 adds Docker (TM) compatible container support

i think i got where it goes wrong. As a workaround currently you can after adding container start it, stop it and start again. Mounts should appear. we will try to fix this in next releases

Thanks for the workaround, seems to be working as expected.
by CTassisF
Wed Jul 27, 2022 6:25 pm
Forum: Containers
Topic: v7.1rc3 adds container support
Replies: 493
Views: 162489

Re: v7.1rc3 adds Docker (TM) compatible container support

i just tried locally - your veth configuration is invalid - you are missing bitmask to address, set address to 172.31.0.1/24 Thanks! Default route is working now that veth is configured correctly, but mounts are still broken. [cesar@MikroTik] > /interface/veth/print Flags: X - disabled; R - running...
by CTassisF
Wed Jul 27, 2022 5:06 pm
Forum: Containers
Topic: v7.1rc3 adds container support
Replies: 493
Views: 162489

Re: v7.1rc3 adds Docker (TM) compatible container support

I'm running RouterOS 7.5beta4 on my hAP ac³ and: 1- mounts still doesn't work for me; 2- I noticed that a default route is not being added to my container, even though gateway is defined in interface/veth . [cesar@MikroTik] > /interface/veth/export # jul/27/2022 13:49:44 by RouterOS 7.5beta4 /interf...
by CTassisF
Thu Jul 07, 2022 4:43 am
Forum: Announcements
Topic: v7.4rc is released!
Replies: 116
Views: 30564

Re: v7.4rc1 is released!

/container/mounts/ seems to be broken: you create a new mount but it does not show in /file/print or via FTP; not sure what happens to the data the container tries to write to those mounted paths.

Is this known? Will it be fixed in the next RC? Should I generate a supout.rif file and send a report?
by CTassisF
Sat Jun 18, 2022 1:50 am
Forum: RouterOS beta
Topic: posts not strictly related to: v7.4beta [testing]
Replies: 165
Views: 12654

Re: v7.4beta [testing] is released!

moving from one ap to the other
The changelog says "roaming (802.11r) between local AP interfaces", so I guess it only works for interfaces in the same AP (like roaming from 2.4GHz to 5GHz).
by CTassisF
Fri May 20, 2022 4:27 am
Forum: RouterOS beta
Topic: Custom Routing Table + Routing Mark not working
Replies: 8
Views: 7593

Re: Custom Routing Table + Routing Mark not working

Any progress on your configuration? Yes! I was able to make it work. Apparently to make it work you have to do both mark-connection and mark-routing: /ipv6 firewall mangle add action=jump chain=prerouting comment=prerouting-vpn dst-address-list=vpn jump-target=prerouting-vpn add action=mark-connect...
by CTassisF
Wed Apr 20, 2022 10:57 pm
Forum: Announcements
Topic: v7.3rc [testing] is released!
Replies: 452
Views: 103911

Re: v7.3beta [testing] is released!

Upgraded my hAP ac3 from 7.3beta33 to beta34 and now it is boot looping. Will try netinstall.

Edit: successfully recovered using 7.3beta33 netinstall on Windows.
by CTassisF
Sun Apr 03, 2022 6:26 pm
Forum: Announcements
Topic: v7.2rc6 and v7.2rc7 is released!
Replies: 100
Views: 20332

Re: v7.2rc6 and v7.2rc7 is released!

There seems to be a memory leak somewhere in v7.2rc7:

weekly.gif
monthly.gif
by CTassisF
Wed Mar 23, 2022 8:02 pm
Forum: Announcements
Topic: v7.2rc5 is released!
Replies: 91
Views: 24118

Re: v7.2rc5 is released!

Every time I reboot my router this happens to all graphs (CPU, Memory, Interfaces, Queues): daily.gif This has been happening since v7.2rc4. I guess it might be related to my timezone because it's UTC-3 and the graph seems to be missing exactly 3h of data for every reboot. /system clock set time-zon...
by CTassisF
Wed Mar 23, 2022 4:15 pm
Forum: Announcements
Topic: v7.2rc5 is released!
Replies: 91
Views: 24118

Re: v7.2rc5 is released!

I was about to ask why the container package is missing but then I noticed the changelog was updated.
Screen Shot 2022-03-23 at 11.12.44.png
by CTassisF
Wed Feb 23, 2022 10:36 pm
Forum: Announcements
Topic: v7.2rc4 is released!
Replies: 143
Views: 42505

Re: v7.2rc4 is released!

WTF Mikrotik!! Erase the routing tables (/routing/table), leaving me with setting about 50 different routing-marks all who are all over the place!!!!! I also lost the single custom routing table I had after upgrading from rc3 to rc4 🤡 At least in my case it was easy to fix, but it took me a while t...
by CTassisF
Wed Feb 23, 2022 8:27 pm
Forum: Announcements
Topic: v7.2rc4 is released!
Replies: 143
Views: 42505

Re: v7.2rc4 is released!

Has not worked since 6.43, what did you upgrade from?
IIRC it was working on rc3 (the version I was using before rc4).
by CTassisF
Wed Feb 23, 2022 2:29 pm
Forum: Announcements
Topic: v7.2rc4 is released!
Replies: 143
Views: 42505

Re: v7.2rc4 is released!

pppoe-client is not being detected as WAN or INTERNET after upgrading to rc4. [cesar@MikroTik] > /interface/pppoe-client/print detail Flags: X - disabled, I - invalid; R - running 0 R name="pppoe-client" max-mtu=1492 max-mru=1492 mrru=disabled interface=ether3 user="xxx@xxx" pass...
by CTassisF
Wed Jan 19, 2022 8:54 pm
Forum: RouterOS beta
Topic: Custom Routing Table + Routing Mark not working
Replies: 8
Views: 7593

Custom Routing Table + Routing Mark not working

(hAP ac^3 running 7.2rc1) I have properly working IPv4 and IPv6 networks. IPv4 is NATed, IPv6 /64 prefix comes from WAN (PPPoE) via DHCPv6 PD and it is then Router Advertised to my LAN. I wan't to route some of the outgoing traffic via a WireGuard VPN using NAT. To do that I've: - created a new rout...
by CTassisF
Thu Dec 02, 2021 12:54 pm
Forum: RouterOS beta
Topic: v7.1rc7 [development] is released!
Replies: 174
Views: 55278

Re: v7.1rc7 [development] is released!

Version 7.1 1638367647 was briefly released under the "testing" branch, but then this release was rolled back.
by CTassisF
Sun Nov 21, 2021 4:01 pm
Forum: RouterOS beta
Topic: ZeroTier added to RouterOS v7.1rc2
Replies: 335
Views: 310333

Re: ZeroTier added to RouterOS v7rc2

but how to point zerotier local conf ro it in the mikrotik router? You don't have to change local.conf to be able to run your own controllers. When you create a network in a controller, the network ID already contains the ZeroTier address of controller[1]. That way your peers can find the controlle...
by CTassisF
Wed Oct 27, 2021 3:27 pm
Forum: RouterOS beta
Topic: v7.1rc5 [development] is released!
Replies: 167
Views: 49081

Re: v7.1rc5 [development] is released!

v7.1rc5 broke /interface/wifiwave2/channel usage in wifiwave2 interfaces: [cesar@MikroTik] > /interface/wifiwave2/channel/add name=foobar band=2ghz-n [cesar@MikroTik] > /interface/wifiwave2/channel/export # oct/27/2021 09:22:16 by RouterOS 7.1rc5 # # model = RBD53iG-5HacD2HnD /interface wifiwave2 ch...
by CTassisF
Wed Oct 27, 2021 3:20 pm
Forum: RouterOS beta
Topic: v7.1rc5 [development] is released!
Replies: 167
Views: 49081

Re: v7.1rc5 [development] is released!

So, after all, if you take the time to contact support, make sure you provide a full repro and clear description of what you'd expect vs. what you get. I really thought it was the intended behavior, even though it did not make sense. That is why I didn't ever report this issue to them. I'm glad the...
by CTassisF
Wed Oct 27, 2021 4:36 am
Forum: RouterOS beta
Topic: v7.1rc5 [development] is released!
Replies: 167
Views: 49081

Re: v7.1rc5 [development] is released!

*) dhcpv6-server - fixed "address-pool" default value;

I will finally be able to restore my full export.rsc without having to split it in two parts because of the historically missing address-pool default value.
by CTassisF
Mon Sep 20, 2021 4:26 pm
Forum: RouterOS beta
Topic: v7.1rc4 [development] is released!
Replies: 276
Views: 83023

Re: v7.1rc4 [development] is released!

How to explore and get files from container mounts now that they are stored as "container store" and not as directories/files as before?
by CTassisF
Sat Sep 11, 2021 3:17 am
Forum: General
Topic: RIPE Atlas Software Probe running on v7.1rc3 [development]
Replies: 7
Views: 3666

RIPE Atlas Software Probe running on v7.1rc3 [development]

Now that RouterOS v7.1rc3 supports running containers, I took the time to create a Docker image to run RIPE Atlas Software Probe on my MikroTik router. The image is based on the official code provided by RIPE NCC , with a few tweaks to make it run under Alpine Linux. Alpine is based on musl , not gl...
by CTassisF
Mon Sep 06, 2021 4:57 pm
Forum: RouterOS beta
Topic: ZeroTier added to RouterOS v7.1rc2
Replies: 335
Views: 310333

Re: ZeroTier added to RouterOS v7.1rc2

ZeroTier uses Salsa20 to encrypt and Poly1305 to authenticate packets. As far as I know these are (very fast but) software-only algorithms and can't be offloaded to the hardware for acceleration. Since version 1.6.0 ZT has new AES-GMAC-SIV encryption mode, which is supported in hardware accelerated...
by CTassisF
Sun Sep 05, 2021 8:36 am
Forum: RouterOS beta
Topic: ZeroTier added to RouterOS v7.1rc2
Replies: 335
Views: 310333

Re: ZeroTier added to RouterOS v7.1rc2

A question about encryption: what about the hardware acceleration? All models that supports IPsec HW will offload ZT’s encryption? ZeroTier uses Salsa20 to encrypt and Poly1305 to authenticate packets. As far as I know these are (very fast but) software-only algorithms and can't be offloaded to the...
by CTassisF
Sat Sep 04, 2021 6:04 pm
Forum: RouterOS beta
Topic: ZeroTier added to RouterOS v7.1rc2
Replies: 335
Views: 310333

Re: ZeroTier added to RouterOS v7.1rc2

Please add support for ZeroTier Multipath and its various configuration options and policies: https://zerotier.atlassian.net/wiki/spa ... /Multipath
by CTassisF
Wed Sep 01, 2021 2:45 am
Forum: RouterOS beta
Topic: ZeroTier added to RouterOS v7.1rc2
Replies: 335
Views: 310333

Re: ZeroTier added to RouterOS v7rc2

To me this looks more like a partnership between MikroTik and ZeroTier, Inc. https://twitter.com/ZeroTier/status/1432716935024848908 So I guess this is good for both players. And this might "guarantee" this package should not be left unmaintained in the future. But even if that happens (Ro...
by CTassisF
Wed Sep 01, 2021 12:11 am
Forum: RouterOS beta
Topic: ZeroTier added to RouterOS v7.1rc2
Replies: 335
Views: 310333

Re: ZeroTier added to RouterOS v7rc2

Some minor bugs so far: disabled=no disabled=no [cesar@MikroTik] > /zerotier/export verbose /zerotier set zt1 comment="ZeroTier Central controller - https://my.zerotier.com/" disabled=no disabled=no identity="xxx:0:xxx" interfaces=all name=zt1 port=9993 wireless-default queue by ...
by CTassisF
Tue Aug 31, 2021 11:39 pm
Forum: RouterOS beta
Topic: v7.1rc2 [development] is released!
Replies: 194
Views: 44422

Re: v7.1rc2 [development] is released!

v7.1rc2 still doesn't know how to properly bring OWE interfaces up. How they were created: /interface wifiwave2 add configuration.country=Brazil .ssid="Guests" disabled=no mac-address=AA:BB:CC:DD:EE:12 master-interface=wifi1 name=wifi3 security.authentication-types="" add configu...
by CTassisF
Tue Aug 31, 2021 6:36 pm
Forum: RouterOS beta
Topic: ZeroTier added to RouterOS v7.1rc2
Replies: 335
Views: 310333

Re: ZeroTier added to RouterOS v7rc2

I will manage my VPNs on my own, don't need and don't want any external service for that. It is possible (and fairly easy) to run your own ZeroTier One controllers and use that to manage your own ZeroTier networks. There's even an open-source web interface (that mimics my.zerotier.com) somewhere on...
by CTassisF
Mon Aug 30, 2021 10:13 pm
Forum: RouterOS beta
Topic: v7.1rc1 [development] is released!
Replies: 344
Views: 77982

Re: v7.1rc1 [development] is released!

ROS v7 seems to have a much better default firewall configuration. Can you post output of /system default-configuration print (make terminal window real wide, long lines get truncated otherwise) for us to compare to contemporary v6 defaults? Apparently there is no change in the firewall between v6....
by CTassisF
Mon Aug 23, 2021 4:32 pm
Forum: RouterOS beta
Topic: v7.1rc1 [development] is released!
Replies: 344
Views: 77982

Re: v7.1rc1 [development] is released!

So far so good on my hAP ac³ with PPPoE, IPv6, WifiWave2, Hotspot, Web Proxy etc. Only issue I have (and I guess this issue has been going on since the first time I've tested 7.1 betas) is that RouterOS does not know the proper way to setup OWE (opportunistic wireless encryption) after a reboot. Bec...
by CTassisF
Tue Jul 06, 2021 5:54 pm
Forum: Announcements
Topic: v6.49beta [testing] is released!
Replies: 171
Views: 90515

Re: v6.49beta [testing] is released!

Just upgraded to 6.49beta54 and I can confirm that the DNS cache issue is still present.

I was able to reproduce it using the same POC I provided to support (SUP-51096).
by CTassisF
Tue Jul 06, 2021 2:46 am
Forum: Announcements
Topic: v6.49beta [testing] is released!
Replies: 171
Views: 90515

Re: v6.49beta [testing] is released!

This often happens with things like PiHole where it returns a fake address of 0.0.0.0.
Actually from what I was able to reproduce and report to support it seems to be related to CNAME requests.
CNAME requests appear to be bypassing the cache (memory leak?) and increasing memory usage.
by CTassisF
Mon Jul 05, 2021 7:34 pm
Forum: Announcements
Topic: v6.49beta [testing] is released!
Replies: 171
Views: 90515

Re: v6.49beta [testing] is released!

Regarding 6.49beta54:

No fixes for the DNS memory leak introduced in 6.49beta46?

Just asking based on the changelog, haven't tried it yet.
by CTassisF
Mon May 31, 2021 11:08 pm
Forum: Announcements
Topic: v6.49beta [testing] is released!
Replies: 171
Views: 90515

Re: v6.49beta [testing] is released!

Is anyone having DNS cache issues with 6.49beta46 ? [cesar@MikroTik] > /ip dns cache print Flags: S - static # NAME TYPE DATA TTL 0 www.googleadservice... AAAA :: 0s 1 www.googleadservice... A 0.0.0.0 0s 2 cdn.taboola.com AAAA :: 0s 3 cdn.taboola.com A 0.0.0.0 0s [cesar@MikroTik] > /ip dns static pr...
by CTassisF
Fri Apr 23, 2021 7:33 pm
Forum: Announcements
Topic: v6.49beta [testing] is released!
Replies: 171
Views: 90515

Re: v6.49beta [testing] is released!

Both 6.49beta36 and 6.49beta38 are causing kernel failure on my hAP ac^3 RBD53iG-5HacD2HnD.

Ticket: SUP-47971
by CTassisF
Thu Mar 18, 2021 2:14 pm
Forum: Announcements
Topic: v6.49beta [testing] is released!
Replies: 171
Views: 90515

Re: v6.49beta [testing] is released!

So does that mean I should remove those particular subnets from the bad_ipv6_address address list? I think you don't have to. But it will make no difference if you remove those rules either. Those rules were removed because they are redundant, they are overlapped by the "defconf: ipv4 compat&q...
by CTassisF
Thu Mar 11, 2021 11:42 pm
Forum: Announcements
Topic: v6.49beta [testing] is released!
Replies: 171
Views: 90515

Re: v6.49beta [testing] is released!

*) defconf - removed overlapping IPv6 firewall rules; Does anybody know what those rules were/are? Here's the difference between beta11 and beta22: $ diff -u routeros-arm-6.49beta11.npk/nova/lib/defconf/get-custom-defconf routeros-arm-6.49beta22.npk/nova/lib/defconf/get-custom-defconf --- routeros-...
by CTassisF
Sun Feb 14, 2021 4:39 pm
Forum: RouterOS beta
Topic: v7.1beta4 [development] is released!
Replies: 211
Views: 56904

Re: v7.1beta4 [development] is released!

If you disable watchdog automatic-supout will /export work faster? I guess that might work because the autosupout.rif file won't be generated, but I'm not on v7 right now to be able to test it myself.
by CTassisF
Thu Dec 24, 2020 3:15 am
Forum: General
Topic: Is station-roaming recommended for home AP users using the same SSID for 2.4 and 5GHz?
Replies: 0
Views: 482

Is station-roaming recommended for home AP users using the same SSID for 2.4 and 5GHz?

Hello.

I have a hAP ac² running both frequencies (2.4 and 5GHz) with the same SSID.

Is station-roaming=enabled recommended in this configuration? Or is it more harmful than helpful?

Thanks in advance.