Community discussions

MikroTik App

Search found 23 matches

by aboulfad
Fri Dec 29, 2023 1:53 am
Forum: Beginner Basics
Topic: RB5009 not able to factory reset
Replies: 7
Views: 10170

Re: RB5009 not able to factory reset

If you still have trouble check my last post in my thread: https://forum.mikrotik.com/viewtopic.php?t=202754 for my newly acquired L009. In my setup, L009 port2 is connected to my ISP modem. If your device port2 is connected to a PC, the same should still work using winbox/MAC addr. Press the refres...
by aboulfad
Tue Dec 26, 2023 8:02 pm
Forum: RouterBOARD hardware
Topic: SFP transceivers to connect L009 & RB5009
Replies: 13
Views: 4314

Re: SFP transceivers to connect L009 & RB5009

Thanks to all the help here and from MK support, I got two 10Gtek 10GBase-SR SFP+ and OM3 LC-LC FO cable. Connected the L009 SFP port to RB5009 SPF+, then ran the above command (auto-negotiation off, 2.5G Base-X), and it all worked :D
by aboulfad
Tue Dec 26, 2023 1:58 pm
Forum: General
Topic: L009UiGS-RM mode button?
Replies: 2
Views: 598

L009UiGS-RM mode button?

Hello,

Anyone have a clue what’s this side MODE button on the L009? There’s no mention in the user guide or elsewhere: https://help.mikrotik.com/docs/display/ ... andjumpers

Photo 4: https://mikrotik.com/product/l009uigs_rm#fndtn-gallery
by aboulfad
Tue Dec 26, 2023 4:07 am
Forum: Beginner Basics
Topic: Can't connect to new L009
Replies: 4
Views: 1021

Re: Can't connect to new L009

Oh this is funky, so after I connected port2 to the ISP modem, now Winbox has two discovered entries ! One is the ISP DHCP WAN assigned address (192.168.2.0/24 -> port1), and the default 192.168.88.1 (port2)... I guess the default on this switch is running a DHCP server ? So I'd have to connect a la...
by aboulfad
Tue Dec 26, 2023 4:00 am
Forum: Beginner Basics
Topic: Can't connect to new L009
Replies: 4
Views: 1021

Re: Can't connect to new L009

Winbox does not connect to which IP address? 192.168.88.1, the default? Connecting to a port which is not port 1? Using the password printed on the L009 label? The WAN address assigned has nothing to do with the downstream address for your devices. Thank you for the reply. winbox doesn't connect to...
by aboulfad
Tue Dec 26, 2023 3:36 am
Forum: Beginner Basics
Topic: Can't connect to new L009
Replies: 4
Views: 1021

Can't connect to new L009

Hi, I got a new L009 and trying to connect to it without any success. L009 port1 is connected to my ISP modem that assigned it an IP address. I tried http/telnet to that IP address but no response (connection timed out). If I ping that IP address I get a response. Winbox doesn't connect neither to e...
by aboulfad
Fri Dec 22, 2023 10:46 am
Forum: RouterBOARD hardware
Topic: SFP transceivers to connect L009 & RB5009
Replies: 13
Views: 4314

Re: SFP transceivers to connect L009 & RB5009

If you can, then it would still be better to use FO connection. RJ45 SFP+ modules tend to run pretty hot (depends on length of cable connection) which can be a problem in passively cooled devices such as L009 and RB5009. FO modules fare much better in this regard. Thanks for the advice! I can and w...
by aboulfad
Thu Dec 21, 2023 11:39 pm
Forum: RouterBOARD hardware
Topic: SFP transceivers to connect L009 & RB5009
Replies: 13
Views: 4314

Re: SFP transceivers to connect L009 & RB5009

I have a L009. You can use SFP+ transceivers in forced 2.5G mode, or you can use 2.5G transceivers. … Hi, thank you for confirming. I didn’t think for some silly reason I could use rj-45 SFP+ so I ordered the GTEK SFP+ w FO cable to run. I already have a cat6 cable wired between both ends, I’ll che...
by aboulfad
Mon Dec 18, 2023 5:29 pm
Forum: RouterBOARD hardware
Topic: SFP transceivers to connect L009 & RB5009
Replies: 13
Views: 4314

Re: SFP transceivers to connect L009 & RB5009

Exactly. I am going crazy looking for clear steps to do that. I hope someone here is able to help me out I contacted support & I am pleasantly surprised with their promptness & help. They said it should work, just to make sure to execute this command (similar to above link) to get 2.5G link...
by aboulfad
Sat Dec 16, 2023 1:15 am
Forum: Beginner Basics
Topic: Webfig — default login username?
Replies: 3
Views: 1957

Re: Webfig — default login username?

This is such an annoying problem for those that use webfig & created another username. There is no reason why admin would be hardcoded & profiled in the login page, this looks like sloppy implementation & also insecure. Has anyone figured out a workaround ? PS: I have created a support t...
by aboulfad
Fri Dec 15, 2023 2:08 pm
Forum: RouterBOARD hardware
Topic: SFP transceivers to connect L009 & RB5009
Replies: 13
Views: 4314

Re: SFP transceivers to connect L009 & RB5009

Exactly. I am going crazy looking for clear steps to do that. I hope someone here is able to help me out Given you have both products and transceivers, did you try creating a support ticket? You can open a ticket at help.mikrotik.com or email support@mikrotik.com. jfyi, I found this: https://wiki.m...
by aboulfad
Thu Dec 14, 2023 12:57 pm
Forum: Containers
Topic: Small Ookla Speedtest container
Replies: 11
Views: 3507

Re: Small Ookla Speedtest container

I thought I lost my mind when I didn’t find my post :D . Thank you for creating a new thread and appreciate a lot the improvements which will give me more to learn. I had a hunch you’d find much to improve, container noob here. Containerizing is lots of fun ! I actually spent hours being stuck on 3 ...
by aboulfad
Wed Dec 13, 2023 10:41 pm
Forum: Containers
Topic: Small Ookla Speedtest container
Replies: 11
Views: 3507

Small Ookla Speedtest container

I packaged ookla's speedtest (arm64) & with few tweaks I was able to get it running. Kudos to @tangent's work and docs, as my Dockerfile is inspired by @tangent’s iperf3 one. The size of this image is roughly the size of the speedtest static binary (~ 2.5M) FROM alpine:latest AS build RUN wget -...
by aboulfad
Fri Dec 08, 2023 10:06 pm
Forum: Containers
Topic: Small iperf3 container
Replies: 36
Views: 8649

Re: Small iperf3 container

The rpi4 is 1Gbps capable, so I get around 945Mbps to the iperf server in my RB5009 8) The highest speed I can test is 1.5G from RB5009 to my Bell modem, the Mk is connected using the 2.5G port, but I can’t make that test as the Fibe modem doesn’t obviously run iperf.
by aboulfad
Fri Dec 08, 2023 8:54 pm
Forum: Containers
Topic: Small iperf3 container
Replies: 36
Views: 8649

Re: Small iperf3 container

You would have had to go out of your way to get anything else, assuming you're using the latest version of the Makefile, which hard-codes the "3.16" release version string. You can double-check it with a command like "docker run -it --rm tangentsoft/iperf3 --version". Ah, I miss...
by aboulfad
Fri Dec 08, 2023 6:35 pm
Forum: Containers
Topic: Small iperf3 container
Replies: 36
Views: 8649

Re: Small iperf3 container

iperf 3.16 is out, with a significant performance jump in multi-stream tests. My RB4011 numbers went from 3.4 Gbit/sec for 4-stream downloads to over 4 Gbit/sec atop OM4 with generic SFP+ modules. IMO, it's worth recreating your containers to use this version. (And upgrade your clients, too.) Thank...
by aboulfad
Fri Dec 08, 2023 6:18 pm
Forum: RouterBOARD hardware
Topic: SFP transceivers to connect L009 & RB5009
Replies: 13
Views: 4314

Re: SFP transceivers to connect L009 & RB5009

That device L009 has that note 14 plastered all over, but I could also not find any reference to "forced mode", unless it means setting the interface to 2.5G. I didn't buy the L009 for that reason & may resort to buying a 2nd RB5009 and use it as plain dum switch/bridge.
by aboulfad
Wed Nov 29, 2023 7:00 pm
Forum: Beginner Basics
Topic: Disk size in bytes ???
Replies: 5
Views: 1373

Re: Disk size in bytes ???

I wanted to confirm that there is no user configurable settings to display in -h fashion in CLI, and I think that point was confirmed.
by aboulfad
Wed Nov 29, 2023 11:46 am
Forum: Beginner Basics
Topic: Disk size in bytes ???
Replies: 5
Views: 1373

Re: Disk size in bytes ???

Most *nix provide option to show human readable formats (-h), I expected for ease of readability that ROS CLI would too, furthermore it isn’t aligned to the web UI where it shows only in human readable format (or maybe that’s the default for the webUI).
by aboulfad
Wed Nov 29, 2023 1:18 am
Forum: Beginner Basics
Topic: Disk size in bytes ???
Replies: 5
Views: 1373

Disk size in bytes ???

Hello, it seems /disk print shows free/total size in bytes, is there a way to change to a higher factor (M, G,..) ? The webUI displays correctly in G not in bytes, it is odd that the CLI shows the disk size in bytes... RouterOS 7.11.2 RB5009 /disk print Flags: E - EMPTY, B - BLOCK-DEVICE; M - MOUNTE...
by aboulfad
Tue Nov 28, 2023 10:42 am
Forum: RouterBOARD hardware
Topic: SFP transceivers to connect L009 & RB5009
Replies: 13
Views: 4314

Re: SFP adapters to connect L009 & RB5009

Thank you for the reply, The L009 page lists that it supports SFP only but with 2.5G speeds, what does that mean ? Or is it a mistake. If I understand your recommendation, the ideal solution is to have two SFP+ adapters with a FO cable (with connectors) that I can run between the two (50-60ft). I fo...
by aboulfad
Tue Nov 28, 2023 2:26 am
Forum: RouterBOARD hardware
Topic: SFP transceivers to connect L009 & RB5009
Replies: 13
Views: 4314

SFP transceivers to connect L009 & RB5009

Hello, I got the L009 (SFP 2.5G) & RB5009 (SFP+ 10G) as gifts and would appreciate any advice on what adapters to use to connect those two. The speeds that I am interested in for now is a 2.5G link between the two. Distance is roughly 50-60ft. Would I need a SFP+ adapter for the RB and the SFP o...
by aboulfad
Mon Dec 27, 2021 5:57 pm
Forum: Scripting
Topic: ssh-copy-id for Mikrotik to add public key to authorized_keys
Replies: 3
Views: 6811

Re: ssh-copy-id for Mikrotik to add public key to authorized_keys

thank you a bunch ! I couldn't believe that ss-copy-id wasn't support even in routerOS 7.1.1. I was getting this error after entering my router's password during ssh-copy-id:
syntax error (line 1 column 6)