Community discussions

MikroTik App

Search found 34 matches

by deadpete
Sat Jun 08, 2024 9:57 am
Forum: General
Topic: Setting MTU on trunk in upstream or downstream switch
Replies: 4
Views: 343

Re: Setting MTU on trunk in upstream or downstream switch

Hi mkx, Many thanks for taking your time, and the deeper explanation. I agree with you, that the benefits normally are not worth the trouble. But some implementations are not available, if you cannot set a higher MTU. I have got a Dell PowerStore where there's only one MTU setting for the whole appl...
by deadpete
Fri Jun 07, 2024 12:51 pm
Forum: General
Topic: Setting MTU on trunk in upstream or downstream switch
Replies: 4
Views: 343

Re: Setting MTU on trunk in upstream or downstream switch

Hi mkx, Thanks for your input. I have got about 10 VLANs, each with it's own IP range. So where should I set the MTU value in the router? On each VLAN interface in the bridge? Or on the entry interface? I assume the L2MTU values should be set to their maximum values everywhere. I have got one proble...
by deadpete
Thu Jun 06, 2024 11:02 am
Forum: General
Topic: Setting MTU on trunk in upstream or downstream switch
Replies: 4
Views: 343

Setting MTU on trunk in upstream or downstream switch

Hi folks, I have a network backbone with several core switches, servers and endpoint switches connected. An MTU of 9000 is set on the backbone ports, on endpoint switches to 1500. I want to optimize the connection to our router (CCR1009-7G-1C-1S+), where the LAN connection on the router presently is...
by deadpete
Mon Jun 03, 2024 10:45 pm
Forum: General
Topic: CRS112 classic bridge vs. switch chip configuration
Replies: 5
Views: 303

Re: CRS112 classic bridge vs. switch chip configuration

Hi mkx, I'm just curious. If two configurations that should be equivalent display different behavior in some respect, I just cannot leave it like that. Something is missing in one, or the other configuration. About the UniFi APs, I just manage them. I haven't got a clue what makes them tick, neither...
by deadpete
Mon Jun 03, 2024 10:18 pm
Forum: General
Topic: CRS112 classic bridge vs. switch chip configuration
Replies: 5
Views: 303

Re: CRS112 classic bridge vs. switch chip configuration

Hi mkx, Ubiquity UniFi has got some kind of function that detects the topology. What I've seen, the Ubiquity devices communicate with UDP protocol on port 10001, but that's probably not the whole truth. It's useful for example when using meshing. It tells me what APs are connected to each other, and...
by deadpete
Mon Jun 03, 2024 8:48 pm
Forum: General
Topic: CRS112 classic bridge vs. switch chip configuration
Replies: 5
Views: 303

CRS112 classic bridge vs. switch chip configuration

Hi folks, I have some CRS112 switches for light VLAN switching without any L3 stuff. If you also need PoE, this switch is perfect for the job. I noticed that it's necessary to configure the switch using switch chip configuration, as hardware offload is disabled when activating VLAN switching on the ...
by deadpete
Thu May 30, 2024 10:20 am
Forum: General
Topic: Switch CRS112-8P-4S high CPU load [SOLVED]
Replies: 4
Views: 570

Re: Switch CRS112-8P-4S high CPU load [SOLVED]

Hi Biomesh, The problem seems to be solved. Sort of. I have used the configuration in my first post, which hardware offloads traffic on the ethernet ports. I replaced the switch without hardware offload with this one, and the CPU load is now about the same as on a switch without load. I know the CPU...
by deadpete
Mon May 27, 2024 8:19 pm
Forum: General
Topic: Switch CRS112-8P-4S high CPU load [SOLVED]
Replies: 4
Views: 570

Re: Switch CRS112-8P-4S high CPU load [SOLVED]

Hi tdw, Thanks for your comments, most appreciated. VLAN 1 must be tagged on port spf12, as it's a trunk connection to another switch (non MikroTik). VLAN 1 should be untagged on ports ether3 - ether8, and VLAN 90 untagged on ports ether1 and ether2. It's my first ever setup using the switch command...
by deadpete
Mon May 27, 2024 4:46 pm
Forum: General
Topic: Switch CRS112-8P-4S high CPU load [SOLVED]
Replies: 4
Views: 570

Switch CRS112-8P-4S high CPU load [SOLVED]

Hi folks, I have several CRS112-8P-4S switches and using them as VLAN switches. No L3 stuff, no routing, firewalling, filtering or similar. Particularly, I have one switch that is serving 5 camera feeds, and some very light, intermittent traffic. The camera feed in total is below 500 kbit/s. There a...
by deadpete
Thu May 16, 2024 10:21 pm
Forum: General
Topic: Security: Android phones connecting to port 80 on the gateway
Replies: 0
Views: 275

Security: Android phones connecting to port 80 on the gateway

Hi folks, I have noticed that, every time an Android phone connects to the WiFi network, it immediately tries to connect to port 80 on the gateway/router. Not once, but issuing a bunch of requests. For some of you, this may be trivial, but I don't like the behavior. I have blocked access to the WebF...
by deadpete
Wed May 15, 2024 10:16 pm
Forum: General
Topic: Confusing routing behavior CCR1009-7G-1C-1S+ [SOLVED]
Replies: 5
Views: 6134

Re: Confusing routing behavior CCR1009-7G-1C-1S+ [SOLVED]

Hi anav, I set the correct gateway on the printer 172.16.10.93 to 172.16.10.100 and removed the srcnat rule. It works now, I can print from the 192.168.0.0/23 network. There are only 2 ports used on the router (3 if you count ether7 as an emergency port for configuration). I could probably skip it a...
by deadpete
Wed May 15, 2024 9:15 pm
Forum: General
Topic: Confusing routing behavior CCR1009-7G-1C-1S+ [SOLVED]
Replies: 5
Views: 6134

Re: Confusing routing behavior CCR1009-7G-1C-1S+ [SOLVED]

Hi anav, Well, fulfilling your request would take at least the better part of a week, and the volume of text would be a couple of hundred A4 pages :shock: Doing something like that is of course complete madness, just to satisfy ones curiosity. I had the choice of letting it be, everything is working...
by deadpete
Wed May 15, 2024 7:50 pm
Forum: General
Topic: Confusing routing behavior CCR1009-7G-1C-1S+ [SOLVED]
Replies: 5
Views: 6134

Re: Confusing routing behavior CCR1009-7G-1C-1S+ [SOLVED]

Hi anav, It really boils down to those 2 forwarding clauses I described above. The rest works without any quirks. All users in network 172.16.10.0/24 can reach everything in network 192.168.0.0/23. Nobody from network 192.168.0.0/23 can reach the printer 172.16.10.93, unless I add the srcnat rule. T...
by deadpete
Wed May 15, 2024 7:24 pm
Forum: General
Topic: Confusing routing behavior CCR1009-7G-1C-1S+ [SOLVED]
Replies: 5
Views: 6134

Confusing routing behavior CCR1009-7G-1C-1S+ [SOLVED]

Hi folks, I have setup a router according to my best knowledge. There are a number of separate internal LANs connected to the router. There are 3 services reachable from the internet, SMTP (25) on one public IP address, and HTTP (80) / HTTPS (443) on another public IP. The web server is also accessi...
by deadpete
Fri Apr 19, 2024 10:23 pm
Forum: General
Topic: Log entry warning "interface, warning <interface> excessive or late collission, link duplex mismatch?
Replies: 9
Views: 694

Re: Log entry warning "interface, warning <interface> excessive or late collission, link duplex mismatch?

Hi pe1chl, I turned off auto negotiation and set a fixed port speed on the CRS51-C0-8XS-2XQ to 40GbitCR for the 100 Gbit QSFPPlus port. Otherwise no link. Thanks for reminding me about filing a bug report. I definitely consider it a bug, and I just didn't have time yet to file a bug report. If auto ...
by deadpete
Thu Apr 18, 2024 3:49 pm
Forum: General
Topic: Log entry warning "interface, warning <interface> excessive or late collission, link duplex mismatch?
Replies: 9
Views: 694

Re: Log entry warning "interface, warning <interface> excessive or late collission, link duplex mismatch?

Hi pe1chl, Experimentator. Both ends are set to full duplex. Nothing else is acceptable. The problem is auto negotiation when the Mikrotik switch port has got much higher capabilities, than the other end. This also applies when both ends are Mikrotik devices, for example a CRS51 C0-8XS-2XQ-IN connec...
by deadpete
Thu Apr 18, 2024 3:15 pm
Forum: General
Topic: Log entry warning "interface, warning <interface> excessive or late collission, link duplex mismatch?
Replies: 9
Views: 694

Re: Log entry warning "interface, warning <interface> excessive or late collission, link duplex mismatch?

Hi vingjfg, Thanks for the information. I prefer to set a fixed speed. A 100 Mbit speed is unacceptable, as the link would be more or less constantly saturated. With the set 1 Gbit, the old switch in the other end has got no problem to connect. I have scanned the networks for potential loops, withou...
by deadpete
Wed Apr 17, 2024 10:51 am
Forum: General
Topic: Log entry warning "interface, warning <interface> excessive or late collission, link duplex mismatch?
Replies: 9
Views: 694

Re: Log entry warning "interface, warning <interface> excessive or late collission, link duplex mismatch?

Hi Experimentator, I cannot vouch for the problem existing, or not, in earlier versions of RouterOS. All switches I manage are regularly updated to the latest RouterOS version. In this case 7.14.2. At least one switch had 7.14.1 installed, and it also displayed this bad behavior. In any case, the be...
by deadpete
Tue Apr 16, 2024 11:28 am
Forum: General
Topic: Log entry warning "interface, warning <interface> excessive or late collission, link duplex mismatch?
Replies: 9
Views: 694

Log entry warning "interface, warning <interface> excessive or late collission, link duplex mismatch?

Hi folks, After recently having stability problems with 2 switches, both with RouterOS 7.14.2, I noted the following warning in the switch logs: interface, warning <interface> excessive or late collission, link duplex mismatch? This warning coincided with the switches starting to drop connectivity. ...
by deadpete
Mon Apr 15, 2024 8:07 pm
Forum: General
Topic: Unstable CRS326-4C+20G+2Q [SOLVED]
Replies: 16
Views: 1546

Re: Unstable CRS326-4C+20G+2Q [SOLVED]

Hi folks, I think I've nailed the culprit that's causing instability. I have got 2 almost identical setups with one CRS510-8XS-2XQ-IN serving as upstream switch, and then in this case a CRS326-4C+20G+2Q, and in the other setup a CRS354-48P-4S+2Q. In both cases the upstream switch, and the department...
by deadpete
Mon Apr 15, 2024 12:19 pm
Forum: General
Topic: Unstable CRS326-4C+20G+2Q [SOLVED]
Replies: 16
Views: 1546

Re: Unstable CRS326-4C+20G+2Q [SOLVED]

Hi folks, I discovered 2 errors in my configuration. Those errors made the switch unmanageable over VLAN 40: "add name=main pvid=40 vlan-filtering=yes" should be "add frame-types=admit-only-vlan-tagged name=main pvid=40 vlan-filtering=yes" and in "add bridge=main tagged=\ et...
by deadpete
Mon Apr 15, 2024 12:08 pm
Forum: General
Topic: Unstable CRS326-4C+20G+2Q [SOLVED]
Replies: 16
Views: 1546

Re: Unstable CRS326-4C+20G+2Q [SOLVED]

Hi DNAT, ether21 is the management port and it does not equal combo1. Combo1 is either used as the standard RJ-45 port 1T, or SFP+ port 1F. For combo1 I use the RJ-45 port 1T. It needs to be set as untagged for PVID 90. It's completely normal VLAN switching. I could skip admit-only-untagged-and-prio...
by deadpete
Mon Apr 15, 2024 11:56 am
Forum: General
Topic: Unstable CRS326-4C+20G+2Q [SOLVED]
Replies: 16
Views: 1546

Re: Unstable CRS326-4C+20G+2Q [SOLVED]

Hi loloski, Tagged vlan-ids=1 is used for 2 trunk ports qsfpplus1-1 and combo4, the untagged ports are standard switch ports for devices. That's absolutely normal. All interfaces on the switch are flagged with H. I also have some hybrid ports, but those are mostly used to access different VLANs in t...
by deadpete
Mon Apr 15, 2024 10:39 am
Forum: General
Topic: Unstable CRS326-4C+20G+2Q [SOLVED]
Replies: 16
Views: 1546

Re: Unstable CRS326-4C+20G+2Q [SOLVED]

Hi loloski,

Thanks for your input. I forgot to add you in my answer, but that includes you input as well.

Best regards,

Peter
by deadpete
Mon Apr 15, 2024 10:38 am
Forum: General
Topic: Unstable CRS326-4C+20G+2Q [SOLVED]
Replies: 16
Views: 1546

Re: Unstable CRS326-4C+20G+2Q [SOLVED]

Hi erlinden, No, I'm not using multiple bridges. The only bridge that is active is the bridge named main (management through VLAN 40), where all the switched ports are connected. The mgmt bridge is intended for management, but I could as well remove it. To the mgmt bridge is only connected the manag...
by deadpete
Mon Apr 15, 2024 9:57 am
Forum: General
Topic: Unstable CRS326-4C+20G+2Q [SOLVED]
Replies: 16
Views: 1546

Re: Unstable CRS326-4C+20G+2Q [SOLVED]

Hi, Below is the current configuration. I had to set the combo mode manually, as RouterOS was not able to detect the type. I cannot see any errors in the configuration. Best regards, Peter # 2024-04-15 06:17:33 by RouterOS 7.14.2 # software id = KCBF-PET5 # # model = CRS326-4C+20G+2Q+ /interface bri...
by deadpete
Mon Apr 15, 2024 9:44 am
Forum: General
Topic: Unstable CRS326-4C+20G+2Q [SOLVED]
Replies: 16
Views: 1546

Re: Unstable CRS326-4C+20G+2Q [SOLVED]

Hi erlinden,

Sorry for the confusion. I upgraded the RouterOS from the factory installed to 7.14.1 and then to 7.14.2.

Best regards,

Peter
by deadpete
Sun Apr 14, 2024 10:06 pm
Forum: General
Topic: Unstable CRS326-4C+20G+2Q [SOLVED]
Replies: 16
Views: 1546

Re: Unstable CRS326-4C+20G+2Q [SOLVED]

Hi erlinden,

Yes, I have upgraded the firmware twice. First directly after the initial configuration to 7.14.1, then when to 7.14.2 to see if it did any difference (which it did not).

I will post the configuration tomorrow morning before I decommission the switch.

Best regards,

Peter
by deadpete
Sun Apr 14, 2024 9:33 pm
Forum: General
Topic: Unstable CRS326-4C+20G+2Q [SOLVED]
Replies: 16
Views: 1546

Unstable CRS326-4C+20G+2Q [SOLVED]

Hi folks, I replaced an old HPE 1950 department switch with a CRS326-4C+20G+2Q+RM a few days ago. It was more or less a plugin replacement, where all the ethernet ports had the same VLAN assignments as in the old switch. The main difference is the connection to the upstream switch (a Mikrotik CRS510...
by deadpete
Wed Jan 24, 2024 3:50 pm
Forum: General
Topic: Warning message "<network> not a bridge port" after upgrade to RouterOS 13.2
Replies: 4
Views: 741

Re: Warning message "<network> not a bridge port" after upgrade to RouterOS 13.2

Thanks for the information. I will try it out.

This warning was not given under 7.8, so I missed it there.

Best regards,

Peter
by deadpete
Wed Jan 24, 2024 2:38 pm
Forum: General
Topic: Warning message "<network> not a bridge port" after upgrade to RouterOS 13.2
Replies: 4
Views: 741

Warning message "<network> not a bridge port" after upgrade to RouterOS 13.2

Hi folks, Today I upgraded 2 Mikrotik devices (cAP ax, and hAP ac) to the latest stable RouterOS 7.13.2 from 7.8. Both APs are configured more or less identically with respect to VLANs. There is a new message under /interface/bridge/vlan "apnet not a bridge port" which confuses me. Does it...
by deadpete
Thu Apr 20, 2023 9:23 am
Forum: General
Topic: Switch CRS518 100 Gbit interfaces function [SOLVED]
Replies: 3
Views: 532

Re: Switch CRS518 100 Gbit interfaces function [SOLVED]

Hi chechito,
Thanks for the clarification, it's what I suspected. I'm using MC-LAG on the 2 switches and connecting them over a 100g DAC-cable. Works perfectly.
I do not intend to use a break out cable, at least not in the near future.
Best regards,
Peter
by deadpete
Wed Apr 19, 2023 10:37 am
Forum: General
Topic: Switch CRS518 100 Gbit interfaces function [SOLVED]
Replies: 3
Views: 532

Switch CRS518 100 Gbit interfaces function [SOLVED]

Hi folks, I have got 2 switches CRS518-16XS-2XQ-RM and connected them with a 100 Gbit DAC-cable. In Winbox the 100 Gbit interfaces show up as 4 separate interfaces e.g. qsfp28-1-1, qsfp28-1-2, qsfp28-1-3, and qsfp28-1-4. Is it sufficient to just use one of declared interface of the 100 Gbit interfac...
by deadpete
Thu Mar 23, 2023 9:34 pm
Forum: General
Topic: Switch CRS518-16XS-2XQ as Top-of-Rack, stacking
Replies: 0
Views: 421

Switch CRS518-16XS-2XQ as Top-of-Rack, stacking

Hi folks, Is it possible to use two CRS518-16XS-2XQ switches as ToR (top-of-rack) for redundancy in a server rack with a few servers connected? As the Mikrotik switches have got no stacking feature, I guess "stacking" needs to be implemented through the 100Gb ports? If somebody has got exp...