Community discussions

MikroTik App

Search found 12 matches

by JDF
Thu Apr 11, 2024 9:33 am
Forum: Scripting
Topic: REST API - is it a bug? [SOLVED]
Replies: 9
Views: 601

Re: REST API - is it a bug? [SOLVED]

I poked it until it worked for me. I gave the API user all group rights and then the command worked - Then I removed the policies one by one. So at the end I left only policy=local,reboot,read,write,policy,test,api,rest-api active. All other commands i've added before worked with just group policy=r...
by JDF
Wed Apr 10, 2024 9:43 pm
Forum: Scripting
Topic: REST API - is it a bug? [SOLVED]
Replies: 9
Views: 601

Re: REST API - is it a bug? [SOLVED]

My bad, it was a problem with the group policies. The user didn't have the correct rights so it gave me the { "detail": "not enough permissions (9)", "error": 500, "message": "Internal Server Error" } But at first I didn't see the detail as I was usi...
by JDF
Wed Apr 10, 2024 1:33 pm
Forum: Scripting
Topic: REST API - is it a bug? [SOLVED]
Replies: 9
Views: 601

Re: REST API - is it a bug? [SOLVED]

Hey

But what should the post data be? It gives me an error if its left empty but I didn't figure out the correct post data.
by JDF
Tue Oct 31, 2023 8:59 am
Forum: Scripting
Topic: Rest API port reset [SOLVED]
Replies: 3
Views: 2802

Re: Rest API port reset [SOLVED]

I found my mistake by trial and error - correct post data to disable/enable ports is: {".id": "*7"} for port 6 for example. Hi JDF, can you post the entire request? URL, body, etc..... url: http://IP/rest/interface/disable and if you need to enable it then use: interface/enable ...
by JDF
Thu Oct 05, 2023 12:10 pm
Forum: Wireless Networking
Topic: CAP AX - problem with setting
Replies: 16
Views: 2723

Re: CAP AX - problem with setting

Hi, Thank you for your reply. What do you mean by "for now" - is it the issue with OS 7 or with this particular model that it`s not ready yet? I`m not confident with CLI, therefore I could wait if there is any idea when it will be in the soon future. Regards, Nicholas Well i'm not sure wh...
by JDF
Thu Oct 05, 2023 11:35 am
Forum: Wireless Networking
Topic: CAP AX - problem with setting
Replies: 16
Views: 2723

Re: CAP AX - problem with setting

For now capsman only works on CLI.
by JDF
Tue Sep 12, 2023 9:39 am
Forum: Scripting
Topic: REST API schema for Postman & more
Replies: 4
Views: 3590

Re: REST API schema (using RAML) for Postman

Great work! This will be very useful.
by JDF
Tue Sep 05, 2023 6:56 pm
Forum: Scripting
Topic: REST API SFP Temperature / SFP RX Loss parameters [SOLVED]
Replies: 2
Views: 2383

Re: REST API SFP Temperature / SFP RX Loss parameters [SOLVED]

Hey, I got it working with POST /rest/interface/ethernet/monitor post data for sfp4 in my case { "numbers":"*5","duration":"1"} This way I got the temperatures and voltages too. Without the duration it responds with code 200 in about 1minute but without data. ...
by JDF
Wed Aug 30, 2023 7:22 pm
Forum: Scripting
Topic: REST API log filtering/topics [SOLVED]
Replies: 3
Views: 2624

Re: REST API log filtering/topics [SOLVED]

Thank you Amm0! I even saw that post you sent but I still didn't get it working
This does exactly what I need.
{ ".query": ["topics=\"ipsec;info\""]}
by JDF
Wed Aug 30, 2023 6:05 pm
Forum: Scripting
Topic: REST API log filtering/topics [SOLVED]
Replies: 3
Views: 2624

REST API log filtering/topics [SOLVED]

Hello, Does anyone know the correct POST data format for filtering MT logs? I've come this far: when I send a POST request to /rest/log/print with the JSON data {"follow":{"where":{"topics":"ipsec"}}} , it responds, but it doesn't filter out the IPsec logs as ...
by JDF
Tue Aug 22, 2023 10:44 am
Forum: Scripting
Topic: Rest API port reset [SOLVED]
Replies: 3
Views: 2802

Re: Rest API port reset [SOLVED]

I found my mistake by trial and error - correct post data to disable/enable ports is:
 {".id": "*7"} 
for port 6 for example.
by JDF
Wed Aug 16, 2023 1:56 pm
Forum: Scripting
Topic: Rest API port reset [SOLVED]
Replies: 3
Views: 2802

Rest API port reset [SOLVED]

Hey, I've made some templates for Comfortclick bOS so its able to get general info from MikroTik and to control ports with REST API. I got the general info and PoE reset to work but now im stuck at disabling/enabling the interface - all i get is bad request. Does anyone know what is the correct Post...