Community discussions

Search found 48 matches

by ludvik
Tue Aug 14, 2018 3:55 pm
Forum: General
Topic: Correct package for RB450Gx4
Replies: 2
Views: 100

Re: Correct package for RB450Gx4

Wrong firmware is not a malfunction. Upgrade will not be done.

If you login by winbox, what you see in top window border? Or in menu /system/packages? It is ARM.
by ludvik
Sun Jul 15, 2018 1:21 pm
Forum: General
Topic: question about romon
Replies: 2
Views: 156

Re: question about romon

Theoretically: yes
Practically: romon over EoIP not worknig.
by ludvik
Wed May 30, 2018 8:55 pm
Forum: Announcements
Topic: VPNfilter official statement
Replies: 183
Views: 50319

Re: VPNfilter official statement

Firewall will as allways disable fastpath in your system. Setting source ip's allowed on the service is more direct lo level approach witch does not disable fastpath.
Unfortunately, the DNS server does not allow restrictions using ip / services.
by ludvik
Thu May 17, 2018 9:16 pm
Forum: General
Topic: Nat Not Working !!!
Replies: 2
Views: 162

Re: Nat Not Working !!!

Try logging in mangle/postrouting or in raw table. ROS writes to the log when the packet has an original IP address. The change will take place in one of the last chain before leaving the kernel. Look at packet flow diagram (mikrotik wiki will help) ROS is linux. If in linux NAT not working, half of...
by ludvik
Mon Dec 11, 2017 1:18 pm
Forum: General
Topic: Ipv6 firewall bug?
Replies: 6
Views: 412

Re: Ipv6 firewall bug?

Mikrotik is not Cisco. Mikrotik doesn't have hardware routing, doesn't have ASIC chip. Mikrotik is software router based on Linux. Everything going to CPU (except L2 configurations on switch chip). Packet sniffer is tcpdump (or similar sw). Working in promiscuous mode - see everything in network (di...
by ludvik
Sun Dec 10, 2017 1:45 am
Forum: General
Topic: Ipv6 firewall bug?
Replies: 6
Views: 412

Re: Ipv6 firewall bug?

Packet sniffer see everything. IMHO. It work on lower level than IP stack.

Firewall rule is wrong. You droping packet on input, but packets are TX (output).
by ludvik
Wed Dec 06, 2017 1:18 pm
Forum: The User Manager
Topic: User Manager source interface.
Replies: 4
Views: 1002

Re: User Manager source interface.

This not working.
NAT rule change source-port to 1024.

to-ports parametr not working, if is same as src-port.
by ludvik
Wed Dec 06, 2017 12:54 pm
Forum: The User Manager
Topic: User manager on router
Replies: 0
Views: 177

User manager on router

Hi mikrotik. Feature needed: to use loopback ip address. Telling user manager (customer) to use specific source address. Or use IP address from request packet automatically ... In today situation, radius request arriving IP adress on router - but usermanager answer going from IP address by route tab...
by ludvik
Mon Nov 28, 2016 7:27 pm
Forum: Announcements
Topic: v6.37.2 [current] is released!
Replies: 50
Views: 10931

Re: v6.37.2 [current] is released!

In version 6.37.1 I may write: ip firewall filter> add action=add-src-to-address-list address-list=sysVlan52 address-list-timeout=1h5m chain=forward connection-state=new in-bridge-port=vlan52 in-interface=bridge1 But in 6.37.2: add action=add-src-to-address-list address-list=ttt address-list-timeout...
by ludvik
Sun Jul 17, 2016 1:07 am
Forum: General
Topic: DHCPv6
Replies: 2
Views: 298

Re: DHCPv6

Yes. I need static prefix delegation. For example for servers behind router and theirs DNS records.
by ludvik
Tue Jul 12, 2016 1:29 am
Forum: General
Topic: DHCPv6
Replies: 2
Views: 298

DHCPv6

Hi. I testing DHCPv6 (on ROS 6.34.6) with TP-Link router Archer C7 (with latest firmware 3.15). Basically everything work fine ... router got IPv6 prefix with DNS servers. But I cannot set this delegation static. After every reboot (or renew) tp-link got new prefix from pool. I thing, mistake is in ...
by ludvik
Thu Apr 09, 2015 3:21 am
Forum: Forwarding Protocols
Topic: packed marked with bridge output are not queued
Replies: 3
Views: 1245

Re: packed marked with bridge output are not queued

It's sounds as bug for me ... Queues based on INPUT ports in bridge is OK, but based on OUTPUT ports is impossible? Why? In ROS 6.27. I need this! Marking packets in bridge filter working (counter increasing), but not usable in QT nor in SQ (in /ip firewall filter is also unusable). add action=mark-...
by ludvik
Thu Feb 28, 2013 6:49 pm
Forum: General
Topic: 5.24 released!
Replies: 161
Views: 40517

Re: 5.24 released!

Where is SNMP in 5.24 MIPSBE (RB450G)? Not working ... turned on, none firewall, snmp doesn't respond. Downgrade to 5.23 - it's OK. Same configuration, but POWERPC (RB1100AH) - everything fine. edit: without ANY configuration changes ... SNMP is working. I just waited an hour. I'm stupid, or ROS? I ...
by ludvik
Tue Nov 20, 2012 12:59 pm
Forum: RouterOS v6 RC and v7 BETA
Topic: Loopguard
Replies: 35
Views: 24111

Re: Loopguard

This "HUB" is maybe user's lowcost switch. There is no real change each device for home users. This feature is named "loopback-detection" and every better switch have it. This is a protection against trouble users. And every routerboard has switch chip. The outlined situation it is necessary to inse...
by ludvik
Wed Oct 24, 2012 5:54 pm
Forum: RouterOS v6 RC and v7 BETA
Topic: Multihoming IPV6
Replies: 6
Views: 3431

Re: Multihoming IPV6

IPv6 NAT will be in linux kernel 3.7. Probably stateless (1:1).
by ludvik
Thu Oct 18, 2012 1:00 pm
Forum: General
Topic: Can't connect APC serial UPS
Replies: 4
Views: 973

Re: Can't connect APC serial UPS

Sorry. In 5.21 serial (RS232) UPS working well.
by ludvik
Sun Oct 14, 2012 11:05 pm
Forum: General
Topic: Can't connect APC serial UPS
Replies: 4
Views: 973

Re: Can't connect APC serial UPS

Very good, very good ... One small step for man, one giant leap for mankind. In 5.67 will be fixed.
doesn't work with 5.21 either. Now the UPS shows as invalid.
by ludvik
Sat Oct 13, 2012 10:32 pm
Forum: General
Topic: 5.21 released
Replies: 78
Views: 17539

Re: 5.21 released

by ludvik
Sat Oct 13, 2012 8:49 pm
Forum: General
Topic: Can't connect APC serial UPS
Replies: 4
Views: 973

Re: Can't connect APC serial UPS

Search this forum. In 5.20 is UPS package unusable. Downgrade to 5.19

http://forum.mikrotik.com/viewtopic.php?f=2&t=64785
by ludvik
Sat Oct 06, 2012 12:58 pm
Forum: RouterOS v6 RC and v7 BETA
Topic: Supported UPS`s
Replies: 49
Views: 28149

Re: Supported UPS`s

AP9620 price is low ... about 40euro (official from APC is 45E). It's not standard "full" SmartSlot - only RS232 & USB is on it. Compatible APC Smart UPSes is SU and SC. Letter "M" in product number mean "Microlink protocol" - and thus doesn't work with apcupsd and ROS. For additional information vi...
by ludvik
Fri Oct 05, 2012 1:59 pm
Forum: RouterOS v6 RC and v7 BETA
Topic: Supported UPS`s
Replies: 49
Views: 28149

Re: Supported UPS`s

New "SM" UPSes doesn't work in apcupsd too. APC changed protocol. You must use SmartSlot AP9620 card. UPS APC SMT1000I SMART 1000VA doesn't work with Mikrotik via Serial Cable ( G5 -> DB9) supplied with device. Anyone have experience with it? Works fine via USB, but this port is not present in some ...
by ludvik
Mon Oct 01, 2012 10:03 pm
Forum: General
Topic: v5.20 released
Replies: 113
Views: 35502

Re: v5.20 released

It's probably typo in source code. Small error - Why mikrotik not issued the new package? Why do we have to wait for the new full ROS release?
UPS doesnt work in 5.20, mistake of one of the best mikrotik programators....
You must wait till next release....
by ludvik
Fri Sep 21, 2012 8:20 pm
Forum: General
Topic: v5.20 released
Replies: 113
Views: 35502

Re: v5.20 released

Same here. APC Smart-UPS 620I on RS232 in RB450G Same here. v5.19 UPS package works fine, but not in v5.20. Put everything back to v5.19 and UPS is good and working. Need this fixed! Thanks! Brad When i try to add UPS - The following errors: "Couldn`t add New UPS - opening serial port failed: 2 9 (6...
by ludvik
Sun Jun 03, 2012 11:19 pm
Forum: General
Topic: How to connect APC Smart UPS to RB1100?
Replies: 10
Views: 4777

Re: How to connect APC Smart UPS to RB1100?

system - routerboad - settings: Enter setup on delete key.

Default is "any key" and it is wrong.
by ludvik
Mon Mar 05, 2012 1:01 am
Forum: General
Topic: DHCPv6 server prefix delegation
Replies: 3
Views: 1005

Re: DHCPv6 server prefix delegation

I know, what DUID client generate. I wrote it in this thread. My question is about SERVER. From RFC 3315: Clients and servers MUST treat DUIDs as opaque values and MUST only compare DUIDs for equality. Clients and servers MUST NOT in any other way interpret DUIDs. Clients and servers MUST NOT restri...
by ludvik
Sat Mar 03, 2012 11:30 am
Forum: Virtualization
Topic: MetaRouter and 1100AH on ROS 5.8 not working?
Replies: 36
Views: 17556

Re: MetaRouter and 1100AH on ROS 5.8 not working?

Doesn't use RAM? And how its working? Worlds first computer without ram & storage ... :-) But you probably not inform your distributors about storage change. http://www.wifihw.cz/soubory/546/RB1100AH.pdf http://i4wifi.cz/img.asp?attid=241750 And I bought this device, because I seen 512MB NAND. Too e...
by ludvik
Mon Feb 27, 2012 11:45 am
Forum: General
Topic: IPv6 DHCP Server
Replies: 16
Views: 3221

Re: IPv6 DHCP Server

Problem is redistribute-anything :-) Static or Connected doesn't matter. - routes to delegated prefixes are added to routing table with the "Dynamic Static" flags - I'd prefer to have the "Dynamic Connected" flags set (and Static unset) as the entry is not static and can disappear when the client re...
by ludvik
Sat Feb 25, 2012 2:39 am
Forum: General
Topic: DHCPv6 server prefix delegation
Replies: 3
Views: 1005

DHCPv6 server prefix delegation

What format DUID accept ROS DHCPv6 server? Tested with version 5.14 and 5.9 I have CPE with wide-dhcp6 client, DUID file content is 00:03:00:06:00:27:22:39:E5:B7 (DUID Based on Link-layer Address [DUID-LL]). But ROS isn't working: echo: dhcp,debug,packet recv server1 fe80::227:22ff:fe39:e5b7 -> ff02...
by ludvik
Tue Jan 24, 2012 3:46 pm
Forum: Forwarding Protocols
Topic: OSPFv3 aera other than 0 (backbone) does not work
Replies: 1
Views: 2276

Re: OSPFv3 aera other than 0 (backbone) does not work

In Quagga OSPFv3 areas doesn't implemented yet ... In mikrotik probably too.
by ludvik
Sat Jan 21, 2012 11:26 pm
Forum: General
Topic: IPv6 ND router-preference
Replies: 3
Views: 818

IPv6 ND router-preference

Please, add parameter router-preference to the ND configuration. http://www.ietf.org/rfc/rfc4191.txt If anybody have windows with "internet connection sharing", then advertise prefix to LAN with "medium" preference (i think). And ROS too. If switches is on lan without RA-guard (only small number of ...
by ludvik
Tue Jan 10, 2012 9:56 pm
Forum: Virtualization
Topic: MetaRouter and 1100AH on ROS 5.8 not working?
Replies: 36
Views: 17556

Re: MetaRouter and 1100AH on ROS 5.8 not working?

It's great ... 2GB RAM and 40MB HDD. Very funny ... >sys resource print uptime: 4d58m19s version: 5.11 free-memory: 1520936KiB total-memory: 1555456KiB cpu: e500v2 cpu-count: 1 cpu-frequency: 1066MHz cpu-load: 1% free-hdd-space: 24900KiB total-hdd-space: 41768KiB architecture-name: powerpc board-nam...
by ludvik
Wed Jan 04, 2012 12:41 pm
Forum: Forwarding Protocols
Topic: OSPF - ethernet disable-running-check
Replies: 6
Views: 1669

Re: OSPF - ethernet disable-running-check

I know, what is OSPF ... But usage of Mikrotik is "SOHO" - and disable-running-check is good option for many reasons. Why not be better than Cisco? We are small ISP, with small clouds with many PtP links - if i configure loop-back IP on every router, i have about 200 records in route table moreover....
by ludvik
Tue Jan 03, 2012 9:53 am
Forum: General
Topic: DHCP server on inactive interface (v5.11)
Replies: 4
Views: 639

Re: DHCP server on inactive interface (v5.11)

No! I have some separate ethernet and separate VLAN with separate IP segments. I don't have bridge ...
by ludvik
Sat Dec 31, 2011 3:50 pm
Forum: Forwarding Protocols
Topic: OSPF - ethernet disable-running-check
Replies: 6
Views: 1669

Re: OSPF - ethernet disable-running-check

because "network operation center" software is connected only to ONE IP address of this router. And this routers have two or more backbone link to core network - can not be used one of them IP address, must be uset IP which is always available from every part of the network in every situation. But o...
by ludvik
Sat Dec 31, 2011 2:32 pm
Forum: Forwarding Protocols
Topic: OSPF - ethernet disable-running-check
Replies: 6
Views: 1669

OSPF - ethernet disable-running-check

Please, add parameter disable-running-check for ethernet interfaces. OSPF doesn't propagate route, if not link on interface. I have "management IP" on lan side of infrastructure routers. If customer power-off self switch or CPE connected on lan side, i lose route from global route table. Creating br...
by ludvik
Sat Dec 31, 2011 12:35 am
Forum: General
Topic: Sample Installations - Sticky Please
Replies: 230
Views: 130633

Re: Sample Installations - Sticky Please

Theoretically ... http://en.jirous.com/anteny-5ghz/jrc-29ex
What the model of you parabolic antenna?
it look very nice and i believe the performance should very great...

thanks.
by ludvik
Fri Dec 23, 2011 8:19 pm
Forum: General
Topic: DHCP server on inactive interface (v5.11)
Replies: 4
Views: 639

DHCP server on inactive interface (v5.11)

Hi. I have DHCP server on three interfaces. Eth, bridge and VLAN. If routerboard (RB1100AH) boot with no-link on physical interface (tested on VLAN), DHCP server is not active on this interface. If link is up (connect switch, for example) - dhcp still inactive. In winbox seems normal - as active. I ...
by ludvik
Thu Dec 22, 2011 11:01 pm
Forum: RouterBOARD hardware
Topic: Problems with new revision of RB711-5Hn
Replies: 63
Views: 18794

Re: Problems with new revision of RB711-5Hn

Certify the problem described by OndrejSkipala. Client with new 711-5Hn (s/n 2F2801044309): -66 seen on access point, client RX signal is -45. But between 11 - 15 hours (CET) have -40 on access point (and rx signal is still same)! Yes, sunny noon ... It probably depends on the temperature. TX-Power ...
by ludvik
Wed Dec 14, 2011 1:37 pm
Forum: General
Topic: IPv6 experience ... and needs.
Replies: 7
Views: 1600

Re: IPv6 experience ... and needs.

2. DUID was generated from the first detected interface that had MAC address. We will add command in next version that will show what DUID will be used. Thanks. It would also be appropriate if it was persistent DUID to survive a reinstallation of ROS. Routerboard it meets (in most cases, network in...
by ludvik
Wed Dec 14, 2011 1:31 pm
Forum: General
Topic: IPv6 experience ... and needs.
Replies: 7
Views: 1600

Re: IPv6 experience ... and needs.

1. As per RFC only hosts should receive stateless address. Routers should not. A have a choice. I'm network administrator. But: without accept RA router doesn't default route! Global IP address may be absent, but default route not. I have to configure statically or using OSPFv3 (not usable in every...
by ludvik
Wed Dec 14, 2011 12:27 am
Forum: General
Topic: IPv6 experience ... and needs.
Replies: 7
Views: 1600

IPv6 experience ... and needs.

I have first experience with Ipv6 on mikrotik 5.11 in "client mode". It's horrible ... At first: I need accept router-advertisiments on routers. CPE doesn't have default route without RA (ospf is not applicable). It is linux problem, http://tldp.org/HOWTO/Linux+IPv6-HOWTO/proc-sys-net-ipv6..html (if...
by ludvik
Tue Jul 19, 2011 10:52 pm
Forum: General
Topic: How to connect APC Smart UPS to RB1100?
Replies: 10
Views: 4777

Re: How to connect APC Smart UPS to RB1100?

RB1100 doesn't boot with RS232 APC UPS (Smart-UPS 620I) connected. If I connect UPS after boot ROS, everything working fine. ROS version 5.5, latest firmware.
Any idea?
by ludvik
Fri Apr 15, 2011 1:23 am
Forum: Scripting
Topic: 3.24 API->disconnect
Replies: 7
Views: 1269

Re: 3.24 API->disconnect

Please! MT programmer, create patch for this problem in 4.x version. 4.17 has still bug in logout from API connection ("/user active" is a very very long list). Very please ...
by ludvik
Fri Jun 06, 2008 1:02 am
Forum: Beginner Basics
Topic: OSPF redistribute-connected
Replies: 6
Views: 2920

Re: OSPF redistribute-connected

But: if ethernet interface does not link detect (pc or switch unplug), ospf NO REDISTRIBUTE any network assigned on this interface. Is a bug or feature? IMHO bug ... On wireless interfaces exists property disable-running-check, which is a solution this problem. But on ethernet ... nothing!(?) p.s.: ...
by ludvik
Mon Jun 02, 2008 10:27 am
Forum: Wireless Networking
Topic: 5.4GHz band in czech regulatory domain
Replies: 11
Views: 3999

Re: 5.4GHz band in czech regulatory domain

I thing, frequency 5480 IS NOT illegal in most countries (specially in EU). Allowed frequency band starting at 5470, and frequency bandwidth 802.11a is 20MHz, so 5480 is absolutly legal. official document from Czech Telecommunication Office: http://www.ctu.cz/164/download/VOR/VOR-12-08-2005-34.pdf (...
by ludvik
Tue May 27, 2008 12:25 pm
Forum: Wireless Networking
Topic: 5.4GHz band in czech regulatory domain
Replies: 11
Views: 3999

Re: 5.4GHz band in czech regulatory domain

I try all of countries ... nothing.

For example zimbabwe: bad band and/or channel. Doesn't work ...

In versions prior 3.0 exists Albania, it work ... in new versions same as zimbabwe, doesn't work.
by ludvik
Mon May 26, 2008 5:49 pm
Forum: Wireless Networking
Topic: 5.4GHz band in czech regulatory domain
Replies: 11
Views: 3999

5.4GHz band in czech regulatory domain

Please, tell me why does Mikrotik (version 3.7) unsupported frequency 5480?

Band 5.4 in czech republic is from 5470 MHz to 5725 MHz with 1W e.r.i.p (in english: http://www.ctu.cz/164/download/VOR/VOR- ... 005-34.pdf), but mikrotik starting at 5500 MHz.

Please, fix it. Thank you.