Community discussions

Search found 159 matches

by lukkes
Wed May 17, 2017 10:44 pm
Forum: General
Topic: Unavailabilty to LAN Resources While Sharing VPN over VLAN Interfaces
Replies: 4
Views: 302

Re: Unavailabilty to LAN Resources While Sharing VPN over VLAN Interfaces

Hello, I have the same problem and seems that to many people its the same, nobody can help with this problem. if you know the solution, please tell me, thanks
by lukkes
Tue May 17, 2016 6:56 pm
Forum: Scripting
Topic: Backup over SSH or telnet ?
Replies: 24
Views: 11614

Re: Backup over SSH or telnet ?

MTU in the same network segment? in a local LAN, i dont think so, also there is no firewall blocking nothing between them
and the problem it's just with one ap, other tan the email with attachment problem.
by lukkes
Tue May 17, 2016 5:23 pm
Forum: Scripting
Topic: Backup over SSH or telnet ?
Replies: 24
Views: 11614

Re: Backup over SSH or telnet ?

I have the same problem, with one of my 16 ap, with SCP the transfer is stalled. any ideas?
thanks
by lukkes
Sun May 15, 2016 6:29 am
Forum: Scripting
Topic: error sending email WITH ATTACHMENTS
Replies: 5
Views: 480

Re: error sending email WITH ATTACHMENTS

ok, i understand your advice, but just to clarify to you, this ap is behind a router like other 16 aps, all of them can send the email without problems, there's nothing blocking ping, in fact, i dont have nothing blocked in my network, so where i must change the mtu and how? also, i dont understand ...
by lukkes
Sat May 14, 2016 3:38 pm
Forum: Scripting
Topic: error sending email WITH ATTACHMENTS
Replies: 5
Views: 480

Re: error sending email WITH ATTACHMENTS

it's so strange cause, without the attachment the email goes fine, the same script it's working in all other aps in the network, same RouterOS version, all it's the same config.
by lukkes
Sat May 14, 2016 12:14 pm
Forum: Scripting
Topic: error sending email WITH ATTACHMENTS
Replies: 5
Views: 480

error sending email WITH ATTACHMENTS

Good night, this command /tool e-mail send to="destination@gmail.com" subject=([/system identity get name]." backup") file=export.rsc start-tls=yes; works fine and send the email when I remove the file attachment, but when i try to send the export file the log show stuck in "email: send ." and the e...
by lukkes
Sat Apr 09, 2016 6:00 am
Forum: Scripting
Topic: run an array and compare
Replies: 0
Views: 457

run an array and compare

good nights, i have an array with routing marks array1 ("wan1","wan2","wan3","wan4","wan5",..."wanX") and I get an array with the command :foreach routes in=[/ip route find where comment~"^[a-z]*wan" ] do={ :set routename ([/ip route get $routes comment]); :set array2 ($array2, $routename); } the se...
by lukkes
Sat Jun 20, 2015 1:45 am
Forum: Forwarding Protocols
Topic: Anyone running MPLS on production WISP network ?
Replies: 4
Views: 1511

Re: Anyone running MPLS on production WISP network ?

I have The same question, I have a few wireless nodes with basebox in routed mode, and a backhaul bridged so I want to know I migrating the backhaul to mpls will improve the performance of the backhaul links.
by lukkes
Sat May 02, 2015 3:42 am
Forum: General
Topic: DHCP relay and external Linux DHCP server
Replies: 8
Views: 2570

Re: DHCP relay and external Linux DHCP server

hello did you resolve your problem? i test the same scenario and doesn't work at first test, so i increment the "delay threshold" and works fine
by lukkes
Tue Apr 21, 2015 8:54 pm
Forum: Scripting
Topic: find with logic AND
Replies: 4
Views: 449

Re: find with logic AND

ok bro, i will try that, thanks a lot.
by lukkes
Tue Apr 21, 2015 7:15 pm
Forum: Scripting
Topic: find with logic AND
Replies: 4
Views: 449

Re: find with logic AND

this is so shameful for me, i hace experience in some programming languages, routers included, and when i post some question it's because i've tried everything, last night i try a lot of times this :foreach iface in=[/ip dhcp-client find comment~"balance" && status="bound"] do={ :set ifname ([/ip dh...
by lukkes
Tue Apr 21, 2015 5:57 pm
Forum: Scripting
Topic: find with logic AND
Replies: 4
Views: 449

find with logic AND

Hello people, i have a list of dhcp-client interfaces wan1 bound comment balanced wan2 bound comment balanced wan3 bound comment balanced wan4 bound comment balanced wan5 bound comment balanced wan6 bound comment balanced wan7 bound comment admin there is a way to ([find status = "bound"] and commen...
by lukkes
Sat Jan 24, 2015 12:55 am
Forum: General
Topic: Simple Queue on transparent bridge in v.6.1
Replies: 1
Views: 828

Re: Simple Queue on transparent bridge in v.6.1

hi, did you find a solution? now i have the same problem.
by lukkes
Fri Sep 05, 2014 4:18 pm
Forum: Wireless Networking
Topic: What would happen if...
Replies: 20
Views: 3763

Re: What would happen if...

when you install the sxt on side, there is no problem with water drop inside the antenna?
by lukkes
Fri Sep 05, 2014 3:30 pm
Forum: Wireless Networking
Topic: ch0/ch1...the polarity of sextant 5hnd
Replies: 25
Views: 9088

Re: ch0/ch1...the polarity of sextant 5hnd

I got a strange behaivor, i try to connect a sxt5 to a Vpol rootena, i try everything, disabling chain0-tx as indicated in manual, also enabling all chains, but the only way ut can connect is truning the radio 90degrees and connect perfect with an impressive signal strenght, but i cant leave the rad...
by lukkes
Fri Sep 05, 2014 5:32 am
Forum: General
Topic: Which Load Balancing Option?
Replies: 1
Views: 379

Re: Which Load Balancing Option?

PCC works great, try it
by lukkes
Fri Sep 05, 2014 5:28 am
Forum: General
Topic: how to load balance "router itself" "local" traffic
Replies: 1
Views: 331

how to load balance "router itself" "local" traffic

Good Nights, i have a 6 adsl load balance, works great, but all the dns request goes trough the default gateway, i want to load balance those requests and disable any default gateway, i try to mark connections in output, but doesnt work, somebody has this same issue? thanks
by lukkes
Wed Mar 05, 2014 6:07 pm
Forum: Beginner Basics
Topic: what does it mean ??
Replies: 1
Views: 302

Re: what does it mean ??

the user is trying to log on, but has some error, sometime password issue
by lukkes
Wed Mar 05, 2014 4:56 am
Forum: General
Topic: QoS + Load Balance same router
Replies: 1
Views: 594

Re: QoS + Load Balance same router

I resolved this using another router. thanks anyway
by lukkes
Wed Mar 05, 2014 4:53 am
Forum: General
Topic: Btest on multi wan doesn't work
Replies: 0
Views: 288

Btest on multi wan doesn't work

Good nights, i have a strange behavior in my router, i have 7 DSL lines with pcc load balance, everything works perfect, i can access my router, and the server inside my network remotely, so the prerouting chains to in & out for the same gateway is working perfect, i can use all my 7 ip to access pe...
by lukkes
Tue Mar 04, 2014 5:42 am
Forum: Scripting
Topic: is there any associative array, hash, map?
Replies: 24
Views: 5752

Re: is there any associative array, hash, map?

hi, is there a way to assign values to a variable array in ros 5.21 ? just ike this
{a=1;b=3}

thanks;
by lukkes
Tue Feb 25, 2014 6:40 pm
Forum: General
Topic: QoS + Load Balance same router
Replies: 1
Views: 594

QoS + Load Balance same router

hello everybody, i'm trying to configure a working QoS on a router with a 12 ADSL PCC balance, it seems don't works fine cause the QoS marks overwrite the PCC load balance marks, somebody has configured something like that? thanks
by lukkes
Tue Mar 12, 2013 6:02 am
Forum: Virtualization
Topic: frequent changing of gateway in load balancing
Replies: 6
Views: 3278

Re: frequent changing of gateway in load balancing

I have change the per-connection-classifier to "both addresses, i noticed that the IP address are no longer changing. But another problem i noticed now is that ISP2 which is 4M seems to be carrying traffic more than the ISP1 that is 10M. I want clients to pass through the 10M more than the 4M. what...
by lukkes
Sat Mar 09, 2013 11:42 pm
Forum: Virtualization
Topic: frequent changing of gateway in load balancing
Replies: 6
Views: 3278

Re: frequent changing of gateway in load balancing

if you are using pcc you should use a connection classifier Both-Addresses, add action=mark-connection chain=prerouting comment="balance conn $routemark" \ disabled=no dst-address-type=!local in-interface=bridge1 \ new-connection-mark="$routemark" passthrough=yes per-connection-classifier= "both-add...
by lukkes
Tue Mar 05, 2013 3:41 am
Forum: Scripting
Topic: startup script runs at every hour error
Replies: 2
Views: 926

Re: startup script runs at every hour error

Thanks for the answer, i really dont worry about the globals, cause is with the result of script running every 5 minutes, the real problem is why the startup script runs at many times on day if the router has not rebooted.
by lukkes
Mon Mar 04, 2013 6:03 am
Forum: Scripting
Topic: startup script runs at every hour error
Replies: 2
Views: 926

startup script runs at every hour error

good nights, i have a script to send email when the router reboots, it works fine, but sometimes it runs when the router has not reboot, also i can see that my global variables disappears from the environment tab, i checked the uptime of the router and is normal,so the router has not been rebooted. ...
by lukkes
Sat Mar 02, 2013 4:31 am
Forum: General
Topic: Webfig skins (tutorial)
Replies: 100
Views: 82848

Re: Webfig skins (tutorial)

i want remove or add column in the wireless registration table, also i want to view inline comments, is's possible? thanks
by lukkes
Wed Nov 14, 2012 3:34 pm
Forum: General
Topic: Error sending e-mail: error handling file
Replies: 12
Views: 2995

Re: Error sending e-mail: error handling file

Hi, i got the same error, the email can go fine when has no attachement, the snesitive policy is set, the debug log stucks in RCV: 354 enter mail, end with "." on a line by itself, error sending email, abnormal termination timeout when i send the email without backup it works fine, also i try to sen...
by lukkes
Mon Nov 12, 2012 8:13 pm
Forum: Scripting
Topic: working, assign to array var the ip to compare later change
Replies: 1
Views: 972

working, assign to array var the ip to compare later change

god morning, in this script i scan all the interfaces that have name "WANxxx" like WAN1, WAN2, and then obtain it's ip address, then put that ip in an array, make it global and later run script again to check if any has changed, it works fine, but i have a problem, when some interface has no ip addr...
by lukkes
Mon Nov 12, 2012 4:03 am
Forum: Scripting
Topic: simple log info command doesn't print
Replies: 2
Views: 795

Re: simple log info command doesn't print

Thanks
how you say it works, but i need that the lines be print just one time, not for each interface, so, i dont need it inside the loop, Understand?
by lukkes
Sat Nov 10, 2012 6:09 am
Forum: Scripting
Topic: simple log info command doesn't print
Replies: 2
Views: 795

simple log info command doesn't print

Good nights people, can somebody tell me why the two last lines in my script, it's not printed? but when i comment this line ":set currip [/ip address get [find interface="$ifname"] address];" it print the lines.. what i'm doing wrong? the script works good, but with the problem of the two last line...
by lukkes
Thu Jun 14, 2012 7:29 am
Forum: Scripting
Topic: Get the interface name in dhcp-client
Replies: 4
Views: 2507

Re: Get the interface name in dhcp-client

tratando de obtener los nombres de las interfaces que estan en dhcp-client para luego preguntar sus defaults gateways y crear las rutas dinamicamente

sorry for write in spanish

im trying to get the interfaces names to use it for recreate the routes dynamically
by lukkes
Thu Jun 14, 2012 7:20 am
Forum: Scripting
Topic: Get the interface name in dhcp-client
Replies: 4
Views: 2507

Re: Get the interface name in dhcp-client

thanks, it works, but doesnt understand why doesnt work by the way y test...
thanks again
by lukkes
Thu Jun 14, 2012 5:51 am
Forum: Scripting
Topic: Get the interface name in dhcp-client
Replies: 4
Views: 2507

Get the interface name in dhcp-client

Good night, i need to monitor the status of a interface in the dhcp-client module, status like, bound, searching, renewing, etc, i need to get the interface name to make some process but nothing works for me, i have 12 wan interfaces, all of them with dhcp-client active i try with :local intname [ /...
by lukkes
Sat Apr 28, 2012 10:25 am
Forum: The Dude
Topic: Dude on Mac
Replies: 5
Views: 6916

Re: Dude on Mac

works perfect, but only if connect to a remot and change de ip as you told, thanks...
by lukkes
Sat Apr 28, 2012 5:02 am
Forum: The Dude
Topic: Dude on Mac
Replies: 5
Views: 6916

Re: Dude on Mac

i tryed wineskin, it install perfect and runs, but stuck in conecting to server....! seems that the local server dont start
by lukkes
Tue Sep 27, 2011 11:50 pm
Forum: General
Topic: ping routing-table error, manual gateway issue
Replies: 5
Views: 723

Re: ping routing-table error, manual gateway issue

:(
Anyone helps please
by lukkes
Mon Aug 29, 2011 3:58 pm
Forum: General
Topic: ping routing-table error, manual gateway issue
Replies: 5
Views: 723

Re: ping routing-table error, manual gateway issue

Yes, you're right, but remember that the gateway i'm talking about are the gateway created manually for the balancing, the routes with specific routing-mark, understand? in other side, all ethernet has marked the in dhcp client the option add-default-route with differents distance, so when one gatew...
by lukkes
Mon Aug 29, 2011 3:33 pm
Forum: General
Topic: ping routing-table error, manual gateway issue
Replies: 5
Views: 723

Re: ping routing-table error, manual gateway issue

Thanks for your help.. it's ethernet adsl, really it's a 8 wan balancer, it's strange cause 7 of them works fine, i double check that all the routes are identical, only change the routing mark and the wan gateway.. why you say that it's not working good? so what it's the correct way to make a router...
by lukkes
Sat Aug 27, 2011 4:36 am
Forum: General
Topic: ping routing-table error, manual gateway issue
Replies: 5
Views: 723

ping routing-table error, manual gateway issue

hello forum, i got a problem when i try to set automatic the gateway for a route when i set a interface as a gateway the ping with routing table parameter doesn't work, but when i set the gateway manually it works perfect, this is the scenario --------------------- with this config: ;;; route wan1 d...
by lukkes
Wed Dec 08, 2010 9:51 pm
Forum: General
Topic: Step by step Load balancing in v4.4 helpfull for many users.
Replies: 55
Views: 11761

Re: Step by step Load balancing in v4.4 helpfull for many us

hmmm so i should program an script that take the default gateway and create the static route, but when run this script? that's the problem...
by lukkes
Tue Dec 07, 2010 5:45 am
Forum: General
Topic: Step by step Load balancing in v4.4 helpfull for many users.
Replies: 55
Views: 11761

Re: Step by step Load balancing in v4.4 helpfull for many us

hi chupaka, what about the dhcp taken gateways when two or more adsl have the same gateway? how should i use your command?
by lukkes
Tue Dec 07, 2010 5:37 am
Forum: General
Topic: two or more adsl with the same gateway
Replies: 1
Views: 263

two or more adsl with the same gateway

Hello, i have a load balance with 8 dsl modem, but sometimes two or more of them take the same default gateway, there is a way to manually set the default gateway that appears in the nexthops tab? thanks
by lukkes
Wed Sep 29, 2010 2:15 pm
Forum: General
Topic: Load Balance, Multiwan with webproxy
Replies: 65
Views: 14434

Re: Load Balance, Multiwan with webproxy

set prerouting rule over the others with the ipsec mark and action accept it will send all packets to the default gateway and will not use the balance, also you can do it with all that breaks with the balance, https, msn, etc
by lukkes
Mon Sep 27, 2010 3:50 am
Forum: General
Topic: Redirect traffic to Squid ( Linux )
Replies: 30
Views: 83393

Re: Redirect traffic to Squid ( Linux )

ip firewall nat add action=dst-nat dst-port=80 protocol=tcp src-address="client's_used subnet" to-addresses="squid_address" to-ports=8080 chain=dstnat http://www.mikrotik.com/testdocs/ros/2.9/ip/nat.php This is the correct way, dont waste more time, your problem it's on the squid box, a bad squid a...
by lukkes
Sun Sep 26, 2010 5:23 am
Forum: General
Topic: Redirect traffic to Squid ( Linux )
Replies: 30
Views: 83393

Re: Redirect traffic to Squid ( Linux )

using a parent proxy and setup many clients can use all your cpu of the routerboard, the best way it's to use the redirect chains
by lukkes
Mon Sep 06, 2010 9:54 pm
Forum: Beginner Basics
Topic: dstnat problem
Replies: 18
Views: 1517

Re: dstnat problem

what do you mean when say PRIVATE SITE? dont understand
by lukkes
Mon Sep 06, 2010 9:45 pm
Forum: Beginner Basics
Topic: dstnat problem
Replies: 18
Views: 1517

Re: dstnat problem

what it's the ip address and gateway of the apache webserver?
by lukkes
Mon Sep 06, 2010 8:53 pm
Forum: Beginner Basics
Topic: dstnat problem
Replies: 18
Views: 1517

Re: dstnat problem

of course the webserver should have as a default gateway the LAN ip of the mikrotik router
by lukkes
Mon Sep 06, 2010 8:44 pm
Forum: Beginner Basics
Topic: dstnat problem
Replies: 18
Views: 1517

Re: dstnat problem

/ip firewall nat add action=masquerade chain=srcnat comment="" disabled=no out-interface=ether1 add action=dst-nat chain=dstnat comment="" disabled=no dst-port=8080 in-interface=ether1 protocol=tcp to-addresses=192.168.88.5 to-ports=80 add action=dst-nat chain=dstnat comment="" disabled=no dst-port...